Verwenden der Solver-VBA-FunktionenUsing the Solver VBA Functions

Bevor Sie die Solver-VBA-Funktionen in VBA verwenden können, müssen Sie das Solver-Add-In im Dialogfeld Excel-Optionen aktivieren.Before you can use the Solver VBA functions from VBA, you must enable the Solver add-in in the Excel Options dialog box.

  1. Klicken Sie auf die Registerkarte Datei, und klicken Sie dann unter der Registerkarte Excel auf Optionen.Click the File tab, and then click Options below the Excel tab.

  2. Klicken Sie im Dialogfeld Excel-Optionen auf Add-Ins.In the Excel Options dialog box, click Add-Ins.

  3. Wählen Sie im Dropdownfeld Verwalten die Option Excel-Add-Ins aus, und klicken Sie dann auf Gehe zu.In the Manage drop-down box, select Excel Add-ins, and then click Go.

  4. In the Add-Ins dialog box, select Solver Add-in, and then click OK.In the Add-Ins dialog box, select Solver Add-in, and then click OK.

Nachdem Sie das Solver-Add-In aktiviert haben, installiert Excel automatisch das Add-In, wenn es noch nicht installiert ist, und der Befehl Solver wird auf dem Menüband auf der Registerkarte Daten der Gruppe Analyse hinzugefügt.After you have enabled the Solver add-in, Excel will auto-install the Add-in if it is not already installed, and the Solver command will be added to the Analysis group on the Data tab in the ribbon.

Before you can use the Solver VBA functions in the Visual Basic Editor, you must establish a reference to the Solver add-in.Before you can use the Solver VBA functions in the Visual Basic Editor, you must establish a reference to the Solver add-in. Klicken Sie im Visual Basic-Editor mit einem aktiven Modul auf Verweise im Menü Extras, und wählen Sie dann Solver unter Verfügbare Verweise aus.In the Visual Basic Editor, with a module active, click References on the Tools menu, and then select Solver under Available References. Wenn Solver nicht unter Verfügbare Verweise angezeigt wird, klicken Sie auf Durchsuchen, und öffnen Sie dann Solver.xlam im Unterordner \Program Files\Microsoft Office\Office14\Library\SOLVER.If Solver does not appear under Available References, click Browse, and then open Solver.xlam in the \Program Files\Microsoft Office\Office14\Library\SOLVER subfolder. Die folgenden Funktionen können verwendet werden, um das Solver-Add-In in VBA zu steuern.The following functions can be used to control the Solver add-in from VBA. Jede Funktion entspricht einer Aktion, die interaktiv mithilfe der Dialogfelder Solver-Parameter, Solver-Optionen und Solver-Ergebnisse des Solver-Add-Ins ausgeführt werden kann.Each function corresponds to an action that you can perform interactively, through the Solver Parameters, Solver Options, and Solver Results dialog boxes of the Solver add-in.

Support und FeedbackSupport and feedback

Haben Sie Fragen oder Feedback zu Office VBA oder zu dieser Dokumentation?Have questions or feedback about Office VBA or this documentation? Unter Office VBA-Support und Feedback finden Sie Hilfestellung zu den Möglichkeiten, wie Sie Support erhalten und Feedback abgeben können.Please see Office VBA support and feedback for guidance about the ways you can receive support and provide feedback.