VM reagiert nicht beim Anwenden der Richtlinie „Gruppenrichtlinie für lokale Benutzer und Gruppen“

In diesem Artikel werden die Schritte zum Beheben von Problemen beschrieben, bei denen der Ladebildschirm beim Anwenden einer Richtlinie während des Starts eines virtuellen Azure-Computers (VM) nicht mehr reagiert.

Problembeschreibung

Wenn Sie Startdiagnose verwenden, um einen Screenshot der VM anzuzeigen, reagiert der Bildschirm beim Laden nicht mehr und zeigt folgende Meldung an: „Anwendung der Gruppenrichtlinie Lokale Benutzer und Gruppen“ oder „Bitte warten.“

Screenshot: Ladevorgang zum Anwenden der Gruppenrichtlinie für lokale Benutzer und Gruppen in Windows Server 2012 R2.

Screenshot: Ladevorgangs zum Anwenden der Gruppenrichtlinie für lokale Benutzer und Gruppen in Windows Server 2012.

Screenshot zeigt „Bitte warten“ wird in Windows Server 2012 geladen.

Ursache

Es gibt widersprüchliche Sperren, wenn die Richtlinie versucht, alte Benutzerprofile zu bereinigen.

Hinweis

Dies betrifft nur Windows Server 2012 und Windows Server 2012 R2.

Dies ist die problematische Richtlinie:

Computer Configuration\Policies\Administrative Templates\System/User Profiles\Delete user profiles older than a specified number of days on system restart

Lösung

Übersicht über das Verfahren

Tipp

Wenn Sie über eine aktuelle Sicherung der VM verfügen, können Sie versuchen, die VM aus der Sicherung wiederherzustellen, um das Startproblem zu beheben.

  1. Erstellen und Aufrufen einer Reparatur-VM
  2. Deaktivieren der Richtlinie
  3. Aktivieren der seriellen Konsole und der Speicherabbilderfassung
  4. Neuerstellen der VM

Hinweis

Wenn dieser Startfehler auftritt, ist das Gastbetriebssystem nicht funktionsfähig. Sie müssen die Problembehandlung im Offlinemodus durchführen.

Schritt 1: Erstellen und Aufrufen einer Reparatur-VM

  1. Führen Sie die Schritte 1 bis 3 der Reparaturbefehle für virtuelle Computer aus, um eine Reparatur-VM vorzubereiten.
  2. Stellen Sie über die Remotedesktopverbindung eine Verbindung mit der Reparatur-VM her.

Schritt 2: Deaktivieren der Richtlinie

  1. Öffnen Sie auf der Reparatur-VM den Registrierungs-Editor.

  2. Suchen Sie den Schlüssel HKEY_LOCAL_MACHINE, und klicken Sie dann im Menü Datei auf Struktur laden.

    Screenshot mit hervorgehobenem Schlüssel HKEY_LOCAL_MACHINE und dem Menü, das „Struktur laden“ enthält.

    • Über „Struktur laden“ können Sie Registrierungsschlüssel aus einem Offlinesystem laden. In diesem Fall ist das System der mit der Reparatur-VM verknüpfte beschädigte Datenträger.
    • Systemweite Einstellungen sind unter HKEY_LOCAL_MACHINE gespeichert und können als „HKLM“ abgekürzt werden.
  3. Navigieren Sie auf dem angefügten Datenträger zur Datei \windows\system32\config\SOFTWARE und öffnen Sie sie.

    1. Wenn Sie zur Angabe eines Namens aufgefordert werden, geben Sie „BROKENSOFTWARE“ ein.
    2. Um zu überprüfen, ob BROKENSOFTWARE geladen wurde, erweitern Sie HKEY_LOCAL_MACHINE, und suchen Sie nach dem hinzugefügten Schlüssel BROKENSOFTWARE.
  4. Navigieren Sie zu BROKENSOFTWARE, und überprüfen Sie, ob der Schlüssel CleanupProfiles in der geladenen Struktur vorhanden ist.

    1. Wenn dies der Fall ist, ist die CleanupProfiles-Richtlinie festgelegt. Der Wert stellt die in der Aufbewahrungsrichtlinie festgelegte Dauer in Tagen dar. Fahren Sie mit dem Löschen des Schlüssels fort.
    2. Wenn der Schlüssel nicht vorhanden ist, ist die CleanupProfile-Richtlinie nicht festgelegt. Senden Sie ein Supportticket, und schließen Sie die memory.dmp-Datei ein, die sich im Windows-Verzeichnis des angefügten Betriebssystem-Datenträgers befindet.
  5. Löschen Sie den CleanupProfiles-Schlüssel mit diesem Befehl:

    reg delete "HKLM\BROKENSOFTWARE\Policies\Microsoft\Windows\System" /v CleanupProfiles /f
    
  6. Entladen Sie die BROKENSOFTWARE-Struktur mit diesem Befehl:

    reg unload HKLM\BROKENSOFTWARE
    

Schritt 3: Aktivieren der seriellen Konsole und der Speicherabbilderfassung

Führen Sie dieses Skript aus, um die Speicherabbilderfassung und die serielle Konsole zu aktivieren:

  1. Öffnen Sie eine Eingabeaufforderungssitzung mit erhöhten Rechten. (Als Administrator ausführen.)

  2. Führen Sie diese Befehle aus, um die serielle Konsole zu aktivieren:

    bcdedit /store <VOLUME LETTER WHERE THE BCD FOLDER IS>:\boot\bcd /ems {<BOOT LOADER IDENTIFIER>} ON
    
    bcdedit /store <VOLUME LETTER WHERE THE BCD FOLDER IS>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Überprüfen Sie, ob der freie Speicherplatz auf dem Betriebssystem-Datenträger mindestens der Größe des Arbeitsspeichers (RAM) der VM entspricht.

    Wenn auf dem Betriebssystem-Datenträger nicht genügend Speicherplatz vorhanden ist, ändern Sie den Speicherort des Speicherabbilds in einen Ort auf einen angefügten Datenträger mit genügend freiem Speicherplatz. Ersetzen Sie „%SystemRoot%“ in den folgenden Befehlen durch den Laufwerkbuchstaben (z. B. „F:“) des Datenträgers, um den Speicherort zu ändern.

    Empfohlene Konfiguration für das Aktivieren des Betriebssystemabbilds

    Laden Sie den beschädigten Betriebssystem-Datenträger:

    REG LOAD HKLM\BROKENSYSTEM <VOLUME LETTER OF BROKEN OS DISK>:\windows\system32\config\SYSTEM
    

    Aktivieren für „ControlSet001“:

    REG ADD "HKLM\BROKENSYSTEM\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    REG ADD "HKLM\BROKENSYSTEM\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    REG ADD "HKLM\BROKENSYSTEM\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Aktivieren für „ControlSet002“:

    REG ADD "HKLM\BROKENSYSTEM\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    REG ADD "HKLM\BROKENSYSTEM\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    REG ADD "HKLM\BROKENSYSTEM\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Entladen des beschädigten Betriebssystemdatenträgers:

    REG UNLOAD HKLM\BROKENSYSTEM
    

Schritt 4: Neuerstellen der VM

Führen Sie Schritt 5 der VM-Reparaturbefehle aus, um die VM zu reassemblieren.

Wenn das Problem behoben wurde, ist die Richtlinie nun lokal deaktiviert. Eine dauerhafte Lösung ist das Nichtverwenden der CleanupProfiles-Richtlinie auf VMs. Verwenden Sie eine andere Methode, um Profilbereinigungen durchzuführen.

Verwenden Sie diese Richtlinie nicht:

Machine\Admin Templates\System\User Profiles\Delete user profiles older than a specified number of days on system restart

Nächste Schritte

Wenn beim Anwenden eines Windows Updates Probleme auftreten, lesen Sie VM reagiert nicht mehr bei Anwenden von Windows Update, und Fehler C01A001D wird ausgegeben.

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