Der virtuelle Computer reagiert nicht, wenn eine Gruppenrichtlinie für lokale Benutzer und Gruppen angewendet wird.

Dieser Artikel enthält Schritte zum Beheben von Problemen, bei denen der Ladebildschirm nicht reagiert, wenn ein virtueller Computer (VM) von Azure während des Starts eine Richtlinie angewendet.

Problembeschreibung

Wenn Sie die Startdiagnose verwenden, um einen Screenshot des virtuellen Computers anzuzeigen, bleibt der Bildschirm beim Laden mit der Meldung hängen: "Anwenden einer Gruppenrichtlinie für lokale Benutzer und Gruppenrichtlinien".

Screenshot of Applying Group Policy Local Users and Groups policy loading (Windows Server 2012 R2).

Screenshot of Applying Group Policy Local Users and Groups policy loading (Windows Server 2012).

Ursache

Es gibt widersprüchliche Sperren, wenn die Richtlinie versucht, alte Benutzerprofile zu bereinigen.

Hinweis

Dies gilt nur für Windows Server 2012 und Windows Server 2012 R2.

Dies ist die problematische Richtlinie:

Computer Configuration\Policies\Administrative Templates\System/User Profiles\Delete user profiles older than a specified number of days on system restart

Lösung

Übersicht über das Verfahren

Tipp

Wenn Sie eine aktuelle Sicherung des virtuellen Computers haben, versuchen Sie möglicherweise, den virtuellen Computer aus der Sicherung wiederherzustellen, um das Startproblem zu beheben.

  1. Erstellen und Zugreifen auf einen virtuellen Reparatur-COMPUTER
  2. Richtlinie deaktivieren
  3. Aktivieren der seriellen Konsole und Speicherabbildsammlung
  4. Neuerstellen des virtuellen Computers

Hinweis

Wenn dieser Startfehler auftritt, ist das Gastbetriebssystem nicht betriebsbereit. Sie müssen eine Problembehandlung im Offlinemodus ausgeführt werden.

Schritt 1: Erstellen und Zugreifen auf einen virtuellen Computer für die Reparatur

  1. Verwenden Sie die Schritte 1 bis 3 der VM-Reparaturbefehle, um einen virtuellen Computer für die Reparatur vorzubereiten.
  2. Verwenden Sie die Remotedesktopverbindung, um eine Verbindung mit dem virtuellen Computer für die Reparatur herzustellen.

Schritt 2: Deaktivieren der Richtlinie

  1. Öffnen Sie auf dem virtuellen Computer zum Reparieren den Registrierungs-Editor.

  2. Suchen Sie den HKEY_LOCAL_MACHINE, und wählen Sie im Menü "Struktur > laden" aus.

    Screenshot shows highlighted HKEY_LOCAL_MACHINE and the menu containing Load Hive.

    • Sie können "Struktur laden" verwenden, um Registrierungsschlüssel aus einem Offlinesystem zu laden. In diesem Fall ist das System der beschädigte Datenträger, der an den virtuellen Computer für die Reparatur angefügt ist.
    • Systemweite Einstellungen werden gespeichert und können als HKEY_LOCAL_MACHINE "HKLM" abgekürzt werden.
  3. Wechseln Sie auf dem angefügten Datenträger zu der \windows\system32\config\SOFTWARE Datei, und öffnen Sie sie.

    1. Wenn Sie zur Eingabe eines Namens aufgefordert werden, geben Sie BROKENSOFTWARE ein.
    2. Um zu überprüfen, ob BROKENSOFTWARE geladen wurde, erweitern HKEY_LOCAL_MACHINE und suchen Sie nach dem hinzugefügten BROKENSOFTWARE-Schlüssel.
  4. Wechseln Sie zu BROKENSOFTWARE, und überprüfen Sie, ob der Schlüssel "CleanupProfile" in der geladenen Struktur vorhanden ist.

    1. Wenn der Schlüssel vorhanden ist, wird die Richtlinie "CleanupProfile" festgelegt. Der Wert stellt die in Tagen gemessene Aufbewahrungsrichtlinie dar. Fahren Sie mit dem Löschen des Schlüssels fort.
    2. Wenn der Schlüssel nicht vorhanden ist, wird die Richtlinie "CleanupProfile" nicht festgelegt. Übermitteln Sie ein Supportticket,einschließlich der Datei "memory.dmp", die sich im Verzeichnis "Windows" des angeschlossenen Betriebssystemdatenträgers befindet.
  5. Löschen Sie den Schlüssel "CleanupProfiles" mit dem folgenden Befehl:

    reg delete "HKLM\BROKENSOFTWARE\Policies\Microsoft\Windows\System" /v CleanupProfiles /f
    
  6. Entladen Sie die STRUKTUR BROKENSOFTWARE mit dem folgenden Befehl:

    reg unload HKLM\BROKENSOFTWARE
    

Schritt 3: Aktivieren der seriellen Konsole und Speicherabbildsammlung

Führen Sie dieses Skript aus, um die Speicherabbildsammlung und die serielle Konsole zu aktivieren:

  1. Öffnen Sie eine Eingabeaufforderungssitzung mit erhöhten Rechten. (Als Administrator ausführen.)

  2. Führen Sie die folgenden Befehle aus, um die serielle Konsole zu aktivieren:

    bcdedit /store <VOLUME LETTER WHERE THE BCD FOLDER IS>:\boot\bcd /ems {<BOOT LOADER IDENTIFIER>} ON
    
    bcdedit /store <VOLUME LETTER WHERE THE BCD FOLDER IS>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Überprüfen Sie, ob der freie Speicherplatz auf dem Betriebssystemdatenträger mindestens der Arbeitsspeichergröße (RAM) des virtuellen Computers entspricht.

    Wenn nicht genügend Speicherplatz auf dem Betriebssystemdatenträger vorhanden ist, ändern Sie den Speicherort des Speicherabbilds, und verweisen Sie ihn auf einen angeschlossenen Datenträger mit genügend freiem Speicherplatz. Um den Speicherort zu ändern, ersetzen Sie "%SystemRoot%" durch den Laufwerkbuchstaben (z. B. "F:") des Datenträgers in den folgenden Befehlen.

    Vorgeschlagene Konfiguration zum Aktivieren des Betriebssystemabbilds

    Laden des beschädigten Betriebssystemdatenträgers:

    REG LOAD HKLM\BROKENSYSTEM <VOLUME LETTER OF BROKEN OS DISK>:\windows\system32\config\SYSTEM
    

    Aktivieren auf ControlSet001:

    REG ADD "HKLM\BROKENSYSTEM\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f 
    REG ADD "HKLM\BROKENSYSTEM\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f 
    REG ADD "HKLM\BROKENSYSTEM\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f 
    

    Aktivieren auf ControlSet002:

    REG ADD "HKLM\BROKENSYSTEM\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f 
    REG ADD "HKLM\BROKENSYSTEM\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f 
    REG ADD "HKLM\BROKENSYSTEM\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f 
    

    Entladen des beschädigten Betriebssystemdatenträgers:

    REG UNLOAD HKLM\BROKENSYSTEM
    

Schritt 4: Neuerstellen des virtuellen Computers

Verwenden Sie Schritt 5 der VM-Reparaturbefehle, um den virtuellen Computer erneut zusammen zu setzen.

Wenn das Problem behoben ist, ist die Richtlinie jetzt lokal deaktiviert. Verwenden Sie für eine dauerhafte Lösung nicht die Richtlinie "CleanupProfiles" auf VMs. Verwenden Sie eine andere Methode, um Profilbereinigungen durchzuführen.

Verwenden Sie diese Richtlinie nicht:

Machine\Admin Templates\System\User Profiles\Delete user profiles older than a specified number of days on system restart

Nächste Schritte

Wenn beim Anwenden von Windows Update Probleme auftreten, sehen Sie, dass vm beim Anwenden von Windows Update nicht mit dem Fehler "C01A001D" reagiert.