Willkommen in der Visual Studio-IDEWelcome to the Visual Studio IDE

Die integrierte Entwicklungsumgebung für Visual Studio ist eine kreative Startplattform, die Sie verwenden können, um Code erst zu bearbeiten, zu debuggen und zu kompilieren und anschließend eine App zu veröffentlichen.The Visual Studio integrated development environment is a creative launching pad that you can use to edit, debug, and build code, and then publish an app. Bei einer integrierten Entwicklungsumgebung (IDE) handelt es sich um ein funktionsreiches Programm, das für viele Aspekte der Softwareentwicklung verwendet werden kann.An integrated development environment (IDE) is a feature-rich program that can be used for many aspects of software development. Neben dem üblichen Editor und Debugger, den die meisten IDEs bereitstellen, enthält Visual Studio Compiler, Codevervollständigungstools, grafische Designer und viele andere Features zur Erleichterung der Softwareentwicklung.Over and above the standard editor and debugger that most IDEs provide, Visual Studio includes compilers, code completion tools, graphical designers, and many more features to ease the software development process.

Die Visual Studio 2017-IDE

Auf diesem Bild sehen Sie Visual Studio mit einem geöffneten Projekt und einigen wichtigen Toolfenstern, die Sie wahrscheinlich verwenden:This image shows Visual Studio with an open project and several key tool windows you'll likely use:

  • ImProjektmappen-Explorer (rechts oben) können Sie Ihre Codedateien anzeigen, durch die Dateien navigieren und sie verwalten.Solution Explorer (top right) lets you view, navigate, and manage your code files. Der Projektmappen-Explorer kann Sie beim Ordnen Ihres Codes unterstützen, indem er die Dateien in Projektmappen und Projekte gruppiert.Solution Explorer can help organize your code by grouping the files into solutions and projects.

  • Im Editorfenster (Mitte), in dem Sie die meiste Zeit verbringen werden, werden Dateiinhalte angezeigt.The editor window (center), where you'll likely spend a majority of your time, displays file contents. Hier können Sie Code bearbeiten oder eine Benutzeroberfläche wie etwa ein Fenster mit Schaltflächen und Textfeldern entwerfen.This is where you can edit code or design a user interface such as a window with buttons and text boxes.

  • Das Fenster Ausgabe (Mitte unten) ist der Ort, an den Visual Studio Benachrichtigungen sendet, z.B. Debug- und Fehlermeldungen, Compilerwarnungen, Nachrichten zum Veröffentlichungsstatus und mehr.The Output window (bottom center) is where Visual Studio sends notifications such as debugging and error messages, compiler warnings, publishing status messages, and more. Jede Nachrichtenquelle verfügt über eine eigene Registerkarte.Each message source has its own tab.

EditionenEditions

Visual Studio ist für Windows und Mac verfügbar.Visual Studio is available for Windows and Mac. Visual Studio für Mac enthält viele der Features von Visual Studio 2017 und wurde für die Entwicklung plattformübergeifender und mobiler Apps optimiert.Visual Studio for Mac has many of the same features as Visual Studio 2017, and is optimized for developing cross-platform and mobile apps. Dieser Artikel konzentriert sich auf die Windows-Version von Visual Studio 2017.This article focuses on the Windows version of Visual Studio 2017.

Es gibt drei Editionen von Visual Studio 2017: Community, Professional und Enterprise.There are three editions of Visual Studio 2017: Community, Professional, and Enterprise. Unter Visual Studio 2017-IDEs im Vergleich wird erläutert, welche Features in jeder Edition unterstützt werden.See Compare Visual Studio 2017 IDEs to learn about which features are supported in each edition.

Visual Studio ist für Windows und Mac verfügbar.Visual Studio is available for Windows and Mac. Visual Studio für Mac enthält viele der Features von Visual Studio 2019 und wurde für die Entwicklung plattformübergreifender und mobiler Apps optimiert.Visual Studio for Mac has many of the same features as Visual Studio 2019, and is optimized for developing cross-platform and mobile apps. Dieser Artikel konzentriert sich auf die Windows-Version von Visual Studio 2019.This article focuses on the Windows version of Visual Studio 2019.

Es gibt drei Editionen von Visual Studio 2019: Community, Professional und Enterprise.There are three editions of Visual Studio 2019: Community, Professional, and Enterprise. Unter Visual Studio-IDEs im Vergleich erfahren Sie, welche Features in der jeweiligen Edition unterstützt werden.See Compare Visual Studio IDEs to learn about which features are supported in each edition.

Einige gängige Features in Visual Studio, mit denen Sie bei der Entwicklung von Software noch produktiver sind:Some of the popular features in Visual Studio that help you to be more productive as you develop software include:

  • Wellenlinien und schnelle AktionenSquiggles and Quick Actions

    Wellenlinien sind wellenförmige Unterstreichungen, die Sie auf Fehler oder mögliche Probleme in Ihrem Code hinweisen.Squiggles are wavy underlines that alert you to errors or potential problems in your code as you type. Dank dieser visuellen Hinweisen können Sie Probleme sofort beheben, ohne zu warten, bis der Fehler beim Kompilieren oder beim Ausführen des Programms entdeckt wird.These visual clues enable you to fix problems immediately without waiting for the error to be discovered during build or when you run the program. Wenn Sie auf eine Wellenlinie zeigen, werden zusätzliche Informationen zum Fehler angezeigt.If you hover over a squiggle, you see additional information about the error. Am linken Rand wird ggf. auch eine Glühbirne mit Aktionen, schnelle Aktionen genannt, zum Beheben des Fehlers angezeigt.A light bulb may also appear in the left margin with actions, known as Quick Actions, to fix the error.

    Wellenlinien in Visual Studio

  • RefactoringRefactoring

    Refactoring umfasst Vorgänge wie das intelligente Umbenennen von Variablen, das Extrahieren von Codezeilen in eine neue Methode, das Ändern der Reihenfolge von Methodenparametern und vieles mehr.Refactoring includes operations such as intelligent renaming of variables, extracting one or more lines of code into a new method, changing the order of method parameters, and more.

    Refactoring in Visual Studio

  • IntelliSenseIntelliSense

    IntelliSense steht für eine Gruppe von Features, mit denen Informationen zum Code direkt im Editor angezeigt und in einigen Fällen kleine Codeabschnitte für Sie geschrieben werden.IntelliSense is a term for a set of features that displays information about your code directly in the editor and, in some cases, write small bits of code for you. Damit verfügen Sie über eine grundlegende Dokumentation, die in den Editor integriert ist, sodass Sie die Typinformationen nicht mehr an anderer Stelle nachsehen müssen.It's like having basic documentation inline in the editor, which saves you from having to look up type information elsewhere. Die Features von IntelliSense variieren je nach Sprache.IntelliSense features vary by language. Weitere Informationen finden Sie unter C#-IntelliSense, Visual C++ IntelliSense, JavaScript IntelliSense und Visual Basic IntelliSense.For more information, see C# IntelliSense, Visual C++ IntelliSense, JavaScript IntelliSense, and Visual Basic IntelliSense. In der folgenden Abbildung ist dargestellt, wie mit IntelliSense eine Memberliste für einen Typ angezeigt wird:The following illustration shows how IntelliSense displays a member list for a type:

    Visual Studio, Member-Liste

  • SchnellstartQuick Launch

    Visual Studio kann angesichts der zahlreichen Menüs, Optionen und Eigenschaften zuweilen übermächtig wirken.Visual Studio can seem overwhelming at times with so many menus, options, and properties. Mit dem Suchfeld Schnellstart finden Sie in Visual Studio schnell, was Sie suchen.The Quick Launch search box is a great way to rapidly find what you need in Visual Studio. Wenn Sie beginnen, den Namen dessen einzugeben, wonach Sie suchen, listet Visual Studio Ergebnisse auf, mit denen Sie ans gewünschte Ziel gelangen.When you start typing the name of something you're looking for, Visual Studio lists results that take you exactly where you need to go. Wenn Sie Visual Studio Funktionalitäten wie etwa die Unterstützung für eine zusätzliche Programmiersprache hinzufügen müssen, liefert Schnellstart Ergebnisse, mit denen Sie Visual Studio-Installer zum Installieren einer Workload oder einer einzelnen Komponente öffnen können.If you need to add functionality to Visual Studio, for example to add support for an additional programming language, Quick Launch provides results that open Visual Studio Installer to install a workload or individual component.

    Tip

    Drücken Sie STRG+Q, um direkt zum Suchfeld Schnellstart zu wechseln.Press Ctrl+Q as a shortcut to the Quick Launch search box.

    Suchfeld „Schnellstart“ in Visual Studio 2017

    Suchfeld „Schnellstart“ in Visual Studio 2019

  • Live ShareLive Share

    Führen Sie unabhängig von App-Typ oder Programmiersprache gemeinsam und in Echtzeit Bearbeitungs- und Debugvorgänge aus.Collaboratively edit and debug with others in real time, regardless of what your app type or programming language. Sie können Ihr aktuelles Projekt sowie Debugsitzungen, Terminalinstanzen, Localhost-Web-Apps, Sprachanrufe und vieles mehr sofort und sicher freigeben.You can instantly and securely share your project and, as needed, debugging sessions, terminal instances, localhost web apps, voice calls, and more.

  • AufrufhierarchieCall Hierarchy

    Im Fenster Aufrufhierarchie werden die Methoden angezeigt, mit denen eine ausgewählte Methode aufgerufen wird.The Call Hierarchy window shows the methods that call a selected method. Diese Informationen können nützlich sein, wenn Sie die Methode ändern oder entfernen oder einen Fehler aufspüren möchten.This can be useful information when you're thinking about changing or removing the method, or when you're trying to track down a bug.

    Fenster „Aufrufhierarchie“

  • CodeLensCodeLens

    Mit CodeLens können Sie nach Verweisen auf Ihren Code, Änderungen an Ihrem Code, verknüpften Fehlern, Arbeitselementen, Codeüberprüfungen und Komponententests suchen, ohne den Editor verlassen zu müssen.CodeLens helps you find references to your code, changes to your code, linked bugs, work items, code reviews, and unit tests, all without leaving the editor.

    CodeLens

  • Gehe zu DefinitionGo To Definition

    Mit der Funktion „Gehe zu Definition“ gelangen Sie direkt zu der Stelle, an der eine Funktion oder ein Typ definiert ist.The Go To Definition feature takes you directly to the location where a function or type is defined.

    Zur Definition wechseln

  • Definition einsehenPeek Definition

    Im Fenster Definitionsvorschau wird die Definition einer Methode oder eines Typs angezeigt, ohne eine separate Datei zu öffnen.The Peek Definition window shows the definition of a method or type without actually opening a separate file.

    Definitionsvorschau

Installieren von Visual Studio-IDEInstall the Visual Studio IDE

In diesem Abschnitt erstellen Sie ein einfaches Projekt, um einige Dinge auszuprobieren, die mit Visual Studio möglich sind.In this section, you'll create a simple project to try out some of the things you can do with Visual Studio. Sie verwenden IntelliSense als Programmierhilfe, debuggen eine App, um den Wert einer Variablen während der Ausführung des Programms anzuzeigen, und ändern das Farbschema.You'll use IntelliSense as a coding aid, debug an app to see the value of a variable during the program's execution, and change the color theme.

Laden Sie zunächst Visual Studio herunter, und installieren Sie es auf Ihrem System.To get started, download Visual Studio and install it on your system. Mit dem modularen Installationsprogramm können Sie Workloads auswählen und installieren, die Gruppen von Funktionen sind, die für die bevorzugte Programmiersprache oder Plattform erforderlich sind.The modular installer enables you to choose and install workloads, which are groups of features needed for the programming language or platform you prefer. Damit Sie die Schritte zum Erstellen eines Programms ausführen können, müssen Sie während der Installation die Workload Plattformübergreifende .NET Core-Entwicklung auswählen.To follow the steps for creating a program, be sure to select the .NET Core cross-platform development workload during installation.

Laden Sie zunächst Visual Studio herunter, und installieren Sie es auf Ihrem System.To get started, download Visual Studio and install it on your system. Mit dem modularen Installationsprogramm können Sie Workloads auswählen und installieren, die Gruppen von Funktionen sind, die für die bevorzugte Programmiersprache oder Plattform erforderlich sind.The modular installer enables you to choose and install workloads, which are groups of features needed for the programming language or platform you prefer. Damit Sie die Schritte zum Erstellen eines Programms ausführen können, müssen Sie während der Installation die Workload Plattformübergreifende .NET Core-Entwicklung auswählen.To follow the steps for creating a program, be sure to select the .NET Core cross-platform development workload during installation.

Workload für die plattformübergreifende .NET Core-Entwicklung im Visual Studio-Installer

Wenn Sie Visual Studio zum ersten Mal öffnen, können Sie sich optional mit Ihrem Microsoft-Konto oder Ihrem Geschäfts-, Schul- oder Unikonto anmelden.When you open Visual Studio for the first time, you can optionally sign in using your Microsoft account or your work or school account.

Erstellen eines ProgrammsCreate a program

Darum werden wir mit Ihnen jetzt ein einfaches Programm erstellen.Let's dive in and create a simple program.

  1. Öffnen Sie Visual Studio.Open Visual Studio.

  2. Klicken Sie auf der Menüleiste auf Datei > Neu > Projekt.On the menu bar, choose File > New > Project.

    „Datei“ > „Neu“ > „Projekt“ in der Menüleiste

    Im Dialogfeld Neues Projekt werden mehrere Projektvorlagen angezeigt.The New Project dialog box shows several project templates. Eine Vorlage enthält die grundlegenden Dateien und Einstellungen, die für einen bestimmten Projekttyp erforderlich sind.A template contains the basic files and settings needed for a given project type.

  3. Wählen Sie unter Visual C# die Vorlagenkategorie .NET Core und anschließend die Vorlage Konsolen-App (.NET Core) aus.Choose the .NET Core template category under Visual C#, and then choose the Console App (.NET Core) template. Geben Sie HelloWorld im Textfeld Name ein, und klicken Sie auf OK.In the Name text box, type HelloWorld, and then select the OK button.

    .NET Core-App-Vorlage

    Note

    Wenn die Kategorie .NET Core nicht angezeigt wird, müssen Sie die Workload Plattformübergreifende .NET Core-Entwicklung installieren.If you don't see the .NET Core category, you need to install the .NET Core cross-platform development workload. Klicken Sie hierfür im Dialogfeld Neues Projekt unten links auf den Link Visual Studio-Installer öffnen.To do this, choose the Open Visual Studio Installer link on the bottom left of the New Project dialog. Nachdem der Visual Studio-Installer geöffnet wurde, wählen Sie die Workload Plattformübergreifende .NET Core-Entwicklung aus, und klicken Sie dann auf Ändern.After Visual Studio Installer opens, scroll down and select the .NET Core cross-platform development workload, and then select Modify.

    Visual Studio erstellt daraufhin das Projekt.Visual Studio creates the project. Die Vorlage erstellt eine einfache „Hello World“-Anwendung, mit der die Console.WriteLine()-Methode aufgerufen wird, um die Literalzeichenfolge „Hello World!“It's a simple "Hello World" application that calls the Console.WriteLine() method to display the literal string "Hello World!" im Konsolenfenster (Programmausgabe).in the console (program output) window.

    Kurz darauf sollte nun etwa Folgendes angezeigt werden:Shortly, you should see something like the following:

    Visual Studio-IDE

    Der C#-Code für Ihre Anwendung wird im Editor-Fenster angezeigt, der den meisten Raum einnimmt.The C# code for your application shows in the editor window, which takes up most of the space. Beachten Sie, dass der Text automatisch farbig hervorgehoben wird, um verschiedene Bestandteile des Codes anzuzeigen, z.B. Schlüsselwörter und Typen.Notice that the text is automatically colorized to indicate different parts of the code, such as keywords and types. Darüber hinaus zeigen kleine, vertikale gestrichelte Linien im Code an, welche geschweiften Klammern zusammengehören, und anhand der Zeilennummern können Sie sich später im Code orientieren.In addition, small, vertical dashed lines in the code indicate which braces match one another, and line numbers help you locate code later. Sie können die kleinen Minuszeichen in Kästchen auswählen, um Codeblöcke ein- oder auszublenden.You can choose the small, boxed minus signs to collapse or expand blocks of code. Mit dieser Codegliederungsfunktion können Sie Code ausblenden, den Sie nicht benötigen, um die Übersichtlichkeit des Bildschirms zu optimieren.This code outlining feature lets you hide code you don't need, helping to minimize onscreen clutter. Auf der rechten Seite werden im Fenster Projektmappen-Explorer die Projektdateien aufgelistet.The project files are listed on the right side in a window called Solution Explorer.

    Visual Studio-IDE mit roten Markierungen

    Es sind noch mehr Menüs und Toolfenster verfügbar, aber für den Moment wenden wir uns Anderem zu.There are other menus and tool windows available, but let's move on for now.

  4. Starten Sie nun die App.Now, start the app. Wählen Sie hierzu auf der Menüleiste im Menü Debuggen die Option Ohne Debuggen starten aus.You can do this by choosing Start Without Debugging from the Debug menu on the menu bar. Alternativ können Sie auch die Tastenkombination STRG+F5 drücken.You can also press Ctrl+F5.

    Menü „Debuggen“ > „Ohne Debuggen starten“

    Visual Studio erstellt die App, und es wird ein Konsolenfenster mit der Meldung Hello World! geöffnet.Visual Studio builds the app, and a console window opens with the message Hello World!. Sie haben nun eine funktionierende App!You now have a running app!

    Konsolenfenster

  5. Drücken Sie eine beliebige Taste auf der Tastatur, um das Konsolenfenster zu schließen.To close the console window, press any key on your keyboard.

  6. Fügen wir der App weiteren Code hinzu.Let's add some additional code to the app. Fügen Sie vor der Zeile Console.WriteLine("Hello World!"); den folgenden Code ein:Add the following C# code before the line that says Console.WriteLine("Hello World!");:

    Console.WriteLine("\nWhat is your name?");
    var name = Console.ReadLine();
    

    Der Code zeigt What is your name? (Wie heißen Sie?) im Konsolenfenster an und wartet, bis der Benutzer Text eingegeben und die EINGABETASTE gedrückt hat.This code displays What is your name? in the console window, and then waits until the user enters some text followed by the Enter key.

  7. Ändern Sie die Zeile Console.WriteLine("Hello World!"); in den folgenden Code:Change the line that says Console.WriteLine("Hello World!"); to the following code:

    Console.WriteLine($"\nHello {name}!");
    
  8. Führen Sie die App erneut aus, indem Sie Debuggen > Ohne Debuggen starten auswählen oder STRG+F5 drücken.Run the app again by selecting Debug > Start Without Debugging or by pressing Ctrl+F5.

    Visual Studio erstellt die App neu, und Sie werden im nun geöffneten Konsolenfenster zur Eingabe Ihres Namens aufgefordert.Visual Studio rebuilds the app, and a console window opens and prompts you for your name.

  9. Geben Sie Ihren Namen im Konsolenfenster ein, und drücken Sie die EINGABETASTE.Enter your name in the console window and press Enter.

    Konsolenfenstereingabe

  10. Drücken Sie eine beliebige Taste, um das Konsolenfenster zu schließen und das ausgeführte Programm zu beenden.Press any key to close the console window and stop the running program.

  1. Öffnen Sie Visual Studio.Open Visual Studio.

    Daraufhin wird das Startfenster angezeigt. Dort können Sie unter anderem ein Repository klonen, ein kürzlich verwendetes Projekt öffnen oder ein neues Projekt erstellen.The start window appears with various options for cloning a repo, opening a recent project, or creating a brand new project.

  2. Wählen Sie Neues Projekt erstellen aus.Choose Create a new project.

    „Neues Projekt erstellen“ im Startfenster von Visual Studio

    Das Fenster Neues Projekt erstellen wird geöffnet und zeigt verschiedene Vorlagen für Projekte an.The Create a new project window opens and shows several project templates. Eine Vorlage enthält die grundlegenden Dateien und Einstellungen, die für einen bestimmten Projekttyp erforderlich sind.A template contains the basic files and settings needed for a given project type.

  3. Geben Sie .NET Core Konsole in das Suchfeld ein, um die gewünschte Vorlage zu finden.To find the template we want, type or enter .net core console in the search box. Die Liste mit den verfügbaren Vorlagen wird automatisch nach den eingegebenen Schlüsselwörtern gefiltert.The list of available templates is automatically filtered based on the keywords you entered. Sie können die Vorlagenergebnisse noch weiter filtern, indem Sie in der Dropdownliste Sprache die Option C# auswählen.You can further filter the template results by choosing C# from the Language drop-down list. Wählen Sie die Vorlage Konsolen-App (.NET Core) und anschließend Weiter aus.Select the Console App (.NET Core) template, and then choose Next.

    Erstellen eines neuen Projekts in Visual Studio

  4. Geben Sie im Fenster Neues Projekt konfigurieren im Feld Projektname die Zeichenfolge HelloWorld ein, ändern Sie optional das Verzeichnis für Ihre Projektdateien, und wählen Sie anschließend Erstellen aus.In the Configure your new project window, enter HelloWorld in the Project name box, optionally change the directory location for your project files, and then choose Create.

    Konfigurieren eines neuen Projekts in Visual Studio

    Visual Studio erstellt daraufhin das Projekt.Visual Studio creates the project. Die Vorlage erstellt eine einfache „Hello World“-Anwendung, mit der die Console.WriteLine()-Methode aufgerufen wird, um die Literalzeichenfolge „Hello World!“It's a simple "Hello World" application that calls the Console.WriteLine() method to display the literal string "Hello World!" im Konsolenfenster (Programmausgabe).in the console (program output) window.

    Kurz darauf sollte nun etwa Folgendes angezeigt werden:Shortly, you should see something like the following:

    Visual Studio-IDE

    Der C#-Code für Ihre Anwendung wird im Editor-Fenster angezeigt, der den meisten Raum einnimmt.The C# code for your application shows in the editor window, which takes up most of the space. Beachten Sie, dass der Text automatisch farbig hervorgehoben wird, um verschiedene Bestandteile des Codes anzuzeigen, z.B. Schlüsselwörter und Typen.Notice that the text is automatically colorized to indicate different parts of the code, such as keywords and types. Darüber hinaus zeigen kleine, vertikale gestrichelte Linien im Code an, welche geschweiften Klammern zusammengehören, und anhand der Zeilennummern können Sie sich später im Code orientieren.In addition, small, vertical dashed lines in the code indicate which braces match one another, and line numbers help you locate code later. Sie können die kleinen Minuszeichen in Kästchen auswählen, um Codeblöcke ein- oder auszublenden.You can choose the small, boxed minus signs to collapse or expand blocks of code. Mit dieser Codegliederungsfunktion können Sie Code ausblenden, den Sie nicht benötigen, um die Übersichtlichkeit des Bildschirms zu optimieren.This code outlining feature lets you hide code you don't need, helping to minimize onscreen clutter. Auf der rechten Seite werden im Fenster Projektmappen-Explorer die Projektdateien aufgelistet.The project files are listed on the right side in a window called Solution Explorer.

    Visual Studio-IDE mit roten Markierungen

    Es sind noch mehr Menüs und Toolfenster verfügbar, aber für den Moment wenden wir uns Anderem zu.There are other menus and tool windows available, but let's move on for now.

  5. Starten Sie nun die App.Now, start the app. Wählen Sie hierzu auf der Menüleiste im Menü Debuggen die Option Ohne Debuggen starten aus.You can do this by choosing Start Without Debugging from the Debug menu on the menu bar. Alternativ können Sie auch die Tastenkombination STRG+F5 drücken.You can also press Ctrl+F5.

    Menü „Debuggen“ > „Ohne Debuggen starten“

    Visual Studio erstellt die App, und es wird ein Konsolenfenster mit der Meldung Hello World! geöffnet.Visual Studio builds the app, and a console window opens with the message Hello World!. Sie haben nun eine funktionierende App!You now have a running app!

    Konsolenfenster

  6. Drücken Sie eine beliebige Taste auf der Tastatur, um das Konsolenfenster zu schließen.To close the console window, press any key on your keyboard.

  7. Fügen wir der App weiteren Code hinzu.Let's add some additional code to the app. Fügen Sie vor der Zeile Console.WriteLine("Hello World!"); den folgenden Code ein:Add the following C# code before the line that says Console.WriteLine("Hello World!");:

    Console.WriteLine("\nWhat is your name?");
    var name = Console.ReadLine();
    

    Der Code zeigt What is your name? (Wie heißen Sie?) im Konsolenfenster an und wartet, bis der Benutzer Text eingegeben und die EINGABETASTE gedrückt hat.This code displays What is your name? in the console window, and then waits until the user enters some text followed by the Enter key.

  8. Ändern Sie die Zeile Console.WriteLine("Hello World!"); in den folgenden Code:Change the line that says Console.WriteLine("Hello World!"); to the following code:

    Console.WriteLine($"\nHello {name}!");
    
  9. Führen Sie die App erneut aus, indem Sie Debuggen > Ohne Debuggen starten auswählen oder STRG+F5 drücken.Run the app again by selecting Debug > Start Without Debugging or by pressing Ctrl+F5.

    Visual Studio erstellt die App neu, und Sie werden im nun geöffneten Konsolenfenster zur Eingabe Ihres Namens aufgefordert.Visual Studio rebuilds the app, and a console window opens and prompts you for your name.

  10. Geben Sie Ihren Namen im Konsolenfenster ein, und drücken Sie die EINGABETASTE.Enter your name in the console window and press Enter.

    Konsolenfenster

  11. Drücken Sie eine beliebige Taste, um das Konsolenfenster zu schließen und das ausgeführte Programm zu beenden.Press any key to close the console window and stop the running program.

Verwenden von Refactoring und IntelliSenseUse refactoring and IntelliSense

Im Folgenden werden einige Methoden erläutert, wie Sie mit Refactoring und IntelliSense effizienter programmieren können.Let's look at a couple of the ways that refactoring and IntelliSense can help you code more efficiently.

Benennen Sie zunächst die Variable name um:First, let's rename the name variable:

  1. Doppelklicken Sie auf die Variable name, um sie auszuwählen.Double-click the name variable to select it.

  2. Geben Sie den neuen Namen (username) der Variable ein.Type in the new name for the variable, username.

    Achten Sie auf das graue Feld, das die Variable umgibt und auf die Glühbirne, die am Rand angezeigt wird.Notice that a gray box appears around the variable, and a light bulb appears in the margin.

  1. Klicken Sie auf das Glühbirnensymbol, um die verfügbaren Schnellaktionen anzuzeigen.Select the light bulb icon to show the available Quick Actions. Klicken Sie auf 'name' in 'username' umbenennen.Select Rename 'name' to 'username'.

    Umbenennen einer Aktion in Visual Studio

    Die Variable wird für im gesamten Projekt umbenannt, in diesem Fall betrifft dies nur zwei Stellen.The variable is renamed across the project, which in our case is only two places.

    Animiertes GIF, das das Refactoring „Umbenennen“ in Visual Studio anzeigt

  1. Klicken Sie auf das Glühbirnensymbol, um die verfügbaren Schnellaktionen anzuzeigen.Select the light bulb icon to show the available Quick Actions. Klicken Sie auf 'name' in 'username' umbenennen.Select Rename 'name' to 'username'.

    Umbenennen einer Aktion in Visual Studio

    Die Variable wird für im gesamten Projekt umbenannt, in diesem Fall betrifft dies nur zwei Stellen.The variable is renamed across the project, which in our case is only two places.

  1. Im Folgenden wird IntelliSense näher erläutert.Now let's take a look at IntelliSense. Geben Sie unterhalb der Zeile Console.WriteLine($"\nHello {username}!"); DateTime now = DateTime. ein.Below the line that says Console.WriteLine($"\nHello {username}!");, type DateTime now = DateTime..

    Ein Feld zeigt die Members der Klasse DateTime an.A box displays the members of the DateTime class. Darüber hinaus wird die Beschreibung des aktuell ausgewählten Members in einem separaten Feld angezeigt.In addition, the description of the currently selected member displays in a separate box.

    Auflistung von Members durch IntelliSense in Visual Studio

  2. Wählen Sie den Member Now aus, bei dem es sich um eine Eigenschaft der Klasse handelt, indem Sie auf diesen doppelklicken oder die TAB-Taste drücken. Vervollständigen Sie die Codezeile, indem Sie ein Semikolon am Ende hinzufügen.Select the member named Now, which is a property of the class, by double-clicking on it or pressing Tab. Complete the line of code by adding a semi-colon to the end.

  3. Geben Sie darunter folgende Codezeilen ein, oder kopieren Sie diese:Below that, type in or paste the following lines of code:

    int dayOfYear = now.DayOfYear;
    
    Console.Write("Day of year: ");
    Console.WriteLine(dayOfYear);
    

    Tip

    Console.Write ist ein wenig anders als Console.WriteLine, denn es fügt nach dem Einfügen kein Zeilenabschlusszeichen hinzu.Console.Write is a little different to Console.WriteLine in that it doesn't add a line terminator after it prints. Das bedeutet, dass der nächste Textabschnitt, der an die Ausgabe gesendet wird, in der gleichen Zeile ausgegeben wird.That means that the next piece of text that's sent to the output will print on the same line. Sie können auf jede dieser Methoden in Ihrem Code zeigen, um deren Beschreibung anzuzeigen.You can hover over each of these methods in your code to see their description.

  4. Anschließend wird erneut ein Refactoring durchgeführt, um den Code etwas präziser zu gestalten.Next, we'll use refactoring again to make the code a little more concise. Klicken Sie in der Zeile DateTime now = DateTime.Now; auf die Variable now.Click on the variable now in the line DateTime now = DateTime.Now;.

    Beachten Sie, dass ein kleines Schraubendrehersymbol am Rand dieser Zeile angezeigt wird.Notice that a little screwdriver icon appears in the margin on that line.

  5. Klicken Sie auf das Schraubendrehersymbol, um zu sehen, welche Vorschläge Visual Studio macht.Click the screwdriver icon to see what suggestions Visual Studio has available. In diesem Fall zeigt es das Refactoring Inline temporär variabel an, um eine Codezeile zu entfernen, ohne das gesamte Verhalten des Codes zu ändern:In this case, it's showing the Inline temporary variable refactoring to remove a line of code without changing the overall behavior of the code:

    Refactoring „Inline temporär variabel“ in Visual Studio

  6. Klicken Sie auf Inline temporär variabel, um den Code umzugestalten.Click Inline temporary variable to refactor the code.

  1. Führen Sie das Programm erneut aus, indem Sie STRG+F5 drücken.Run the program again by pressing Ctrl+F5. Die Ausgabe sieht in etwa folgendermaßen aus:The output looks something like this:

    Konsolenfenster mit Programmausgabe

  1. Führen Sie das Programm erneut aus, indem Sie STRG+F5 drücken.Run the program again by pressing Ctrl+F5. Die Ausgabe sieht in etwa folgendermaßen aus:The output looks something like this:

    Konsolenfenster mit Programmausgabe

Debuggen von CodeDebug code

Wenn Sie Code schreiben, müssen Sie ihn auszuführen und auf Fehler prüfen.When you write code, you need to run it and test it for bugs. Mit dem Debugsystem von Visual Studio können Sie Ihren Code Anweisung für Anweisung durchlaufen und dabei die Variablen untersuchen.Visual Studio's debugging system lets you step through code one statement at a time and inspect variables as you go. Sie können Breakpoints festlegen, mit denen die Codeausführung an einer bestimmten Zeile beendet wird.You can set breakpoints that stop execution of the code at a particular line. Sie können sehen, wie sich der Wert einer Variablen bei der Codeausführung ändert, und vieles mehr.You can observe how the value of a variable changes as the code runs, and more.

Legen Sie einen Breakpoint fest, um den Wert der Variable username zu sehen, während das Programm ausgeführt wird.Let's set a breakpoint to see the value of the username variable while the program is "in flight".

  1. Suchen Sie die Codezeile Console.WriteLine($"\nHello {username}!");.Find the line of code that says Console.WriteLine($"\nHello {username}!");. Wenn Sie einen Breakpoint für diese Codezeile festlegen, damit die Ausführung des Programms an dieser Zeile angehalten wird, klicken Sie auf den äußeren linken Rand des Editors.To set a breakpoint on this line of code, that is, to make the program pause execution at this line, click in the far left margin of the editor. Sie können auch an einer anderen Stelle der Codezeile klicken und dann F9 drücken.You can also click anywhere on the line of code and then press F9.

    Ein roter Kreis wird am äußeren linken Rand angezeigt, und der Code wird rot hervorgehoben.A red circle appears in the far left margin, and the code is highlighted in red.

    Breakpoint an einer Codezeile in Visual Studio

  2. Starten Sie das Debuggen, indem Sie auf Debuggen > Debuggen starten klicken oder F5 drücken.Start debugging by selecting Debug > Start Debugging or by pressing F5.

  3. Wenn das Konsolenfenster angezeigt wird und Sie nach Ihrem Namen fragt, geben Sie diesen ein, und drücken Sie die EINGABETASTE.When the console window appears and asks for your name, type it in and press Enter.

    Der Fokus kehrt zum Code-Editor von Visual Studio zurück und die Codezeile mit dem Breakpoint wird gelb hervorgehoben.The focus returns to the Visual Studio code editor and the line of code with the breakpoint is highlighted in yellow. Das bedeutet, dass dies die nächste Codezeile ist, die vom Programm ausgeführt wird.This signifies that it's the next line of code that the program will execute.

  4. Zeigen Sie mit der Maus auf die Variable username, um deren Wert anzuzeigen.Hover your mouse over the username variable to see its value. Alternativ können Sie mit der rechten Maustaste auf username klicken und Überwachung hinzufügen auswählen, um die Variable zum Überwachungsfenster hinzuzufügen. Dort wird deren Wert ebenfalls angezeigt.Alternatively, you can right-click on username and select Add Watch to add the variable to the Watch window, where you can also see its value.

    Variablenwert während des Debuggens in Visual Studio

  5. Drücken Sie erneut F5, damit das Programm bis zum Abschluss ausgeführt wird.To let the program run to completion, press F5 again.

Weitere Informationen über den Debugprozess in Visual Studio finden Sie unter Tour zu den Debuggerfeatures.To get more details about debugging in Visual Studio, see Debugger feature tour.

Anpassen von Visual StudioCustomize Visual Studio

Sie können die Benutzeroberfläche von Visual Studio personalisieren und beispielsweise das Standardfarbdesign ändern.You can personalize the Visual Studio user interface, including change the default color theme. So ändern Sie das Design in Dunkel:To change to the Dark theme:

  1. Klicken Sie auf der Menüleiste auf Extras > Optionen, um das Dialogfeld Optionen zu öffnen.On the menu bar, choose Tools > Options to open the Options dialog.
  1. Ändern Sie auf der Optionenseite Umgebung > Allgemein die Auswahl für Farbdesign in Dunkel, und wählen Sie anschließend OK aus.On the Environment > General options page, change the Color theme selection to Dark, and then choose OK.

    Das Farbdesign wird für die gesamte IDE in Dunkel geändert.The color theme for the entire IDE changes to Dark.

    Visual Studio im Design „Dunkel“

  1. Ändern Sie auf der Optionenseite Umgebung > Allgemein die Auswahl für Farbdesign in Dunkel, und wählen Sie anschließend OK aus.On the Environment > General options page, change the Color theme selection to Dark, and then choose OK.

    Das Farbdesign wird für die gesamte IDE in Dunkel geändert.The color theme for the entire IDE changes to Dark.

    Visual Studio im Design „Dunkel“

Weitere Informationen dazu, wie Sie die IDE personalisieren können, finden Sie unter Personalisieren der Visual Studio-IDE.To learn about other ways you can personalize the IDE, see Personalize Visual Studio.

Nächste SchritteNext steps

Informationen zu weiteren Features von Visual Studio finden Sie in den folgenden Artikeln:Explore Visual Studio further by following along with one of these introductory articles:

Wenn Sie sich ausführlicher mit dem Codieren beschäftigen möchten, erhalten Sie weitere Informationen in den folgenden sprachspezifischen Schnellstarts:If you're ready to dive into more coding, one of the following language-specific quickstarts is a good next step:

Siehe auchSee also