Primary SMTP addresses are displayed incorrectly or secondary SMTP addresses are missing
Original KB number: 3173405
Problem
When you sync users to Exchange Online, the primary SMTP address is shown incorrectly as user@contoso.onmicrosoft.com or the secondary SMTP address is missing. Depending on your configuration, this may cause mail routing issues and generate non-delivery reports (NDRs) for these recipients.
For example, you receive an NDR that contains the following error message:
554 5.4.14 Hop Count exceeded - possible mail loop ATTR34
Cause
This behavior occurs by design when you have one or more unverified domains in Microsoft 365.
Solution
To resolve this behavior, add and verify the missing domains. For the steps, see Add a domain to Microsoft 365.
If this fix doesn't fit or work for your business needs, contact Support for further assistance.
More information
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