"An error has occurred" message when you load an Access web app in Internet Explorer
Symptoms
When you try to load a Microsoft Access web app in Internet Explorer, the app may not load completely, and then you receive an "Error has occurred. Sorry, something went wrong. Please try again later" error message.
Note
The "TECHNICAL DETAILS" section of the error does not show a value for the Correlation ID.
Cause
Internet Explorer imposes a time-out limit for the server to return data through the ReceiveTimeout registry key. The value that's specified for this time-out may have been changed to a value that's less than what's needed for the server to respond to the Access app request.
Resolution
To resolve this issue, change the default time-out setting for Internet Explorer by following these steps:
Important
This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information, see How to back up and restore the registry in Windows.
Start Registry Editor.
Locate the following subkey:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
In this subkey, add a
ReceiveTimeout
DWORD entry that has a value of (<number of seconds>)*1000. For example, if you want the time-out duration to be 5 minutes, set the value of theReceiveTimeout
entry to 300000 (<300>*1000).Restart the computer.
Note
This setting becomes the new global timeout which applies to both Internet Explorer and any WinINet application.
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