question

healee-5771 avatar image
2 Votes"
healee-5771 asked HughF-6374 answered

How to change network settings from public to private?

I have a crossover cable connecting a Windows 10 and a Windows 7 system. They are connected but can't see each other. Both show public network. I would like to be able to copy files across using the connection. I don't have other network or router to use.

I don't seem to be able to find Open Start > Settings > Network & Internet, under Change your network settings, click Sharing options. As far as I know the system is up to date.

Windows 10 Version 2004 (OSBuild 19041.450)

windows-10-network
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,
Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

2 Votes 2 ·
SSengupta-4080 avatar image
4 Votes"
SSengupta-4080 answered POFFE-2124 published


  1. Open Settings.

  2. Click on the Network and Internet icon.

  3. As you are using a wired connection, click on Ethernet.

  4. Click on the connection name on the right. In my case, it is named just "Network".

  5. Turn on the desired option


· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

How long it took forever turnén it off in a second


List item



0 Votes 0 ·
KapilArya avatar image
0 Votes"
KapilArya answered MeganLacey-5531 published

Hello,

See if this helps you:

https://www.kapilarya.com/switch-network-from-public-to-private-and-domain-windows-10

Hope this helps!

Note: Included link in this reply refers to blog post by a trusted Microsoft MVP.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

This article was very helpful! Thanks!

0 Votes 0 ·
GloriaGu-MSFT avatar image
16 Votes"
GloriaGu-MSFT answered EmilyReinhart-9297 commented

Hi,

In regards to your issue, here're my suggestions:

You can use PowerShell command to change network settings from public to private: Run PS as administrater

  1. Get-NetConnectionProfile and press Enter. Information is then shown about the active network connection.

  2. Set-NetConnectionProfile -Name "NetworkName" -NetworkCategory Private. Replace NetworkName with the value of the Name field shared by the previous command.
    To double check that the network location was changed, run the Get-NetConnectionProfile again and see the results. The NetworkCategory field should have a different value.

19724-2.png

  1. You can open sharing options for different network profiles in Control Panel> Network and sharing center> Advanced sharing settings

19742-3.png

-------If my answer is helpful to you, please remember to mark them as answer. Thank you!------


Regards
Gloria



2.png (22.0 KiB)
3.png (23.4 KiB)
· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi,
Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

1 Vote 1 ·

It works by why in the world do users have to jump these command line hoops instead of using the windows control panel or settings GUI?

3 Votes 3 ·

Used the Powershell as Admin
Typed in your commands as you listed them.
It accepted the commands
But did not change the network to private.
This is my home network. I have Windows 10 Ver 2004
Been working on the problem for a long time this year.
Can't get the network to say private no matter what I do.
Help

1 Vote 1 ·

Tried the method mentioned just above yours of modifying the registry value & rebooting - that worked for about 10 seconds, then one of my various protection softwares put it back (go figure, the software did it's job!)

Your option worked, and my machine has been showing 'private network' for more than 20 minutes, and stayed as such after reboot.

thank you muchly!

0 Votes 0 ·
AnasPV-3591 avatar image
0 Votes"
AnasPV-3591 answered

HI ,
Try Changing this
Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings

You can find all networks below as drop down menu

Make sure IP's Configurations are proper .Both PC's IP should be on same network ,Automatically its not going to connect since you don't have router or switch
1.Default gateway should be same for both PC's
2.Ip's of systems should be on same network
try to ping each other

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

HughF-6374 avatar image
0 Votes"
HughF-6374 answered

@GloriaGu-MSFT That has helped, thanks. There is no guarantee that the NLA service won't change it back again!
I still have a problem that it won't let me turn network discovery on - I turn it on in Advanced sharing settings, Save changes, then go back in and it's off again. More searching needed.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.