Sleep issues after Windows 7 SP1 installation

Some customers reported the issues of power management.

Symptom:

Prior to the SP1 installation the system properly went into sleep mode and properly woke up. But, after installing Windows 7 SP1 you may be not able to properly put the system into sleep mode.

You have to press the power button to force the system restart, and it will show an error that the machine was not shut down properly.

Resolution:

Please try the following methods:

1. Install the following hotfix:

A crash memory dump file is not created, or hibernation does not work, when you use a SCSIport miniport driver as the startup device driver in Windows 7 or in Windows Server 2008 R2

http://support.microsoft.com/kb/2495523

2. If the above hotfix didn't resolve the issue, try:

  • Open "Power options" in the control panel.
  • Change the active power plan by clicking the "Change plan settings".
  • Then click "Change the advanced power settings".
  • Scroll down the "Sleep" option and expand it.
  • Change the option "Allow hyprid sleep" to off.
  • Click "OK".

*note*: Someone said the issue was also fixed by switching "Internet Explorer" ->"JavaScript Timer Frequency" to "Maximum Power Savings".

Reference:

========

http://social.technet.microsoft.com/Forums/en-US/w7itproinstall/thread/822d20b5-862d-4d62-b4aa-b13a83975709/

http://social.technet.microsoft.com/Forums/en-US/w7itproperf/thread/f3339d0f-d115-42c4-b5c7-7b4897315956

http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/e6afead7-d70a-472f-8f18-26bca208b571/

http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/69b8c603-c3a5-4d12-a6f7-24c8d88d59da/

http://social.technet.microsoft.com/Forums/kk-KZ/w7itproSP/thread/d1ce698f-7c4e-4c12-acf4-eaf1aeb7e542

http://social.technet.microsoft.com/Forums/en/w7itproinstall/thread/2cadc5dd-0236-4b12-9f18-c862478c5b5e

http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_update/sp1-disables-sleep-function/cb5397b4-e312-4883-9963-a7271734991e