Update Rollup for the Hyper-V Role – Important if you are running Nehalem 5500 CPU's

So, I logged into my lab this morning to once again find that BOTH of my Hyper-V server’s had restarted because of a blue screen issue.

This is what I saw:

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7600.2.0.0.274.10
Locale ID: 1033

Additional information about the problem:
BCCode: 101
BCP1: 000000000000000D
BCP2: 0000000000000000
BCP3: FFFFF880022E2180
BCP4: 000000000000000C
OS Version: 6_1_7600
Service Pack: 0_0
Product: 274_3

These are HP Server’s running dual Intel Xeon 5520 Nehalem CPU’s.

Ah, what to do…

  • I download the x64 Debugger Tool and install that.  I need to see what the dump says about this issue…
  • After the install, click START and type “windbg” and run that application
  • The first thing you’ll want to do there is point the debugger to the symbols path by using FILE –> SYMBOL FILE PATH.  Use this URL: http://msdl.microsoft.com/download/symbols
  • After that, you get to open the minidump file.  Windows typically sticks them in the \windows\minidump folder unless you change it.
  • Click FILE –> OPEN CRASH DUMP
  • Browse to the location of the dump file you want to examine and open
  • It will take a minute for it to complete, be patient. :)

Now, when I first ran this on my server – it came up with this:

image

Make sure you click the link to ANALYZE –V to get detailed debugging information.  In my case, this came up:

image

So, now I know the issue.

The Fix:

http://support.microsoft.com/kb/2264080

If your servers are set for automatic updates – you’re probably OK.  In my lab, I had them set for manual updates and I hadn’t done anything since sometime in June.  There is a very recent rollup that addresses this specific issue.  I just patched my machine (after running WU, the rollup package was in the list) and hopefully we’re done with this.

Another option is to install the SP1 Beta – the rollup is in there as well.

Happy patching!!