SQL Server 2005 Service Pack 2 (SP2) post fixes explained - 9.0.3054 OR 9.0.3059

This is from Bob Ward's Blog - http://blogs.msdn.com/psssql/archive/2007/04/06/post-sql-server-2005-service-pack-2-sp2-fixes-explained.aspx  

This is the summary from his blog above. It is very good information. Bob did very good job of explaining this in detail.     

Summary:

I don't have SQL Server 2005 SP2 yet

  1. Apply SP2 from http://www.microsoft.com/downloads/details.aspx?familyid=D07219B2-1E23-49C8-8F0C-63FA18F26D3A&displaylang=en
  2. Apply GDR2 from http://support.microsoft.com/?kbid=934458 (Microsoft Update will also notify you of this after you applied SP2)
  3. You will now be on version 9.00.3054

I installed SP2 but don't know if I applied this before March 5th

  1. Don't worry about checking when you applied SP2, just go right to GDR2 athttp://support.microsoft.com/?kbid=934458 (Microsoft Update may have already notified you)
  2. You will now be on version 9.00.3054

I have applied SP2 and the GDR1 fix

  1. You should have a version of 9.00.3050
  2. If you do, then apply GDR2 at http://support.microsoft.com/?kbid=934458 (Microsoft Update will also notify you of this)
  3. You will now be on version 9.00.3054

I think I was provided a hotfix that did not make it into SP2 but now I want to install SP2

  1. I hope you already know if you applied a hotfix that falls under this category, but if not you can check the version of SQLSERVR.EXE. If you have a version between 9.0.2214 through build 9.0.2219 then this set of steps applies to you. (DO NOT USE THESE STEPS IF YOU ARE NOT USING THESE BUILDS)
  2. If you are in this situation, first apply SP2. Do not delay in moving to step #3. Do it immediately after applying SP2. This is because if you wait and are subscribed to Microsoft Update you may get notified to apply GDR2 (build 9.00.3054). 9.00.3054 is not the build you want if you are in this scenario.
  3. Now apply the cumulative hotfix package at http://support.microsoft.com/default.aspx?scid=kb;EN-US;933097
  4. Now apply GDR2 Hotfix that applies only to the cumulative hotfix package at http://support.microsoft.com/kb/934459/ (Microsoft Update is smart enough to recognize you need this specific version of the GDR2 fix as well once you have applied build 9.00.3152).
  5. You should now be at version 9.00.3159

So as you can see from this summary, after applying the critical updates you should be on either build 9.00.3054 or 9.00.3159.