Scenario: Port conflict when starting services in Azure HDInsight

This article describes troubleshooting steps and possible resolutions for issues when interacting with Azure HDInsight clusters.

Issue

A service fails to start.

Cause

A port conflict exists.

Resolution

Method 1

Use below commands to get/kill all the running processes, which are affected by the port issue.

netstat -lntp | grep <port>
ps -ef | grep <service>
kill -9 <service>

Then start service.

Method 2

Reboot the node.

Next steps

If you didn't see your problem or are unable to solve your issue, visit one of the following channels for more support:

  • Get answers from Azure experts through Azure Community Support.

  • Connect with @AzureSupport - the official Microsoft Azure account for improving customer experience. Connecting the Azure community to the right resources: answers, support, and experts.

  • If you need more help, you can submit a support request from the Azure portal. Select Support from the menu bar or open the Help + support hub. For more detailed information, review How to create an Azure support request. Access to Subscription Management and billing support is included with your Microsoft Azure subscription, and Technical Support is provided through one of the Azure Support Plans.