Install the .NET Framework on Windows XP and Windows Server 2003

Note

Windows XP is no longer supported by Microsoft. We recommend you upgrade to Windows 10, which is supported and includes the latest version of the .NET Framework. This document is provided solely as a helpful troubleshooting guide.

The .NET Framework is required to run many applications on Windows. You can use the following instructions to install it. You may have arrived on this page after trying to run an application and seeing the following dialog on your machine.

This application could not be started

These instructions will help you install the .NET Framework versions you need. The .NET Framework 4.8 is the latest version. It is not supported on Windows XP and Windows Server 2003. It is included with Windows 10 May 2019 Update.

.NET Framework 4.0.3

The .NET Framework 4.0.3 is the latest supported .NET Framework version on Windows XP and Windows Server 2003. The .NET Framework 4.0.3 requires that the .NET Framework 4 is installed first. Both of these .NET Framework versions are no longer supported by Microsoft.

.NET Framework 4

You can install the .NET Framework 4 on Windows XP. It's no longer supported by Microsoft.

.NET Framework 3.5

You can install the .NET Framework 3.5 on Windows XP.

The .NET Framework 3.5 can be used to run applications built for .NET Framework 1.0 through 3.5.

See also