Getting started

Requirements

The Microsoft IIS Administration API supports Windows 7 and above.

The IIS Administration API depends on .NET Core and will automatically download and install it if it is not present on the machine

Installing

The latest version of the Microsoft IIS Administration API is available for download here.

After installation is a perfect time to configure the service for its intended purpose. To get a better idea of what the API has to offer take a look at the built-in API explorer. To learn how to use the web UI at manage.iis.net read the page on connecting to the management portal