Duplicate phone calls are created when you use Sales accelerator

This article provides a resolution for an issue where duplicate phone calls are created when you use the Sales accelerator in Microsoft Dynamics 365 Sales.

Symptoms

When you make a call from the Sales accelerator in Dynamics 365, multiple phone calls are created for the same call.

Cause

This issue occurs because both the Sales accelerator and Microsoft Teams dialer create a phone call.

Resolution

To resolve this issue, select the Exclude phone call activities checkbox on the Sequence activities page to avoid creating a duplicate phone call activity.

Screenshot that shows the Exclude phone call activities checkbox on the Sequence activities page of Sales accelerator settings.