"Smtp server returned GeneralOutgoingEmailServerError GeneralFailure exception" warning is logged when using Gmail to send email from Microsoft Dynamics 365
This article provides a solution to an error that occurs when using Gmail to send email from Dynamics 365.
Applies to: Microsoft Dynamics 365
Original KB number: 4341507
Symptoms
When using Gmail to send email from Dynamics 365, emails aren't sent and appear in a Pending Send status. If you open the mailbox record in Dynamics 365 and select Alerts, you see the following warning:
"An unexpected error occurred while sending the email message [Email Subject] through the mailbox [Mailbox Name]. The owner of the associated email server profile [Email Server Profile name] has been notified. The system will try to send the message again later.
Email Server Error Code: Smtp server returned GeneralOutgoingEmailServerError GeneralFailure exception."
Cause
This message may be logged if you exceed the number of emails that Gmail allows you to send from a single mailbox.
Resolution
For more information about sending limits from Gmail, see Gmail sending limits in Google Workspace.
If you need to send bulk emails, a solution such as Dynamics 365 for Marketing or another solution designed for sending large numbers of emails should be used.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
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