Tutorial: Get started with C# and ASP.NET Core in Visual Studio

In this tutorial for C# development with ASP.NET Core using Visual Studio, you'll create a C# ASP.NET Core web app, make changes to it, explore some features of the IDE, and then run the app.

If you haven't already installed Visual Studio, go to the Visual Studio downloads page to install it for free.

Create a project

First, you'll create a ASP.NET Core project. The project type comes with all the template files you'll need for a fully functional website, before you've even added anything!

  1. Open Visual Studio 2017.

  2. From the top menu bar, choose File > New > Project.

  3. In the New Project dialog box in the left pane, expand Visual C#, expand Web, and then choose .NET Core. In the middle pane, choose ASP.NET Core Web Application. Then, name the file MyCoreApp and choose OK.

    ASP.NET Core Web Application project template in the New Project dialog box in the Visual Studio IDE

Add a workload (optional)

If you don't see the ASP.NET Core Web Application project template, you can get it by adding the ASP.NET and web development workload. You can add this workload in one of the two following ways, depending on which Visual Studio 2017 updates are installed on your machine.

Option 1: Use the New Project dialog box

  1. Select the Open Visual Studio Installer link in the left pane of the New Project dialog box.

    Select the Open Visual Studio Installer link from the New Project dialog box

  2. The Visual Studio Installer launches. Choose the ASP.NET and web development workload, and then choose Modify.

    .NET Core cross-platform development workload in the Visual Studio Installer

    (You might have to close Visual Studio before you can continue installing the new workload.)

Option 2: Use the Tools menu bar

  1. Cancel out of the New Project dialog box. Then, from the top menu bar, choose Tools > Get Tools and Features.

  2. The Visual Studio Installer launches. Choose the ASP.NET and web development workload, and then choose Modify.

    (You might have to close Visual Studio before you can continue installing the new workload.)

Add a project template

  1. In the New ASP.NET Core Web Application dialog box, choose the Web Application project template.

  2. Verify that ASP.NET Core 2.1 appears in the top drop-down menu. Then, choose OK.

    New ASP.NET Core Web Application dialog box

About your solution

This solution follows the Razor Page design pattern. It is different than the Model-View-Controller (MVC) design pattern in that its streamlined to include the model and controller code within the Razor Page itself.

Tour your solution

  1. The project template creates a solution with a single ASP.NET Core project that is named MyCoreApp. Choose the Solution Explorer tab to view its contents.

    ASP.NET Solution Explorer in Visual Studio for Razor Pages solution that is named MyCoreApp

  2. Expand the Pages folder, and then expand About.cshtml.

    The About.cshtml file in the Solution Explorer in Visual Studio

  3. View the About.cshtml file in the code editor.

    View the About.cshtml file in the Visual Studio code editor

  4. Choose the About.cshtml.cs file.

    Choose the About.cshtml.cs file in the Visual Studio code editor

  5. View the About.cshtml.cs file in the code editor.

    View the About.cshtml file in the Visual Studio code editor

  6. The project contains a wwwroot folder that is the root for your website. Expand the folder to view its contents.

    wwwroot folder in the Solution Explorer in Visual Studio

    You can put static site content—such as CSS, images, and JavaScript libraries—directly in the paths where you want them.

  7. The project also contains configuration files that manage the web app at runtime. The default application configuration is stored in appsettings.json. However, you can override these settings by using appsettings.Development.json. Expand the appsettings.json file to view the appsettings.Development.json file.

    Configuration files in the Solution Explorer in Visual Studio

Run, debug, and make changes

  1. Choose the IIS Express button in the IDE to build and run the app in Debug mode. (Alternatively, press F5, or choose Debug > Start Debugging from the menu bar.)

    Select the IIS Express button in Visual Studio

    Note

    If you get an error message that says Unable to connect to web server 'IIS Express', close Visual Studio and then open it by using the Run as administrator option from the right-click or context menu. Then, run the application again.

  2. Visual Studio launches a browser window. You should then see Home, About, and Contact pages in the menu bar. (If you do not, choose the "hamburger" menu item to view them.)

    Select the "hamburger" menu item from the menu bar in your web app

  3. Choose About from the menu bar.

    Select About in the browser window's menu bar for your app

    Among other things, the About page in the browser renders the text that is set in the About.cshtml file.

    View the text on the About page

  4. Keep the browser window open and return to Visual Studio.

  5. In Visual Studio, choose About.cshtml. Then, delete the word additional and in its place, add the words file and directory.

    Change the text in the About.cshtml file

  6. Choose About.cshtml.cs. Then, clean up the using directives at the top of the file by using the following shortcut:

    Choose any of the grayed-out using directives and a Quick Actions light bulb will appear just below the caret or in the left margin. Choose the light bulb, and then choose Remove Unnecessary Usings.

    Remove unnecessary Usings in the About.cshtml.cs file

    Visual Studio deletes the unnecessary using directives from the file.

  7. Next, in the OnGet() method, change the body to the following code:

    public void OnGet()
    {
        string directory = Environment.CurrentDirectory;
    Message = String.Format("Your directory is {0}.", directory);
    }
    
  8. Notice that two wavy underlines appear under Environment and String. The wavy underlines appear because these types are not in scope.

    Errors marked with wavy underlines in OnGet method

    Open the Error List toolbar to see the same errors listed there. (If you don't see the Error List toolbar, choose View > Error List from the top menu bar.)

    Error List in Visual Studio

  9. Let's fix this. In the code editor, place your cursor on either line that contains the error, and then choose the Quick Actions light bulb in the left margin. Then, from the drop-down menu, choose using System; to add this directive to the top of your file and resolve the errors.

    Add the "using System;" directive

  10. Press Ctrl+S to save your changes and refresh your app in the web browser.

  11. At the top of the web site, choose About to view your changes.

    View the updated About page that includes the changes you made

  12. Close the web browser, press Shift+F5 to stop Debug mode, and then close Visual Studio.

Quick answers FAQ

Here's a quick FAQ to highlight some key concepts.

What is C#?

C# is a type-safe and object-oriented programming language that's designed to be both robust and easy to learn.

What is ASP.NET Core?

ASP.NET Core is an open-source and cross-platform framework for building internet-connected applications, such as web apps and services. ASP.NET Core apps can run on either .NET Core or the .NET Framework. You can develop and run your ASP.NET Core apps cross-platform on Windows, Mac, and Linux. ASP.NET Core is open source at GitHub.

What is Visual Studio?

Visual Studio is an integrated development suite of productivity tools for developers. Think of it as a program you can use to create programs and applications.

Next steps

Congratulations on completing this tutorial! We hope you learned a little bit about C#, ASP.NET Core, and the Visual Studio IDE. To learn more about creating a web app or website with C# and ASP.NET, continue with the following tutorials:

See also

Publish your web app to Azure App Service by using Visual Studio