IEditionUpgradeHelper::CanUpgrade method (editionupgradehelper.h)

Checks if the user has sufficient permissions to upgrade the operating system, and prompts the user to run as an administrator if needed.

Syntax

HRESULT CanUpgrade(
  BOOL *isAllowed
);

Parameters

isAllowed

TRUE if the user has sufficient permissions to upgrade the operating system; otherwise FALSE.

Return value

If this method succeeds, it returns S_OK. Otherwise, it returns an HRESULT error code.

Requirements

   
Minimum supported client Windows 10 [desktop apps only]
Minimum supported server Windows Server 2016 [desktop apps only]
Target Platform Windows
Header editionupgradehelper.h

See also

IEditionUpgradeHelper