Xamarin.iOS Installation

Required Components

To build for Xamarin.iOS, the following are required:

  • the latest iOS SDK
  • the latest version of Xcode
  • macOS High Sierra (10.13) and above

The latest version of Xcode can be downloaded from the iOS Developer Center (login required), or via the Mac App Store:

Mac Installation

For instructions on installing Xamarin.iOS on a Mac, visit the Mac Installation guide.

Windows Installation

For instructions on installing Xamarin.iOS on a Windows machine, visit the Windows Installation guide.

Development and Device Provisioning

Once you have successfully installed Xamarin.iOS, learn how to provision your iOS device so that you can develop and test a Xamarin.iOS application on device.