Trabajar con R en Visual Studio

R es un entorno y lenguaje muy extensible para cálculos estadísticos y gráficos. Se distribuye de forma gratuita bajo la Licencia para el Público en General GNU, cuenta con soporte técnico de la comunidad seguro y se conoce por su capacidad para generar gráficos con calidad de publicación, como fórmulas y símbolos matemáticos. Puede obtener más información sobre R en r project.org y An Introduction to R (Introducción a R).

R Tools para Visual Studio (RTV) es una extensión de código abierto gratis para Visual Studio 2017 y Visual Studio 2015 Update 3 (o posterior), publicada bajo licencia MIT. (Un segundo componente de código abierto denominado RHost, que se enlaza a los binarios del intérprete de R, se ha publicado bajo la Licencia para el Público GNU V2).

Nota

Actualmente, RTVS solo se admite en Visual Studio 2017 en Windows y no en Visual Studio para Mac. Aún no está disponible para Visual Studio 2019.

Para experimentar R en Visual Studio:

A continuación, siga los vínculos que aparecen a continuación para obtener más información sobre características relacionadas con R, así como las funcionalidades generales del propio Visual Studio.

Característica Descripción Documentación general de Visual Studio
Sistema de proyectos de Visual Studio Organice y administre archivos relacionados en una estructura práctica y aproveche plantillas útiles para elementos como código de R, documentación de R, R Markdown, consultas de SQL y procedimientos almacenados. Disfrute también del administrador de paquetes y de la integración de SQL Server. Soluciones y proyectos en Visual Studio
Área de trabajo RTVS se puede enlazar a áreas de trabajo locales y remotas, lo que le permite desarrollar código de R localmente con conjuntos de datos más pequeños para después ejecutarlo en equipos basados en la nube más eficaces con conjuntos de datos mucho más grandes. N/D
Opciones de R Tools Controlan diferentes aspectos de RTVS. Opciones (cuadro de diálogo)
Edición enriquecida, IntelliSense y fragmentos de código Incluye colores de sintaxis, IntelliSense en todo el código y las bibliotecas, formateo de código, ayuda para las firmas, Ir a definición, Buscar todas las referencias, fragmentos de código y mucho más. Características del editor de código
R Markdown Los documentos de R Markdown ayudan a compartir los resultados de datos con código de R integrado dentro de bloques de código de Markdown. N/D
Ventana interactiva Proporciona una experiencia completa de REPL para R con la capacidad de ejecutar código fácilmente en un archivo de origen en la ventana interactiva. N/D
Visualización de datos El trazado es una parte integral de la experiencia de R y RTVS admite varias ventanas de trazado independientes, cada una con su propio historial y la capacidad de mover trazados entre ventanas. Los trazados se pueden guardar en archivos de mapa de bits y PDF, o copiarse al Portapapeles como un mapa de bits o metarchivo. N/D
Explorador de variables Examine variables en los ámbitos globales o específicos del paquete, con la capacidad de ver tablas que se puede ordenar y exportar a CSV. N/D
Depuración repleta de características Incluye integración con la ventana interactiva. Depurar en Visual Studio

Vea también las preguntas más frecuentes.

icono de cámara de vídeo Vea un vídeo (youtube.com) de una introducción a Herramientas de R para Visual Studio (12 min 36 s). Vea también más vídeos sobre Herramientas de R.

Envíenos sus comentarios.

  1. Problemas de GitHub: la mejor forma de ponerse en contacto con el equipo de RTVS es archivar un problema en GitHub, o mediante el menú R Tools > Comentarios.

  2. Enviar una sonrisa o una desaprobación: el menú R Tools > Comentarios es una manera rápida de enviar comentarios y adjuntar archivos de registro de RTVS para ayudar en el diagnóstico del problema. (Los registros se escriben en %temp%/RTVSlogs.zip, en caso de que quiera enviarlos por separado). Si ha desactivado la telemetría de Visual Studio a través del comando de menú Ayuda > Comentarios > Configuración o durante la instalación, el registro está deshabilitado.

  3. Correo electrónico: puede enviar comentarios directamente al equipo a rtvsuserfeedback (arroba) microsoft.com.