Implementar una solución de Office mediante ClickOnceDeploy an Office solution by using ClickOnce

Puede implementar su solución de Office en menos pasos si usa ClickOnce.You can deploy your Office solution in fewer steps if you use ClickOnce. Si publica actualizaciones, la solución las detectará e instalará automáticamente.If you publish updates, your solution will automatically detect and install them. Sin embargo, ClickOnce requiere que instale la solución por separado para cada usuario de un equipo.However, ClickOnce requires that you install your solution separately for each user of a computer. Por lo tanto, debe considerar el uso de Windows Installer (.msi) si más de un usuario ejecutará la solución en el mismo equipo.Therefore, you should consider using Windows Installer (.msi) if more than one user will run your solution on the same computer.

En este temaIn this topic

Publicar la soluciónPublish the solution

Puede publicar la solución mediante el Asistente para publicación o Diseñador de proyectos.You can publish your solution by using the Publish Wizard or the Project Designer. En este procedimiento, usará el Diseñador de proyectos porque proporciona el conjunto completo de opciones de publicación.In this procedure, you'll use the Project Designer because it provides the complete set of publishing options. Consulte Asistente para publicación (desarrollo de Office en Visual Studio).See Publish wizard (Office development in Visual Studio).

Para publicar la soluciónTo publish the solution

  1. En el Explorador de soluciones, elija el nodo que se denomina para el proyecto.In Solution Explorer, choose the node that's named for your project.

  2. En la barra de menús, elija proyecto, ProjectName propiedades.On the menu bar, choose Project, ProjectName Properties.

  3. En el Diseñador de proyectos, elija el publicar ficha, que se muestra en la siguiente ilustración.In the Project Designer, choose the Publish tab, which the following illustration shows.

    La pestaña publicar del Diseñador de proyectosThe publish tab of the Project Designer

  4. En el ubicación de la carpeta de publicación (servidor ftp o ruta de acceso de archivo) , escriba la ruta de acceso de la carpeta donde desea que el Diseñador de proyectos para copiar los archivos de solución.In the Publishing Folder Location (ftp server, or file path) box, enter the path of the folder where you want the Project Designer to copy the solution files.

    Puede especificar cualquiera de los siguientes tipos de rutas.You can enter any of the following types of paths.

    • Una ruta de acceso local (por ejemplo, C:\FolderName\FolderName).A local path (for example, C:\FolderName\FolderName).

    • Una ruta de acceso de convención de nomenclatura universal (UNC) a una carpeta en la red (por ejemplo, \\ServerName\FolderName).A Uniform Naming Convention (UNC) path to a folder on your network (for example, \\ServerName\FolderName).

    • Una ruta de acceso relativa (por ejemplo, carpetaDePublicación\, que es la carpeta en la que se publica el proyecto de forma predeterminada).A relative path (for example, PublishFolder\, which is the folder into which the project is published by default).

  5. En el dirección URL de la carpeta de instalación , escriba la ruta de acceso completa de la ubicación donde los usuarios finales encontrarán su solución.In the Installation Folder URL box, enter the fully qualified path of the location where end users will find your solution.

    Si aún no conoce la ubicación, no especifique nada en este campo.If you don't know the location yet, don't enter anything into this field. De forma predeterminada, ClickOnce busca actualizaciones en la carpeta en la que los usuarios instalan la solución.By default, ClickOnce looks for updates in the folder from which your users install the solution.

  6. Elija el botón Requisitos previos .Choose the Prerequisites button.

  7. En el requisitos previos diálogo cuadro, asegúrese de que el crear programa de instalación para instalar los componentes necesarios casilla está activada.In the Prerequisites dialog box, ensure that the Create setup program to install prerequisite components check box is selected.

  8. En el elegir qué requisitos previos para instalar lista, seleccione las casillas de verificación para Windows Installer 4.5 y el paquete de .NET Framework adecuado.In the Choose which prerequisites to install list, select the check boxes for Windows Installer 4.5 and the appropriate .NET Framework package.

    Por ejemplo, si su solución tiene como destino el .NET Framework 4.5.NET Framework 4.5, active las casillas de verificación de Windows Installer 4.5 y Microsoft .NET Framework 4.5 Full.For example, if your solution targets the .NET Framework 4.5.NET Framework 4.5, select the check boxes for Windows Installer 4.5 and Microsoft .NET Framework 4.5 Full.

  9. Si su solución tiene como destino .NET Framework 4.5, seleccione también el Visual Studio 2010 Tools para Office Runtime casilla de verificación.If your solution targets the .NET Framework 4.5, also select the Visual Studio 2010 Tools for Office Runtime check box.

    Note

    De forma predeterminada, esta casilla no aparece.By default, this check box doesn't appear. Para mostrar esta casilla, debe crear un paquete de programa previo.To show this check box, you must create a Bootstrapper package. Consulte crear un paquete de programa previo para un Office 2013 complemento VSTO con Visual Studio 2012.See Create a Bootstrapper package for an Office 2013 VSTO Add-in with Visual Studio 2012.

  10. En especificar la ubicación de instalación de requisitos previos, elija una de las opciones que aparecen y, a continuación, elijan el Aceptar botón.Under Specify the install location for prerequisites, choose one of the options that appear, and then choose the OK button.

    En la siguiente tabla se describe cada una de las opciones.The following table describes each option.

    OpciónOption DescripciónDescription
    Descargar los requisitos previos del sitio web del proveedor de los componentesDownload prerequisites from the component vendor's web site Se pedirá al usuario que descargue e instale estos requisitos previos del proveedor.The user is prompted to download and install these prerequisites from the vendor.
    Descargar los requisitos previos de la misma ubicación que mi aplicaciónDownload prerequisites from the same location as my application El software necesario se instala con la solución.The prerequisite software is installed with the solution. Si elige esta opción, Visual Studio copia automáticamente todos los paquetes de requisitos previos en la ubicación de publicación.If you choose this option, Visual Studio copies all of the prerequisite packages to the publish location for you. Para que esta opción funcione, los paquetes se deben encontrar en el equipo de desarrollo.For this option to work, the prerequisite packages must be on the development computer.
    Descargar los requisitos previos de la siguiente ubicaciónDownload prerequisites from the following location Visual Studio copia todos los paquetes de requisitos previos en la ubicación especificada y los instala con la solución.Visual Studio copies all of the prerequisite packages to the location that you specify and installs them with the solution.

    Consulte cuadro de diálogo de requisitos previos.See Prerequisites dialog box.

  11. Elija la actualizaciones botón, especifique con qué frecuencia desea que cada usuario final complementos de VSTO o personalización para comprobar si hay actualizaciones y, a continuación, elija el Aceptar botón.Choose the Updates button, specify how often you want each end user's VSTO Add-in or customization to check for updates, and then choose the OK button.

    Note

    Si va a implementar mediante un CD o una unidad extraíble, elija el buscar nunca actualizaciones botón de opción.If you're deploying by using a CD or a removable drive, choose the Never check for updates option button.

    Para obtener información sobre cómo publicar una actualización, vea publicar una actualización.For information about how to publish an update, see Publish an update.

  12. Elija la opciones botón, revise las opciones en el opciones diálogo cuadro y, a continuación, elija el Aceptar botón.Choose the Options button, review the options in the Options dialog box, and then choose the OK button.

  13. Elija la publicar ahora botón.Choose the Publish Now button.

    Visual Studio agrega las siguientes carpetas y archivos a la carpeta de publicación especificada anteriormente en este procedimiento.Visual Studio adds the following folders and files to the publishing folder that you specified earlier in this procedure.

    • El archivos de la aplicación carpeta.The Application Files folder.

    • El programa de instalaciónThe setup program.

    • Un manifiesto de implementación que apunta al manifiesto de implementación de la última versiónA deployment manifest that points to the deployment manifest of the most recent version.

      El archivos de la aplicación carpeta contiene una subcarpeta para cada versión que se publica.The Application Files folder contains a subfolder for each version that you publish. Cada subcarpeta específica de la versión contiene los archivos siguientes.Each version-specific subfolder contains the following files.

    • Un manifiesto de aplicaciónAn application manifest.

    • Un manifiesto de implementaciónA deployment manifest.

    • Ensamblados de personalizaciónCustomization assemblies.

      En la siguiente ilustración se muestra la estructura de la carpeta de publicación de un complemento de VSTO de Outlook.The following illustration shows the structure of the publish folder for an Outlook VSTO Add-in.

      Publicar la estructura de carpetasPublish Folder Structure

    Note

    ClickOnce anexa la .deploy extensión a los ensamblados para que una instalación segura de Internet Information Services (IIS) no bloquee los archivos debido a una extensión no segura.ClickOnce appends the .deploy extension to assemblies so that a secured installation of Internet Information Services (IIS) won't block the files because of an unsafe extension. Cuando el usuario instala la solución, ClickOnce quitará la .deploy extensión.When the user installs the solution, ClickOnce removes the .deploy extension.

  14. Copie los archivos de la solución en la ubicación de instalación especificada anteriormente en este procedimiento.Copy the solution files to the installation location that you specified earlier in this procedure.

Decidir cómo conceder confianza a la soluciónDecide how you want to grant trust to the solution

Para que una solución pueda ejecutarse en los equipos de los usuarios, debe conceder confianza o los usuarios deben responder al mensaje relativo a la confianza cuando instalen la solución.Before a solution can run on user computers, either you must grant trust or users must respond to a trust prompt when they install the solution. Para conceder confianza a la solución, firme los manifiestos mediante un certificado que identifique un publicador de confianza conocido.To grant trust to the solution, sign the manifests by using a certificate that identifies a known and trusted publisher. Consulte confiar en la solución de firmar los manifiestos de aplicación e implementación.See Trust the solution by signing the application and deployment manifests.

Si va a implementar una personalización de nivel de documento y desea colocar el documento en una carpeta en el equipo del usuario o que el documento esté disponible en un sitio de SharePoint, asegúrese de que Office confíe en la ubicación del documento.If you're deploying a document-level customization and you want to put the document into a folder on the user's computer or make the document available on a SharePoint site, ensure that Office trusts the location of the document. Consulte conceder confianza a los documentos.See Grant trust to documents.

Ayudar a los usuarios a instalar la soluciónHelp users install the solution

Los usuarios pueden instalar la solución, ejecute el programa de instalación, abriendo el manifiesto de implementación o durante la personalización de nivel de documento, abriendo el documento directamente.Users can install the solution by running the setup program, opening the deployment manifest, or during document-level customization, opening the document directly. El procedimiento recomendado es que los usuarios instalen la solución mediante el programa de instalación.As a best practice, users should install your solution by using the setup program. Los otros dos enfoques no garantizan que el software necesario está instalado.The other two approaches don't ensure that the prerequisite software is installed. Si los usuarios desean abrir el documento desde la ubicación de instalación, deben agregarlo a la lista de ubicaciones de confianza en el Centro de confianza de la aplicación de Office.If users want to open the document from the installation location, they must add it to the list of trusted locations in the Trust Center of the Office application.

Abrir el documento de una personalización de nivel de documentoOpening the document of a document-level customization

Los usuarios pueden abrir el documento de una personalización de nivel de documento directamente desde la ubicación de instalación o copiando el documento en el equipo local y después abriendo la copia.Users can open the document of a document-level customization directly from the installation location or by copying the document to their local computer and then opening the copy.

Como procedimiento recomendado, los usuarios deben abrir una copia del documento en sus equipos para impedir que varios usuarios intenten abrir la misma copia al mismo tiempo.As a best practice, users should open a copy of the document on their computers so that multiple users won't try to open the same copy at the same time. Para aplicar esta práctica recomendada, puede configurar el programa de instalación de forma que copie el documento en los equipos de los usuarios.To enforce this practice, you can configure your setup program to copy the document to user computers. Consulte colocar el documento de una solución en el equipo del usuario final (solo para personalizaciones de nivel de documento).See Put the document of a solution onto the end user's computer (document-level customizations only).

Instalar la solución abriendo el manifiesto de implementación desde un sitio Web de IISInstall the solution by opening the deployment manifest from an IIS website

Los usuarios pueden instalar una solución de Office abriendo el manifiesto de implementación desde la Web.Users can install an Office solution by opening the deployment manifest from the web. Sin embargo, una instalación segura de Internet Information Services (IIS) bloqueará los archivos que tienen la .vsto extensión.However, a secured installation of Internet Information Services (IIS) will block files that have the .vsto extension. El tipo MIME se debe definir en IIS para poder implementar una solución de Office mediante IIS.The MIME type must be defined in IIS before you can deploy an Office solution by using IIS.

Para agregar el tipo MIME .vsto a IIS 6.0To add the .vsto MIME type to IIS 6.0
  1. En el servidor que ejecuta IIS 6.0, elija iniciar > todos los programas > herramientas administrativas > De Internet Information Services (IIS) Manager.On the server that's running IIS 6.0, choose Start > All Programs > Administrative Tools > Internet Information Services (IIS) Manager.

  2. Elija el nombre del equipo, el sitios Web carpeta o el sitio web que está configurando.Choose the computer name, the Web Sites folder, or the web site that you're configuring.

  3. En la barra de menús, elija acción > propiedades.On the menu bar, choose Action > Properties.

  4. En el encabezados HTTP ficha, elija la tipos MIME botón.On the HTTP Headers tab, choose the MIME Types button.

  5. En el tipos MIME ventana, elija el New botón.In the MIME Types window, choose the New button.

  6. En el tipo MIME ventana, escriba .vsto como la extensión, escriba application/x-ms-vsto como MIME escriba y, a continuación, aplicar la nueva configuración.In the MIME Type window, enter .vsto as the extension, enter application/x-ms-vsto as the MIME type, and then apply the new settings.

    Note

    Para que los cambios surtan efecto, debe reiniciar el Servicio de publicación World Wide Web o esperar hasta que el proceso de trabajo se recicle.For the changes to take effect, you must restart the World Wide Web Publishing Service or wait for the worker process to recycle. Debe Vaciar caché de disco del explorador y, a continuación, intente abrir el .vsto archivo nuevo.You must then flush the browser's disk cache and then try to open the .vsto file again.

Para agregar el tipo MIME .vsto a IIS 7,0To add the .vsto MIME type to IIS 7.0
  1. En el servidor que ejecuta IIS 7.0, elija iniciar > todos los programas > Accesorios.On the server that's running IIS 7.0, choose Start > All Programs > Accessories.

  2. Abra el menú contextual para símboloy, a continuación, elija ejecutar como administrador.Open the shortcut menu for Command Prompt, and then choose Run as administrator.

  3. En el abierto cuadro, escriba la siguiente ruta de acceso y, a continuación, elija el Aceptar botón.In the Open box, enter the following path, and then choose the OK button.

    %windir%\system32\inetsrv
    
  4. Escriba el comando siguiente y, a continuación, aplique la nueva configuración.Enter the following command, and then apply the new settings.

    set config /section:staticContent /+[fileExtension='.vsto',mimeType='application/x-ms-vsto']
    

    Note

    Para que los cambios surtan efecto, debe reiniciar el Servicio de publicación World Wide Web o debe esperar hasta que el proceso de trabajo se recicle.For the changes to take effect, you must restart the World Wide Web Publishing Service, or you must wait for the worker process to recycle. Debe Vaciar caché de disco del explorador y, a continuación, intente abrir el .vsto archivo nuevo.You must then flush the browser's disk cache and then try to open the .vsto file again.

Colocar el documento de una solución en el equipo del usuario final (solo para personalizaciones de nivel de documento)Put the document of a solution onto the end user's computer (document-level customizations only)

Puede copiar el documento de la solución en el equipo del usuario final para ellos mediante la creación de una acción posterior a la implementación.You can copy the document of your solution onto the end user's computer for them by creating a post-deployment action. De este modo, el usuario no tiene que copiar manualmente el documento desde la ubicación de instalación en su equipo después de instalar la solución.That way, the user doesn't have to manually copy the document from the installation location to their computer after they install your solution. Tendrá que crear una clase que define la acción posterior a la implementación, compilar y publicar la solución, modificar el manifiesto de aplicación y volver a firmar el manifiesto de aplicación e implementación.You'll have to create a class that defines the post-deployment action, build and publish the solution, modify the application manifest, and re-sign the application and deployment manifest.

Los procedimientos siguientes se supone que es el nombre del proyecto ExcelWorkbook y publicar la solución en una carpeta creada denominada C:\publish en el equipo.The following procedures assume that your project name is ExcelWorkbook and that you publish the solution into a created folder named C:\publish on your computer.

Crear una clase que defina la acción posterior a la implementaciónCreate a class that defines the post-deployment action

  1. En la barra de menús, elija archivo > agregar > nuevo proyecto.On the menu bar, choose File > Add > New Project.

  2. En el Agregar nuevo proyecto cuadro de diálogo el plantillas instaladas panel, elija el Windows carpeta.In the Add New Project dialog box, in the Installed Templates pane, choose the Windows folder.

  3. En el plantillas panel, elija el biblioteca de clases plantilla.In the Templates pane, choose the Class Library template.

  4. En el nombre , introduzca FileCopyPDAy, a continuación, elija el Aceptar botón.In the Name field, enter FileCopyPDA, and then choose the OK button.

  5. En el Explorador de soluciones, elija el FileCopyPDA proyecto.In Solution Explorer, choose the FileCopyPDA project.

  6. En la barra de menús, elija Proyecto > Agregar referencia.On the menu bar, choose Project > Add Reference.

  7. En el .NET pestaña, agregue referencias a Microsoft.VisualStudio.Tools.Applications.Runtime y Microsoft.VisualStudio.Tools.Applications.ServerDocument.On the .NET tab, add references to Microsoft.VisualStudio.Tools.Applications.Runtime and Microsoft.VisualStudio.Tools.Applications.ServerDocument.

  8. Cambie el nombre de la clase a FileCopyPDA y reemplace el contenido del archivo con el código.Rename the class to FileCopyPDA, and then replace the contents of the file with the code. Este código realiza las tareas siguientes:This code performs the following tasks:

    • Copia el documento en el escritorio del usuario.Copies the document to the user's desktop.

    • Cambia la propiedad _AssemblyLocation desde una ruta de acceso relativa a una ruta de acceso completa para el manifiesto de implementación.Changes the _AssemblyLocation property from a relative path to a fully qualified path for the deployment manifest.

    • Elimina el archivo si el usuario desinstala la solución.Deletes the file if the user uninstalls the solution.

      Imports Microsoft.VisualStudio.Tools.Applications.Deployment
      Imports Microsoft.VisualStudio.Tools.Applications
      
      Public Class FileCopyPDA
          Implements IAddInPostDeploymentAction
      
          Sub Execute(ByVal args As AddInPostDeploymentActionArgs) Implements IAddInPostDeploymentAction.Execute
              Dim dataDirectory As String = "Data\ExcelWorkbook.xlsx"
              Dim file As String = "ExcelWorkbook.xlsx"
              Dim sourcePath As String = args.AddInPath
              Dim deploymentManifestUri As Uri = args.ManifestLocation
              Dim destPath As String = Environment.GetFolderPath(Environment.SpecialFolder.DesktopDirectory)
              Dim sourceFile As String = System.IO.Path.Combine(sourcePath, dataDirectory)
              Dim destFile As String = System.IO.Path.Combine(destPath, file)
      
              Select Case args.InstallationStatus
                  Case AddInInstallationStatus.InitialInstall, AddInInstallationStatus.Update
                      System.IO.File.Copy(sourceFile, destFile)
                      ServerDocument.RemoveCustomization(destFile)
                      ServerDocument.AddCustomization(destFile, deploymentManifestUri)
                      Exit Select
                  Case AddInInstallationStatus.Uninstall
                      If System.IO.File.Exists(destFile) Then
                          System.IO.File.Delete(destFile)
                      End If
                      Exit Select
              End Select
          End Sub
      
      using Microsoft.VisualStudio.Tools.Applications.Deployment;
      using Microsoft.VisualStudio.Tools.Applications;
      using System.IO;
      
      namespace FileCopyPDA
      {
          public class FileCopyPDA : IAddInPostDeploymentAction
          {
              public void Execute(AddInPostDeploymentActionArgs args) 
              {
                  string dataDirectory = @"Data\ExcelWorkbook.xlsx";
                  string file = @"ExcelWorkbook.xlsx";
                  string sourcePath = args.AddInPath;
                  Uri deploymentManifestUri = args.ManifestLocation;
                  string destPath = Environment.GetFolderPath(Environment.SpecialFolder.DesktopDirectory);
                  string sourceFile = System.IO.Path.Combine(sourcePath, dataDirectory);
                  string destFile = System.IO.Path.Combine(destPath, file);
      
                  switch (args.InstallationStatus)
                  {
                      case AddInInstallationStatus.InitialInstall:
                      case AddInInstallationStatus.Update:
                          File.Copy(sourceFile, destFile);
                          ServerDocument.RemoveCustomization(destFile);
                          ServerDocument.AddCustomization(destFile, deploymentManifestUri);
                          break;
                      case AddInInstallationStatus.Uninstall:
                          if (File.Exists(destFile))
                          {
                              File.Delete(destFile);
                          }
                          break;
                  }
              }
          }
      }
      

Compilar y publicar la soluciónBuild and publish the solution

  1. En el Explorador de soluciones, abra el menú contextual para el FileCopyPDA del proyecto y, a continuación, elija compilar.In Solution Explorer, open the shortcut menu for the FileCopyPDA project, and then choose Build.

  2. Abra el menú contextual para el ExcelWorkbook del proyecto y, a continuación, elija compilar.Open the shortcut menu for the ExcelWorkbook project, and then choose Build.

  3. Abra el menú contextual para el ExcelWorkbook del proyecto y, a continuación, elija Agregar referencia.Open the shortcut menu for the ExcelWorkbook project, and then choose Add Reference.

  4. En el Agregar referencia diálogo cuadro, elija el proyectos ficha, elija FileCopyPDAy, a continuación, elija el Aceptar botón.In the Add Reference dialog box, choose the Projects tab, choose FileCopyPDA, and then choose the OK button.

  5. En el Explorador de soluciones, elija el ExcelWorkbook proyecto.In Solution Explorer, choose the ExcelWorkbook project.

  6. En la barra de menús, elija proyecto > nueva carpeta.On menu bar, choose Project > New Folder.

  7. ENTRAR datosy, a continuación, elija el ENTRAR clave.Enter Data, and then choose the Enter key.

  8. En el Explorador de soluciones, elija el datos carpeta.In Solution Explorer, choose the Data folder.

  9. En la barra de menús, elija proyecto > Agregar elemento existente.On the menu bar, choose Project > Add Existing Item.

  10. En el Agregar elemento existente cuadro de diálogo, vaya al directorio de salida para el ExcelWorkbook del proyecto, elija el ExcelWorkbook.xlsx de archivo y, a continuación, elija el Agregar botón.In the Add Existing Item dialog box, browse to the output directory for the ExcelWorkbook project, choose the ExcelWorkbook.xlsx file, and then choose the Add button.

  11. En el Explorador de soluciones elegir el ExcelWorkbook.xlsx archivo.In Solution Explorer choose the ExcelWorkbook.xlsx file.

  12. En el propiedades ventana, cambie el acción de compilación propiedad contenido y el Copy to Output Directory propiedad Copiar si es posterior.In the Properties window, change the Build Action property to Content and the Copy to Output Directory property to Copy if newer.

    Cuando haya completado estos pasos, el proyecto será similar a la siguiente ilustración.When you've completed these steps, your project will resemble the following illustration.

    Estructura del proyecto de la acción posterior a la implementación. Project structure of the post deployment action.

  13. Publicar el ExcelWorkbook proyecto.Publish the ExcelWorkbook project.

Modificar el manifiesto de aplicaciónModify the application manifest

  1. Abra el directorio de la solución, c:\publish, mediante el uso de Explorador de archivos.Open the solution directory, c:\publish, by using File Explorer.

  2. Abra el archivos de la aplicación carpeta y, a continuación, abra la carpeta que corresponde a la más reciente publican la versión de la solución.Open the Application Files folder, and then open the folder that corresponds to the most recent published version of your solution.

  3. Abra el ExcelWorkbook.dll.manifest archivo en un editor de texto como Bloc de notas.Open the ExcelWorkbook.dll.manifest file in a text editor such as Notepad.

  4. Agregue el código siguiente detrás del elemento </vstav3:update>.After the </vstav3:update> element, add following code. El atributo de clase de la <vstav3:entryPoint> elemento, use la sintaxis siguiente: NombreDeEspacioDeNombres.nombreDeClase.For the class attribute of the <vstav3:entryPoint> element, use the following syntax: NamespaceName.ClassName. En el ejemplo siguiente, los nombres de clase y espacio de nombres son los mismos, por lo que el nombre del punto de entrada resultante es FileCopyPDA.FileCopyPDA.In the following example, the namespace and class names are the same, so the resulting entry point name is FileCopyPDA.FileCopyPDA.

    <vstav3:postActions>
      <vstav3:postAction>
        <vstav3:entryPoint
          class="FileCopyPDA.FileCopyPDA">
          <assemblyIdentity
            name="FileCopyPDA"
            version="1.0.0.0"
            language="neutral"
            processorArchitecture="msil" />
        </vstav3:entryPoint>
        <vstav3:postActionData>
        </vstav3:postActionData>
      </vstav3:postAction>
    </vstav3:postActions>
    

Volver a firmar los manifiestos de aplicación e implementaciónRe-sign the application and deployment manifests

  1. En el %USERPROFILE%\Documents\Visual Studio 2013\Projects\ExcelWorkbook\ExcelWorkbook carpeta, copie el ExcelWorkbook_TemporaryKey.pfx archivo de certificado y, a continuación, péguelo en el CarpetaDePublicación \Application Files\ExcelWorkbook_Versiónpublicadamásreciente carpeta.In the %USERPROFILE%\Documents\Visual Studio 2013\Projects\ExcelWorkbook\ExcelWorkbook folder, copy the ExcelWorkbook_TemporaryKey.pfx certificate file, and then paste it into the PublishFolder \Application Files\ExcelWorkbook_MostRecentPublishedVersion folder.

  2. Abra el símbolo del sistema de Visual Studio y, a continuación, cambie los directorios a la c:\publish\Application de aplicación\excelworkbook_Versiónpublicadamásreciente carpeta (por ejemplo, c:\publish\Application Files\ExcelWorkbook_1_0_0_4).Open the Visual Studio command prompt, and then change directories to the c:\publish\Application Files\ExcelWorkbook_MostRecentPublishedVersion folder (for example, c:\publish\Application Files\ExcelWorkbook_1_0_0_4).

  3. Firme el manifiesto de aplicación modificado ejecutando el siguiente comando:Sign the modified application manifest by running the following command:

    mage -sign ExcelWorkbook.dll.manifest -certfile ExcelWorkbook_TemporaryKey.pfx
    

    Aparece el mensaje "ExcelWorkbook.dll.manifest firmado correctamente".The message "ExcelWorkbook.dll.manifest successfully signed" appears.

  4. Cambie a la c:\publish manifiesto carpeta y, a continuación, actualización y la implementación del inicio de sesión, ejecute el comando siguiente:Change to the c:\publish folder, and then update and sign the deployment manifest by running the following command:

    mage -update ExcelWorkbook.vsto -appmanifest "Application Files\Ex
    celWorkbookMostRecentVersionNumber>\ExcelWorkbook.dll.manifest" -certfile "Application Files\ExcelWorkbookMostRecentVersionNumber>\ExcelWorkbook_TemporaryKey.pfx"
    

    Note

    En el ejemplo anterior, reemplace MostRecentVersionNumber con el número de versión de la versión publicada más recientemente de la solución (por ejemplo, 1_0_0_4).In the previous example, replace MostRecentVersionNumber with the version number of the most recently published version of your solution (for example, 1_0_0_4).

    Aparece el mensaje "ExcelWorkbook.vsto firmado correctamente".The message "ExcelWorkbook.vsto successfully signed" appears.

  5. Copia el ExcelWorkbook.vsto del archivo a la c:\publish\Application de aplicación\excelworkbook_MostRecentVersionNumber directory.Copy the ExcelWorkbook.vsto file to the c:\publish\Application Files\ExcelWorkbook_MostRecentVersionNumber directory.

Colocar el documento de una solución en un servidor que ejecute SharePoint (solo para personalizaciones de nivel de documento)Put the document of a solution onto a server that's running SharePoint (document-level customizations only)

Puede publicar la personalización de nivel de documento para los usuarios finales mediante SharePoint.You can publish your document-level customization to end users by using SharePoint. Cuando los usuarios van al sitio de SharePoint y abren el documento, el runtime instala automáticamente la solución desde la carpeta de red compartida en el equipo local del usuario.When users go to the SharePoint site and open the document, the runtime automatically installs the solution from the shared network folder to the user's local computer. Una vez instalada localmente la solución, la personalización seguirá funcionando aunque el documento se copie en otra parte, como el escritorio.After the solution is installed locally, the customization will still function even if the document is copied elsewhere, such as the desktop.

Para colocar el documento en un servidor que ejecuta SharePointTo put the document on a server that's running SharePoint

  1. Agregue el documento de la solución a una biblioteca de documentos en un sitio de SharePoint.Add the solution document to a document library on a SharePoint site.

  2. Siga los pasos de alguno de estos enfoques:Perform the steps for one of the following approaches:

    • Utilice la herramienta de configuración de Office para agregar el servidor que ejecuta SharePoint al Centro de confianza de Word o Excel en todos los equipos de los usuarios.Use the Office Configuration Tool to add the server that's running SharePoint to the Trust Center in Word or Excel on all user computers.

      Consulte las directivas de seguridad y configuración de Office 2010.See Security policies and settings in Office 2010.

    • Asegúrese de que cada usuario realice los pasos siguientes.Ensure that each user performs the following steps.

      1. En el equipo local, abra Word o Excel, elija el archivo pestaña y, a continuación, elija el opciones botón.On the local computer, open Word or Excel, choose the File tab, and then choose the Options button.

      2. En el centro de confianza diálogo cuadro, elija el ubicaciones de confianza botón.In the Trust Center dialog box, choose the Trusted Locations button.

      3. Seleccione el Permitir ubicaciones de confianza en la red (no recomendado) casilla de verificación y, a continuación, elija el agregar nueva ubicación botón.Select the Allow Trusted Locations on my network (not recommended) check box, and then choose the Add new location button.

      4. En el ruta , escriba la dirección URL de la biblioteca de documentos de SharePoint que contiene el documento cargado (por ejemplo, http://SharePointServerName/TeamName/ProjectName/DocumentLibraryName).In the Path box, enter the URL of the SharePoint document library that contains the document that you uploaded (for example, http://SharePointServerName/TeamName/ProjectName/DocumentLibraryName).

        No agregue el nombre de la página Web predeterminada, como default.aspx o AllItems.aspx.Don't add the name of the default Web page, such as default.aspx or AllItems.aspx.

      5. Seleccione el las subcarpetas de esta ubicación también son de confianza casilla de verificación y, a continuación, elija el Aceptar botón.Select the Subfolders of this location are also trusted check box, and then choose the OK button.

        Cuando los usuarios abran el documento desde el sitio de SharePoint, se abrirá el documento y se instalará la personalización.When users open the document from the SharePoint site, the document opens, and the customization is installed. Los usuarios pueden copiar el documento en el escritorio.Users can copy the document to their desktop. La personalización se ejecutará igualmente porque las propiedades del documento apuntan a la ubicación de red del documento.The customization will still run because properties in the document point to the network location of the document.

Crear a un instalador personalizadoCreate a custom installer

Puede crear a un instalador personalizado para la solución de Office, en lugar de usar el programa de instalación que se crea automáticamente al publicar la solución.You can create a custom installer for your Office solution, instead of using the setup program that's created for you when you publish the solution. Por ejemplo, podría utilizar un inicio de sesión en la secuencia de comandos para iniciar la instalación, o podría usar un archivo por lotes para instalar la solución sin interacción del usuario.For example, you could use a sign in script to start the installation, or you could use a batch file to install the solution without user interaction. Estos escenarios funcionan mejor si los requisitos previos ya están instalados en los equipos de los usuarios finales.These scenarios work best if the prerequisites are already installed on end-user computers.

Como parte del proceso de instalación personalizada, llame a la herramienta de instalación para las soluciones de Office (VSTOInstaller.exe), que se instala en la siguiente ubicación predeterminada:As part of your custom installation process, call the installer tool for Office solutions (VSTOInstaller.exe), which is installed in the following location by default:

%CommonProgramFiles%\Microsoft shared\VSTO\10.0\VSTOInstaller.exe%commonprogramfiles%\microsoft shared\VSTO\10.0\VSTOInstaller.exe

Si la herramienta no se encuentra en esa ubicación, puede usar el HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VSTO Runtime Setup\v4\InstallerPath o HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VSTO Runtime Setup\v4 \InstallerPath clave del registro para buscar la ruta de acceso a esa herramienta.If the tool isn't in that location, you can use the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VSTO Runtime Setup\v4\InstallerPath or HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VSTO Runtime Setup\v4\InstallerPath registry key to find the path to that tool.

Puede usar los siguientes parámetros con VSTOinstaller.exe.You can use the following parameters with VSTOinstaller.exe.

ParámetroParameter DefiniciónDefinition
/Install o /I/Install or /I Instala la solución.Install the solution. Esta opción debe ir seguida de la ruta de acceso de un manifiesto de implementación.You must follow this option with the path of a deployment manifest. Puede especificar una ruta de acceso en el equipo local —un recurso compartido de archivos de convención de nomenclatura universal (UNC)—.You can specify a path on the local computer, a universal naming convention (UNC) file share. Puede especificar una ruta de acceso local (C:\FolderName\PublishFolder), una ruta de acceso relativa (publicar\), o una ubicación completa (\\ServerName\ NombreDeCarpeta o http://nombreDeServidor/nombreDeCarpeta).You can specify a local path (C:\FolderName\PublishFolder), a relative path (Publish\), or a fully qualified location (\\ServerName\FolderName or http://ServerName/FolderName).
/Uninstall o /U/Uninstall or /U Desinstala la solución.Uninstall the solution. Esta opción debe ir seguida de la ruta de acceso de un manifiesto de implementación.You must follow this option with the path of a deployment manifest. Puede especificar que una ruta de acceso puede estar en el equipo local, en un recurso compartido de archivos UNC.You can specify a path can be on the local computer, a UNC file share. Puede especificar una ruta de acceso local (c:\FolderName\PublishFolder), una ruta de acceso relativa (publicar\), o una ubicación completa (\\ServerName\ NombreDeCarpeta o http://nombreDeServidor/nombreDeCarpeta).You can specify a local path (c:\FolderName\PublishFolder), a relative path (Publish\), or a fully qualified location (\\ServerName\FolderName or http://ServerName/FolderName).
/Silent o /S/Silent or /S Instala o desinstala sin solicitar la entrada de datos del usuario ni mostrar ningún mensaje.Install or uninstall without prompting the user for input or displaying any messages. Si se requiere un símbolo del sistema de confianza, la personalización no está instalada o actualizada.If a trust prompt is required, the customization isn't installed or updated.
/Help o /?/Help or /? Muestra la información de Ayuda.Display the Help information.

Al ejecutar VSTOinstaller.exe, es posible que aparezcan los siguientes códigos de error.When you run VSTOinstaller.exe, the following error codes might appear.

Código de errorError Code DefiniciónDefinition
00 La solución se instaló o desinstaló correctamente o se mostró la Ayuda de VSTOInstaller.The solution was successfully installed or uninstalled, or the VSTOInstaller Help appeared.
-100-100 Una o varias opciones de línea de comandos no son válidas o se ha configurado más de una vez.One or more command-line options aren't valid or was set more than once. Para obtener más información, escriba "¿vstoinstaller /?"For more information, enter "vstoinstaller /?" o bien consulte crear un instalador personalizado para una solución de ClickOnce Office.or see Create a custom installer for a ClickOnce Office solution.
-101-101 Una o varias opciones de línea de comandos no son válidas.One or more command-line options aren't valid. Para obtener más información, escriba “vstoinstaller/?”.For more information, enter "vstoinstaller /?".
-200-200 El URI del manifiesto de implementación no es válido.The deployment manifest URI isn't valid. Para obtener más información, escriba “vstoinstaller/?”.For more information, enter "vstoinstaller /?".
-201-201 No se pudo instalar la solución porque el manifiesto de implementación no es válido.The solution couldn't be installed because the deployment manifest isn't valid. Consulte manifiestos de implementación para soluciones de Office.See Deployment manifests for Office solutions.
-202-202 No se pudo instalar la solución porque Visual Studio Tools para la sección de Office del manifiesto de aplicación no es válido.The solution couldn't be installed because the Visual Studio Tools for Office section of the application manifest isn't valid. Consulte manifiestos de aplicación para soluciones de Office.See Application manifests for Office solutions.
-203-203 No se pudo instalar la solución porque se produjo un error en la descarga.The solution couldn't be installed because a download error occurred. Compruebe el URI o la ubicación del archivo de red del manifiesto de implementación e inténtelo de nuevo.Check the URI or network file location of the deployment manifest, and then try again.
-300-300 No se pudo instalar la solución porque se produjo una excepción de seguridad.The solution couldn't be installed because a security exception occurred. Consulte soluciones de Office Secure.See Secure Office solutions.
-400-400 No se pudo instalar la solución.The solution couldn't be installed.
-401-401 No se pudo desinstalar la solución.The solution couldn't be uninstalled.
-500-500 Se ha cancelado la operación porque no se pudo instalar o desinstalar la solución o porque no se pudo descargar el manifiesto de implementación.The operation has been canceled because the solution couldn't be installed or uninstalled or the deployment manifest couldn't be downloaded.

Publicar una actualizaciónPublish an update

Para actualizar una solución, publíquela de nuevo mediante el uso de la Diseñador de proyectos o Asistente para publicación, y, a continuación, copie la solución actualizada en la ubicación de instalación.To update a solution, you publish it again by using the Project Designer or Publish Wizard, and then you copy the updated solution to the installation location. Cuando copie los archivos en la ubicación de instalación, asegúrese de sobrescribir los archivos anteriores.When you copy the files to the installation location, make sure that you overwrite the previous files.

La próxima vez que comprueba la solución para una actualización, lo encontrará y cargar la nueva versión automáticamente.The next time that the solution checks for an update, it will find and load the new version automatically.

Cambiar la ubicación de instalación de una soluciónChange the installation location of a solution

Puede agregar o cambiar la ruta de instalación después de publicar una solución.You can add or change the installation path after a solution is published. Puede cambiar la ruta de instalación por alguna de las siguientes razones:You might want to change the installation path for one or more of the following reasons:

  • El programa de instalación se compiló antes de que se conociera la ruta de instalación.The setup program was compiled before the installation path was known.

  • Los archivos de la solución se han copiado en otra ubicación.The solution files have been copied to a different location.

  • El servidor que hospeda los archivos de instalación tiene un nombre o una ubicación nuevos.The server that hosts the installation files has a new name or location.

    Para cambiar la ruta de instalación de una solución, debe actualizar el programa de instalación. Los usuarios tendrán que ejecutar este programa.To change the installation path of a solution, you must update the setup program, and then users must run it. Para las personalizaciones de nivel de documento, los usuarios también deben actualizar una propiedad en el documento para que apunte a la nueva ubicación.For document-level customizations, users must also update a property in their document to point to the new location.

Note

Si no desea pedir a los usuarios para actualizar las propiedades del documento, puede pedir a los usuarios obtener el documento actualizado de la ubicación de instalación.If you don't want to ask users to update their document properties, you can ask users to get the updated document from the installation location.

Para cambiar la ruta de instalación en el programa de instalaciónTo change the installation path in the setup program

  1. Abra un símbolo ventana y, a continuación, cambie los directorios a la carpeta de instalación.Open a Command Prompt window, and then change directories to the installation folder.

  2. Ejecute el programa de instalación e incluya el parámetro /url, que toma la nueva ruta de instalación como una cadena.Run the setup program, and include the /url parameter, which takes the new installation path as a string.

    En el ejemplo siguiente se muestra cómo cambiar la ruta de instalación a una ubicación del sitio web de Fabrikam, pero puede reemplazar esa dirección URL por la ruta que desee:The following example shows how to change the installation path to a location on the Fabrikam website, but you can replace that URL with the path that you want:

    setup.exe /url="http://www.fabrikam.com/newlocation"
    

    Note

    Si aparece un mensaje y se indica que la firma del archivo ejecutable se va a invalidar, el certificado utilizado para firmar la solución ya no es válido y se desconoce el publicador.If a message appears and state that the signature of the executable will be invalidated, the certificate that was used to sign the solution is no longer valid, and the publisher is unknown. Como resultado, los usuarios deberán confirmar que confían en el origen de la solución para poder instalarla.As a result, users will need to confirm that they trust the source of the solution before they can install it.

    Note

    Para mostrar el valor actual de la dirección URL, ejecute setup.exe /url.To display the current value of the URL, run setup.exe /url.

    Para las personalizaciones de nivel de documento, los usuarios deben abrir el documento y, a continuación, actualice su propiedad _AssemblyLocation.For document-level customizations, users must open the document and then update its _AssemblyLocation property. Los pasos siguientes describen cómo los usuarios pueden realizar esta tarea.The following steps describe how users can perform this task.

Para actualizar la propiedad _AssemblyLocation en un documentoTo update the _AssemblyLocation property in a document

  1. En el archivo ficha, elija información, que se muestra en la siguiente ilustración.On the File tab, choose Info, which the following illustration shows.

    Pestaña información de ExcelInfo tab in Excel

  2. En el propiedades elija propiedades avanzadas, que se muestra en la siguiente ilustración.In the Properties list, choose Advanced Properties, which the following illustration shows.

    Propiedades avanzadas de Excel. Advanced Properties in Excel.

  3. En el personalizado pestaña en el propiedades elija _AssemblyLocation, como se muestra en la ilustración siguiente.On the Custom tab in the Properties list, choose _AssemblyLocation, as the following illustration shows.

    La propiedad AssemblyLocation. The AssemblyLocation property.

    El valor cuadro contiene el identificador del manifiesto de implementación.The Value box contains the deployment manifest identifier.

  4. Delante del identificador, escriba la ruta de acceso completa del documento, seguido por una barra, con el formato ruta|identificador (por ejemplo, File://ServerName/ Nombre de archivo/nombreCarpeta | 74744e4b-e4d6-41eb-84f7-ad20346fe2d9.Before the identifier, enter the fully qualified path of the document, followed by a bar, in the format Path|Identifier (for example, File://ServerName/FolderName/FileName|74744e4b-e4d6-41eb-84f7-ad20346fe2d9.

    Para obtener más información acerca de cómo dar formato a este identificador, consulte información general de las propiedades de documento personalizada.For more information about how to format this identifier, see Custom document properties overview.

  5. Elija la Aceptar botón y, a continuación, guarde y cierre el documento.Choose the OK button, and then save and close the document.

  6. Ejecute el programa de instalación sin el parámetro /url para instalar la solución en la ubicación especificada.Run the setup program without the /url parameter to install the solution in the specified location.

Revertir una solución a una versión anteriorRoll back a solution to an earlier version

Cuando se revierte una solución, se revierte a los usuarios a una versión anterior de la solución.When you roll back a solution, you revert users back to an earlier version of that solution.

Para revertir una soluciónTo roll back a solution

  1. Abra la ubicación de instalación de la solución.Open the installation location of the solution.

  2. Carpeta de publicación en el nivel superior, elimine el manifiesto de implementación (el .vsto archivo).In the top-level publish folder, delete the deployment manifest (the .vsto file).

  3. Busque la subcarpeta correspondiente a la versión a la que desea efectuar la reversión.Find the subfolder for the version to which you want to roll back.

  4. Copie el manifiesto de implementación de esa subcarpeta en la carpeta de publicación de nivel superior.Copy the deployment manifest from that subfolder to the top-level publish folder.

    Por ejemplo, para revertir una solución que se llama OutlookAddIn1 desde la versión 1.0.0.1 a la versión 1.0.0.0, copie el archivo OutlookAddIn1.vsto desde el OutlookAddIn1_1_0_0_0 carpeta.For example, to roll back a solution that's called OutlookAddIn1 from version 1.0.0.1 to version 1.0.0.0, copy the file OutlookAddIn1.vsto from the OutlookAddIn1_1_0_0_0 folder. Pegue el archivo en el nivel superior publicar la carpeta, sobrescribiendo el manifiesto de implementación específico de la versión OutlookAddIn1_1_0_0_1 que ya estaba allí.Paste the file into the top-level publish folder, overwriting the version-specific deployment manifest for OutlookAddIn1_1_0_0_1 that was already there.

    La ilustración siguiente muestra la estructura de carpetas de publicación de este ejemplo.The following illustration shows the publish folder structure in this example.

    Publicar la estructura de carpetasPublish Folder Structure

    La próxima vez que un usuario abra la aplicación o el documento personalizado se detectará el cambio del manifiesto de implementación.The next time that a user opens the application or customized document, the deployment manifest change is detected. La versión anterior de la solución de Office se ejecutará desde la caché de ClickOnce.The earlier version of the Office solution runs from the ClickOnce cache.

Note

Los datos locales se guardan para una sola versión anterior de una solución.Local data is saved for only one previous version of a solution. Si revierte a dos versiones, no se conservan los datos locales.If you roll back two versions, local data isn't retained. Para obtener más información sobre los datos locales, consulte tener acceso a datos locales y remotos en aplicaciones ClickOnce.For more information about local data, see Access local and remote data in ClickOnce applications.

Vea tambiénSee also