Implementar una solución de Office mediante Windows InstallerDeploy an Office solution by using Windows Installer

Obtenga información sobre cómo crear un archivo de Windows Installer para la solución de Office mediante Visual Studio 2013Visual Studio 2013.Learn how to create a Windows Installer for your Office solution by using Visual Studio 2013Visual Studio 2013.

Al usar Visual Studio para crear un archivo de Windows Installer, puede implementar una solución de Office que requiera acceso administrativo en el equipo del usuario final.By using Visual Studio to create a Windows Installer, you can deploy an Office solution that requires administrative access on the end user's computer. Por ejemplo, puede utilizar este archivo para instalar una solución solo una vez para todos los usuarios de un equipo.For example, you can use such a file to install a solution only once for all users of a computer. También puede implementar una solución de Office mediante ClickOnce, aunque esa solución se debe instalar por separado para cada usuario del equipo.You can also deploy an Office solution by using ClickOnce, but that solution must be installed separately for each user of the computer.

En este temaIn this topic

Para obtener más información sobre cómo implementar una solución de Office mediante ClickOnce, vea implementar una solución de Office mediante ClickOnce.For more information about how to deploy an Office solution by using ClickOnce, see Deploy an Office solution by using ClickOnce.

Para obtener información acerca de cómo crear un archivo de Windows Installer mediante Visual Studio 2010Visual Studio 2010, consulte implementar un Visual Studio 2010 Tools para soluciones de Office mediante Windows Installer.For information about how to create a Windows Installer file by using Visual Studio 2010Visual Studio 2010, see Deploy a Visual Studio 2010 Tools for Office solution using Windows Installer.

Descargar ejemplosDownload samples

Este tema hace referencia a los ejemplos descargables siguientes.This topic refers to the following downloadable samples.

EjemploSample

DescripciónDescription

ExcelAddInExcelAddIn

Complemento VSTO de Excel que se puede instalar en un equipo que ejecute una versión de Office de 32 o de 64 bits.An Excel VSTO Add-in that you can install on a computer that runs a 32-bit or 64-bit version of Office.

ExcelWorkbookExcelWorkbook

Personalización de nivel de documento de Excel que se puede instalar en un equipo que ejecute una versión de Office de 32 o de 64 bits.An Excel document-level customization that you can install on a computer that runs a 32-bit or 64-bit version of Office.

Decidir cómo conceder confianza a la soluciónDecide how to grant trust to the solution

Para que una solución pueda ejecutarse en los equipos de los usuarios, debe conceder confianza de una de las siguientes maneras, o los usuarios deben responder al mensaje relativo a la confianza cuando instalen la solución.Before a solution can run on user computers, you must grant trust in either of the following ways, or users must respond to a trust prompt when they install the solution.

Note

En las personalizaciones de nivel de documento, la ubicación del documento también debe ser de confianza.For document-level customizations, the location of the document must also be trusted. Para obtener más información, consulte conceder confianza a los documentos.For more information, see Grant trust to documents.

Obtener InstallShield Limited EditionGet InstallShield Limited Edition

Puede crear un archivo de Windows Installer mediante InstallShield Limited Edition (ISLE), que está disponible de forma gratuita si ha instalado Visual Studio.You can create a Windows Installer file by using InstallShield Limited Edition (ISLE), which is free if you've installed Visual Studio. ISLE reemplaza a la funcionalidad de las plantillas de proyecto para la configuración y la implementación de las versiones anteriores de Visual Studio.ISLE replaces the functionality of the project templates for setup and deployment that previous versions of Visual Studio offered.

Para obtener InstallShield Limited EditionTo get InstallShield Limited Edition

  1. En la barra de menús, elija Archivo > Nuevo > Proyecto.On the menu bar, choose File > New > Project.

    Aparece el cuadro de diálogo Nuevo proyecto .The New Project dialog box opens.

  2. En el panel de plantillas, expanda Otros tipos de proyectosy después elija la plantilla Instalación e implementación .In the templates pane, expand Other Project Types, and then choose the Setup and Deployment template.

  3. En la lista de tipos de proyecto de Instalación e implementación, seleccione Habilitar InstallShield Limited Editiony elija el botón Aceptar .In the list of project types for Setup and Deployment, choose Enable InstallShield Limited Edition, and then choose the OK button.

    Aparece una página que proporciona información sobre cómo obtener InstallShield Limited Edition.A page appears that provides information about how to get InstallShield Limited Edition.

  4. En esa página, elija el vínculo Vaya al sitio web de descarga .On that page, choose the Go to the download web site link.

  5. En la página de descarga de InstallShield Limited Edition, escriba la información necesaria en los campos correspondientes y elija el vínculo Descargar ahora .On the download page for InstallShield Limited Edition, enter the required information into the appropriate fields, and then choose the Download Now link.

    Después de descargar, instalar y activar el producto, la plantilla Proyecto de InstallShield Limited Edition aparece en Visual Studio.After you download, install, and activate the product, the InstallShield Limited Edition Project template appears in Visual Studio.

Crear un proyecto de instalaciónCreate a setup project

  1. En Visual StudioVisual Studio, abra el proyecto de Office que desea implementar.In Visual StudioVisual Studio, open the Office project that you want to deploy.

    Los ejemplos de complementos de VSTO asociados a este tema contienen un proyecto denominado ExcelAddIn.The VSTO Add-in samples that are associated with this topic contain a project that's named ExcelAddIn. Los ejemplos de personalizaciones de nivel de documento contienen un proyecto denominado ExcelWorkbook.The document-level customization samples contain a project that's named ExcelWorkbook. En este tema se hace referencia al proyecto de Office en la solución mediante uno de los dos nombres.This topic will refer to the Office project in your solution by using one of those two names.

  2. En la barra de menús, elija archivo > agregar > nuevo proyecto.On the menu bar, choose File > Add > New Project.

    Se abre el cuadro de diálogo Agregar nuevo proyecto .The Add New Project dialog box opens.

  3. En el panel de plantillas, expanda Otros tipos de proyectosy después elija la plantilla Instalación e implementación .In the templates pane, expand Other Project Types, and then choose the Setup and Deployment template.

  4. En la lista de tipos de proyecto para Instalación e implementación, elija Proyecto de InstallShield Limited Edition, asigne un nombre al proyecto y elija el botón Aceptar .In the list of project types for Setup and Deployment, choose InstallShield Limited Edition Project, name the project, and then choose the OK button.

    El proyecto de instalación de InstallShield que ha creado aparece en la solución.The InstallShield setup project that you created appears in your solution.

    Los ejemplos de este tema contienen un proyecto de instalación que se denomina OfficeAddInSetup.The samples for this topic contain a setup project that's named OfficeAddInSetup. En este tema se hace referencia al proyecto de instalación de la solución con el mismo nombre.This topic will refer to the setup project in your solution by using the same name.

Agregar el resultado del proyectoAdd the project output

Configure el proyecto OfficeAddInSetup para incluir el resultado del proyecto de Office.You configure the OfficeAddInSetup project to include the output of your Office project. Para los proyectos de complemento de VSTO, el resultado del proyecto es solo el ensamblado de solución.For VSTO Add-in projects, the project output is the solution assembly only. Para los proyectos de personalización de nivel de documento, el resultado del proyecto incluye el ensamblado de solución y, además, el propio documento.For document-level customization projects, the project output includes not only the solution assembly but also the document itself.

Para agregar el resultado del proyectoTo add the project output

  1. En el Explorador de soluciones, expanda el nodo de proyecto OfficeAddInSetup y, a continuación, elija el archivo Project Assistant (Asistente para proyectos), que se muestra en la siguiente ilustración.In Solution Explorer, expand the OfficeAddInSetup project node, and then choose the Project Assistant file, which the following illustration shows.

    Asistente de archivo en el Explorador de soluciones de proyectoProject Assistant File in Solution Explorer

  2. En la barra de menús, elija vista > abierto.On the menu bar, choose View > Open.

  3. En la parte inferior de la página Project assistant (Asistente para proyectos), elija el botón Archivos de aplicación , como se muestra en la siguiente ilustración.At the bottom of the Project assistant page, choose the Application Files button, which the following illustration shows.

    El botón archivos de la aplicación. The Application Files button.

  4. En la página de Archivos de aplicación , elija el botón Agregar resultados del proyecto .In the Application Files page, choose the Add Project Outputs button.

  5. En el cuadro de diálogo del selector de resultados de Visual Studio , active la casilla Resultado principal y después elija el botón Aceptar .In the Visual Studio Output Selector dialog box, select the Primary Output check box, and then choose the OK button.

Agregar los manifiestos de implementación y de aplicaciónAdd the deployment and application manifests

  1. En la página Archivos de aplicación , elija el botón Agregar archivos .In the Application Files page, choose the Add Files button.

  2. En el cuadro de diálogo Abrir , vaya al directorio de resultados del proyecto ExcelAddIn .In the Open dialog box, browse to the output directory of the ExcelAddIn project.

    Normalmente, el directorio de resultados es la subcarpeta bin\release del directorio raíz del proyecto, según la configuración de compilación que elija.Usually, the output directory is the bin\release subfolder of the project root directory, depending on the build configuration that you choose.

  3. En el directorio de resultados, seleccione los archivos ExcelAddIn.vsto y ExcelAddIn.dll.manifest y elija el botón Abrir .In the output directory, choose the ExcelAddIn.vsto and ExcelAddIn.dll.manifest files, and then choose the Open button.

    La página Archivos de aplicación contiene ahora el archivo de salida del proyecto, el manifiesto de implementación y el manifiesto de aplicación, como muestra la siguiente ilustración.The Application Files page now contains the project output file, the deployment manifest, and the application manifest, as the following illustration shows.

    Los archivos de salida de su proyecto de instalación. The output files of your setup project.

Configurar los componentes dependientes como requisitos previosConfigure the dependent components as prerequisites

En la aplicación de instalación, debe incluir los componentes siguientes y cualquier otro componente necesario para ejecutar la solución.In your setup application, you must include not only the following components but also any other components that are required for your solution to run.

  • La versión de .NET Framework a la que se destina la solución de Office.The version of the .NET Framework that your Office solution targets.

  • Runtime de Microsoft Visual Studio 2010 Tools para Office.The Microsoft Visual Studio 2010 Tools for Office Runtime.

Agregar .NET Framework 4 o .NET Framework 4.5 como requisito previoAdd the .NET Framework 4 or the .NET Framework 4.5 as a prerequisite

  1. En el Explorador de soluciones, expanda el nodo de proyecto OfficeAddInSetup , expanda el nodo Specify Application Data (Especificar datos de la aplicación) y, a continuación, elija el archivo de Redistributables (Componentes redistribuibles), que se muestra en la siguiente ilustración.In Solution Explorer, expand the OfficeAddInSetup project node, expand the Specify Application Data node, and then choose the Redistributables file, which the following illustration shows.

    El archivo de redistribuibles en el Explorador de solucionesThe Redistributables file in Solution Explorer

  2. En la barra de menús, elija vista > abierto.On the menu bar, choose View > Open.

    Se abre la página Redistributables .The Redistributables page opens.

  3. En la lista de componentes redistribuibles, active la casilla correspondiente para la versión de .NET Framework de destino de la solución.In the list of redistributable components, select appropriate the check box for the version of the .NET Framework that your solution targets.

    Por ejemplo, si la solución tiene como destino .NET Framework 4.5.NET Framework 4.5, active la casilla de Microsoft .NET Framework 4.5 Full (Microsoft .NET Framework 4.5 versión completa).For example, if your solution targets the .NET Framework 4.5.NET Framework 4.5, select the Microsoft .NET Framework 4.5 Full check box. Puede aparecer un cuadro de diálogo preguntando si desea instalar el componente redistribuible, que InstallShield requiere para poder agregar el componente como requisito previo.A dialog box might appear asking whether you want to install the redistributable component, which InstallShield requires before you can add the component as a prerequisite. Si no aparece este cuadro de diálogo, el componente ya existe en el equipo.If this dialog box doesn't appear, the component already exists on your computer.

  4. Si aparece el cuadro de diálogo, elija el botón No .If this dialog box appears, choose the No button.

Agregar Runtime de Visual Studio 2010 Tools para OfficeAdd the Visual Studio 2010 Tools for Office Runtime

La página Redistributables contiene un elemento denominado Microsoft VSTO 2010 Runtime(Tiempo de ejecución de Microsoft VSTO 2010), aunque hace referencia a una versión anterior del runtime.The Redistributables page contains an item that's named Microsoft VSTO 2010 Runtime, but it refers to an older version of the runtime. Por lo tanto, podría crear manualmente un archivo de configuración que haga referencia a la versión más reciente.Therefore, you could manually create a configuration file that refers to the most recent version. A continuación, coloque el archivo en el mismo directorio que los archivos de configuración de todos los demás elementos que aparecen en la página Redistributables .You must then put that file into the same directory as the configuration files for all of the other items that appear in the Redistributables page.

Para agregar el Visual Studio 2010 Tools para Office runtime como un requisito previoTo add the Visual Studio 2010 Tools for Office runtime as a prerequisite

  1. Abra el Bloc de notas y, a continuación, pegue el siguiente código XML en un archivo de texto.Open Notepad, and then paste the following XML into a text file.

    <?xml version="1.0" encoding="UTF-8"?>
    <SetupPrereq>
    <conditions>
        <condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VSTO Runtime Setup\v4R" FileName="Version" ReturnValue="10.0.50903" Bits="2"></condition>
    <condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VSTO Runtime Setup\v4R" FileName="Version" ReturnValue="10.0.50903" Bits="2"></condition>
    </conditions>
    <files>
        <file LocalFile="<ISProductFolder>\SetupPrerequisites\VSTOR\vstor_redist.exe" URL="http://download.microsoft.com/download/C/0/0/C001737F-822B-48C2-8F6A-CDE13B4B9E9C/vstor_redist.exe" CheckSum="88b8aa9e8c90818f98c80ac4dd998b88" FileSize=" 0,40117912"></file>
    </files>
    <execute file="vstor_redist.exe" returncodetoreboot="1641,3010" requiresmsiengine="1">
    </execute>
    <properties Id="{15965040-56BB-49B8-A88F-3525C48D9BA8}" Description="This prerequisite installs the most recent version of the Microsoft Visual Studio 2010 Tools for Office Runtime." >
    </properties>
    
    </SetupPrereq>
    
  2. Genere un GUID en Visual Studio.Generate a GUID in Visual Studio. En el menú Herramientas , elija Crear GUID.On the Tools menu, choose Create GUID.

  3. En el programa Generador GUID , elija el botón de opción Formato de registro , elija el botón Copiar y, por último, haga clic en el botón Salir .In the GUID generator program, choose the Registry Format option button, choose the Copy button, and then choose the Exit button.

  4. En el Bloc de notas, reemplace el texto Your GUID goes here por el GUID.In Notepad, replace the text Your GUID goes here by pasting the GUID in its place.

    Aparece el cuadro de diálogo <properties> del archivo se asemeja al siguiente fragmento de código.The <properties> element of your file resembles the following.

    <properties Id="{87989B73-21DC-4403-8FD1-0C68A41A6D8C}" Description="This prerequisite installs the most recent version of the Microsoft Visual Studio 2010 Tools for Office Runtime." >
    </properties>
    
  5. En la barra de menús del Bloc de notas, elija archivo > guardar.On the menu bar in Notepad, choose File > Save.

  6. En el cuadro de diálogo Guardar como , vaya a la carpeta Escritorio .In the Save As dialog box, browse to your Desktop folder.

  7. En el Guardar como tipo elija todos los archivos (*.*) .In the Save as type list, choose All Files (*.*).

  8. En el cuadro Nombre de archivo , escriba Runtime de Visual Studio 2010 Tools para Office.prqy elija el botón Guardar .In the File name box, enter Visual Studio 2010 Tools for Office Runtime.prq, and then choose the Save button.

    Note

    Asegúrese de agregar .prq al final del nombre de archivo para identificarlo como un archivo necesario.Make sure that you add .prq at the end of the file name to identify this file as a prerequisite file.

  9. Cierre el Bloc de notas.Close Notepad.

  10. Desde su Desktop carpeta, copie el Visual Studio 2010 Tools para Office.prq archivo en uno de los siguientes directorios en el equipo.From your Desktop folder, copy the Visual Studio 2010 Tools for Office Runtime.prq file to one of the following directories on your computer.

Para los sistemas operativos de 32 bits: %ProgramFiles%\InstallShield\2013LE\SetupPrerequisites\For 32-bit operating systems: %ProgramFiles%\InstallShield\2013LE\SetupPrerequisites\

Para los sistemas operativos de 64 bits: % ProgramFiles (x86) %\2013LE\SetupPrerequisites\For 64-bit operating systems: %ProgramFiles(x86)%\2013LE\SetupPrerequisites\

  1. En la página Redistributable del proyecto de InstallShield, elija el botón de actualizar para actualizar la lista de componentes redistribuibles, como se muestra en la siguiente ilustración.In the Redistributable page of the InstallShield project, choose the Refresh button to refresh the list of redistributable components, as the following illustration shows.

El botón Actualizar. The refresh button.

  1. En la lista de componentes redistribuibles, active la casilla Visual Studio 2010 Tools for Office Runtime (Runtime de Visual Studio 2010 Tools para Office).In the list of redistributable components, select the Visual Studio 2010 Tools for Office Runtime check box.

Puede aparecer un cuadro de diálogo preguntando si desea instalar el componente redistribuible.A dialog box might appear asking whether you want to install the redistributable component. Si no aparece este cuadro de diálogo, puede ir a la especifique dónde desea implementar la solución en el equipo del usuario sección de este tema.If this dialog box doesn't appear, you can skip to the Specify where you want to deploy the solution on the user's computer section of this topic.

  1. Si aparece el cuadro de diálogo, elija el botón No .If this dialog box appears, choose the No button.

Especificar la ubicación de instalación de la solución en el equipo del usuarioSpecify where to install the solution on the user's computer

  1. En el Explorador de soluciones, expanda el nodo OfficeAddInSetup , después, expanda el nodo Organize your Setup (Organizar la instalación) y, por último, elija el archivo General Information (Información general).In Solution Explorer, expand the OfficeAddInSetup node, expand the Organize your Setup node, and then choose the General Information file.

  2. En la barra de menús, elija vista > abierto.On the menu bar, choose View > Open.

  3. En la lista de propiedades, elija el botón Examinar junto a la propiedad INSTALLDIR .In the list of properties, choose the Browse button next to the INSTALLDIR property.

  4. En el establecer INSTALLDIR cuadro de diálogo, seleccione una carpeta en el equipo del usuario donde desea instalar la solución.In the Set INSTALLDIR dialog box, choose a folder on the user's computer where you want to install the solution.

    Note

    También puede crear subdirectorios en el cuadro de diálogo Set INSTALLDIR (Establecer INSTALLDIR) abriendo el menú contextual de cualquier carpeta de la lista.You can also create subdirectories in the Set INSTALLDIR dialog box by opening the shortcut menu for any folder in the list.

Configurar un complemento de VSTOConfigure a VSTO Add-in

Puede especificar si desea instalar el complemento VSTO para todos los usuarios del equipo (por equipo) o solo para el usuario que realiza la instalación (por usuario).You can specify whether you want your VSTO Add-in to be installed for all users of the computer (per-computer), or only for the user performing the installation (per-user).

Si desea admitir las instalaciones por equipo, cree dos instaladores independientes.If you want to support per-computer installations, create two separate installers. Puede dividir los instaladores en función de la versión de Office (32 y 64 bits) o de la versión de Windows (32 bits y 64 bits) que el usuario ejecute.You can split installers based on the Office version (32-bit and 64-bit) or on the Windows version (32-bit and 64-bit) that the user is running.

Las instalaciones por usuario solo requieren un instalador, independientemente de la versión de Office o de Windows que se utilice.Per-user installations require only one installer regardless of Office or Windows version.

Note

En esta sección solo se aplica si va a implementar un complemento VSTO.This section applies only if you're deploying a VSTO Add-in. Si va a implementar una personalización de nivel de documento, puede pasar inmediatamente a la configurar una personalización de nivel de documento sección.If you're deploying a document-level customization, you can immediately go to the Configure a document-level customization section.

Para especificar si desea admitir las instalaciones por usuario o por equipoTo specify whether you want to support per-user or per-computer installations

  1. En el Explorador de soluciones, expanda el nodo de proyecto OfficeAddInSetup , después, expanda el nodo Organize Your Setup (Organizar la instalación) y, por último, elija el archivo General Information (Información general).In Solution Explorer, expand the OfficeAddInSetup project node, expand the Organize Your Setup node, and then choose the General Information file.

  2. En la barra de menús, elija vista > abierto.On the menu bar, choose View > Open.

    Aparecerán las propiedades del proyecto de instalación.The properties of the setup project appear.

  3. En la lista de la propiedad AllUSERS , especifique si desea que esta solución se instale para todos los usuarios del equipo o solo para el usuario que instala la solución.In the list for the AllUSERS property, specify whether you want this solution to be installed for all users of the computer or for only the user who installs the solution.

    Para instalar el complemento VSTO para el usuario actual, elija ALLUSERS = "" (instalación por usuario).To install the VSTO Add-in for the current user, choose ALLUSERS="" (Per-user installation). Para instalar el complemento VSTO para todos los usuarios del equipo, elija ALLUSERS=1 (Per-machine installation)(ALLUSERS=1 (instalación por equipo)).To install the VSTO Add-in for all users of the computer, choose ALLUSERS=1 (Per-machine installation)

    En el siguiente procedimiento, creará las claves del registro para habilitar la aplicación de Office detecte y cargue el complemento de VSTO.In the next procedure, you'll create registry keys to enable the Office application to discover and load the VSTO Add-in. Consulte entradas del registro para complementos VSTO.See Registry entries for VSTO Add-ins.

Para crear las claves del RegistroTo create registry keys

  1. En el Explorador de soluciones, elija el nodo Project Assistant (Asistente para proyectos).In Solution Explorer, choose the Project Assistant node.

    En la barra de menús, elija vista > abierto.On the menu bar, choose View > Open.

  2. En la parte inferior de la página Project assistant (Asistente para proyectos), elija el botón Application Registry (Registro de aplicaciones), como se muestra en la siguiente ilustración.At the bottom of the Project assistant page, choose the Application Registry button, which the following illustration shows.

    El botón del registro de aplicación. The Application Registry button.

    Aparece la página Application Registry (Registro de aplicaciones).The Application Registry page appears.

  3. Cuando se le pregunte Do you want to configure the registry data that your application will install?(¿Desea configurar los datos del Registro que la aplicación va a instalar?), elija el botón de opción Yes (Sí).Under Do you want to configure the registry data that your application will install?, choose the Yes option button.

  4. En el vista de registro del equipo de destino lista, agregue la jerarquía clave que permite que el tipo de instalador que desea crear.In the Destination computer's Registry view list, add the key hierarchy that enables the type of installer you want to create.

    La ruta de acceso que se configura en esta sección depende de si crea un instalador por usuario o por equipo.The path that you configure in this section depends on whether you create a per-user installer or a per-computer installer.

    Instalador por usuarioPer-user installer

    HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

    Instaladores por equipo según la versión de OfficePer-computer installers based on Office version

Versión de OfficeOffice version

Ruta de acceso de configuración de InstallShieldInstallShield Configuration Path

32 bits32-bit

HKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

64 bits64-bit

HKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

Instaladores por equipo según la versión de WindowsPer-computer installers based on Windows version

Versión de WindowsWindows version

Ruta de acceso de configuración de InstallShieldInstallShield Configuration Path

32 bits32-bit

HKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

64 bits64-bit

HKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

HKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

Note

Un instalador para Windows de 64 bits requiere dos rutas de acceso del registro porque es posible que los usuarios ejecuten las versiones de 32 bits y 64 bits de Office en un equipo que ejecuta Windows de 64 bits.An installer for 64-bit Windows requires two registry paths because it's possible for users to run 32-bit and 64-bit versions of Office on a computer that runs 64-bit Windows.

Note

Como procedimiento recomendado, escriba el nombre de la compañía al principio del nombre del complemento VSTO.As a best practice, start the name of your VSTO Add-in with the name of your company. Esta convención aumenta la probabilidad de que la clave sea única y reduce la posibilidad de conflictos con un complemento VSTO de otro proveedor.This convention increases the chance that the key will be unique and decreases the chance of conflict with a VSTO Add-in from another supplier. Los complementos que tienen el mismo nombre pueden, por ejemplo, sobrescribir las claves del Registro entre ellos.Add-ins that have the same name can, for example, overwrite each other's registration keys. Este método no garantiza que la clave sea única, pero ayuda a reducir posibles conflictos con los nombres.This approach can't guarantee that the key will be unique but can reduce potential name collisions.

  1. Después de crear la jerarquía de claves, abra el menú contextual para el SampleCompany.ExcelAddIn clave, elija Newy, a continuación, elija valor de cadena.After you've created the hierarchy of keys, open the shortcut menu for the SampleCompany.ExcelAddIn key, choose New, and then choose String Value.

    Aparece el nuevo valor de cadena en datos de registro del equipo de destino lista.The new string value appears in the Destination computer's Registry data list. El nombre del valor de cadena se resalta de modo que se pueda cambiar.The name of the string value is highlighted so that you can rename it.

  2. Cambie el nombre del valor a Description.Rename the value to Description.

  3. Repita este proceso para crear los valores siguientes.Repeat this process to create the following values.

Tipo de valorValue Type

NameName

Valor de cadenaString Value

FriendlyNameFriendlyName

Valor DWORDDWORD Value

LoadBehaviorLoadBehavior

Valor de cadenaString Value

ManifestManifest

  1. Abra el menú contextual del valor Description y, a continuación, elija Modificar.Open the shortcut menu for the Description value, and then choose Modify.

    Aparece el cuadro de diálogo Editar datos .The Edit Data dialog box appears.

  2. En el cuadro de texto Datos del valor , escriba Excel Demo Add-Iny elija el botón Aceptar .In the Value data text box, enter Excel Demo Add-In, and then choose the OK button.

    Esta descripción aparece cuando el usuario abre la aplicación de Office, abre el cuadro de diálogo Opciones y, a continuación, en el panel Complementos , elige el complemento VSTO.This description appears when the user opens the Office application, opens the Options dialog box, and then, in the Add-Ins pane, chooses the VSTO Add-in.

  3. Abra el menú contextual del valor FriendlyName y, a continuación, elija Modificar.Open the shortcut menu for the FriendlyName value, and then choose Modify.

Aparece el cuadro de diálogo Editar datos .The Edit Data dialog box appears.

  1. En el cuadro de texto Datos del valor , escriba Excel Demo Add-Iny elija el botón Aceptar .In the Value data text box, enter Excel Demo Add-In, and then choose the OK button.

Esta cadena aparece en el cuadro de diálogo Complementos COM en la aplicación de Office.This string appears in the COM Add-Ins dialog box in the Office application. De forma predeterminada, el valor de la cadena es el identificador del complemento VSTO.By default, the value of the string is the VSTO Add-in ID.

  1. Abra el menú contextual del valor LoadBehavior y, a continuación, elija Modificar.Open the shortcut menu for the LoadBehavior value, and then choose Modify.

Aparece el cuadro de diálogo Editar datos .The Edit Data dialog box appears.

  1. En el cuadro de texto Datos del valor , escriba 3y, a continuación, elija el botón Aceptar .In the Value data text box, enter 3, and then choose the OK button.

El valor 3 carga el complemento VSTO cuando se inicia la aplicación.A value of 3 loads the VSTO Add-in when the application starts. Para obtener más información sobre los valores LoadBehavior, consulte entradas del registro para complementos VSTO.For more information about LoadBehavior values, see Registry entries for VSTO Add-ins.

  1. Abra el menú contextual del valor Manifest y, a continuación, elija Modificar.Open the shortcut menu for the Manifest value, and then choose Modify.

Aparece el cuadro de diálogo Editar datos .The Edit Data dialog box appears.

  1. En el cuadro de texto Datos del valor , escriba file:///[INSTALLDIR]ExcelAddIn.vsto|vstolocaly, a continuación, elija el botón Aceptar .In the Value data text box, enter file:///[INSTALLDIR]ExcelAddIn.vsto|vstolocal, and then choose the OK button.

Runtime de Visual Studio 2010 Tools para Office utiliza esta ruta para buscar el manifiesto de implementación.The Visual Studio 2010 Tools for Office Runtime uses this path to locate the deployment manifest. La parte [INSTALLDIR] de esta ruta de acceso es una macro que se asigna a la propiedad INSTALLDIR en la página de propiedades General Information del programa de instalación de InstallShield.The [INSTALLDIR] portion of this path is a macro that maps to the INSTALLDIR property in the General Information property page of your InstallShield setup project. Esta propiedad especifica la ubicación de instalación del complemento VSTO en el equipo de destino.This property specifies the location on the target computer to install the VSTO Add-in. El sufijo |vstolocal garantiza que la solución se cargue desde la carpeta de instalación, no desde la memoria caché de ClickOnce.The |vstolocal suffix ensures that your solution is loaded from the installation folder, not the ClickOnce cache.

Important

Si crea un área de formulario personalizada en un complemento VSTO para Outlook, debe crear más entradas del registro para registrar el área en Outlook.If you create a custom form region in a VSTO Add-in for Outlook, you must create more registry entries to register the region with Outlook. Para obtener más información, consulte áreas de formulario de entradas del registro para Outlook.For more information, see Registry entries for Outlook form regions.

Configure a document-level customizationConfigure a document-level customization

En esta sección solo se aplica si va a implementar una personalización de nivel de documento.This section applies only if you're deploying a document-level customization. Si va a implementar un complemento de VSTO, puede pasar inmediatamente a la compilar el proyecto de instalación sección.If you're deploying a VSTO Add-in, you can go immediately to the Build the setup project section.

Las personalizaciones de nivel de documento no use las claves del registro.Document-level customizations don't use registry keys. En su lugar, las propiedades de documento personalizadas contienen la ubicación del manifiesto de implementación.Instead, custom document properties contain the location of the deployment manifest.

Para modificar las propiedades personalizadas, crear un programa que quita la personalización de nivel de documento del documento, modifica las propiedades adecuadas y, a continuación, vuelve a adjuntar personalización al documento.To modify custom properties, you create a program that removes the document-level customization from the document, modifies the appropriate properties, and then reattaches customization to the document. Después, se crea una acción personalizada que ejecuta el programa y se agrega al proyecto de instalación.You then create a custom action that runs the program, and you add that action to your setup project.

Para crear un programa que modifique las propiedades del documentoTo create a program that modifies document properties

  1. En la barra de menús, elija archivo > agregar > nuevo proyecto.On the menu bar, choose File > Add > New Project.

    Aparece el cuadro de diálogo Agregar nuevo proyecto .The Add New Project dialog box appears.

  2. En el panel de plantillas, debajo del nodo del lenguaje que desee usar, elija la carpeta Windows .In the templates pane, under the node for the language that you want to use, choose the Windows folder.

  3. En la lista de tipos de proyecto para Windows, elija la plantilla Aplicación de consola .In the list of project types for Windows, choose the Console Application template.

  4. Asigne el nombre SetExcelDocumentPropertiesal proyecto y, a continuación, elija el botón Aceptar .Name the project SetExcelDocumentProperties, and then choose the OK button.

  5. En el Explorador de soluciones, elija el botón Mostrar todos los archivos , abra el menú contextual del nodo de proyecto SetExcelDocumentProperties y elija Agregar referencia.In Solution Explorer, choose the Show All Files button, open the shortcut menu for the SetExcelDocumentProperties project node, and then choose Add Reference.

  6. En el cuadro de diálogo Administrador de referencias , elija la pestaña Extensiones , active la casilla situada junto a los siguientes ensamblados y, después, elija el botón Aceptar .In the Reference Manager dialog box, choose the Extensions tab, and then select the check box next to the following assemblies, and then choose the OK button.

    • Microsoft.VisualStudio.Tools.Applications.RuntimeMicrosoft.VisualStudio.Tools.Applications.Runtime

    • Microsoft.VisualStudio.Tools.Applications.ServerDocumentMicrosoft.VisualStudio.Tools.Applications.ServerDocument

  7. En el Explorador de soluciones, elija el archivo Program.cs (para las aplicaciones de C#) o el archivo Module1.vb (para las aplicaciones de Visual Basic).In Solution Explorer, choose the Program.cs file (for C# applications) or the Module1.vb file (for Visual Basic applications).

  8. En la barra de menús, elija vista > abierto.On the menu bar, choose View > Open.

  9. Reemplace el contenido de todo el archivo por el código siguiente.Replace the contents of the entire file with the following code.

Imports Microsoft.VisualStudio.Tools.Applications.Runtime
Imports Microsoft.VisualStudio.Tools.Applications

Module Module1

    Sub Main()

        Dim assemblyLocation As String = ""
        Dim solutionID As Guid
        Dim deploymentManifestLocation As Uri = Nothing
        Dim documentLocation As String = ""
        Dim nonpublicCachedDataMembers As String() = Nothing

        Dim CommandLineArgs As  _
            System.Collections.ObjectModel.ReadOnlyCollection(Of String) = _
            My.Application.CommandLineArgs

        For i As Integer = 0 To CommandLineArgs.Count - 1

            Console.WriteLine(CommandLineArgs(i))
            Dim oArugment As String() = CommandLineArgs(i).Split("=")

            Select Case oArugment(0)

                Case "/assemblyLocation"
                    assemblyLocation = oArugment(1)

                Case "/deploymentManifestLocation"
                    If Not Uri.TryCreate(oArugment(1), UriKind.Absolute, _
                                         deploymentManifestLocation) Then
                        MsgBox("Error creating URI")
                    End If

                Case "/documentLocation"
                    documentLocation = oArugment(1)

                Case "/solutionID"
                    solutionID = Guid.Parse(oArugment(1))
            End Select
        Next
        Try
            ServerDocument.RemoveCustomization(documentLocation)
            ServerDocument.AddCustomization(documentLocation, assemblyLocation, _
                                            solutionID, deploymentManifestLocation, _
                                            True, nonpublicCachedDataMembers)

            Console.WriteLine("Insallation Location Modified Successfully")

        Catch ex As System.IO.FileNotFoundException
            Console.WriteLine("The specified document does not exist.")
            Console.ReadLine()


        Catch ex As System.IO.IOException
            Console.WriteLine("The specified document is read-only.")
            Console.ReadLine()


        Catch ex As InvalidOperationException

            Console.WriteLine("The customization could not be removed.\n" &
                ex.Message)
            Console.ReadLine()


        Catch ex As DocumentNotCustomizedException
            Console.WriteLine("The document could not be customized.\n" &
                ex.Message)
            Console.ReadLine()

        End Try
    End Sub

End Module
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using Microsoft.VisualStudio.Tools.Applications.Runtime;
using Microsoft.VisualStudio.Tools.Applications;

namespace SetExcelDocumentProperties
{
    class Program
    {
        static void Main(string[] args)
        {
            string assemblyLocation = "";
            Guid solutionID = new Guid();
            Uri deploymentManifestLocation = null;
            string documentLocation = "";
            string[] nonpublicCachedDataMembers = null;

            for (int i = 0; i <= args.Count() - 1; i++)
            {
                Console.WriteLine(args[i]);
                string[] oArugment = args[i].Split('=');

                switch (oArugment[0])
                {
                    case "/assemblyLocation":
                        assemblyLocation = oArugment[1];
                        break;
                    case "/deploymentManifestLocation":
                        if (!Uri.TryCreate(oArugment[1], UriKind.Absolute, out deploymentManifestLocation))
                        {
                            Console.WriteLine("Error creating URI");
                        }
                        break;
                    case "/documentLocation":
                        documentLocation = oArugment[1];
                        break;
                    case "/solutionID":
                        solutionID = Guid.Parse(oArugment[1]);
                        break;
                }
            }
            try
            {
                ServerDocument.RemoveCustomization(documentLocation);
                ServerDocument.AddCustomization(documentLocation, assemblyLocation,
                                            solutionID, deploymentManifestLocation,
                                            true, out nonpublicCachedDataMembers);

            }
            catch (System.IO.FileNotFoundException)
            {
                Console.WriteLine("The specified document does not exist.");
            }
            catch (System.IO.IOException)
            {
                Console.WriteLine("The specified document is read-only.");
            }
            catch (InvalidOperationException ex)
            {
                Console.WriteLine("The customization could not be removed.\n" +
                    ex.Message);
            }
            catch (DocumentNotCustomizedException ex)
            {
                Console.WriteLine("The document could not be customized.\n" +
                    ex.Message);
            }
        }
    }
}
  1. Compile el proyecto.Compile the project.

Para agregar una acción personalizada que ejecute el programaTo add a custom action that runs your program

  1. En el Explorador de soluciones, expanda el nodo de proyecto OfficeAddInSetup y, a continuación, elija el archivo Project Assistant (Asistente para proyectos), que se muestra en la siguiente ilustración.In Solution Explorer, expand the OfficeAddInSetup project node, and then choose the Project Assistant file, which the following illustration shows.

    Asistente de archivo en el Explorador de soluciones de proyectoProject Assistant File in Solution Explorer

  2. En la barra de menús, elija vista > abierto.On the menu bar, choose View > Open.

  3. En la parte inferior de la página Project assistant (Asistente para proyectos), elija el botón Archivos de aplicación , como se muestra en la siguiente ilustración.At the bottom of the Project assistant page, choose the Application Files button, which the following illustration shows.

    El botón archivos de la aplicación. The Application Files button.

  4. En la página de Archivos de aplicación , elija el botón Agregar resultados del proyecto .In the Application Files page, choose the Add Project Outputs button.

    Aparece el cuadro de diálogo del selector de resultados de Visual Studio .The Visual Studio Output Selector dialog box appears.

  5. Bajo el nodo SetExcelDocumentProperties , active la casilla Resultado principal y después elija el botón Aceptar .Under the SetExcelDocumentProperties node, select the Primary Output check box, and then choose the OK button.

  6. En el Explorador de soluciones, bajo el nodo OfficeAddInSetup , expanda el nodo Define Setup Requirements and Actions (Definir acciones y requisitos de instalación) y, después, elija la carpeta Acciones personalizadas .In Solution Explorer, under the OfficeAddInSetup node, expand the Define Setup Requirements and Actions node, and then choose the Custom Actions folder.

  7. En la barra de menús, elija vista > abierto.On the menu bar, choose View > Open.

    Aparece una lista de eventos en un panel a un lado de la pantalla.A list of events appear in a pane to the side of the screen.

    Note

    Solo algunos de los eventos que aparecen en esta lista están disponibles en InstallShield Limited Edition.Only a few events that appear in this list are available in InstallShield Limited Edition. En este procedimiento, va a ejecutar el programa mediante el uso de la diálogo correcta después de la instalación completa eventos.In this procedure, you'll run the program by using the After Setup Complete Success dialog event.

  8. En la lista de eventos, en Custom Actions During Installation(Acciones personalizadas durante la instalación), abra el menú contextual del evento de cuadro de diálogo de instalación correcta después de la finalización y, a continuación, elija New EXE(Nuevo EXE).In the list of events, under Custom Actions During Installation, open the shortcut menu for the After Setup Complete Success dialog event, and then choose New EXE.

    Aparece una acción personalizada denominada NewCustomAction1 bajo el evento de cuadro de diálogo de instalación correcta después de la finalización .A custom action that's named NewCustomAction1 appears under the After Setup Complete Success dialog event. Un conjunto de propiedades para la acción personalizada aparece en un panel junto a los eventos.A set of properties for the custom action appears in a pane next to the events.

    Important

    Dos eventos de cuadro de diálogo de instalación correcta después de la finalización aparecen en la lista de eventos.Two After Setup Complete Success dialog events appear in the list of events. Asegúrese de elegir la instancia del evento de cuadro de diálogo de instalación correcta después de la finalización que aparece bajo el nodo de Custom Actions During Installation (Acciones personalizadas durante la instalación).Make sure that you choose the instance of the After Setup Complete Success dialog event that appears under the Custom Actions During Installation node.

  9. En la lista de la propiedad Source Location (Ubicación de origen), elija Installed with the Product(Instalado con el producto).In the list for the Source Location property, choose Installed with the Product.

  10. Elija el botón Examinar junto a la propiedad Nombre de archivo .Choose the Browse button next to the File Name property.

  11. En el cuadro de diálogo de Browse for a Destination File (Buscar un archivo de destino), vaya al archivo SetExcelDocumentProperties.Primary.output y elija el botón Abrir .In the Browse for a Destination File dialog box, browse to the SetExcelDocumentProperties.Primary.output file, and then choose the Open button.

    La ubicación de este archivo depende de la carpeta que se especificó para la propiedad INSTALLDIR del proyecto de instalación.The location of this file depends on the folder that you specified for the INSTALLDIR property of the setup project. Por ejemplo, si establece esta propiedad en una carpeta que se denomina [PersonalFolder]DemoWorkbookApp, el archivo SetExcelDocumentProperties.Primary.output se encuentra en [ProgramFilesFolder]\DemoWorkbookApp.For example, if you set that property to a folder that's named [PersonalFolder]DemoWorkbookApp, you can find the SetExcelDocumentProperties.Primary.output file by browsing to [ProgramFilesFolder]\DemoWorkbookApp.

    En los pasos siguientes, se obtendrá el identificador de la solución del documento y, a continuación, pasar ese identificador como un parámetro a la aplicación de consola.In the next few steps, you'll get the solution ID of the document and then pass that ID as a parameter to the console application. También deberá pasar la ubicación del documento, el manifiesto de implementación y el ensamblado del documento.You'll also pass the location of the document, the deployment manifest, and the document assembly.

  12. Abra el menú contextual del proyecto ExcelWorkbook y, a continuación, elija Abrir carpeta en el Explorador de Windows o Abrir carpeta en el Explorador de archivos , según el sistema operativo.Open the shortcut menu for the ExcelWorkbook project, and then choose Open Folder in Windows Explorer or Open Folder in File Explorer depending on your operating system.

    Se abre la carpeta que contiene la solución.The folder that contains your solution opens.

  13. Abra el archivo de proyecto de la solución en el Bloc de notas.Open the project file of your solution in Notepad. Para proyectos de Visual Basic, el nombre del archivo es ExcelWorkbook.vbproj.For Visual Basic projects, the name of the file is ExcelWorkbook.vbproj. Para proyectos de C#, el nombre del archivo es ExcelWorkbook.csproj.For C# projects, the name of the file is ExcelWorkbook.csproj.

  14. En el archivo de proyecto, busque el <SolutionID> elemento, copie su valor en el Portapapeles y, a continuación, cierre el Bloc de notas.In the project file, search for the <SolutionID> element, copy its value to the Clipboard, and then close Notepad.

    Este valor se transfiere a la aplicación de consola como un parámetro.You pass this value into the console app as a parameter.

  15. En la página de propiedades de NewCustomAction1, establezca la propiedad de Línea de comandos en la siguiente línea de texto.In the properties page of NewCustomAction1, set the Command Line property to the following line of text.

/assemblyLocation="[INSTALLDIR]ExcelWorkbook.dll" /deploymentManifestLocation="[INSTALLDIR]ExcelWorkbook.vsto" /documentLocation="[INSTALLDIR]ExcelWorkbook.xlsx" /solutionID="Your Solution ID"
  1. Reemplace Your Solution ID por el identificador de la solución que copió en el Portapapeles.Replace Your Solution ID with the solution ID that you copied to the Clipboard.

Important

Pruebe el instalador para comprobar que la aplicación de consola que ejecuta esta acción personalizada tiene acceso a los documentos del directorio [INSTALLDIR].Test your installer to verify that the console application that this custom action runs can access documents in the [INSTALLDIR] directory. Algunos directorios en el equipo del usuario pueden requerir acceso administrativo (por ejemplo, el directorio de archivos de programa).Some directories on the user's computer might require administrative access (for example, the Program Files directory). Si va a implementar la solución en un directorio que requiere acceso administrativo, abra el propiedades cuadro de diálogo de la setup.exe de archivos, elija el compatibilidad pestaña y, a continuación, seleccione el ejecutar este programa como administrador casilla de verificación antes de distribuir el instalador.If you're deploying your solution to a directory that requires administrative access, you should open the Properties dialog box of the setup.exe file, choose the Compatibility tab, and then select the Run this program as administrator check box before you distribute the installer. Si no desea que los usuarios ejecuten el programa de instalación con permisos administrativos, establezca la propiedad [INSTALLDIR] en un directorio al que el usuario probablemente tenga acceso aún, como el documentos directory.If you don't want users to run the setup program with administrative permissions, set the [INSTALLDIR] property to a directory to which the user probably has access already, such as the Documents directory. Para obtener más información, consulte el especifique dónde desea instalar la solución en el equipo del usuario sección de este tema.For more information, see the Specify Where You Want to Install the Solution on the user's computer section of this topic.

Build the setup projectBuild the setup project

  1. En el Explorador de soluciones, expanda el nodo de Prepare for Release (Preparar para lanzamiento) y, a continuación, elija el archivo Versiones .In Solution Explorer, expand the Prepare for Release node, and then choose the Releases file.

  2. En la barra de menús, elija vista > abierto.On the menu bar, choose View > Open.

    Se abre el explorador de compilaciones en un panel lateral para poder elegir el tipo de versión que desea crear.The Builds explorer opens in a side pane so that you can choose the type of release that you want to create.

  3. En el explorador de compilaciones , elija la carpeta SingleImage .In the Builds explorer, choose the SingleImage folder.

  4. En el panel situado junto al explorador de compilaciones , elija la pestaña Setup.exe .In the pane next to the Builds explorer, choose the Setup.exe tab.

  5. En la página de propiedades de Setup.exe , en la lista InstallShield Prerequisites Location (Ubicación de los requisitos previos de InstallShield), elija Download From The Web(Descargar de la Web).In the Setup.exe property page, from the InstallShield Prerequisites Location list, choose Download From The Web.

  6. En la barra de menús, elija Compilar > Administrador de configuración.On the menu bar, choose Build > Configuration Manager.

  7. En la lista Configuración de soluciones activas , elija SingleImage.In the Active solution configuration list, choose SingleImage.

  8. En la tabla Contextos del proyecto , en la columna Configuración del proyecto OfficeAddInSetup , elija SingleImagey, después, elija el botón Cerrar .In the Project contexts table, in the Configuration column of the OfficeAddInSetup project, choose SingleImage, and then choose the Close button.

  9. En la barra de menús, elija compilar > compilar OfficeAddInSetup.On the menu bar, choose Build > Build OfficeAddInSetup.

    Una vez finalizada la compilación, puede buscar el setup.exe archivos de la OfficeAddInSetup proyecto en la siguiente ubicación: OfficeAddInSetupProjectRoot\OfficeAddInSetup\Express\SingleImage\DiskImages\DISK1\After the build completes, you can locate the setup.exe file of the OfficeAddInSetup project at the following location: OfficeAddInSetupProjectRoot\OfficeAddInSetup\Express\SingleImage\DiskImages\DISK1\

Vea tambiénSee also