Recopilación automática de dependenciasDependency auto-collection

A continuación encontrará la lista de las llamadas de dependencia admitida actualmente que se detectan automáticamente como dependencias sin requerir ninguna modificación adicional en el código de la aplicación.Below is the currently supported list of dependency calls that are automatically detected as dependencies without requiring any additional modification to your application's code. Estas dependencias se visualizan en el Mapa de aplicación de Application Insights y las vistas de Diagnóstico de transacciones.These dependencies are visualized in the Application Insights Application map and Transaction diagnostics views. Si la dependencia no se encuentra en la siguiente lista, todavía puede realizar un seguimiento manual con una llamada a TrackDependency .If your dependency isn't on the list below, you can still track it manually with a track dependency call.

.NET.NET

Marcos de trabajo de aplicacionesApp frameworks VersionesVersions
WebForms de ASP.NETASP.NET Webforms 4.5+4.5+
ASP.NET MVCASP.NET MVC 4+4+
WebAPI de ASP.NETASP.NET WebAPI 4.5+4.5+
ASP.NET CoreASP.NET Core 1.1+1.1+
Bibliotecas de comunicaciones Communication libraries
HttpClientHttpClient 4.5+, .NET Core 1.1+4.5+, .NET Core 1.1+
SqlClientSqlClient .NET Core 1.0+, NuGet 4.3.0.NET Core 1.0+, NuGet 4.3.0
Microsoft.Data.SqlClientMicrosoft.Data.SqlClient 1.1.0: versión estable más reciente.1.1.0 - latest stable release. (Consulte la siguiente nota).(See Note below.)
SDK de cliente de Event HubsEventHubs Client SDK 1.1.01.1.0
SDK de cliente de Service BusServiceBus Client SDK 3.0.03.0.0
Clientes de StorageStorage clients
ADO.NETADO.NET 4.5+4.5+

Nota

Hay un problema conocido con versiones anteriores de Microsoft.Data.SqlClient.There is a known issue with older versions of Microsoft.Data.SqlClient. Se recomienda usar la versión 1.1.0 o posterior para mitigar este problema.We recommend using 1.1.0 or later to mitigate this issue. Entity Framework Core no necesariamente se distribuye con la versión estable más reciente de Microsoft.Data.SqlClient, por lo que se recomienda confirmar que está usando al menos la versión 1.1.0 para evitar este problema.Entity Framework Core does not necessarily ship with the latest stable release of Microsoft.Data.SqlClient so we advise confirming that you are on at least 1.1.0 to avoid this issue.

JavaJava

Servidores de aplicacionesApp servers VersionesVersions
TomcatTomcat 7, 87, 8
JBoss EAPJBoss EAP 6, 76, 7
JettyJetty 99
Marcos de trabajo de aplicacionesApp frameworks
SpringSpring 3.03.0
Spring BootSpring Boot 1.5.9+*1.5.9+*
Servlet de JavaJava Servlet 3.1+3.1+
Bibliotecas de comunicacionesCommunication libraries
Cliente HTTP de ApacheApache Http Client 4.3+4.3+
Clientes de StorageStorage clients
SQL ServerSQL Server 1+1+
PostgreSQL (compatibilidad con la versión beta)PostgreSQL (Beta Support)
OracleOracle 1+1+
MySQLMySql 1+1+
Bibliotecas de registroLogging libraries
LogbackLogback 1+1+
Log4jLog4j 1.2+1.2+
Bibliotecas de métricasMetrics libraries
JMXJMX 1.0+1.0+

Nota

* Excepto el soporte técnico de programación reactivo.*Except reactive programing support.
† Requiere la instalación del agente de JVM.†Requires installation of JVM Agent.

Node.jsNode.js

Bibliotecas de comunicacionesCommunication libraries VersionesVersions
HTTP, HTTPSHTTP, HTTPS 0.10+0.10+
Clientes de StorageStorage clients
RedisRedis 2.x2.x
MongoDb; MongoDb CoreMongoDb; MongoDb Core 2.x - 3.x2.x - 3.x
MySQLMySQL 2.0.0 - 2.16.x2.0.0 - 2.16.x
PostgreSQL;PostgreSql; 6.x - 7.x6.x - 7.x
pg-poolpg-pool 1.x - 2.x1.x - 2.x
Bibliotecas de registroLogging libraries
Consolaconsole 0.10+0.10+
BunyanBunyan 1.x1.x
WinstonWinston 2.x - 3.x2.x - 3.x

JavaScriptJavaScript

Bibliotecas de comunicacionesCommunication libraries VersionesVersions
XMLHttpRequestXMLHttpRequest AllAll

Pasos siguientesNext steps