ActiveSync-asiakasohjelmat eivät voi muodostaa yhteyttä tai synkronointi viivästyy Exchange Server ympäristössä

Alkuperäinen KT-numero: 4456227, 4337638

Oireet

Exchange Server 2016- tai Exchange Server 2013 -ympäristössä Exchange ActiveSync asiakasohjelmat eivät voi muodostaa yhteyttä tai he kokevat viiveitä, kun käyttäjät synkronoivat mobiililaitteensa. Näiden ongelmien lisäksi kaikki CAS-roolin funktiot lakkaavat toimimasta. Tämä ongelma ilmenee sen jälkeen, kun Exchange ActiveSync sovellussarjaa suoritetaan jonkin aikaa, yleensä useita viikkoja. Lisäksi saatat kohdata seuraavaa toimintaa:

  • Tapahtumatunnus 4227 kirjataan Tapahtumienvalvonta järjestelmälokiin.
  • Exchange ActiveSync sovellussarjaan kuluu paljon muistoja.
  • .NET CLR Memory/% Aika GC-laskurissaw3wp-esiintymälle, joka vastaa Exchange ActiveSync sovellussarja on epätavallisen suuri.
  • TCP-portin sammuminen johtuu Exchange ActiveSync olevien pyyntöjen suuresta määrästä.
  • MSExchangeSyncAppPool-esiintymänW3SVC_W3WP/aktiiviset pyynnöt -laskuri näyttää tasaisesti kasvavan arvon useiden päivien tai viikkojen aikana.
  • Komento netstat -anob voi näyttää useita yhteyksiä CLOSE_WAIT tilassa.

Syy

Tämä on tunnettu ongelma, joka ilmenee, kun Exchange ActiveSync Ping-komennot jäävät jumiin sovellussarjaan.

Vaihtoehtoinen menetelmä

Jotta Exchange Server 2013 voidaan kiertää tämä ongelma, pyöräile säännöllisesti Exchange ActiveSync sovellussarjaa kaikille palvelimille, jotta jumiutuneet komennot voidaan vapauttaa. Lisätietoja siitä, miten voit määrittää sovellussarjan kierrättämään automaattisesti säännöllisin väliajoin, on kohdassa Sovellussarjan <kierrätyksen> asetukset.

Ratkaisu

Ratkaise ongelma asentamalla Exchange Server 2016 kumulatiivinen päivitys 11 Exchange Server 2016:lle tai uudempi kumulatiivinen päivitys Exchange Server 2016.

Tila

Microsoft on vahvistanut, että tämä on ongelma Microsoft-tuotteissa, jotka on lueteltu kohdassa Koskee.

Lisätietoja

Tutustu terminologiaan , jota Microsoft käyttää ohjelmistopäivitysten kuvaamiseen.