PowerPoint ei voi ladata apuohjelmaa, kun lasket makron suojaustasoa

Huomautus

Office 365 ProPlus nimetään uudelleen Microsoft 365 Apps for enterprise -sovellukseksi. Lisätietoja tästä muutoksesta on tässä blogikirjoituksessa.

Oireet

Kun lasket makrosuojaustasoa Microsoft PowerPointissa ja avaat sitten PowerPoint-apuohjelmatiedoston (*.ppa), uutta makrosuojaustasoa ei ehkä sovelleta eikä apuohjelmatiedosto ehkä toimi odotetulla tavalla. Apuohjelma näkyy käytettävissä olevana apuohjelmana Add-Ins-valintaikkunassa, mutta valintaruutua ei ole valittu, ja näyttöön tulee seuraavan kaltainen virhesanoma, kun yrität valita valintaruudun:

PowerPoint ei pystynyt lataamaan apuohjelmaa tiedostonimi.

Syy

Tämä voi tapahtua, jos seuraavat ehdot täyttyvät:

  1. Yrität avata PowerPoint-apuohjelmatiedoston Tiedosto-valikon Avaa-komennolla, kun makron suojaustasoksi on määritetty Korkea.
  2. Lasket makron suojaustason asetusta.
  3. Voit avata saman PowerPoint-apuohjelmatiedoston Tiedosto-valikon Avaa-komennolla.

Kun yrität avata apuohjelmatiedoston ja apuohjelmaa ei ladata makrosuojaussyistä, PowerPoint tallentaa tilapäisesti (välimuistit) tämän apuohjelman virhetiedot. PowerPoint ei voi ladata apuohjelmaa sen jälkeen, kun olet laskenut makron suojaustasoa, kunnes välimuistiin tallennetut tiedot on tyhjenetty.

Vaihtoehtoinen menetelmä

Voit ratkaista ongelman tyhjentämällä välimuistiin tallennetut tiedot ja lataamalla apuohjelman jommankumman seuraavista tavoista makrosuojaustason asetuksen muutoksen jälkeen.

Menetelmä 1: PowerPointin lopettaminen ja käynnistäminen uudelleen

  1. Sulje PowerPoint.
  2. Käynnistä PowerPoint uudelleen.
  3. Avaa apuohjelmatiedosto.
  4. Lataa apuohjelma valitsemalla HYVÄKSYN.

Menetelmä 2: Apuohjelman poistaminen ja lisääminen

Voit poistaa apuohjelman ja lisätä sen PowerPoint 2002:ssa seuraavasti:

  1. Valitse Työkalut-valikossa Apuohjelmat.
  2. Valitse käytettävissä Add-Ins-luettelosta apuohjelma ja valitse sitten Poista.
  3. Valitse Lisää uusi, valitse apuohjelma, valitse OK, lataa apuohjelma valitsemalla HYVÄKSYN ja valitse sitten Sulje.

Voit poistaa apuohjelman PowerPoint 2007:ssä seuraavasti:

  1. Napsauta Microsoft Office -painiketta, valitse PowerPointin asetukset ja valitse sitten Apuohjelmat.
  2. Valitse Hallinta-luettelosta PowerPoint-apuohjelmat ja valitse sitten Siirry.
  3. Valitse Käytettävissä olevat apuohjelmat -luettelosta poistettava apuohjelma, valitse Poista ja valitse sitten Sulje.

Jos haluat lisätä apuohjelman PowerPoint 2007:ssä, toimi seuraavasti:

  1. Napsauta Microsoft Office -painiketta, valitse PowerPointin asetukset ja valitse sitten Apuohjelmat.
  2. Valitse Hallinta-luettelosta PowerPoint-apuohjelmat ja valitse sitten Siirry.
  3. Valitse Apuohjelmat-valintaikkunassa Lisää uusi.
  4. Etsi Lisää uusi PowerPoint-apuohjelma -valintaikkunassa apuohjelma, jonka haluat lisätä, ja valitse sitten OK.
  5. Näkyviin tulee suojausilmoitus. Jos olet varma, että apuohjelma on peräisin luotettavasta lähteestä, valitse Ota makrot käyttöön ja valitse sitten Sulje.

Tila

Microsoft on varmistanut, että tämä on ongelma Microsoft-tuotteissa, jotka on lueteltu Koskee seuraavia -osassa.

Ongelman toistaminen uudelleen

PowerPoint 2007

  1. Käynnistä PowerPoint 2007.

  2. Valitse Kehitystyökalut-välilehden Koodi-ryhmässä Makrosuojaus.

    Huomautus

    Kehitystyökalut-välilehti ei ole oletusarvoisesti näkyvissä. Saat Kehitystyökalut-välilehden näkyviin napsauttamalla Microsoft Office-painiketta , valitsemalla PowerPointin asetukset , valitsemalla Näytä Kehitystyökalut-välilehden valintanauhan PowerPointin käyttöasetukset -kohdasta ja valitsemalla sitten OK.

  3. Valitse Luottamuskeskus-sivun Makrojen asetukset -kohdassa Poista käytöstä kaikki makrot ilmoituksen kanssa ja valitse sitten OK.

  4. Valitse Office-valikossa Avaa.

  5. Napsauta avattavassa Tiedostotyyppi-ruudussa olevaa nuolta ja valitse PowerPoint-apuohjelmat(.ppam;. ppa), valitse apuohjelma ja valitse sitten Avaa.

    Huomautus

    Apuohjelma ei lataudu odotetulla tavalla.

  6. Valitse Kehitystyökalut-välilehden Koodi-ryhmässä Makrosuojaus.

  7. Valitse Luottamuskeskus-sivulla Ota käyttöön kaikki makrot (ei suositella; saattaa sallia mahdollisesti haitallisen koodin suorittamisen) kohdassa Makroasetukset ja valitse sitten OK.

  8. Valitse Office-valikossa Avaa.

  9. Napsauta avattavassa Tiedostotyyppi-ruudussa olevaa nuolta ja valitse PowerPoint-apuohjelmat(.ppam;. ppa), valitse apuohjelma ja valitse sitten Avaa.

    Huomautus

    Sinua ei kehoteta ottamaan makroa käyttöön tai poistamaan sitä käytöstä. Lisäksi apuohjelma ei edelleenkään lataudu.

PowerPoint 2002

  1. Käynnistä PowerPoint.

  2. Valitse Työkalut-valikossa Makro ja valitse sitten Suojaus.

  3. Valitse Suojaustaso-välilehdessä Korkea.

  4. Valitse Tiedosto-valikossa Avaa.

  5. Napsauta Tiedostotyyppi-ruudussa olevaa nuolta, valitse PowerPoint-apuohjelmat, valitse apuohjelma ja valitse sitten Avaa.

    Huomautus

    Apuohjelma ei lataudu odotetulla tavalla.

  6. Valitse Työkalut-valikossa Makro ja valitse sitten Suojaus.

  7. Valitse Suojaustaso-välilehdessä Normaali.

  8. Valitse Tiedosto-valikossa Avaa.

  9. Napsauta Tiedostotyyppi-ruudussa olevaa nuolta, valitse PowerPoint-apuohjelmat, valitse apuohjelma ja valitse sitten Avaa.

    Huomautus

    Sinua ei kehoteta ottamaan makroa käyttöön tai poistamaan sitä käytöstä, eikä apuohjelma lataudu.