Power BI Desktopin käytön aloittaminenGetting started with Power BI Desktop

Onko tästä sivusta apua?

Tervetuloa Power BI Desktopin aloitusoppaaseen.Welcome to the Power BI Desktop Getting Started Guide. Tässä lyhyessä esittelyssä kerrotaan, miten Power BI Desktop toimii ja mitä sillä voi tehdä, ja autetaan sinua rakentamaan tehokkaita tietomalleja ja upeita raportteja, jotka vahvistavat liiketoimintatietojasi.This short tour of Power BI Desktop gets you acquainted with how it works, demonstrates what it can do, and accelerates your ability to build robust data models — along with amazing reports — that amplify your business intelligence efforts.

Katsotko mieluummin lukemisen sijaan?Prefer to watch instead of read? Voit myös tutustua aloitusvideoomme.Feel free to take a look at our getting started video. Jos haluat seurata videota vastaavilla mallitiedoilla, voit ladata tämän Excel-mallityökirjan.And if you want to follow along with the video with matching sample data, you can download this sample Excel workbook.

Power BI Desktopin avulla voit luoda kyselykokoelmia, tietoyhteyksiä ja raportteja, jotka on helppo jakaa muiden kanssa.Power BI Desktop lets you create a collection of queries, data connections, and reports that can easily be shared with others. Power BI Desktopissa yhdistyvät Microsoftin taatut tekniikat – tehokas kyselyohjelma, tietomallinnus ja visualisoinnit – ja se toimii saumattomasti Power BI -palvelun verkkoversion kanssa.Power BI Desktop integrates proven Microsoft technologies – the powerful Query engine, data modeling, and visualizations – and works seamlessly with the online Power BI service.

Yhdessä Power BI Desktop (jossa analyytikot ym. voivat luoda tehokkaita tietoyhteyksiä, malleja ja raportteja) ja Power BI -palvelu (jossa Power BI Desktopin raportit voidaan jakaa, jotta käyttäjät voivat tarkastella ja ja käyttää niitä) tarjoavat uusia merkityksellisiä tietoja, jotka on helpompi mallintaa, rakentaa, jakaa ja laajentaa.With the combination of Power BI Desktop (where analysts and others can create powerful data connections, models and reports) and the Power BI service (where Power BI Desktop reports can be shared so users can view and interact with them), new insights from the world of data are easier to model, build, share, and extend.

Tietoanalyytikot tulevat huomaamaan, että Power BI Desktop on tehokas, joustava ja erittäin helppo työkalu käyttää, mallintaa tietoja, rakentaa tehokkaita tietomalleja ja luoda hyvin jäsenneltyjä raportteja.Data analysts will find Power BI Desktop a powerful, flexible, and a highly accessible tool to connect with and shape the world of data, build robust models, and craft well-structured reports.

Tämän oppaan käyttäminenHow to use this guide

Voit käyttää tätä opasta muutamalla eri tavalla – voit selailla sitä nopeasti tai lukea läpi jokaisen osan, jolloin saat vahvan käsityksen siitä, miten Power BI Desktop toimii.You can use this guide in a couple of ways – scan it for a quick overview, or read through each section for a strong understanding of how Power BI Desktop works.

Jos sinulla on kiire, voit silmäillä oppaan läpi muutamassa minuutissa ja silti saada hyvän kuvan siitä, miten Power BI Desktop toimii ja miten sitä käytetään.If you’re in a hurry you can do a visual sweep of this guide in just a couple minutes, and come away with a good sense of how Power BI Desktop operates, and how to use it. Suurin osa tästä oppaasta koostuu näytöistä, jotka kertovat, miten Power BI Desktop toimii.Most of this guide consists of screens that visually show how Power BI Desktop works.

Jos haluat kattavamman käsityksen, voit lukea jokaisen osan, noudattaa vaiheita ja lopuksi julkaista itse luomasi Power BI Desktop -tiedoston Power BI -palveluun ja jakaa sen muiden kanssa.For a more thorough understanding you can read through each section, perform the steps, and walk away with your own Power BI Desktop file that’s ready to post onto the Power BI service, and share with others.

Huomautus

Power BI:stä on myös erillinen erikoisversio, Power BI -raporttipalvelin, joka on tarkoitettu asiakkaille, joiden tietoja ja raportteja on säilytettävä paikallisesti.There is also a separate and specialized version of Power BI called Power BI Report Server, which is for customers who need their data and reporting to remain on-premises. Power BI Desktopista on myös saatavilla erillinen erikoisversio, Power BI Desktop Power BI -raporttipalvelimelle, joka toimii ainoastaan Power BI:n raporttipalvelinversion kanssa.For use with that specialized version, there's also a separate and specialized version of Power BI Desktop called Power BI Desktop for Power BI Report Server, which works only with the Report Server version of Power BI. Tämä artikkeli käsittelee Power BI Desktopin perusversiota.This article describes the standard Power BI Desktop.

Näin Power BI Desktop toimiiHow Power BI Desktop works

Power BI Desktopin avulla voit yhdistää tietoihin (yleensä useita tietolähteitä), muotoilla niitä (kyselyillä, jotka luovat oivaltavia ja vakuuttavia tietomalleja) ja käyttää mallia raporttien luomiseen (muut voivat hyödyntää, käyttää pohjana ja jakaa raportteja).With Power BI Desktop, you connect to data (usually multiple data sources), shape that data (with queries that build insightful, compelling data models), and use that model to create reports (which others can leverage, build upon, and share).

Kun olet suorittanut vaiheet eli yhdistämisen, muotoilun ja raportoinnin, voit tallentaa työsi Power BI Desktopin .pbix-tiedostomuodossa.When the steps are completed to your satisfaction – connect, shape, and report – you can save that work in Power BI Desktop file format, which is the .pbix extension. Power BI Desktop -tiedostoja voi jakaa minkä tahansa muun tiedoston tapaan, mutta paras tapa on ladata (jakaa) ne Power BI -palveluun.Power BI Desktop files can be shared like any other file, but the most compelling way to share Power BI Desktop files is to upload them (share them) on the Power BI service.

Power BI Desktop keskittää, yksinkertaistaa, tehostaa ja nopeuttaa muutoin hajaantunutta, irrallista ja hankalaa liiketoimintatietojen säilöjen ja raporttien suunnittelu- ja luontiprosessia.Power BI Desktop centralizes, simplifies, and streamlines what can otherwise be a scattered, disconnected, and arduous process of designing and creating business intelligence repositories and reports.

Oletko valmis kokeilemaan?Ready to give it a try? Aloitetaanpa.Let’s get started.

Power BI Desktopin asentaminen ja suorittaminenInstall and run Power BI Desktop

Voit ladata Power BI Desktopin Power BI -palvelusta valitsemalla rataskuvakkeen ja sitten Power BI Desktop.You can download Power BI Desktop from the Power BI service, by selecting the gear icon, then select Power BI Desktop.

Power BI Desktop asennetaan sovelluksena, jonka voit suorittaa työpöydältäsi.Power BI Desktop is installed as an application, and runs on your desktop.

Kun käynnistät Power BI Desktopin, näyttöön avautuu Tervetuloa-näyttö.When you run Power BI Desktop, a Welcome screen is displayed.

Voit noutaa tiedot, katsoa viimeaikaiset lähteet tai avata muita raportteja suoraan Tervetuloa-näytössä (vasemmanpuoleisen ruudun linkeistä).You can Get Data, see Recent Sources, or Open Other Reports directly from the Welcome screen (from the links in the left pane). Jos suljet näytön (valitse x ikkunan oikeassa yläkulmassa), Power BI Desktopin Raportti-näkymä avautuu.If you close the screen (select the x in the top right corner), the Report view of Power BI Desktop is displayed.

Power BI Desktopissa on kolme näkymää: Raportti-, Tiedot- ja Suhteet-näkymät.There are three views in Power BI Desktop: Report view, Data view, and Relationships view. Power BI Desktop sisältää myös kyselyeditorin, joka avautuu erilliseen ikkunaan.Power BI Desktop also includes Query Editor, which opens in a separate window. Kyselyeditorissa voit laatia kyselyjä, muuntaa tietoja, ladata sitten tarkennetun tietomallin Power BI Desktopiin ja luoda raportteja.In Query Editor, you can build queries and transform data, then load that refined data model into Power BI Desktop, and create reports.

Power BI Desktopin vasemmassa reunassa on kolme näkymäkuvaketta, jotka näkyvät seuraavassa ruudussa: ylhäältä alaspäin ne ovat Raportti, Tiedot ja Suhteet.The following screen shows the three view icons along the left of Power BI Desktop: Report, Data, and Relationships, from top to bottom. Keltainen palkki vasemmalla on merkki parhaillaan käytössä olevasta näkymästä.The currently displayed view is indicated by the yellow bar along the left. Tässä tapauksessa Raportti-näkymä on käytössä.In this case, Report view is currently displayed. Voit vaihtaa näkymää valitsemalla minkä tahansa kolmesta kuvakkeesta.You can change views by selecting any of those three icons.

Kun Power BI Desktop on asennettu, voit muodostaa yhteyden tietoihin, muotoilla niitä ja luoda raportteja (yleensä juuri tässä järjestyksessä).With Power BI Desktop installed you’re ready to connect to data, shape data, and build reports (usually in that order). Seuraavissa osissa esittelemme jokaisen vaiheen erikseen.In the next few sections, we take a tour through each in turn.

Tietoihin yhdistäminenConnect to data

Kun Power BI Desktop on asennettu, olet valmis muodostamaan yhteyden alati laajenevaan tietomaailmaan.With Power BI Desktop installed, you’re ready to connect to the ever expanding world of data. Kyselyikkunassa on käytettävissä kaikenlaisia tietolähteitä.There are all sorts of data sources available in the Query window. Seuraavassa kuvassa näytetään, miten voit yhdistää tietoihin, valitsemalla Aloitus-valintanauhan ja sitten Nouda tiedot > Lisää.The following image shows how to connect to data, by selecting the Home ribbon, then Get Data > More.

Tätä pikaesittelyä varten yhdistämme muutamaan eri verkkotietolähteeseen.For this quick tour, we'll connect to a couple different Web data sources.

Kuvittele olevasi jäämässä eläkkeelle; haluat elää paikassa, jossa paistaa aurinko ja jossa on suotuisampi verotus ja hyvä terveydenhuolto. Tai ehkä olet tietoanalyytikko ja haluat auttaa näillä tiedoilla asiakkaitasi.Imagine you’re retiring – you want to live where there’s lots of sunshine, preferable taxes, and good health care – or perhaps you’re a data analyst, and you want that information to help your customers. Saatat esimerkiksi haluta auttaa aurinkolasien jälleenmyyjääsi kohdistamaan myynti sellaisille alueille, joilla aurinko paistaa eniten.For example, perhaps you want to help your sunglasses retailer target sales where the sun shines most frequently.

Joka tapauksessa seuraava verkkoresurssi sisältää kiinnostavaa tietoa näistä ja muista aiheista:Either way, the following Web resource has interesting data about those topics, and more:

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Valitse Nouda tiedot > Verkko ja liitä osoite.Select Get Data > Web and paste the address.

Kun valitset OK, Power BI Desktopin Kysely-toiminto käynnistyy.When you select OK, the Query functionality of Power BI Desktop goes to work. Kysely muodostaa yhteyden verkkoresurssiin, ja Siirtymistoiminnon ikkuna palauttaa verkkosivulta löydetyn sisällön.Query contacts the Web resource, and the Navigator window returns what it found on that Web page. Tässä tapauksessa se löysi taulukon (Table 0) ja yleisen verkkoasiakirjan.In this case, it found a table (Table 0) and the overall Web Document. Meitä kiinnostaa taulukko, joten valitsemme sen luettelosta.We’re interested in the table, so we select it from the list. Siirtymistoiminnon ikkuna näyttää esikatselun.The Navigator window displays a preview.

Tässä vaiheessa voimme muokata kyselyä ennen taulukon lataamista valitsemalla ikkunan alareunassa Muokkaa tai voimme ladata taulukon.At this point we can edit the query before loading the table, by selecting Edit from the bottom of the window, or we can load the table.

Kun valitsemme Muokkaa, kyselyeditori käynnistyy ja tyypillinen taulukkonäkymä näytetään.When we select Edit, Query Editor launches and a representative view of the table is presented. Kyselyasetukset-ruutu avautuu (jos ei, valitse valintanauhassa Näytä ja avaa Kyselyasetukset-ruutu valitsemalla Näytä > kyselyasetukset).The Query Settings pane is displayed (if it’s not, you can select View from the ribbon, then Show > Query Settings to display the Query Settings pane). Se näyttää tältä.Here’s what that looks like.

Lisätietoa tietoihin yhdistämisestä on ohjeartikkelissa Tietoihin yhdistäminen Power BI Desktopissa.For more information about connecting to data, see Connect to Data in Power BI Desktop.

Seuraavassa osassa muokkaamme tietoja tarpeittemme mukaan.In the next section, we adjust the data so it meets our needs. Yhdistettyjen tietojen muokkaamista kutsutaan tietojen muotoilemiseksi.The process of adjusting connected data is called shaping data.

Tietojen muotoileminen ja yhdistäminenShape and combine data

Nyt kun tietolähde on yhdistetty, meidän on muokattava tietoja tarpeittemme mukaan.Now that we’ve connected to a data source, we need to adjust the data to meet our needs. Joskus muokkaaminen tarkoittaa tietojen muuntamista, kuten sarakkeiden tai taulukoiden nimeämistä uudelleen, tekstin muuntamista numeroiksi, rivien poistamista, ensimmäisen rivin määrittämistä otsikoiksi ja niin edelleen.Sometimes adjusting means transforming the data – such as renaming columns or tables, changing text to numbers, removing rows, setting the first row as headers, and so on.

Power BI Desktopin kyselyeditorissa käytetään runsaasti hiiren kakkospainikkeella avattavien valikoiden toimintoja sekä valintanauhan toimintoja.The Query editor in Power BI Desktop makes ample use of right-click menus, in addition to having tasks available on the ribbon. Useimmat toiminnot, jotka ovat valittavissa Muunna-valintanauhassa, ovat käytettävissä myös napsauttamalla kohdetta (esimerkiksi saraketta) hiiren kakkospainikkeella ja valitsemalla sitten toiminto näyttöön avautuvasta valikosta.Most of what you can select in the Transform ribbon is also available by right-clicking an item (such as a column) and choosing from the menu that appears.

Tietojen muotoileminenShape data

Kun muotoilet tietoja kyselyeditorissa, annat vaiheittaiset ohjeet (jotka kyselyeditori toteuttaa puolestasi) tietojen muokkaamiseksi, kun kyselyeditori lataa ja näyttää tiedot.When you shape data in the Query Editor, you’re providing step-by-step instructions (that Query Editor carries out for you) to adjust the data as Query Editor loads and presents it. Tämä ei vaikuta alkuperäiseen tietolähteeseen, sillä vain tätä tietonäkymää muokataan eli muotoillaan.The original data source is not affected; only this particular view of the data is adjusted, or shaped.

Määrittämäsi vaiheet (esimerkiksi taulukon nimeäminen uudelleen, tietotyypin muuntaminen tai sarakkeiden poistaminen) kirjataan kyselyeditoriin. Nämä vaiheet suoritetaan sitten aina, kun kysely muodostaa yhteyden tietolähteeseen, jotta tiedot muotoillaan aina määrittämälläsi tavalla.The steps you specify (such as rename a table, transform a data type, or delete columns) are recorded by Query Editor, and each time this query connects to the data source those steps are carried out so that the data is always shaped the way you specify. Tämä prosessi suoritetaan aina, kun käytät Power BI Desktopin kyselyä tai kun joku käyttää jaettua kyselyäsi esimerkiksi Power BI -palvelussa.This process occurs whenever you use the query in Power BI Desktop, or for anyone who uses your shared query, such as in the Power BI service. Vaiheet kirjataan järjestyksessä Kyselyasetukset-ruudun Käytössä olevat vaiheet -kohtaan.Those steps are captured, sequentially, in the Query Settings pane under Applied Steps.

Seuraavasta kuvasta näet Kyselyasetukset-ruudun kyselylle, jota on muotoiltu. Käymme läpi kaikki nämä vaiheet seuraavissa kappaleissa.The following image shows the Query Settings pane for a query that has been shaped – we’ll go through each of those steps in the next few paragraphs.

Palataan eläketietoihin, jotka löysimme yhdistämämme verkkotietolähteen kautta, ja muotoillaan ne tarpeittemme mukaan.Let’s get back to our retirement data, which we found by connecting to a Web data source, and shape that data to fit our needs.

Ensinnäkin useimmat luokitukset tuotiin kyselyeditoriin kokonaislukuina, mutta eivät kaikki (yksi sarake sisälsi tekstiä ja numeroita, joten sitä ei muunnettu automaattisesti).For starters, most ratings were brought into Query Editor as whole numbers, but not all of them (one column contained text and numbers, so it wasn't automatically converted). Tietojen on oltava numeroita.We need the data to be numbers. Voit vaihtaa tietotyypin helposti napsauttamalla vain hiiren kakkospainikkeella sarakkeen otsikkoa ja valitsemalla Muuta tyyppi > Kokonaisluku.No problem – just right-click the column header, and select Change Type > Whole Number to change the data type. Jos haluamme valita useita sarakkeita, valitsemme ensimmäisen sarakkeen, painamme VAIHTO-näppäimen pohjaan, valitsemme vierekkäisiä sarakkeita ja vaihdamme sitten kaikki valitut sarakkeet napsauttamalla hiiren kakkospainikkeella jotain valittua sarakeotsikkoa.If we needed to choose more than one column, we could first select a column then hold down SHIFT, select additional adjacent columns, and then right-click a column header to change all selected columns. Voit valita muita kuin vierekkäisiä sarakkeita myös CTRL-painikkeella.You can also use CTRL to select non-adjacent columns.

Voit myös muuttaa tai muuntaa nämä sarakkeet tekstistä otsikoksi Muunna-valintanauhan avulla.You can also change, or transform, those columns from text to header by using the Transform ribbon. Tässä on Muunna-valintanauha, jossa on Tietotyyppi-painikkeeseen osoittava nuoli. Tällä painikkeella voit muuntaa tietotyypin toiseksi.Here’s the Transform ribbon, with an arrow pointing toward the Data Type button, which lets you transform the current data type to another.

Huomaa, että Kyselyasetukset-kohdan Käytössä olevat vaiheet kuvastavat tehtyjä muutoksia.Note that in Query Settings, the Applied Steps reflect the changes that were made. Jos haluan poistaa vaiheen muotoiluprosessista, valitsen haluamani vaiheen vasemmalta puolelta X.If I want to remove any step from the shaping process, I simply select that step, and then select the X to the left of the step.

Meidän on vielä tehtävä pari muuta muutosta, jotta kyselystä tulee sellainen kuin haluamme:We need to make a few more changes to get the query where we want it:

  • Poistetaan ensimmäinen sarake – emme tarvitse sitä, sillä se sisältää vain ylimääräisiä rivejä, joissa sanotaan ”Katso, miten osavaltiosi sijoittuu eläkeasioissa”, joka on verkkopohjaisen taulukon artefakti.Remove the first column – we don’t need it, it just includes redundant rows that say “Check out how your state ranks for retirement” which is an artifact of this being a Web based table
  • Korjataan muutama virhe – verkkosivulla yhdessä sarakkeessa oli sekaisin tekstiä ja numeroita (jotkin osavaltiot liitetty yhteen luokkaan).Fix a few Errors – on the Web page, one column had text mixed in with the numbers (some states tied in one category). Se toimii hyvin sivustossa, mutta ei meidän tietoanalyysissamme.That works well in the website, but not for our data analysis. Tämä on helppo korjata (tässä tapauksessa) ja osoittaa kyselyeditorin ja sen käytössä olevien vaiheiden joitakin hienoja ominaisuuksia ja toimintoja.It's easy (in this case) to fix, and shows some cool features and capabilities of Query Editor and its Applied Steps
  • Vaihdetaan taulukon nimiTable 0 ei ole hyödyllinen kuvaus, mutta nimen vaihtaminen on helppoa.Change the Table Name – that Table 0 is not a useful descriptor, but changing it simple

Jokainen näistä vaiheista esitellään ohjeartikkelissa Tietojen muotoilu ja yhdistäminen Power BI Desktopissa .Each of these steps is demonstrated in Shape and Combine Data in Power BI Desktop. Tutustu vapaasti kyseiseen sivuun tai jatka tämän oppaan seuraamista ja katso seuraavat vaiheet.Feel free to check out that page, or keep going in this document to see what you would do next. Seuraavassa osassa jatketaan siitä, kun edellä mainitut muutokset on otettu käyttöön.The next section picks up after the changes above are applied.

Tietojen yhdistäminenCombine data

Nämä tiedot eri osavaltioista ovat mielenkiintoisia. Niistä on myös hyötyä muidenkin analyysien ja kyselyiden luomisessa.That data about various states is interesting, and will be useful for building additional analysis efforts and queries. Tässä on kuitenkin yksi ongelma: suurin osa saatavilla olevista tiedoista käyttää kaksikirjaimisia osavaltiolyhenteitä, ei osavaltioiden koko nimiä.But there’s one problem: most data out there uses a two-letter abbreviation for state codes, not the full name of the state. Meidän täytyy siis yhdistää osavaltioiden nimet ja niiden lyhenteet.We need some way to associate state names with their abbreviations.

Meillä on kuitenkin onnea, sillä eräs toinen julkinen tietolähde tekee juuri tämän, mutta sen tiedot vaativat suhteellisen paljon muotoilua, ennen kuin voimme yhdistää ne tähän eläköitymistaulukkoomme.We’re in luck: there’s another public data source that does just that, but it needs a fair amount of shaping before we can connect it to our retirement table. Tässä on osavaltiolyhenteiden verkkoresurssi:Here’s the Web resource for state abbreviations:

http://en.wikipedia.org/wiki/List_of_U.S._state_abbreviations

Valitaan kyselyeditorin Aloitus-valintanauhasta Nouda tiedot > Verkko ja kirjoitetaan osoite ja valitaan OK. Sen jälkeen Siirtymistoiminnon ikkuna näyttää verkkosivulta löydetyn sisällön.From the Home ribbon in Query Editor, we select Get Data > Web and type the address, select OK, and the Navigator window shows what it found on that Web page.

Valitse Taulukko[muokkaa] , koska se sisältää haluamamme tiedot. Niitä täytyy kuitenkin muotoilla melko paljon, ennen kuin voimme yhdistää taulukon tiedot.We select Table[edit] because it includes the data we want, but it’s going to take quite a bit of shaping to pare that table’s data down. Jokainen näistä vaiheista esitellään ohjeartikkelissa Tietojen muotoilu ja yhdistäminen Power BI Desktopissa .Each of these steps is also demonstrated in Shape and Combine Data in Power BI Desktop. Yhteenveto mainituista vaiheista on seuraava:To summarize those steps, here's what we do:

Valitaan Muokkaa ja sitten:We select Edit, then:

  • Poistetaan kaksi ylintä riviä – ne ovat seurausta tavasta, jolla verkkosivun taulukko on luotu, emmekä tarvitse niitä.Remove the top two rows – they’re a result of the way that Web page’s table was created, and we don’t need them.
  • Poistetaan alimmat 26 riviä – ne ovat kaikki alueita, joita meidän ei tarvitse sisällyttää.Remove the bottom 26 rows – they’re all the territories, which we don’t need to include.
  • Poissuljetaan Washington DC – eläköitymistilastojen taulukko ei sisällä Washington DC:tä, joten suljemme sen pois luettelostamme.Filter out Washington DC – the retirement stats table doesn't include DC, so we'll exclude it from our list.
  • Poistetaan muutamat tarpeettomat sarakkeet – meidän täytyy yhdistää vain osavaltio sen viralliseen kaksikirjaimiseen lyhenteeseen, joten voimme poistaa muut sarakkeet.Remove a few unneeded columns – we only need the mapping of state to its official two-letter abbreviation, so we can remove the other columns.
  • Käytetään ensimmäistä riviä otsikkona – koska poistimme kolme ylintä riviä, nykyinen ylin rivi on haluamamme otsikkorivi.Use the first row as headers – since we removed the top three rows, the current top row is the header we want.

    Huomautus

    Tämä on hyvä hetki huomauttaa, että kyselyeditorissa käytössä olevien vaiheiden järjestys on tärkeä. Se voi myös vaikuttaa tietojen muotoiluun.This is a good time to point out that the sequence of applied steps in Query Editor is important, and can affect how the data is shaped. On tärkeää huomioida se, miten yksi vaihe voi vaikuttaa toiseen myöhempään vaiheeseen. Jos poistat vaiheen käytössä olevista vaiheista, myöhemmät vaiheet eivät ehkä toimi niin kuin alun perin tarkoitit, koska vaiheen poistaminen kyselyn vaihejärjestyksestä vaikuttaa muihin vaiheisiin.It’s also important to consider how one step may impact another subsequent step; if you remove a step from the Applied Steps, subsequent steps may not behave as originally intended, because of the impact of the query’s sequence of steps.

  • Nimetään sarakkeet ja itse taulukko uudelleen – tuttuun tapaan sarakkeen voi nimetä uudelleen muutamalla eri tavalla, ja voit valita itsellesi mieluisimman tavan.Rename the columns, and the table itself – as usual, there are a couple ways to rename a column, you can choose whichever you prefer.

Nyt kun olemme muotoilleet StateCodes-taulukon, voimme yhdistää nämä kaksi taulukkoa (tai kyselyä) yhdeksi. Koska taulukot, jotka meillä nyt ovat, ovat tulos kyselyistä, jotka suoritimme tiedoille, niitä kutsutaan usein kyselyiksi.With the StateCodes table shaped, we can combine these two tables, or queries, into one; since the tables we now have are a result of the queries we applied to the data, they’re often referred to as queries.

Kyselyitä voi yhdistää kahdella tavalla: yhdistämällä tai loppuun liittämällä.There are two primary ways of combining queries – merging and appending.

Jos sinulla on sarake tai sarakkeita, jonka tai jotka haluat lisätä toiseen kyselyyn, yhdistä kyselyt.When you have one or more columns that you’d like to add to another query, you merge the queries. Jos sinulla on lisärivejä tietoja, jotka haluat lisätä olemassa olevaan kyselyyn, liitä ne kyselyn loppuun.When you have additional rows of data that you’d like to add to an existing query, you append the query.

Tässä tapauksessa haluamme yhdistää kyselyt.In this case we want to merge queries. Aloitetaan valitsemalla kysely, johon haluamme yhdistää toisen kyselyn, ja valitaan sen jälkeen valintanauhan Aloitus-välilehdessä Yhdistä kyselyt.To get started, we select the query into which we want the other query to merge, then select Merge Queries from the Home tab on the ribbon.

Seuraavaksi näyttöön avautuu Yhdistä-ikkuna, jossa kysytään, minkä taulukon haluamme yhdistää valittuun taulukkoon ja pyydetään myös määrittämään yhdistämisen vastaavat sarakkeet.The Merge window appears, prompting us to select which table we’d like merged into the selected table, and then, the matching columns to use for the merge. Valitse RetirementStats-taulukosta (kysely) State-sarake ja valitse sitten StateCodes-kysely (tämä on tässä tapauksessa helppoa, koska muita kyselyitä on vain yksi, mutta kun yhdistettynä on useita tietolähteitä, valittavissa olevia kyselyitä on paljon).Select State from the RetirementStats table (query), then select the StateCodes query (easy in this case, since there’s only one other query – when you connect to many data sources, there are many queries to choose from). Kun valitsemme oikeat vastaavat sarakkeet (State-sarake RetirementStats-taulukosta ja State Name -sarake StateCodes-taulukosta), Yhdistä-ikkuna näyttää seuraavanlaiselta. Myös OK-painike on käytettävissä.When we select the correct matching columns – State from RetirementStats, and State Name from StateCodes – the Merge window looks like the following, and the OK button is enabled.

Kyselyn loppuun luodaan NewColumn, joka sisältää sen taulukon (kyselyn) sisällön, joka yhdistettiin olemassa olevaan kyselyyn.A NewColumn is created at the end of the query, which is the contents of the table (query) that was merged with the existing query. Kaikki yhdistetyn kyselyn sarakkeet tiivistetään NewColumn-sarakkeeseen, mutta voit laajentaa taulukon ja sisällyttää haluamasi sarakkeet.All columns from the merged query are condensed into the NewColumn, but you can select to Expand the table, and include whichever columns you want. Jos haluat laajentaa yhdistetyn taulukon ja valita sisällytettävät sarakkeet, valitse laajennuskuvake ().To expand the merged table, and select which columns to include, select the expand icon (). Näyttöön avautuu Laajenna-ikkuna.The Expand window appears.

Tässä tapauksessa haluamme vain State Code -sarakkeen, joten valitsemme sen ja sitten OK.In this case, we only want the State Code column, so we select only that column and then select OK. Poistamme Käytä alkuperäisen sarakkeen nimeä etuliitteenä -valintaruudun valinnan, koska emme tarvitse tai halua sitä. Jos jätämme tämän valituksi, yhdistetyn sarakkeen nimi olisi NewColumn.State Code (alkuperäisen sarakkeen nimi eli NewColumn, sitten piste ja kyselyyn tuodun sarakkeen nimi).We clear the checkbox from Use original column name as prefix because we don’t need or want that; if we leave that selected, the merged column would be named NewColumn.State Code (the original column name, or NewColumn, then a dot, then the name of the column being brought into the query).

Huomautus

Haluatko kokeilla eri tapoja tuoda tämä NewColumn-taulukko?Want to play around with how to bring in that NewColumn table? Voit kokeilla eri tapoja. Jos et pidä tuloksista, poista kyseinen vaihe Kyselyasetukset-ruudun käytössä olevien vaiheiden luettelosta. Tämä palauttaa kyselysi tilaan, jossa se oli ennen tätä laajennusvaihetta.You can experiment a bit, and if you don’t like the results, just delete that step from the Applied Steps list in the Query Settings pane; your query returns to the state prior to applying that Expand step. Voit siis kokeilla eri tapoja vapaasti niin monta kertaa kuin haluat, kunnes saat laajennusprosessista haluamasi kaltaisen.It’s like a free do-over, which you can do as many times as you like until the expand process looks the way you want it.

Nyt meillä on yksi kysely (taulukko), joka yhdistää kaksi tietolähdettä, jotka kummatkin on muotoiltu tarpeidemme mukaisesti.We now have a single query (table) that combined two data sources, each of which has been shaped to meet our needs. Tämän kyselyn pohjalta voit luoda paljon muitakin kiinnostavia tietoyhteyksiä, esimerkiksi asumiskuluista, demografisista tiedoista tai työmahdollisuuksista missä tahansa osavaltiossa.This query can serve as a basis for lots of additional, interesting data connections – such as housing cost statistics, demographics, or job opportunities in any state.

Tarkempia tietoja kustakin tietojen muotoilun ja yhdistämisen vaiheesta on ohjeartikkelissa Tietojen muotoilu ja yhdistäminen Power BI Desktopissa.For a more complete description of each of these shape and combine data steps, see Shape and Combine Data in Power BI Desktop.

Nyt meillä on riittävästi tietoja muutaman kiinnostavan raportin luomiseen Power BI Desktopissa.For now, we have enough data to create a few interesting reports, all within Power BI Desktop. Koska olemme saavuttaneet välivaiheen, tallennetaan tämä Power BI Desktop -tiedosto nimellä Power BI Desktopin käytön aloittaminen.Since this is a milestone let’s save this Power BI Desktop file – we’ll call it Getting Started with Power BI Desktop. Ota muutokset käyttöön kyselyeditorissa ja lataa ne Power BI Desktopiin valitsemalla Aloitus-valintanauhassa Sulje ja ota käyttöön.To apply the changes in Query Editor and load them into Power BI Desktop, select Close & Apply from the Home ribbon.

Raporttien luominenBuild reports

Lisää muutoksia voi tehdä sen jälkeen, kun taulukko on ladattu, ja voit ottaa käyttöön tekemäsi muutokset lataamalla mallin uudelleen.Additional changes can be made after the table is loaded, and you can reload a model to apply any changes you make. Toistaiseksi tämä kuitenkin kelpaa.But for now this will do. Raportin luominen aloitetaan Power BI Desktopin Raportti-näkymässä.In Power BI Desktop Report view, you can begin to build reports.

Raportti-näkymässä on viisi pääaluetta:The Report view has five main areas:

  1. Valintanauha sisältää raportteihin ja visualisointeihin liittyvät yleisimmät tehtävät.The ribbon, which displays common tasks associated with reports and visualizations

  2. Raportti-näkymä eli kangas on paikka, jossa visualisointeja luodaan ja järjestellään.The Report view, or canvas, where visualizations are created and arranged

  3. Alaosassa olevalla Sivut-välilehtialueella voit valita tai lisätä raporttisivun.The Pages tab area along the bottom, which lets you select or add a report page

  4. Visualisoinnit-ruudussa voit esimerkiksi muuttaa visualisointeja, mukauttaa värejä tai akseleita, käyttää suodattimia ja siirtää kenttiä.The Visualizations pane, where you can change visualizations, customize colors or axes, apply filters, drag fields, and more

  5. Kentät-ruudussa olevia kyselyelementtejä ja suodattimia voi vetää Raportti-näkymään tai Visualisoinnit-ruudun Suodattimet-alueelle.The Fields pane, where query elements and filters can be dragged onto the Report view, or dragged to the Filters area of the Visualizations pane

Visualisoinnit- ja Kentät-ruudut voi kutistaa valitsemalla reunassa olevan pienen nuolen, jolloin Raportti-näkymään jää enemmän tilaa näyttävien visualisointien luomiselle.The Visualizations and Fields pane can be collapsed by selecting the small arrow along the edge, providing more space in the Report view to build cool visualizations. Visualisointeja muokatessasi näet myös ylös ja alas osoittavat nuolet, joilla osion voi laajentaa tai kutistaa.When modifying visualizations, you'll also see these arrows pointing up or down, which means you can expand or collapse that section, accordingly.

Aloita visualisoinnin luominen vetämällä kenttä Kentät-luettelosta Raportti-näkymään.To create a visualization, just drag a field from the Fields list onto the Report view. Tässä tapauksessa voimme vetää State-kentän RetirementStats-luettelosta ja katsoa, mitä tapahtuu.In this case, let’s drag the State field from RetirementStats, and see what happens.

Vaikuttavaa, eikö totta? Power BI Desktop loi automaattisesti karttapohjaisen visualisoinnin, koska se tunnisti, että State-kenttä sisälsi maantieteellistä sijaintia kuvaavia tietoja.Look at that... Power BI Desktop automatically created a map-based visualization, because it recognized that the State field contained geolocation data.

Huomaa, että Visualisoinnit-ruudussa voi valita erityyppisiä visualisointeja ja niiden kuvakkeiden alapuolisella alueella ottaa käyttöön selitteen tai muokata visualisointia muulla tavalla raahaamalla kenttiä eri alueille.Notice that in the Visualizations pane, I can select different types of visualizations, and in the area below those icons, I can drag fields to different areas to apply a Legend, or otherwise modify the visualization.

Hypätään hiukan eteenpäin ja katsotaan, miltä Raportti-näkymä näyttää muutamien visualisointien ja uusien raporttisivujen lisäämisen jälkeen.Let’s fast-forward a bit, and see what the Report view looks like after a handful of visualizations have been added, as well as a few new Report pages. Lisätietoja raporteista on ohjeartikkelissa Raportti-näkymä Power BI Desktopissa.For more information about reports, see Report View in Power BI Desktop.

Ensimmäinen raporttisivu antaa yleiskuvan tiedoista yleisen sijoittumisen perusteella.The first Report page provides a perspective of the data based on Overall rank. Kun valitsemme yhden visualisoinneista, Kentät ja suodattimet -ruudussa näkyy valitut kentät ja visualisoinnin rakenne (mitä kenttiä on käytetty Jaettu akseli-, Sarakkeen arvot-, ja Riviarvot-tietoihin).When we select one of the visualizations, the Fields and Filters pane shows which fields are selected, and the structure of the visualization (which fields are applied to the Shared Axis, Column Values, and Line Values).

Tässä raportissa on kuusi sivua, joista jokainen visualisoi tietojemme tiettyjä elementtejä.There are six Pages in this Report, each visualizing certain elements of our data.

  1. Yllä näkyvä ensimmäinen sivu näyttää kaikki osavaltiot yleisen sijoittumisen perusteella.The first page, shown above, shows all states based on Overall rank.
  2. Toisella sivulla keskitytään kärkikymmenikössä oleviin osavaltioihin yleisen sijoittumisen perusteella.The second page focuses on the top ten states based on Overall rank.
  3. Kolmannella sivulla on visualisoitu kymmenen parhaan osavaltion elinkustannukset (ja niihin liittyvät tiedot).For the third page, the best 10 states for cost of living (and associated data) are visualized.
  4. Neljännellä sivulla sää on keskipisteessä: sivulle on suodatettu 15 aurinkoisinta osavaltiota.Weather is the focus of the fourth page, filtered to the 15 sunniest states.
  5. Viidennellä sivulla on kaavio ja visualisointi yhteisön hyvinvoinnista 15 parhaassa osavaltiossa.On the fifth page, Community well-being is charted and visualized for the top 15 states.
  6. Viimeisellä sivulla on visualisoitu kymmenen ensimmäisen (ja myös viimeisen) osavaltion rikollisuustilastot.Lastly, crime statistics are visualized, showing the best (and well, the last) ten states.

Elinkustannuksiin keskittyvä raporttisivu näyttää tältä.Here’s what the cost of living-focused Report page looks like.

Voit luoda erilaisia kiinnostavia raportteja ja visualisointeja.There are all sorts of interesting reports and visualizations you can create.

Töiden jakaminenShare your work

Nyt kun meillä on Power BI Desktop -raportti, joka on lähes valmis, voimme jakaa sen muiden kanssa Power BI -palvelussa.Now that we have a Power BI Desktop report that’s reasonably complete, we can share it with others on the Power BI service. Power BI Desktopissa työt voi jakaa muutamalla eri tavalla.There are a few ways to share your work in Power BI Desktop. Voit julkaista ne Power BI -palveluun, ladata .pbix-tiedoston suoraan Power BI -palvelusta tai tallentaa .pbix-tiedoston ja lähettää sen tavallisen tiedoston tapaan.You can publish to the Power BI service, you can upload the .pbix file directly from the Power BI service, or you can save the .pbix file and send it like any other file.

Katsotaan ensin, miten julkaisu Power BI Desktopista suoraan Power BI -palveluun tapahtuu.First, let's look at publishing to the Power BI service directly from Power BI Desktop. Valitse Aloitus-valintanauhassa Julkaise.On the Home ribbon, select Publish.

Sinua saatetaan pyytää kirjautumaan sisään Power BI:hin.You may be prompted to sign in to Power BI.

Kun olet kirjautunut sisään ja julkaisuprosessi on valmis, näet seuraavan valintaikkunan.When you've signed in and the publish process is complete, you see the following dialog.

Kun kirjaudut Power BI:hin, näet juuri lataamasi Power BI Desktop -tiedoston palvelun Raporttinäkymät-, Raportit- ja Tietojoukot-osissa.When you sign in to Power BI, you'll see Power BI Desktop file you just loaded in the Dashboards, Reports, and Datasets sections of the service.

Toinen tapa jakaa työsi on ladata se Power BI -palvelun kautta.Another way to share your work is to load it from within the Power BI service. Seuraava linkki avaa Power BI -palvelun selaimeen:The following link brings up the Power BI service in a browser:

https://app.powerbi.com

Aloita Power BI Desktop -raportin latausprosessi valitsemalla Nouda tiedot.Select Get Data to start the process of loading your Power BI Desktop report.

Näkyviin tulee Nouda tiedot -sivu, jolla voit valita, mistä tiedot haetaan.The Get Data page appears, from which you can select where to get your data from. Tässä tapauksessa valitsemme Tiedostot-ruudussa Hae.In this case, we select Get from the Files box.

Tiedostot-näkymä avautuu.The Files view appears. Tässä tapauksessa valitsemme Paikallinen tiedosto.In this case, we select Local File.

Kun tiedosto valitaan, Power BI lataa sen palveluun.When you select the file, Power BI uploads the file.

Kun tiedosto on ladattu, voit valita sen Power BI -palvelun vasemmassa ruudussa olevasta Raportit-kohdasta.Once the file is uploaded, you can select the file from the Reports in the left pane of the Power BI service.

Power BI -palvelu näyttää raportin ensimmäisen sivun.The Power BI service displays the first page of the report. Sivun alaosassa voit valita minkä tahansa välilehden, jolloin raportin kyseinen sivu avataan.Along the bottom of the page, you can select any tab to display that page of the report.

Voit tehdä raporttiin muutoksia Power BI -palvelussa valitsemalla raporttipohjan yläosassa Muokkaa raporttia.You can make changes to a report in the Power BI service by selecting Edit Report from the top of the report canvas.

Tallenna raporttisi valitsemalla palvelussa Tiedosto > Tallenna nimellä.To save your report, select File > Save As from the service. Power BI -palvelussa voit luoda raportistasi erilaisia kiinnostavia visualisointeja, jotka voit kiinnittää raporttinäkymään.There are all sorts of interesting visuals you can create in the Power BI service from your report, which you can pin to a dashboard. Lisätietoja Power BI -palvelun raporttinäkymistä on raporttinäkymien suunnittelua koskevassa artikkelissa.To learn about dashboards in the Power BI service, see Tips for designing a great dashboard.

Kun raportti on tallennettu, valitse pääsivulla Jaa-kuvake.Once saved, select the Share icon on the main page.

Tätä kautta voit lähettää sähköpostiviestin niille työtovereille, joiden kanssa haluat jakaa raporttinäkymän.From here, you can send an email to colleagues with whom you’d like to share the dashboard.

Lisätietoja raporttinäkymien luomisesta, jakamisesta ja muokkaamisesta on kohdassa Raporttinäkymän jakaminen.For more information about creating, sharing, and modifying dashboards, see Share a dashboard.

Power BI Desktopin ja Power BI -palvelun avulla voi tehdä erilaisia vakuuttavia tietoihin pohjautuvia koosteita ja visualisointeja.There are all sorts of compelling data-related mash-ups and visualizations you can do with Power BI Desktop, and with the Power BI service. Katso lisätietoja seuraavasta osasta.Check out the next section for more information.

DiagnostiikkaDiagnostics

Power BI Desktop tukee diagnostiikkaporttiin yhdistämistä.Power BI desktop supports connecting to a diagnostics port. Diagnostiikkaportti sallii yhteydenmuodostuksen muilla työkaluilla ja sen avulla voidaan suorittaa jäljityksiä vianmääritystä varten.The diagnostic port allows for other tools to connect to and perform traces for diagnostic purposes. Muutosten tekemistä malliin ei tueta! Malliin tehdyt muutokset saattavat johtaa vioittumiseen ja tietojen menettämiseen.Making any changes to the model is not supported! Changes to the model may lead to corruption and data loss.

Seuraavat vaiheetNext steps

Voit tehdä kaikenlaista Power BI Desktopilla.There are all sorts of things you can do with Power BI Desktop. Saat lisätietoja sen toiminnoista seuraavista resursseista:For more information on its capabilities, check out the following resources: