Comment résoudre les problèmes de documents endommagés dans Word

Notes

Office 365 ProPlus est renommé Applications Microsoft 365 pour les entreprises. Pour plus d’informations sur ce changement, lisez ce billet de blog.

Résumé

Cet article décrit comment identifier un document endommagé dans Word 2007 et dans les versions plus récentes. En outre, il contient des procédures de récupération du texte et des données contenus dans un document identifié comme étant endommagé.

Cet article s’adresse aux utilisateurs débutants ou d’un niveau intermédiaire. Il vous sera peut-être plus facile de suivre ces étapes si vous imprimez d'abord l'article.

Mettre à jour Microsoft Office et Windows

De nombreux problèmes logiciels peuvent être résolus en mettant à jour les programmes Microsoft Office et Windows.

Windows Update : FAQ

Installer les mises à jour d’Office

Mise à jour d’Office avec Microsoft Update

Un document endommagé ou un problème logiciel ?

Un document Word peut être endommagé pour plusieurs raisons qui vous empêcheront de l'ouvrir. Ce comportement peut être lié à l'endommagement du document ou au modèle sur lequel le document est basé. Ce comportement peut comprendre les éléments suivants :

  • Renumérotation incessante des pages existantes dans le document
  • Repagination incessante du document
  • Présentation et mise en forme incorrectes du document
  • Caractères illisibles à l'écran
  • Messages d'erreur au cours du traitement
  • Ordinateur cessant de répondre quand vous ouvrez le fichier
  • Tout autre comportement inattendu qui ne peut pas être attribué au fonctionnement normal du programme

Parfois, ce comportement peut être provoqué par des facteurs autres que l'endommagement du document. Il est important de déterminer si le document est endommagé ou s'il s'agit d'un problème logiciel. Pour éliminer ces autres facteurs, procédez comme suit :

  1. Recherchez des comportements similaires dans d'autres documents. Essayez d'ouvrir d'autres documents Word pour voir si le même problème se produit. S’ils s’ouvrent correctement, le problème est peut-être lié à votre document Word.
  2. Recherchez des comportements similaires dans d'autres programmes Microsoft Office. Dans ce cas, le problème peut provenir d’une autre application ou du système d’exploitation.

Si l'une de ces étapes indique que le problème ne provient pas du document, vous devrez alors dépanner Word, la suite Office ou le système d'exploitation exécuté sur l'ordinateur.

Étapes de résolution des problèmes à essayer si le document endommagé ne s'ouvre pas

Essayez les méthodes dans l'ordre indiqué. Si une méthode ne fonctionne pas, essayez la suivante.

Étape 1 : Configuration de Word

  1. Démarrez Word.
  2. Sous l'onglet Affichage, cliquez sur Brouillon dans le groupe Vues.
  3. Cliquez sur Menu Fichier, puis sur Options et enfin sur Options avancées.
  4. Dans la section Afficher le contenu des documents, sélectionnez Utiliser la police brouillon en mode Plan et Brouillon et Afficher les espaces réservés pour les images.
  5. Dans la section Général, désactivez la case à cocher Mettre à jour les liaisons automatiques à l'ouverture, cliquez sur OK, puis fermez Word.

Étape 2 : Ouverture du document endommagé

  1. Démarrez Word.
  2. Sélectionnez le Menu Fichier, puis Ouvrir.
  3. Cliquez sur le document endommagé, puis sur Ouvrir.

Si vous pouvez ouvrir le document, fermez-le et rouvrez-le à l'aide de la méthode 6, puis réparez-le. Sinon, passez à la méthode 2.

Méthode 2 : Insertion du document en tant que fichier dans un nouveau document

Étape 1 : Création d'un nouveau document vierge

  1. Sélectionnez le Menu Fichier, puis sélectionnez Nouveau.
  2. Cliquez sur Document vierge, puis sur Créer.

Étape 2 : Insertion du document endommagé dans le nouveau document

  1. Sous l'onglet Insérer, cliquez sur Insérer un objet, puis cliquez sur Texte d'un fichier.

  2. Dans la boîte de dialogue Insérer un fichier, recherchez le document endommagé, puis cliquez dessus. Sélectionnez ensuite Insérer.

    Notes

    Vous devrez peut-être réappliquer une certaine mise en forme à la dernière section du nouveau document.

Étape 1 : Création d'un document vierge

  1. Dans Word, cliquez sur le Menu Fichier, puis sur Nouveau.
  2. Cliquez sur Document vierge, puis sur Créer.
  3. Dans le nouveau document, tapez « Ceci est un test. »
  4. Sélectionnez le Menu Fichier, puis Enregistrer.
  5. Tapez « Lien de secours », puis cliquez sur Enregistrer.
  1. Sélectionnez le texte tapé à l'étape 1-3.
  2. Sous l'onglet Accueil, cliquez sur Copier dans le groupe Presse-papiers.
  3. Sélectionnez le Menu Fichier, puis sélectionnez Nouveau.
  4. Cliquez sur Document vierge, puis sur Créer.
  5. Sous l'onglet Accueil, cliquez sur la flèche figurant sur le bouton Coller dans le groupe Presse-papiers, puis cliquez sur Collage spécial.
  6. Cliquez sur Coller lien, puis sur Texte mis en forme (RTF).
  7. Sélectionnez OK.
  1. Cliquez avec le bouton droit sur le texte lié dans le document, pointez sur Objet Document lié, puis cliquez sur Liaisons.

  2. Dans la boîte de dialogue Liaisons, cliquez sur le nom de fichier du document lié, puis cliquez sur Modifier la source.

  3. Dans la boîte de dialogue Modifier la source, cliquez sur le document que vous ne parvenez pas à ouvrir, puis sur Ouvrir.

  4. Cliquez sur OK pour fermer la boîte de dialogue Liaisons.

    Notes

    Les informations liées au document endommagé s'affichent si du texte ou des données sont récupérables.

  5. Cliquez avec le bouton droit sur le texte lié, pointez sur Objet Document lié, puis cliquez sur Liaisons.

  6. Dans la boîte de dialogue Liaisons, cliquez sur Rompre la liaison.

  7. Lorsque le message suivant s'affiche, cliquez sur Oui : Annuler les liaisons sélectionnées ?

Méthode 4 : Utilisation du convertisseur « Récupérer le texte de tout type de fichier »

Notes

Le convertisseur « Récupérer le texte de tout type de fichier » présente des limites. Par exemple, la mise en forme du document est perdue. En outre, les graphiques, champs, objets dessins, et tous les autres éléments qui ne sont pas du texte sont perdus. En revanche, les en-têtes, les pieds de page, les notes de bas de page et les notes de fin sont interprétés comme du texte simple.

  1. Dans Word, cliquez sur le Menu Fichier, puis sur Ouvrir.
  2. Dans la zone Types de fichiers, cliquez sur Récupérer le texte de tout type de fichier(.).
  3. Sélectionnez le document dont vous souhaitez récupérer le texte.
  4. Sélectionnez Ouvrir.

Une fois le document récupéré à l'aide du convertisseur « Récupérer le texte de tout type de fichier », une partie du texte en données binaires n'est pas convertie. Ce texte se trouve principalement au début et à la fin du document. Vous devez supprimer ce texte en données binaires avant d'enregistrer le fichier au format Word.

Notes

Si vous utilisez Word 2007, il n'y a pas de bouton Fichier dans l'interface utilisateur. Cliquez sur le bouton Office et suivez les instructions si nécessaire.

Étapes de résolution des problèmes à essayer si vous pouvez ouvrir le document endommagé

Méthode 1 : Copie du contenu du document, excepté la dernière marque de paragraphe, dans un nouveau document

Étape 1 : Création d’un document

  1. Dans Word, cliquez sur Fichier sur le Ruban, puis cliquez sur Nouveau.
  2. Cliquez sur Document vierge, puis sur Créer.

Étape 2 : Ouverture du document endommagé

  1. Cliquez sur Fichier sous le Ruban, puis cliquez sur Ouvrir.
  2. Cliquez sur le document endommagé, puis sur Ouvrir.

Étape 3 : Copie, puis collage du contenu du document dans un nouveau document

Notes

Si votre document contient des sauts de section, copiez uniquement le texte entre les sauts de section. N'effectuez pas de copier-coller des sauts de section, sinon vous risquez de copier dans votre nouveau document ce qui endommageait votre fichier d'origine. Affichez le document en mode Brouillon lorsque vous effectuez un copier-coller entre des documents, afin d'éviter de transférer des sauts de section. Pour passer en mode brouillon, sous l'onglet Affichage, sélectionnez Brouillon dans le groupe Affichages document.

  1. Dans le document endommagé, appuyez sur Ctrl+Fin, puis sur Ctrl+Maj+Origine.
  2. Sous l'onglet Accueil, cliquez sur Copier dans le groupe Presse-papiers.
  3. Sous l'onglet Affichage, cliquez sur Changer de fenêtre dans le groupe Fenêtre.
  4. Cliquez sur le nouveau document créé à l'étape 1.
  5. Sous l'onglet Accueil, cliquez sur Coller dans le groupe Presse-papiers.

Si le comportement étrange persiste, passez à la méthode 8.

Méthode 2 : modification du modèle utilisé par le document

Étape 1 : Identification du modèle utilisé par le document

  1. Ouvrez le document endommagé dans Word.
  2. Cliquez sur Fichier sous le Ruban, puis cliquez sur Options.
  3. Sélectionnez Compléments.
  4. Dans la zone Gérer, cliquez sur Modèles sous Afficher et gérer les compléments Office.
  5. Sélectionner Aller. La zone Modèle de document indique le modèle utilisé par le document. Si le modèle indiqué est Normal, passez à l'étape 2. Sinon, passez à l’étape 3.

Étape 2 : Modification du nom du modèle global (Normal.dotm)

  1. Quittez Word.
  2. Cliquez sur le bouton Démarrer.
  3. Dans votre système d'exploitation, recherchez normal.dotm. Il se trouve généralement à cet emplacement : %userprofile%\appdata\roaming\microsoft\templates
  4. Cliquez avec le bouton droit sur Normal.dotm, puis sur Renommer.
  5. Tapez « Oldword.old », puis appuyez sur Entrée.
  6. Fermez l'Explorateur de fichiers.
  7. Démarrez Word, puis ouvrez le document.

Étape 3 : Changement du modèle de document

  1. Ouvrez le document endommagé dans Word.
  2. Cliquez sur Fichier sous le Ruban, puis cliquez sur Options.
  3. Sélectionnez Compléments.
  4. Dans la zone Gérer, cliquez sur Modèles, puis cliquez sur Atteindre.
  5. Sélectionnez Attacher.
  6. Dans le dossier Modèles, cliquez sur Normal.dotm, puis cliquez sur Ouvrir.
  7. Cliquez sur OK pour fermer la boîte de dialogue Modèles et compléments.
  8. Quittez Word.

Étape 4 : Vérification que le changement de modèle a fonctionné

  1. Démarrez Word.
  2. Cliquez sur Fichier sous le Ruban, puis cliquez sur Options.
  3. Cliquez sur le document endommagé, puis sur Ouvrir.

Si le comportement étrange persiste, passez à la méthode 3.

Méthode 3 : démarrage de Word avec les paramètres par défaut

Vous pouvez utiliser le commutateur /a pour démarrer Word avec uniquement les paramètres par défaut de Word. Si vous utilisez le commutateur /a, Word ne chargera aucun module complémentaire. En outre, il n'utilise pas votre modèle Normal.dotm existant. Redémarrez Word à l'aide du commutateur /a.

Étape 1 : Démarrage de Word à l’aide du commutateur /a

  1. Quittez Word.

  2. Cliquez sur le bouton Démarrer, puis cherchez Exécuter. Dans la boîte de dialogue Exécuter, tapez :

    winword.exe /a

Étape 2 : Ouverture du document

  1. Dans Word, cliquez sur Fichier sous le Ruban, puis cliquez sur Ouvrir.
  2. Cliquez sur le document endommagé, puis sur Ouvrir.

Si le comportement étrange persiste, passez à la méthode 4.

Méthode 4 : Changement de pilote d'imprimante

Étape 1 : Essai d'un autre pilote d'imprimante

  1. Dans votre système d'exploitation, recherchez Périphériques et imprimantes.
  2. Cliquez sur Ajouter une imprimante.
  3. Dans la boîte de dialogue Ajouter une imprimante, cliquez sur Ajouter une imprimante locale.
  4. Cliquez sur Utiliser un port existant, puis sur Suivant.
  5. Dans la zone Fabricant, cliquez sur Microsoft.
  6. Cliquez sur Microsoft XPS Document Writer, puis sur Suivant.
  7. Cliquez sur Utiliser le pilote actuellement installé (recommandé), puis cliquez sur Suivant.
  8. Activez la case à cocher Définir en tant qu'imprimante par défaut, puis cliquez sur Suivant.
  9. Sélectionnez Terminer.

Étape 2 : Vérification que le changement de pilote d'imprimante résout le problème

  1. Démarrez Word.
  2. Cliquez sur Fichier sous le Ruban, puis cliquez sur Ouvrir.
  3. Cliquez sur le document endommagé, puis sur Ouvrir.

Si le comportement étrange persiste, passez à l'étape 3.

Étape 3 : Réinstallation du pilote dʼimprimante d'origine

Windows 10 et Windows 7

  1. Dans votre système d'exploitation, recherchez Imprimantes.

  2. Cliquez avec le bouton droit sur l'imprimante par défaut d'origine, puis cliquez sur Supprimer.

    Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer l'opération, entrez votre mot de passe ou sélectionnez Continuer.

  3. Si dans un message vous êtes invité à supprimer tous les fichiers associés à l'imprimante, cliquez sur Oui.

  4. Cliquez sur Ajouter une imprimante, puis suivez les instructions de l'Assistant Ajout d'imprimante pour réinstaller le pilote d'imprimante.

Étape 4 : Vérification que le changement de pilote d'imprimante résout le problème

  1. Démarrez Word.
  2. Cliquez sur Fichier sous le Ruban, puis cliquez sur Ouvrir.
  3. Cliquez sur le document endommagé, puis sur Ouvrir.

Si le comportement étrange persiste, passez à la méthode 5.

Méthode 5 : Tentative de réparation forcée d'un fichier par Word

Étape 1 : Réparation du document

Dans Word, cliquez sur Fichier sous le Ruban, puis cliquez sur Ouvrir.

  1. Dans la boîte de dialogue Ouvrir, faites un clic sur votre document Word pour le mettre en surbrillance.
  2. Cliquez sur la flèche du bouton Ouvrir, puis sur Ouvrir et réparer.

Étape 2 : Vérification que la réparation du document résout le problème

Vérifiez que le comportement étrange ne se produit plus. Si le comportement étrange persiste, redémarrez Windows, puis passez à la méthode 6.

Méthode 6 : Modification du format de document, puis reconversion du document au format Word

Étape 1 : Ouverture du document

  1. Démarrez Word.
  2. Cliquez sur Fichier sous le Ruban, puis cliquez sur Ouvrir.
  3. Cliquez sur le document endommagé, puis sur Ouvrir.

Étape 2 : Enregistrement du document sous un format de fichier différent

  1. Cliquez sur Fichier sous le Ruban, puis cliquez sur Enregistrer sous.
  2. Sélectionnez Autres formats.
  3. Dans la liste Enregistrer sous Type de fichier, cliquez sur Texte mis en forme (*.rtf).
  4. Sélectionnez Enregistrer.
  5. Cliquez sur Fichier sous le Ruban, puis cliquez sur Fermer.

Étape 3 : Ouverture puis reconversion du document au format de fichier Word

  1. Dans Word, sélectionnez Fichier, puis cliquez sur Ouvrir.
  2. Cliquez sur le document converti, puis sur Ouvrir.
  3. Sélectionnez le Fichier, puis cliquez sur Enregistrer sous.
  4. Sélectionnez le type Document Word dans Enregistrer sous.
  5. Modifiez le nom de fichier du document, puis cliquez sur Enregistrer.

Étape 4 : Vérification que la conversion du format de fichier du document résout le problème

Vérifiez que le comportement étrange ne se produit plus. S'il persiste, essayez d'enregistrer le fichier sous un format de fichier différent. Répétez les étapes 1 à 4, puis essayez d'enregistrer le fichier sous les formats de fichier suivants, dans l'ordre présenté :

  • Page Web (.htm; .html)
  • Tout autre format de traitement de texte
  • Texte brut (.txt)

Notes

Si vous enregistrez des fichiers au format Texte brut (.txt), vous pourrez probablement réparer les dommages causés au document. Toutefois, la mise en forme, les codes de macro et les graphiques du document seront perdus. Lorsque vous enregistrez des fichiers au format Texte brut (.txt), vous devez remettre en forme le document. Par conséquent, utilisez le format Texte brut (.txt) uniquement si les autres formats de fichier ne résolvent pas le problème.

Si le comportement étrange persiste, passez à la méthode 7.

Méthode 7 : Copie des parties intactes du document endommagé dans un nouveau document

Étape 1 : Création d’un document

  1. Dans Word, cliquez sur Fichier, puis sur Nouveau.
  2. Cliquez sur Document vierge, puis sur Créer.

Étape 2 : Ouverture du document endommagé

  1. Cliquez sur Fichier, puis sélectionnez Ouvrir.
  2. Cliquez sur le document endommagé, puis sur Ouvrir.

Étape 3 : Copie et collage des parties intactes du document endommagé dans un nouveau document

Notes

Si votre document contient des sauts de section, copiez uniquement le texte entre les sauts de section. Ne copiez pas les sauts de section car cela pourrait entraîner des dommages dans votre nouveau document. Affichez le document en mode Brouillon lorsque vous effectuez un copier-coller entre des documents, afin d'éviter de transférer des sauts de section. Pour passer en mode brouillon, sous l'onglet Affichage, sélectionnez Brouillon dans le groupe Affichages document.

  1. Recherchez et sélectionnez une partie intacte dans le contenu du document endommagé.
  2. Sous l'onglet Accueil, cliquez sur Copier dans le groupe Presse-papiers.
  3. Sous l'onglet Affichage, cliquez sur Changer de fenêtre dans le groupe Fenêtre.
  4. Cliquez sur le nouveau document créé à l'étape 1.
  5. Sous l'onglet Accueil, cliquez sur Coller dans le groupe Presse-papiers.
  6. Répétez les étapes 3a à 3e pour chaque partie intacte du document. Vous devez reconstruire la partie endommagée de votre document.

Méthode 8 : Basculement dans l'affichage document pour supprimer le contenu endommagé

Si le document paraît tronqué (toutes les pages du document ne sont pas affichées), il est possible de basculer dans l'affichage document et de supprimer du document le contenu endommagé.

  1. Déterminez le numéro de la page dont le contenu endommagé provoque la troncation du document.

    1. Dans Word, sélectionnez Fichier, puis cliquez sur Ouvrir.
    2. Cliquez sur le document endommagé, puis sur Ouvrir.
    3. Faites défiler jusqu'à ce que la dernière page avant troncation du document s'affiche. Notez le contenu qui figure sur cette page.
  2. Changez de vue et supprimez le contenu endommagé.

    1. Sous l'onglet Affichage dans le groupe Affichages document, cliquez sur Mise en forme Web ou Affichage brouillon.
    2. Descendez jusqu'au contenu affiché avec que le document ne s'affiche comme tronqué.
    3. Sélectionnez et supprimez le paragraphe, le tableau ou l'objet suivant dans le fichier.
    4. Sous l'onglet Affichage dans le groupe Affichages document, cliquez sur Imprimer la mise en forme. Si le document reste tronqué, continuez à basculer entre les affichages et supprimez du contenu jusqu'à ce que le document ne soit plus tronqué en Mode Page.
    5. Enregistrez le document.

Méthode 9 : Ouvrez le document avec le Bloc-notes

Si le document est corrompu et qu'aucune des méthodes précédentes ne fonctionne, essayez de récupérer son contenu en l'ouvrant avec le Bloc-notes.

Notes

En utilisant cette méthode, vous perdrez toute la mise en forme. Le but est de récupérer le contenu.

  1. Localisez le document endommagé à l'aide de l'Explorateur de fichiers Windows.
  2. Cliquez avec le bouton droit sur le document, puis sélectionnez Ouvrir avec.
  3. Sélectionnez Bloc-notes :

Capture dʼécran de lʼouverture du document Word dans le Bloc-notes.

  1. Le document s'ouvrira dans le Bloc-notes avec du code supplémentaire et du texte autour du contenu.

    Notes

    Vous devrez peut-être remplacer le type de fichier « Fichiers texte (.txt) » par « Tous les fichiers (.*) ».

  2. Nettoyez le texte en supprimant l'ensemble ou la majorité des caractères supplémentaires.

  3. Sélectionnez Fichier, puis cliquez sur Enregistrer sous.... Renommez le document pour vous assurer de ne pas remplacer le document endommagé.

Retournez dans Word et ouvrez le nouveau document. Une fois dans Word, vous pouvez nettoyer le fichier et tenter de réappliquer le format perdu.