Des interblocages de base de données se produisent lorsque vous essayez d’afficher un rapport SSRS en mode intégré SharePoint après avoir mis à jour une source de données

Cet article fournit des solutions pour les blocages qui se produisent lorsque vous essayez d’afficher un rapport SQL Server Reporting Services (SSRS) en mode intégré SharePoint.

Version du produit d’origine : SQL Server
Numéro de la base de connaissances d’origine : 2691331

Symptômes

Prenons l’exemple du scénario suivant :

  • Vous configurez une instance de Microsoft SSRS pour utiliser le mode intégré SharePoint.

  • Vous créez un rapport qui a plusieurs sources de données.

  • Vous déployez le rapport sur un site web SharePoint.

  • Vous mettez à jour l’une des sources de données.

  • Vous essayez d’afficher le rapport à partir d’une page SharePoint personnalisée. Le rapport est incorporé dans un contrôle IFrame de la page à l’aide d’un accès URL direct au point de terminaison proxy SSRS comme suit :

    < http:// Nom> du serveur/<Nom >du site/_vti_bin/ReportServer/<Report Name.rdl> ?<Paramètres de l’URL du rapport>

Dans ce scénario, vous pouvez rencontrer un ou plusieurs des symptômes suivants.

  • Symptôme 1

    Les interblocages de base de données se produisent sur l’une des procédures stockées suivantes dans la base de données du serveur de rapports principal :

    • [dbo].[GetDataSources]
    • [dbo].[DeleteDataSources]
  • Symptôme 2

    Vous recevez l’un des messages d’erreur suivants :

    • Message d'erreur 1

      Une erreur s’est produite dans la base de données du serveur de rapports. Cela peut être dû à un échec de connexion, à un délai d’expiration ou à une condition de disque faible au sein de la base de données. (rsReportServerDatabaseError)

    • Message d'erreur 2

      Délai d’attente expiré. Le délai d’expiration s’est produit avant la fin de l’opération ou le serveur ne répond pas.

  • Symptôme 3

    Le chargement des pages SharePoint est très lent lorsque vous essayez d’accéder au contenu du site SharePoint.

Cause

Ce problème se produit car la source de données n’est pas synchronisée correctement après sa mise à jour.

Résolution

Pour contourner ce problème, appliquez l’une des méthodes suivantes :

  • Méthode 1

    Affichez le rapport directement à partir de la bibliothèque de documents SharePoint après avoir mis à jour la source de données du rapport. Cela permet de s’assurer que la source de données est correctement synchronisée avant d’afficher le rapport via le point de terminaison proxy SSRS.

  • Méthode 2

    Utilisez un composant WebPart Visionneuse de rapports pour afficher le rapport.