Installation du module PowerShell AIPServiceInstalling the AIPService PowerShell module

S’applique à : Azure information protection, Office 365Applies to: Azure Information Protection, Office 365

Utilisez les informations suivantes pour vous aider à installer le module Windows PowerShell pour le service de protection à partir de Azure Information Protection.Use the following information to help you install the Windows PowerShell module for the protection service from Azure Information Protection. Le nom de ce module est AIPService et remplace la version précédente nommée AADRM.The name of this module is AIPService, and it replaces the previous version that was named AADRM.

Vous pouvez utiliser ce module PowerShell pour administrer le service de protection (Azure Rights Management) à partir de la ligne de commande à l’aide de n’importe quel ordinateur Windows disposant d’une connexion Internet et qui satisfait aux conditions préalables indiquées dans la section suivante.You can use this PowerShell module to administer the protection service (Azure Rights Management) from the command line by using any Windows computer that has an internet connection and that meets the prerequisites listed in the next section. Windows PowerShell pour Azure Information Protection prend en charge l’écriture de scripts pour l’automatisation ou peut être nécessaire pour les scénarios de configuration avancée.Windows PowerShell for Azure Information Protection supports scripting for automation or might be necessary for advanced configuration scenarios. Pour plus d’informations sur les tâches d’administration et les configurations prises en charge par le module, consultez administration de la protection à partir de Azure information protection à l’aide de PowerShell.For more information about the administration tasks and configurations that the module supports, see Administering protection from Azure Information Protection by using PowerShell.

PrérequisPrerequisites

Ce tableau répertorie les conditions préalables à l’installation et l’utilisation du module PowerShell AIPService pour le service de protection de Azure Information Protection.This table lists the prerequisites to install and use the AIPService PowerShell module for the protection service from Azure Information Protection.

Condition requiseRequirement Informations complémentairesMore information
Version minimale de Windows PowerShell : 3.0Minimum version of Windows PowerShell: 3.0 Vous pouvez vérifier la version de Windows PowerShell que vous exécutez en tapant $PSVersionTable dans une session PowerShell.You can confirm the version of Windows PowerShell that you are running by typing $PSVersionTable in a PowerShell session.

Si vous devez installer une version ultérieure de Windows PowerShell, consultez Upgrading existing Windows PowerShell (Mise à niveau de Windows PowerShell existant).If you need to install a later version of Windows PowerShell, see Upgrading existing Windows PowerShell.
Version minimale du Microsoft .NET Framework : 4.5Minimum version of the Microsoft .NET Framework: 4.5

Remarque : Cette version du Microsoft .NET Framework étant fournie avec les systèmes d’exploitation de version plus récente, une installation manuelle ne devrait être nécessaire que si le système d’exploitation de votre client est antérieur à Windows 8.0, ou si celui de votre serveur est antérieur à Windows Server 2012.Note: This version of the Microsoft .NET Framework is included with the later operating systems, so you should need to manually install it only if your client operating system is less than Windows 8.0 or your server operating system is less than Windows Server 2012.
Si la version minimale du Framework Microsoft .NET n’est pas déjà installée, vous pouvez télécharger Microsoft .net framework 4,5.If the minimum version of the Microsoft .NET Framework is not already installed, you can download Microsoft .NET Framework 4.5.

Cette version minimale du Microsoft .NET Framework est requise pour certaines des classes utilisées par le module AIPService.This minimum version of the Microsoft .NET Framework is required for some of the classes that the AIPService module uses.

Si le module AADRM est installéIf you have the AADRM module installed

Le module AIPService remplace l’ancien module, AADRM.The AIPService module replaces the older module, AADRM. Si vous avez installé l’ancien module, désinstallez-le, puis installez le module AIPService.If you have the older module installed, uninstall it and then install the AIPService module.

Le module plus récent a des alias pour les noms d’applets de commande dans l’ancien module afin que tous les scripts existants continuent de fonctionner.The newer module has aliases to the cmdlet names in the older module so that any existing scripts will continue to work. Toutefois, prévoyez de mettre à jour ces références avant que l’ancien module ne soit pris en charge.However, plan to update these references before the old module falls out of support. La prise en charge du module AADRM se terminera le 15 juillet 2020.Support for the AADRM module will end July 15, 2020.

Si vous avez installé le module AADRM à partir de la PowerShell Gallery, pour le désinstaller, démarrez une session PowerShell avec l’option exécuter en tant qu’administrateur , puis tapez :If you installed the AADRM module from the PowerShell Gallery, to uninstall it, start a PowerShell session with the Run as Administrator option, and type:

Uninstall-Module -Name AADRM

Si vous avez installé le module AADRM avec l’outil d’administration Azure Rights Management, utilisez programmes et fonctionnalités pour désinstaller Windows Azure ad Rights Management Administration.If you installed the AADRM module with the Azure Rights Management Administration Tool, use Programs and Features to uninstall Windows Azure AD Rights Management Administration.

Comment installer le module AIPServiceHow to install the AIPService module

Le module AIPService se trouve sur le PowerShell Gallery et n’est pas disponible dans le centre de téléchargement Microsoft.The AIPService module is on the PowerShell Gallery and is not available from the Microsoft Download Center.

Si vous n’avez jamais utilisé PowerShell Gallery, consultez Bien démarrer avec PowerShell.If you're new to the PowerShell Gallery, see Get Started with the PowerShell Gallery. Suivez les instructions relatives à la configuration requise de la galerie, avec notamment l’installation du module PowerShellGet et du fournisseur NuGet.Follow the instructions for the gallery requirements, which include installing the PowerShellGet module and the NuGet provider.

Pour plus d’informations sur le module AIPService sur la PowerShell Gallery, consultez la page AIPService.To see details about the AIPService module on the PowerShell Gallery, visit the AIPService page.

Pour installer le module AIPService, démarrez une session PowerShell avec l’option exécuter en tant qu’administrateur , puis tapez :To install the AIPService module, start a PowerShell session with the Run as Administrator option, and type:

Install-Module -Name AIPService

Si vous recevez un avertissement indiquant que l’installation est effectuée à partir d’un dépôt non approuvé, vous pouvez appuyer sur O pour confirmer.If you are warned about installing from an untrusted repository, you can press Y to confirm. Vous pouvez aussi appuyer sur N et configurer le PowerShell Gallery en tant que référentiel approuvé à l’aide de la commande Set-PSRepository -Name PSGallery -InstallationPolicy Trusted , puis réexécuter la commande pour installer le module AIPService.Or, press N and configure the PowerShell Gallery as a trusted repository by using the command Set-PSRepository -Name PSGallery -InstallationPolicy Trusted and then rerun the command to install the AIPService module.

Si vous disposez d’une version précédente du module AIPService installée à partir de la Galerie, mettez-la à jour avec la dernière version en tapant ce qui suit :If you have a previous version of the AIPService module installed from the Gallery, update it to the latest by typing:

Update-Module -Name AIPService

Étapes suivantesNext steps

Dans une session Windows PowerShell, vérifiez la version du module installé.In a Windows PowerShell session, confirm the version of the installed module. Cette vérification est particulièrement importante si vous avez mis à niveau à partir d’une version antérieure :This check is particularly important if you upgraded from an older version:

(Get-Module AIPService –ListAvailable).Version

Notes

Si cette commande échoue, exécutez d’abord import-module AIPService.If this command fails, first run Import-Module AIPService.

Pour voir les applets de commande disponibles, tapez la commande suivante :To see which cmdlets are available, type the following:

Get-Command -Module AIPService

Utilisez la commande Get-Help <cmdlet_name> pour afficher l’aide relative à une applet de commande spécifique, et utilisez le paramètre -online pour afficher l’aide la plus récente sur le site de la documentation de Microsoft.Use the Get-Help <cmdlet_name> command to see the Help for a specific cmdlet, and use the -online parameter to see the latest help on the Microsoft documentation site. Par exemple :For example:

Get-Help Connect-AipService -online

Pour plus d'informations :For more information:

Avant de pouvoir exécuter des commandes qui configurent le service de protection, vous devez vous connecter au service à l’aide de l’applet de commande Connect-AipService .Before you can run any commands that configure the protection service, you must connect to the service by using the Connect-AipService cmdlet.

Lorsque vous avez terminé d’exécuter vos commandes de configuration, il est recommandé de se déconnecter du service à l’aide de l’applet de commande Disconnect-AipService .When you have finished running your configuration commands, as a best practice, disconnect from the service by using the Disconnect-AipService cmdlet. Si vous ne vous déconnectez pas, la connexion est interrompue automatiquement après une période d’inactivité.If you do not disconnect, the connection is automatically disconnected after a period of inactivity. En raison du comportement de déconnexion automatique, vous constaterez que vous devrez occasionnellement vous reconnecter à une session PowerShell.Because of the automatic disconnection behavior, you might find that you need to occasionally reconnect in a PowerShell session.

Notes

Si le service de protection n’est pas encore activé, vous pouvez le faire après vous être connecté au service, à l’aide de l’applet de commande Enable-AipService .If the protection service is not yet activated, you can do this after you have connected to the service, by using the Enable-AipService cmdlet.