Résoudre les problèmes de déploiement liés au redémarrage ou au redimensionnement d’une machine virtuelle Windows existante dans Azure

Lorsque vous essayez de démarrer une machine virtuelle Azure arrêtée ou de redimensionner une machine virtuelle Azure existante, l’erreur la plus fréquemment rencontrée est un échec d’allocation. Cette erreur se produit lorsque le cluster ou la région n’ont pas de ressources disponibles ou ne prennent pas en charge la taille de machine virtuelle demandée.

Si votre problème Azure n’est pas traité dans cet article, consultez les forums Azure sur MSDN et Stack Overflow. Vous pouvez publier votre problème sur ces forums ou sur @AzureSupport sur Twitter. Vous pouvez également envoyer une demande de support Azure. Pour envoyer une demande de support, rendez-vous sur la page du support Azure, puis sélectionnez Obtenir de l’aide.

Collecte des journaux d’activité

Pour résoudre les problèmes, commencez par collecter les journaux d’activité afin d’identifier l’erreur associée au problème. Les liens suivants contiennent des informations détaillées sur le processus :

Voir les opérations de déploiement

Afficher les journaux d’activité pour gérer les ressources Azure

Problème : Erreur lors du démarrage dʼune machine virtuelle arrêtée

Vous essayez de démarrer une machine virtuelle arrêtée, mais obtenez un échec d’allocation.

Cause

La demande de démarrage de la machine virtuelle arrêtée doit être exécutée sur le cluster d’origine qui héberge le service cloud. Toutefois, le cluster n’a pas d’espace libre pour répondre à la demande.

Résolution

  • Arrêtez toutes les machines virtuelles du groupe à haute disponibilité, puis redémarrez chacune d’elles.

    1. Cliquez sur Groupes de ressources>votre groupe de ressources>Ressources>votre groupe à haute disponibilité>Machines virtuelles>votre machine virtuelle>Arrêter.
    2. Après l’arrêt de toutes les machines virtuelles, sélectionnez chacune des machines arrêtées et cliquez sur Démarrer.
  • Relancez la demande de redémarrage ultérieurement.

Problème : Erreur lors du redimensionnement dʼune machine virtuelle existante

Vous essayez de redimensionner une machine virtuelle existante, mais obtenez un échec d’allocation.

Cause

La demande de redimensionnement de la machine virtuelle doit être exécutée sur le cluster d’origine qui héberge le service cloud. Toutefois, le cluster ne prend pas en charge la taille de machine virtuelle demandée.

Résolution

  • Relancez la requête en utilisant une taille inférieure pour la machine virtuelle.

  • Si la taille de la machine virtuelle demandée ne peut pas être modifiée :

    1. Arrêtez toutes les machines virtuelles dans le groupe à haute disponibilité.

      • Cliquez sur Groupes de ressources>votre groupe de ressources>Ressources>votre groupe à haute disponibilité>Machines virtuelles>votre machine virtuelle>Arrêter.
    2. Après l’arrêt de toutes les machines virtuelles, redimensionnez la machine virtuelle souhaitée à une taille supérieure.

    3. Sélectionnez la machine virtuelle redimensionnée, cliquez sur Démarrer, puis démarrez chacune des machines virtuelles arrêtées.

Erreur en cas dʼarrêt, de démarrage, de redémarrage ou de redéploiement dʼune machine virtuelle existante

Lorsque vous essayez d’arrêter, de démarrer, de redémarrer ou de redéployer une machine virtuelle existante, le processus échoue et vous recevez un message « Une erreur inattendue s’est produite lors du traitement du profil réseau de la machine virtuelle. Veuillez réessayer ultérieurement » message d’erreur. Lorsque cette erreur se produit, la machine virtuelle est mise dans un état dʼéchec.

Cause

Ce problème se produit en cas de problème dʼallocation ou de mise à jour des ressources réseau.

Résolution

Essayez de réappliquer lʼétat de la machine virtuelle. Cette opération réexécute lʼapprovisionnement de la machine virtuelle et permet de résoudre lʼétat dʼéchec de cette dernière, dans le cas où lʼapprovisionnement a échoué lors de lʼexécution dʼune action de machine virtuelle précédente.

  1. Accédez à la machine virtuelle bloquée dans lʼétat dʼéchec.
  2. Sous Aider, sélectionnez Redéployer + réappliquer.
  3. Sélectionnez lʼoption Réappliquer.

Prochaines étapes

Si vous rencontrez des problèmes lorsque vous créez une machine virtuelle Windows dans Azure, consultez Résoudre les problèmes de déploiement liés à la création d’une machine virtuelle Windows dans Azure.

Contactez-nous pour obtenir de l’aide

Pour toute demande ou assistance, créez une demande de support ou posez une question au support de la communauté Azure. Vous pouvez également soumettre des commentaires sur les produits à la communauté de commentaires Azure.