Procédure pas à pas : compilation d’un programme C++/CLI qui cible le CLR dans Visual Studio

En utilisant C++/CLI, vous pouvez créer des programmes C++ qui utilisent des classes .NET ainsi que des types C++ natifs. C++/CLI est destiné à une utilisation dans des applications console et dans des dll qui encapsulent du code C++ natif et le rendent accessible à partir de programmes .NET. pour créer une interface utilisateur Windows basée sur .net, utilisez C# ou Visual Basic.

Pour cette procédure, vous pouvez taper votre propre programme C++ ou utiliser l’un des exemples de programmes. L’exemple de programme que nous utilisons dans cette procédure crée un fichier texte nommé textfile.txt et l’enregistre dans le répertoire du projet.

Prérequis

  • Une connaissance des notions de base du langage C++.
  • dans Visual Studio 2017 et versions ultérieures, la prise en charge de C++/cli est un composant facultatif. pour l’installer, ouvrez le Visual Studio Installer à partir du menu Démarrer Windows. Assurez-vous que la vignette développement Desktop avec c++ est cochée, et dans la section composants facultatifs , vérifiez également la prise en charge de C++/CLI.

Créer un projet

Les étapes suivantes varient légèrement selon la version de Visual Studio que vous utilisez. pour consulter la documentation de votre version préférée de Visual Studio, utilisez le contrôle sélecteur de version . Elle se trouve en haut de la table des matières sur cette page.

Pour créer un projet C++/CLI dans Visual Studio

  1. dans Explorateur de solutions, cliquez avec le bouton droit sur le haut pour ouvrir la boîte de dialogue créer un nouvel Project .

  2. en haut de la boîte de dialogue, tapez clr dans la zone de recherche, puis choisissez clr vide Project dans la liste des résultats.

  3. Choisissez le bouton Créer pour créer le projet.

pour créer un projet C++/cli dans Visual Studio 2017

  1. Créez un projet. Dans le menu Fichier , pointez sur Nouveau, puis cliquez sur Projet.

  2. Dans les types de projets Visual C++, cliquez sur CLR, puis sur Projet vide CLR.

  3. Tapez un nom de projet. Par défaut, la solution qui contient le projet porte le même nom que le nouveau projet, mais vous pouvez entrer un autre nom. Si vous le souhaitez, vous pouvez indiquer un emplacement différent pour le projet.

  4. Cliquez sur OK pour créer le projet.

pour créer un projet C++/cli dans Visual Studio 2015

  1. Créez un projet. Dans le menu Fichier , pointez sur Nouveau, puis cliquez sur Projet.

  2. Dans les types de projets Visual C++, cliquez sur CLR, puis sur Projet vide CLR.

  3. Tapez un nom de projet. Par défaut, la solution qui contient le projet porte le même nom que le nouveau projet, mais vous pouvez entrer un autre nom. Si vous le souhaitez, vous pouvez indiquer un emplacement différent pour le projet.

  4. Cliquez sur OK pour créer le projet.

Ajouter un fichier source

  1. Si l’Explorateur de solutions n’est pas visible, cliquez sur Explorateur de solutions dans le menu Affichage.

  2. Ajoutez un nouveau fichier source au projet :

    • cliquez avec le bouton droit sur le dossier fichiers sources dans Explorateur de solutions, pointez sur ajouter, puis cliquez sur nouvel élément.

    • Cliquez sur Fichier C++ (.cpp), tapez un nom de fichier, puis cliquez Ajouter.

    le fichier . cpp apparaît dans le dossier fichiers sources de Explorateur de solutions et une fenêtre à onglets s’affiche dans laquelle vous tapez le code souhaité dans ce fichier.

  3. Cliquez dans l’onglet nouvellement créé dans Visual Studio et tapez un programme Visual C++ valide, ou copiez et collez l’un des exemples de programmes.

    Vous pouvez par exemple utiliser l’exemple de programme Guide pratique pour écrire un fichier texte (C++/CLI) (dans le nœud Gestion de fichiers et E/S du guide de programmation).

    Si vous avez recours à l’exemple de programme, notez que vous devez utiliser le mot clé gcnew à la place de new pour créer un objet .NET, et que gcnew retourne un handle (^) au lieu d’un pointeur (*) :

    StreamWriter^ sw = gcnew StreamWriter(fileName);

    Pour plus d’informations sur la syntaxe C++/CLI, consultez extensions de composant pour les plateformes Runtime.

  4. Dans le menu Générer, cliquez sur Générer la solution.

    La fenêtre Sortie affiche des informations sur la progression de la compilation, comme l’emplacement du journal de génération, et un message indiquant l’état de la build.

    Si vous modifiez et exécutez le programme sans effectuer de génération, une boîte de dialogue peut indiquer que le projet est obsolète. Cochez la case dans cette boîte de dialogue avant de cliquer sur OK si vous souhaitez que Visual Studio utilise toujours les versions actuelles des fichiers au lieu de vous le demander chaque fois qu’il génère l’application.

  5. Dans le menu Déboguer, cliquez sur Démarrer sans débogage.

  6. Quand vous exécutez l’exemple de programme, une fenêtre de commande s’affiche et indique que le fichier texte a été créé.

    Le fichier texte textfile.txt se trouve désormais dans votre répertoire de projet. Vous pouvez ouvrir ce fichier à l’aide du Bloc-notes.

    Notes

    Si vous choisissez le modèle Projet vide CLR, l’option de compilateur /clr est définie automatiquement. Pour le vérifier, cliquez avec le bouton droit sur le projet dans l’Explorateur de solutions, cliquez sur Propriétés, puis examinez l’option Prise en charge du Common Language Runtime dans le nœud Général de Propriétés de configuration.

Voir aussi

Informations de référence sur le langage C++
Projets et systèmes de build