Installer le .NET Framework 3.5 sur Windows 10, Windows 8.1 et Windows 8Install the .NET Framework 3.5 on Windows 10, Windows 8.1, and Windows 8

Vous pouvez avoir besoin de .NET Framework 3.5 pour exécuter une application sur Windows 10, Windows 8.1 et Windows 8.You may need the .NET Framework 3.5 to run an app on Windows 10, Windows 8.1, and Windows 8. Vous pouvez également utiliser ces instructions pour les versions antérieures de Windows.You can also use these instructions for earlier Windows versions.

Installer .NET Framework 3.5 à la demandeInstall the .NET Framework 3.5 on Demand

Vous pouvez voir la boîte de dialogue de configuration suivante si vous essayez d’exécuter une application qui nécessite .NET Framework 3.5.You may see the following configuration dialog if you try to run an app that requires the .NET Framework 3.5. Choisissez Installer cette fonctionnalité pour activer le .NET Framework 3.5.Choose Install this feature to enable the .NET Framework 3.5. Cette option requiert une connexion Internet.This option requires an Internet connection.

Boîte de dialogue d’installation du .NET Framework

Pourquoi cette fenêtre contextuelle apparaît-elle ?Why am I getting this pop-up?

Le .NET Framework est créé par Microsoft et fournit un environnement d’exécution d’applications.The .NET Framework is created by Microsoft and provides an environment for running applications. Différentes versions sont disponibles.There are different versions available. De nombreuses entreprises développent leurs applications pour qu’elles s’exécutent avec le .NET Framework, et ces applications en ciblent une version spécifique.Many companies develop their apps to run using the .NET Framework, and these apps target a specific version. Si vous voyez cette fenêtre contextuelle, cela signifie que vous tentez d’exécuter une application qui nécessite le .NET Framework version 3.5, mais que cette version n’est pas installée sur votre système.If you see this pop-up, you're trying to run an application that requires the .NET Framework version 3.5, but that version is not installed on your system.

Activer .NET Framework 3.5 dans le Panneau de configurationEnable the .NET Framework 3.5 in Control Panel

Vous pouvez activer le .NET Framework 3.5 dans le Panneau de configuration de Windows.You can enable the .NET Framework 3.5 through the Windows Control Panel. Cette option requiert une connexion Internet.This option requires an Internet connection.

  1. Appuyez sur la touche Windows logo Windows de votre clavier, tapez « Fonctionnalités Windows » puis appuyez sur Entrée.Press the Windows key Windows Windows logo on your keyboard, type "Windows Features", and press Enter. La boîte de dialogue Activer ou désactiver des fonctionnalités Windows apparaît.The Turn Windows features on or off dialog box appears.

  2. Cochez la case .NET Framework 3.5 (inclut .NET 2.0 et 3.0), sélectionnez OK et redémarrez l’ordinateur si vous y êtes invité.Select the .NET Framework 3.5 (includes .NET 2.0 and 3.0) check box, select OK, and reboot your computer if prompted.

    Installation de .NET avec le Panneau de configuration

    Vous n’avez pas besoin de sélectionner des éléments enfants pour Activation HTTP de Windows Communication Foundation et Activation non-HTTP de Windows Communication Foundation, sauf si vous êtes un développeur ou un administrateur de serveur ayant besoin de cette fonctionnalité.You don't need to select the child items for Windows Communication Foundation (WCF) HTTP Activation and Windows Communication Foundation (WCF) Non-HTTP Activation unless you're a developer or server administrator who requires this functionality.

Résoudre les problèmes d’installation du .NET Framework 3.5Troubleshoot the installation of the .NET Framework 3.5

Pendant l’installation, si vous rencontrez l’erreur 0x800f0906, 0x800f0907, 0x800f081f ou 0x800F0922, consultez Erreur d’installation de .NET Framework 3.5 : 0x800f0906, 0x800f0907 ou 0x800f081f pour découvrir comment résoudre ces problèmes.During installation, you may encounter error 0x800f0906, 0x800f0907, 0x800f081f, or 0x800F0922, in which case refer to .NET Framework 3.5 installation error: 0x800f0906, 0x800f0907, or 0x800f081f to see how to resolve these issues.

Si vous ne pouvez toujours pas résoudre votre problème d’installation ou si vous n’avez pas de connexion Internet, vous pouvez essayer de l’installer en utilisant votre support d’installation Windows.If you still can't resolve your installation issue or you don't have an Internet connection, you can try installing it using your Windows installation media. Pour plus d’informations, consultez Déployer le .NET Framework 3.5 à l’aide de Gestion et maintenance des images de déploiement (DISM).For more information, see Deploy .NET Framework 3.5 by using Deployment Image Servicing and Management (DISM). Si vous ne disposez pas du support d’installation, consultez Créer un support d’installation pour Windows.If you don't have the installation media, see Create installation media for Windows.

Avertissement

Si vous ne vous basez pas sur Windows Update comme source pour l’installation de .NET Framework 3.5, vous devez veiller à utiliser strictement des sources de la même version du système d’exploitation Windows correspondant.If you're not relying on Windows Update as the source for installing the .NET Framework 3.5, you must ensure to strictly use sources from the same corresponding Windows operating system version. L’utilisation d’un chemin d’accès source qui ne correspond pas à la même version de Windows n’empêchera pas l’installation d’une version incompatible de .NET Framework 3.5.Using a source path that doesn't correspond to the same version of Windows won't prevent a mismatched version of .NET Framework 3.5 from being installed. Toutefois, l’état du système devient inutilisable et non pris en charge.However, this will cause the system to be in an unsupported and unserviceable state.