Invite de commandes développeur pour Visual StudioDeveloper Command Prompt for Visual Studio

Developer Command Prompt for Visual Studio vous permet d’utiliser plus facilement les outils cadres .NET.Developer Command Prompt for Visual Studio enables you to use .NET Framework tools more easily. Il s’agit d’une invite de commande qui définit automatiquement des variables spécifiques de l’environnement.It's a command prompt that automatically sets specific environment variables. Après l’ouverture de Developer Command Prompt, vous pouvez ildasm entrer clrverles commandes pour des outils cadre .NET tels que ou .After opening Developer Command Prompt, you can enter the commands for .NET Framework tools such as ildasm or clrver.

Conditions préalables requisesPrerequisites

Rechercher l’invite de commandes sur votre ordinateurSearch for the command prompt on your machine

Vous pouvez avoir plusieurs invites de commande, selon la version de Visual Studio et les SDK supplémentaires et les charges de travail que vous avez installées.You may have multiple command prompts, depending on the version of Visual Studio and any additional SDKs and workloads you've installed. Si les étapes suivantes ne fonctionnent pas, vous pouvez essayer de localiser manuellement les fichiers sur votre machine ou démarrer l’invite de commande de l’intérieur de Visual Studio.If the following steps don't work, you can try to manually locate the files on your machine or start the command prompt from inside Visual Studio.

Windows 10Windows 10

  1. Sélectionnez La clé de logo Start Windows sur le clavier.Select Start Windows logo key on the keyboard. et faites défiler la lettre V.and scroll to the letter V.

  2. Élargissez le dossier Visual Studio 2019.Expand the Visual Studio 2019 folder.

  3. Choisissez Developer Command Prompt pour VS 2019 (ou l’invite de commande que vous souhaitez utiliser).Choose Developer Command Prompt for VS 2019 (or the command prompt you want to use).

    Alternativement, vous pouvez commencer à taper le nom de l’invite de commande dans la boîte de recherche sur la barre des tâches, et choisir le résultat que vous voulez que la liste de résultat commence à afficher les correspondances de recherche.Alternatively, you can start typing the name of the command prompt in the search box on the taskbar, and choose the result you want as the result list starts to display the search matches.

    Gif animé montrant le comportement de recherche sur Windows 10

Windows 8.1Windows 8.1

  1. Accédez à l’écran Démarrer en appuyant sur la touche de logo Windows Touche de logo Windows de votre clavier.Go to the Start screen, by pressing the Windows logo key Windows logo key on the keyboard. de votre clavier, par exemple.on your keyboard for example.

  2. Sur l’écran Démarrer, appuyez sur Ctrl+Tab pour ouvrir la liste Apps, puis appuyez sur V. Cela fait ressortir une liste qui comprend toutes les invites de commande Visual Studio installées.On the Start screen, press Ctrl+Tab to open the Apps list, and then press V. This brings up a list that includes all installed Visual Studio command prompts.

  3. Choisissez Developer Command Prompt pour VS 2019 (ou l’invite de commande que vous souhaitez utiliser).Choose Developer Command Prompt for VS 2019 (or the command prompt you want to use).

Windows 7Windows 7

  1. Choisissez Démarrer, puis d’élargir tous les programmes.Choose Start and then expand All Programs.

  2. Choisissez Visual Studio 2019 > Visual Studio Tools > Developer Command Prompt pour VS 2019, ou l’invite de commande que vous souhaitez utiliser.Choose Visual Studio 2019 > Visual Studio Tools > Developer Command Prompt for VS 2019, or the command prompt you want to use.

    Menu Windows 7 Démarrer avec l’invite de commande surlignée

Si vous avez d’autres SDK installés, tels que windows 10 SDK ou des versions précédentes,vous pouvez voir des invites de commande supplémentaires.If you have other SDKs installed, such as the Windows 10 SDK or previous versions, you may see additional command prompts. Consultez la documentation relatives aux divers outils afin de déterminer la version de l'invite de commandes que vous devez utiliser.Check the documentation for the individual tools to determine which version of the command prompt you should use.

Recherche manuelle des fichiers sur votre ordinateurManually locate the files on your machine

Habituellement, les raccourcis pour les invites de commande que vous avez installé sont placés dans le dossier de menu Démarrer pour Visual Studio, comme dans % ProgramData%-Microsoft-Windows-Start Menu-Programs-Visual Studio 2019 -Visual Studio Tools.Usually, the shortcuts for the command prompts you have installed are placed at the Start Menu folder for Visual Studio, such as in %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2019\Visual Studio Tools. Mais si, pour une raison quelconque, la recherche de l’invite de commande ne produit pas les résultats attendus, vous pouvez essayer de localiser manuellement le raccourci sur votre machine.But if, for some reason, searching for the command prompt doesn't produce the expected results, you can try to manually locate the shortcut on your machine. Essayez de rechercher le nom du fichier d’invite de commande, tel que VsDevCmd.bat, ou allez au dossier Tools, tels que %ProgramFiles (x86)% -Microsoft Visual Studio-2019-Community-Common7-Tools (changements de chemin selon votre version Visual Studio, édition et emplacement d’installation).Try searching for the name of the command prompt file, such as VsDevCmd.bat, or go to the Tools folder, such as %ProgramFiles(x86)%\Microsoft Visual Studio\2019\Community\Common7\Tools (path changes according to your Visual Studio version, edition, and installation location).

Démarrer l’invite de commande de l’intérieur Visual StudioStart the command prompt from inside Visual Studio

Pour un accès plus facile, vous pouvez ajouter Developer Command Prompt, ou toute autre invite de commande, au menu Tools dans Visual Studio.For easier access, you can add Developer Command Prompt, or any other command prompt, to the Tools menu in Visual Studio. Pour cela, il vous suffit de l’ajouter à la liste des outils externes.To make the tool available, add it to the external tools list. Voici la procédure à suivre :Here are the steps:

  1. Ouvrez Visual Studio.Open Visual Studio.

  2. Dans la fenêtre de démarrage, choisissez Continuer sans code.On the start window, choose Continue without code.

  3. Sur la barre de menu, choisissez Tools > External Tools.On the menu bar, choose Tools > External Tools.

  4. Dans la boîte de dialogue Outils externes, choisissez le bouton Ajouter.On the External Tools dialog box, choose the Add button. Une nouvelle entrée apparaît.A new entry appears.

  5. Entrez un titre pour votre nouvel élément de menu, par exemple Command Prompt.Enter a Title for your new menu item such as Command Prompt.

  6. Dans le champ de commande, spécifiez le fichier que vous souhaitez lancer, tel que %comspec% ou C:\Windows\System32\cmd.exe.In the Command field, specify the file you want to launch, such as %comspec% or C:\Windows\System32\cmd.exe.

  7. Dans le domaine Arguments, spécifiez où trouver /k "C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\Tools\VsDevCmd.bat"l’invite de commande spécifique que vous souhaitez utiliser, comme .In the Arguments field, specify where to find the specific command prompt you want to use, such as /k "C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\Tools\VsDevCmd.bat". Cette commande lance le Developer Command Prompt qui est installé avec Visual Studio 2019 Community.This command launches the Developer Command Prompt that's installed with Visual Studio 2019 Community. Changez cette valeur en fonction de l’emplacement d’installation, de l’édition et de la version de Visual Studio.Change this value according to your Visual Studio version, edition, and installation location.

  8. Dans le domaine de l’annuaire initial, spécifiez l’annuaire dans lequel l’invite de commande commencera.In the Initial directory field, specify the directory in which the command prompt will start. Choisissez une valeur telle que l’annuaire de projet en sélectionnant la flèche à côté du champ.Choose a value such as Project Directory by selecting the arrow next to the field.

  9. Choisissez le bouton OK.Choose the OK button.

    Dialogue outils externes avec les valeurs de champ remplies.

    Le nouvel élément de menu est ajouté et vous pouvez accéder à l’invite de commandes à partir du menu Outils.The new menu item is added, and you can access the command prompt from the Tools menu.

    Élément de menu d’invite de commandes dans Visual Studio

Voir aussiSee also