Résolution des problèmes d’authentification dans les applications Office lorsque vous essayez de vous connecter à un service Office 365

Notes

Office 365 ProPlus est renommé Applications Microsoft 365 pour les entreprises. Pour plus d’informations sur ce changement, lisez ce billet de blog.

Symptômes

L’authentification échoue automatiquement dans certaines applications Microsoft Office et Outlook peut accéder à l’état « nécessite un mot de passe » sans aucune interaction. De plus, lorsque vous effectuez un appel de l’API de gestionnaire de comptes Web vers FindAllAccountsAsync, vous pouvez voir le code d’erreur « -2147024809 » dans les journaux AAD ou les journaux du client Office.

Important

Ce problème se produit uniquement sur les ordinateurs qui exécutent Windows 10, version 1703 ou ultérieure, et Office 365 version 1807 ou ultérieure.

Cause

Le problème d’authentification est dû à des informations de package manquantes sur la bibliothèque d’authentification Active Directory (ADAL) ou l’ID actif.

Résolution

Conseil

Pour diagnostiquer et résoudre automatiquement plusieurs problèmes courants de connexion à Office, vous pouvez télécharger et exécuter l' Assistant support et récupération Microsoft.

Pour résoudre ce problème, utilisez PowerShell pour réinstaller les packages pour ADAL (pour les comptes d’organisation ou de travail) et Live ID (pour les comptes personnels tels que @outlook.com , @hotmail.com , et ainsi de suite). Pour cela, procédez comme suit :

  1. Cliquez avec le bouton droit sur l’icône Windows dans la barre des tâches, puis sélectionnez Windows PowerShell (admin).

  2. Si vous êtes invité par une fenêtre decontrôle de compted’utilisateur, sélectionnez Oui pour démarrer PowerShell.

  3. Si votre problème concerne un compte professionnel, vous devez corriger le package ADAL. Exécutez la commande suivante dans la console de commande :

    if (-not (Get-AppxPackage Microsoft.AAD.BrokerPlugin)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.AAD.BrokerPlugin
    
  4. Si votre problème concerne un compte personnel, vous devez corriger le package Live ID. Exécutez la commande suivante dans la console de commande :

    if (-not (Get-AppxPackage Microsoft.Windows.CloudExperienceHost)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.Windows.CloudExperienceHost
    

Une fois que vous avez exécuté les commandes et si elles se sont terminées sans erreur, vous pouvez voir un indicateur de progression rapide ou un résultat d’État qui contient des informations sur l’installation du package.