Impossible de créer un profil Outlook après une migration avec l’événement 1098 dans Microsoft Entra ID journal

Numéro de la base de connaissances d’origine : 4499299

Symptômes

Lorsque vous essayez de créer un profil Microsoft Outlook après une migration de domaine, vous recevez un message d’erreur indiquant que vous ne pouvez pas démarrer Outlook ou qu’un problème s’est produit. Vous recevez également une invite de connexion.

Capture d’écran des messages d’erreur Outlook.

En outre, vous pouvez voir l’événement 1098 dans Microsoft Entra journal des opérations qui ressemble à l’erreur suivante :

Erreur : 2147943712

ErrorMessage : une session d’ouverture de session spécifiée n’existe pas. Il est possible qu’il ait déjà été arrêté. Une session d’ouverture de session spécifiée n’existe pas. Il est possible qu’il ait déjà été arrêté.

AdditionalInformation : exception de type 'class WinRTException' à webaccountprocessor.cpp, ligne : 190, méthode :
Microsoft Entra ID ::Core ::WebAccountProcessor ::P rocessBrokerRequest ::<lambda_> ::operator (). Journal : échec de l’opération du répartiteur de jetons 0xcaa5001c. Nom de l’opération : RequestToken enregistré au webaccountprocessor.cpp, ligne : 520, méthode : Microsoft Entra ID ::Core ::WebAccountProcessor ::ReportException.

Pour trouver le journal opérationnel Microsoft Entra dans observateur d'événements, recherchez Journaux >des applications et des servicesMicrosoft> Windows >Microsoft Entra ID>Operational.

Capture d’écran montrant Microsoft Entra emplacement dans observateur d'événements.

Cause

Il existe plusieurs scénarios qui peuvent entraîner une modification d’un identificateur de sécurité utilisateur (SID), par exemple, la migration de l’utilisateur vers un nouveau domaine. Toutefois, le profil utilisateur n’est pas modifié et les fichiers de données qui ont l’ancien SID sont désormais mis en cache dans un ancien profil. Dans ce cas, vous pouvez rencontrer un problème de connexion Office ou des boucles d’authentification qui entraînent cette erreur.

Résolution

Pour résoudre ce problème, procédez comme suit :

  1. Supprimez tous les fichiers du dossier Comptes à l’emplacement suivant :

    %LOCALAPPDATA%\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\AC\TokenBroker\Accounts

    Remarque

    Copiez et collez l’emplacement ci-dessus dans la zone Recherche Windows pour rechercher le dossier.

  2. Redémarrez et recréez un profil Outlook.