Les notifications de conseil de stratégie DLP ne s’affichent pas dans Outlook pour Windows

Symptômes

Après avoir configuré certaines stratégies de protection contre la perte de données (DLP) qui incluent des messages de notification de conseil de stratégie, vous remarquez que les clients Outlook pour Windows n’affichent pas les messages de notification ou qu’ils affichent des messages incorrects. Toutefois, Outlook sur le web (OWA) affiche les messages de notification attendus.

Cause

Ce problème se produit parce que les critères de version compatibles traités par l’évaluateur de stratégie sont basés sur la version de mso20win32client.dll, et non sur la version d’Outlook. Dans de nombreux cas, la version de mso20win32client.dll n’est pas identique à la version d’Outlook et d’Office.

Par exemple, un administrateur peut configurer une stratégie très restrictive qui s’applique uniquement à la version 16.0.11727.20244 ou à une version ultérieure d’Outlook. Toutefois, l’évaluateur de stratégie utilise la version 16.0.11727.20222 de mso20win32client.dll et détermine que la règle ne doit pas être appliquée. Dans cet exemple, la règle doit indiquer la version minimale requise de 16.0.11727.20222 pour que le conseil de stratégie apparaisse dans Outlook.

Résolution

Pour s’assurer qu’Outlook applique toutes les stratégies DLP attendues, l’administrateur doit vérifier que la règle d’incitation de stratégie pour minRequiredVersion a une valeur qui n’est pas supérieure à la version installée par le client de mso20win32client.dll. Le fichier mso20win32client.dll peut se trouver dans l’un des dossiers suivants :

  • C :\Program Files (x86)\Microsoft Office\root\vfs\ProgramFilesCommonX86\Microsoft Shared\OFFICE16
  • C :\Program Files (x86)\Common Files\Microsoft Shared\Office16

Informations supplémentaires

Dans des cas similaires, le client Outlook peut être forcé de mettre à jour les fichiers de stratégies et de définitions locaux. Pour ce faire, supprimez la valeur de Registre suivante de la section « Stratégie nudges » de la sous-clé de Registre indiquée :

Sous-clé : HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\15.0\Outlook\PolicyNudges

Valeur : LastDownloadTimesPerAccount

Remarque

  • Cette étape de résolution des problèmes ne résout pas le problème provoqué par la condition décrite dans la section Cause .
  • OWA n’est pas affecté par le problème provoqué par la condition décrite dans la section Cause .

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