Présentation des requêtes dans Power BI DesktopQuery overview in Power BI Desktop

Avec Power BI Desktop, vous pouvez vous connecter à tout un monde de données, créer des rapports attrayants et fondamentaux, puis les partager avec d’autres utilisateurs, qui peuvent ensuite s’appuyer sur votre travail pour développer leurs talents en matière de décisionnel.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop propose trois vues :Power BI Desktop has three views:

  • La vue Rapport : c’est là où vous utilisez des requêtes que vous avez créées pour générer des visualisations attrayantes, organisées comme vous souhaitez qu’elles apparaissent et avec plusieurs pages, que vous pouvez partager avec d’autres utilisateurs.Report view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • La vue Données : elle vous permet de consulter les données de votre rapport dans un format de modèle de données, où vous pouvez ajouter des mesures, créer des colonnes et gérer les relations.Data view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • La vue Relations : elle vous permet d’obtenir une représentation graphique des relations qui ont été définies dans votre modèle de données et de les gérer ou de les modifier si nécessaire.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Vous pouvez accéder à ces vues en sélectionnant l’une des trois icônes affichées sur le côté gauche de Power BI Desktop.These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. Dans l’image suivante, la vue Rapport est sélectionnée, ce qu’indique la bande jaune en regard de l’icône.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Power BI Desktop propose également un Éditeur de requête, avec lequel vous pouvez vous connecter à une ou plusieurs sources de données, former et transformer les données en fonction de vos besoins, puis charger ce modèle dans Power BI Desktop.Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Ce document fournit une vue d’ensemble de ce que vous pouvez faire avec des données dans l’Éditeur de requête.This document provides an overview of the work with data in the Query Editor. Il existe bien entendu de nombreuses autres fonctionnalités. À la fin de ce document, vous trouverez des liens vers des informations détaillées et de l’aide sur les types de données pris en charge, la connexion aux données, la mise en forme des données, la création de relations et la prise en main.There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

Mais tout d’abord, nous allons nous familiariser avec l’ Éditeur de requête.But first, let’s see get acquainted with Query Editor.

Éditeur de requêteThe Query Editor

Pour accéder à l’Éditeur de requête, sous l’onglet Accueil de Power BI Desktop, sélectionnez Modifier les requêtes.To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Sans connexion de données, l’Éditeur de requête se présente sous la forme d’un volet vide, prêt à accueillir des données.With no data connections, Query Editor appears as a blank pane, ready for data.

Une fois qu’une requête est chargée, la fenêtre de l’Éditeur de requête devient plus intéressante.Once a query is loaded, Query Editor view becomes more interesting. Si nous nous connectons à la source de données web suivante, l’Éditeur de requête charge des informations sur les données, que nous pouvons commencer à mettre en forme.If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspxhttp://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Voici à quoi ressemble l’Éditeur de requête une fois qu’une connexion de données est établie :Here’s how Query Editor appears once a data connection is established:

  1. Dans le ruban, de nombreux boutons sont actifs, qui permettent d’interagir avec les données de la requête.In the ribbon, many buttons are now active to interact with the data in the query
  2. Dans le volet gauche, les requêtes sont répertoriées et disponibles pour la sélection, l’affichage et la mise en forme.In the left pane, queries are listed and available for selection, viewing, and shaping
  3. Dans le volet central, les données issues de la requête sélectionnée sont affichées et disponibles pour la mise en forme.In the center pane, data from the selected query is displayed and available for shaping
  4. La fenêtre Paramètres de requête s’affiche. Elle répertorie les propriétés et les étapes appliquéesThe Query Settings window appears, listing the query’s properties and applied steps

Nous allons examiner chacune de ces quatre zones – le ruban, le volet des requêtes, la vue des données et le volet Paramètres d’une requête – dans les sections suivantes.We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

Ruban de la vue RequêteThe query ribbon

Le ruban de l’Éditeur de requête comporte quatre onglets : Accueil, Transformer, Ajouter une colonne et Affichage.The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

L’onglet Accueil contient les tâches de requête courantes, notamment la première étape d’une requête, qui consiste à Obtenir des données.The Home tab contains the common query tasks, including the first step in any query, which is Get Data. L’image suivante montre le ruban Accueil.The following image shows the Home ribbon.

Pour vous connecter à des données et lancer le processus de création de requête, cliquez sur le bouton Obtenir des données .To connect to data and begin the query building process, select the Get Data button. Un menu s’affiche, proposant les sources de données les plus courantes.A menu appears, providing the most common data sources.

Pour plus d’informations sur les sources de données disponibles, consultez Sources de données.For more information about available data sources, see Data Sources. Pour obtenir plus d’informations sur la connexion à des données, ainsi que des exemples et des étapes, consultez Se connecter à des données.For information about connecting to data, including examples and steps, see Connect to Data.

L’onglet Transformer donne accès à des tâches de transformation de données courantes, telles que l’ajout ou la suppression de colonnes, la modification des types de données, le fractionnement des colonnes et d’autres tâches pilotées par des données.The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. L’image suivante montre l’onglet Transformer .The following image shows the Transform tab.

Pour obtenir plus d’informations sur la transformation des données, ainsi que des exemples, consultez Combiner et mettre en forme des données.For more information about transforming data, including examples, see Combine and Shape Data.

L’onglet Ajouter une colonne offre des tâches supplémentaires associées à l’ajout de colonne, à la mise en forme des données d’une colonne et à l’ajout de colonnes personnalisées.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. L’image suivante montre l’onglet Ajouter une colonne .The following image shows the Add Column tab.

L’onglet Affichage du ruban permet d’afficher ou de masquer certains volets ou fenêtres.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Il est également utilisé pour afficher l’Éditeur avancé.It’s also used to display the Advanced Editor. L’image suivante montre l’onglet Affichage.The following image shows the View tab.

Le saviez-vous ? De nombreuses tâches disponibles à partir du ruban sont également accessibles dans le volet central en cliquant avec le bouton droit sur une colonne ou sur des données.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Volet gaucheThe left pane

Le volet gauche affiche le nombre de requêtes actives, ainsi que le nom des requêtes.The left pane displays the number of active queries, as well as the name of the query. Quand vous sélectionnez une requête dans le volet gauche, ses données sont affichées dans le volet central, où vous pouvez mettre en forme et transformer les données à votre guise.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. L’image suivante montre le volet gauche avec plusieurs requêtes.The following image shows the left pane with multiple queries.

Volet central (données)The center (data) pane

Dans le volet central, ou volet Données, les données issues de la requête sélectionnée sont affichées.In the center pane, or Data pane, date from the selected query is displayed. C’est à cet endroit que l’essentiel du travail de la vue Requête est effectué.This is where much of the work of the Query view is accomplished.

Dans l’image suivante, la connexion de données web établie précédemment s’affiche, la colonne Overall score (Score global) est sélectionnée et les éléments de menu disponibles s’affichent quand l’utilisateur clique avec le bouton droit sur l’en-tête de cette colonne.In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. Notez que la plupart de ces éléments de menu contextuel correspondent à des boutons des onglets du ruban.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Quand vous sélectionnez un élément de menu contextuel (ou un bouton de ruban), la fonctionnalité Requête applique l’étape aux données et l’enregistre dans le cadre de la requête proprement dite.When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. Les étapes sont enregistrées séquentiellement dans le volet Paramètres d’une requête , comme décrit dans la section suivante.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Volet Paramètres d’une requêteThe query settings pane

Le volet Paramètres d’une requête affiche toutes les étapes associées à une requête.The Query Settings pane is where all steps associated with a query are displayed. Par exemple, dans l’image suivante, la section Étapes appliquées du volet Paramètres d’une requête reflète le fait que nous venons de modifier le type de la colonne Overall score (Score global).For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

À mesure que d’autres étapes de mise en forme sont appliquées à la requête, elles sont capturées dans la section Étapes appliquées .As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

Il est important de savoir que les données sous-jacentes ne sont pas modifiées ; au lieu de cela, l’Éditeur de requête ajuste et met en forme sa vue des données, et toute interaction avec les données sous-jacentes repose sur la vue ainsi obtenue.It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

Dans le volet Paramètres d’une requête , vous pouvez renommer des étapes, supprimer des étapes ou réorganiser les étapes comme vous le souhaitez.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Pour ce faire, cliquez avec le bouton droit sur l’étape dans la section Étapes appliquées , puis choisissez une option dans le menu qui s’affiche.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Toutes les étapes de la requête sont effectuées dans l’ordre de leur apparition dans le volet Étapes appliquées.All query steps are carried out in the order they appear in the Applied Steps pane.

Éditeur avancéThe Advanced Editor

Si vous voulez voir le code généré par l’Éditeur de requête à chaque étape ou créer votre propre code de mise en forme, vous pouvez utiliser l’ Éditeur avancé.If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. Pour lancer l’Éditeur avancé, sélectionnez Affichage dans le ruban, puis sélectionnez Éditeur avancé.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Une fenêtre apparaît, affichant le code de requête existant.A window appears, showing the existing query code.

Vous pouvez modifier le code directement dans la fenêtre Éditeur avancé .You can directly edit the code in the Advanced Editor window. Pour fermer la fenêtre, cliquez sur le bouton Terminé ou Annuler .To close the window, select the Done or Cancel button.

Enregistrement de votre travailSaving your work

Quand votre requête est là où vous le voulez, vous pouvez faire en sorte que l’Éditeur de requête applique les modifications au modèle de données dans Power BI Desktop, puis fermer l’Éditeur de requête.When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. Pour cela, sélectionnez Fermer et appliquer dans le menu Fichier de l’Éditeur de requête.To do that, select Close & Apply from Query Editor's File menu.

À chaque étape, Power BI Desktop affiche une boîte de dialogue pour afficher l’état de la progression.As progress is made, Power BI Desktop provides a dialog to display its status.

Une fois que votre requête est prête, ou si vous souhaitez simplement ne rien perdre de votre travail, Power BI Desktop peut enregistrer ce dernier sous la forme d’un fichier .pbix.Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

Pour enregistrer votre travail, sélectionnez Fichier>Enregistrer(ouFichier>Enregistrer sous), comme illustré dans l’image suivante.To save your work, select File > Save (or File > Save As), as shown in the following image.

Étapes suivantesNext steps

Power BI Desktop vous permet d’effectuer des tâches très diverses.There are all sorts of things you can do with Power BI Desktop. Pour plus d’informations sur ses fonctionnalités, passez en revue les ressources suivantes :For more information on its capabilities, check out the following resources: