Obtenir des données de fichiers Power BI DesktopGet data from Power BI Desktop files

Power BI Desktop facilite la création de rapports et la prise de décisions.Power BI Desktop makes business intelligence and reporting easy. Power BI Desktop simplifie la connexion à différentes sources de données, l’interrogation et la transformation de données, la modélisation des données et la création de rapports puissants et dynamiques, ce qui rend les tâches décisionnelles plus rapides et intuitives.Whether you're connecting to a many different data sources, querying and transforming data, modeling your data, and creating powerful and dynamic reports, Power BI Desktop makes business intelligence tasks intuitive and fast. Si vous ne maîtrisez pas très bien Power BI Desktop, nous vous recommandons de consulter Prise en main de Power BI Desktop.If you're not familiar with Power BI Desktop, check out Getting started with Power BI Desktop.

Une fois que vous avez mis des données dans Power BI Desktop et créé quelques rapports, récupérez votre fichier enregistré dans le service Power BI.Once you bring data into Power BI Desktop and create a few reports, it’s time to get your saved file into the Power BI service.

L’emplacement d’enregistrement de votre fichier change toutWhere your file is saved makes a difference

Local : si votre fichier est enregistré sur un disque local sur votre ordinateur ou un autre emplacement de votre organisation, vous pouvez importer votre fichier ou publier à partir de Power BI pour récupérer les données et rapports qu’il contient dans Power BI.Local - If you save your file to a local drive on your computer or another location in your organization, you can import your file or you can publish from Power BI Desktop to get its data and reports into Power BI. Votre fichier est en fait conservé sur votre disque local. Il n’est donc pas entièrement déplacé vers Power BI.Your file will actually remain on your local drive, so the whole file isn’t really moved into Power BI. En réalité, un nouveau jeu de données est créé dans Power BI et les données et le modèle de données du classeur Power BI Desktop sont chargés dans ce jeu de données.What really happens is a new dataset is created in Power BI and data and the data model from the Power BI Desktop file are loaded into the dataset. Si votre fichier contient des rapports, ceux-ci apparaissent dans votre site Power BI sous Rapports.If your file has any reports, those will appear in your Power BI site under Reports.

OneDrive Entreprise : si vous disposez de OneDrive Entreprise et que vous vous connectez avec le même compte que pour Power BI, cette méthode est de loin la plus efficace pour que votre travail dans Power BI Desktop et vos jeux de données, rapports et tableaux de bord dans Power BI restent synchronisés. Power BI et OneDrive étant tous les deux dans le cloud, Power BI se connecte à votre fichier sur OneDrive toutes les heures environ.OneDrive - Business – If you have OneDrive for Business and you sign into it with the same account you sign into Power BI with, this is by-far the most effective way to keep your work in Power BI Desktop and your dataset, reports, and dashboards in Power BI in-sync. Because both Power BI and OneDrive are in the cloud, Power BI connects to your file on OneDrive about every hour. Si des modifications sont détectées, vos jeu de données, rapports et tableaux de bord sont automatiquement mis à jour dans Power BI.If any changes are found, your dataset, reports, and dashboards are automatically updated in Power BI.

OneDrive personnel : si vous enregistrez vos fichiers sur votre compte OneDrive personnel, vous bénéficiez de la plupart des avantages obtenus avec OneDrive Entreprise.OneDrive - Personal – If you save your files to your own OneDrive account, you’ll get many of the same benefits as you would with OneDrive for Business. La différence principale réside dans le fait que, la première fois que vous vous connectez à votre fichier (via Obtenir des données > Fichiers > OneDrive personnel), vous devez vous connecter à votre compte OneDrive avec votre compte Microsoft, qui est généralement différent de celui utilisé pour vous connecter à Power BI.The biggest difference is when you first connect to your file (using Get Data > Files > OneDrive – Personal) you’ll need to sign in to your OneDrive with your Microsoft account, which is usually different from what you use to sign in to Power BI. Lorsque vous vous connectez à OneDrive avec votre compte Microsoft, veillez à sélectionner l’option Maintenir la connexion.When signing in with your OneDrive with your Microsoft account, be sure to select the Keep me signed in option. Power BI peut ainsi se connecter à votre fichier toutes les heures environ et s’assurer que votre jeu de données dans Power BI est synchronisé.This way, Power BI will be able to connect to your file about every hour and make sure your dataset in Power BI is in-sync.

Sites d’équipe SharePoint : l’enregistrement de vos fichiers Power BI Desktop sur des sites d’équipe SharePoint revient plus ou moins à enregistrer dans OneDrive Entreprise.SharePoint Team-Sites – Saving your Power BI Desktop files to SharePoint – Team Sites is much the same as saving to OneDrive for Business. La différence majeure réside dans la manière dont vous vous connectez au fichier à partir de Power BI.The biggest difference is how you connect to the file from Power BI. Vous pouvez spécifier une URL ou vous connecter au dossier racine.You can specify a URL or connect to the root folder.

Importer un fichier Power BI Desktop ou s’y connecter à partir de Power BIImport or connect to a Power BI Desktop file from Power BI

Important

La taille de fichier maximale que vous pouvez importer dans Power BI est de 1 gigaoctet.The maximum file size you can import into Power BI is 1 gigabyte.

  1. Dans Power BI, dans le volet de navigation, cliquez sur Obtenir des données.In Power BI, in the navigator pane, click ** Get Data**.

  2. Dans Fichiers, cliquez sur Obtenir.In Files, click Get.

  3. Recherchez votre fichier.Find your file. Les fichiers Power BI Desktop portent l’extension .pbix.Power BI Desktop files have a .PBIX extension.

Publier un fichier à partir de Power BI Desktop sur votre site Power BIPublish a file from Power BI Desktop to your Power BI site

L’utilisation de la fonctionnalité Publier dans Power BI Desktop revient à utiliser Obtenir des données dans Power BI pour importer votre fichier à partir d’un disque local ou vous y connecter sur OneDrive.Using Publish from Power BI Desktop is effectively the same as using Get Data in Power BI to import your file from a local drive or connecting to it on OneDrive. Nous vous présentons ici la procédure rapide, mais vous pouvez consulter Publier à partir de Power BI Desktop pour en savoir plus.Here’s the quick how to, but you can see Publish from Power BI Desktop to learn more.

  1. Dans Power BI Desktop, cliquez sur Fichier > Publier > Publier sur Power BI ou cliquez sur Publier dans le ruban.In Power BI Desktop, click File > Publish > Publish to Power BI, or click Publish on the ribbon.

  2. Connectez-vous à Power BI.Sign in to Power BI. Cette étape est requise uniquement lors de la première utilisation.You'll only need to do this the first time.

    Une fois terminé, vous obtiendrez un lien pour ouvrir votre rapport dans votre site Power BI.When complete, you'll get a link to open your report in your Power BI site.

Étapes suivantesNext steps

Explorez vos données : une fois vos données et rapports importés dans Power BI à partir de votre fichier, il est temps de les explorer.Explore your data - Once you get data and reports from your file into Power BI, it's time to explore. Si votre fichier comprenait déjà des rapports, ceux-ci s’affichent dans le volet de navigation sous Rapports.If your file already has reports in it, they'll appear in the navigator pane in Reports. Si votre fichier contenait uniquement des données, vous pouvez créer de nouveaux rapports. Cliquez simplement avec le bouton droit sur le nouveau jeu de données, puis sélectionnez Explorer.If your file just had data, you can create new reports; just right-click the new dataset and then click Explore.

Actualisez les sources de données externes : si votre fichier Power BI Desktop se connecte à des sources de données externes, vous pouvez configurer l’actualisation planifiée pour être sûr que votre jeu de données est toujours à jour.Refresh external data sources - If your Power BI Desktop file connects to external data sources, you can setup scheduled refresh to make sure your dataset is always up-to-date. Dans la plupart des cas, la configuration de l’actualisation planifiée est relativement simple, mais nous n’en décrivons pas la procédure détaillée dans cet article.In most cases, setting up scheduled refresh is quite easy to do, but going into the details is outside the scope of this article. Pour en savoir plus, consultez Actualisation des données dans Power BI.See Data refresh in Power BI to learn more.