Utilisez Visual Studio pour créer des bases de données pour SQL Server sur LinuxUse Visual Studio to create databases for SQL Server on Linux

Cette rubrique s’applique à : OuiSQL Server (Linux uniquement)aucunbase de données SQL AzureaucunAzure SQL Data Warehouseaucun Parallel Data Warehouse THIS TOPIC APPLIES TO: yesSQL Server (Linux only)noAzure SQL DatabasenoAzure SQL Data WarehousenoParallel Data Warehouse

SQL Server Data Tools (SSDT) transforme Visual Studio en un puissant environnement de développement et de gestion du cycle de vie des bases de données (DLM) pour SQL Server sous Linux.SQL Server Data Tools (SSDT) turns Visual Studio into a powerful development and database lifecycle management (DLM) environment for SQL Server on Linux. Vous pouvez développer, construire, tester et publier votre base de données à partir d'un projet de contrôle de code source, tout comme vous développez votre code d'application.You can develop, build, test, and publish your database from a source-controlled project, just like you develop your application code.

Installer Visual Studio et SQL Server Data ToolsInstall Visual Studio and SQL Server Data Tools

  1. Si vous n'avez pas encore installé Visual Studio sur votre ordinateur Windows, téléchargez et installez Visual Studio.If you have not already installed Visual Studio on your Windows machine, Download and Install Visual Studio. Si vous n'avez pas de licence Visual Studio, Visual Studio Community Edition est un IDE gratuit et complet pour les étudiants, les développeurs open-source et les développeurs individuels.If you do not have a Visual Studio license, Visual Studio Community edition is a free, fully-featured IDE for students, open-source and individual developers.

  2. Pendant l’installation de Visual Studio, sélectionnez personnalisé pour choisir le type d’installation.During the Visual Studio installation, select Custom for the Choose the type of installation option. Cliquez sur Suivant.Click Next

  3. Sélectionnez Microsoft SQL Server Data Tools, Git pour Windows et GitHub Extension pour Visual Studio dans la liste de sélection des fonctionnalités.Select Microsoft SQL Server Data Tools, Git for Windows, and GitHub Extension for Visual Studio from the feature selection list.

    ssdt setup

  4. Cela peut prendre quelques minutes.Continue and finish the installation of Visual Studio. Cela peut prendre quelques minutes.It can take a few minutes.

Mise à niveau des outils SQL Server Data Tools vers la version SSDT 17.0 RCUpgrade SQL Server Data Tools to SSDT 17.0 RC release

SQL Server 2017 sur Linux est pris en charge par SSDT version 17.0 RC ou ultérieur.SQL Server 2017 on Linux is supported by SSDT version 17.0 RC or later.

Créer un nouveau projet de base de données dans le contrôle de code sourceCreate a new database project in source control

  1. Lancez Visual Studio.Launch Visual Studio.

  2. Sélectionnez Team Explorer dans le menu Affichage.Select Team Explorer on the View menu.

  3. Cliquez sur Nouveau dans la section Dépôt Git local sur la page Connexion.Click New in Local Git Repository section on the Connect page.

    local repository

  4. Cliquez sur Créer.Click Create. Une fois que le dépôt Git local est créé, double-cliquez sur SSDTRepo.After the local Git repository is created, double click SSDTRepo.

  5. Cliquez sur nouveau dans la section des Solutions.Click New in the Solutions section. Sélectionnez SQL Server sous la rubrique autres langages dans la boîte de dialogue nouveau projet.Select SQL Server under Other Languages node in the New Project dialog.

    local repository

  6. Entrez TutorialDB pour le nom et cliquez sur OK pour créer un nouveau projet de base de données.Type in TutorialDB for the name and click OK to create a new database project.

Créer une nouvelle table dans le projet de base de donnéesCreate a new table in the database project

  1. Sélectionnez l’Explorateur de solutions sur le menu Affichage.Select Solution Explorer on the View menu.

  2. Ouvrez le menu du projet de la base de données en cliquant avec le bouton droit de la souris sur TutorialDB dans l'explorateur de solutions.Open the database project menu by right-clicking on TutorialDB in Solution Explorer.

  3. Sélectionnez Table sous ajouter.Select Table under Add.

    create table

  4. En utilisant le concepteur de table, ajoutez deux colonnes, Name nvarchar(50) et Location nvarchar(50), comme illustré dans l'image.Using table designer, add two columns, Name nvarchar(50) and Location nvarchar(50), as shown in the picture. SSDT génère le script CREATE TABLE lorsque vous ajoutez les colonnes dans le designer.SSDT generates the CREATE TABLE script as you add the columns in the designer.

    add columns

  5. Enregistrez le fichier Table1.sql.Save the Table1.sql file.

Générer et valider la base de donnéesBuild and validate the database

  1. Ouvrez le menu du projet de la base de données sur TutorialDB et sélectionnez Build.Open the database project menu on TutorialDB and select Build. SSDT compile les fichiers de code source. sql dans votre projet et crée un fichier de type Data-tier Application Package (dacpac).SSDT compiles .sql source code files in your project and builds a Data-tier Application package (dacpac) file. Ceci peut être utilisé pour publier une base de données vers votre instance SQL Server 2017 sur Linux.This can be used to publish a database to your SQL Server 2017 instance on Linux.

    add columns

  2. Vérifiez le message de réussite de la génération dans la fenêtre Sortie de Visual Studio.Check the build success message in Output window in Visual Studio.

Publier la base de données vers l'instance SQL Server 2017 sur LinuxPublish the database to SQL Server 2017 instance on Linux

  1. Ouvrez le menu de projet de base de données sur TutorialDB et sélectionnez publier.Open the database project menu on TutorialDB and select Publish.

  2. Cliquez sur modifier pour sélectionner votre instance de SQL Server sur Linux.Click Edit to select your SQL Server instance on Linux.

    publish dialog

  3. Dans la boîte de dialogue de connexion, tapez le nom d’hôte ou adresse IP de votre instance de SQL Server sur Linux, le nom d’utilisateur et le mot de passe.On the connection dialog, type in the IP address or host name of your SQL Server instance on Linux, user name and password.

    connection dialog

  4. Cliquez sur le bouton publier, dans la boîte de dialogue Publier.Click the Publish button on the publish dialog.

  5. Vérifiez l’état de la publication dans la fenêtre opérations des outils de données.Check the publish status in the Data Tools Operations window.

  6. Cliquez sur Afficher le résultat ou sur Afficher le script pour voir les détails du résultat de la publication de la base de données sur votre serveur SQL Server sur Linux.Click View Reulst or View Script to see details of the database publish result on your SQL Server on Linux.

    publish result

Vous avez créé une base de données sur l'instance SQL Server sur Linux et vous avez appris les bases du développement d'une base de données avec un projet de base de données avec contrôle du code source.You have successfully created a new database on SQL Server instance on Linux and learned the basics of developing a database with a source-controlled database project.

Étapes suivantesNext steps

Si vous utilisez T-SQL, consultez didacticiel : écriture d’instructions Transact-SQL et de référence Transact-SQL (moteur de base de données).If you're new to T-SQL, see Tutorial: Writing Transact-SQL Statements and the Transact-SQL Reference (Database Engine).

Pour plus d’informations sur le développement d’une base de données avec les outils de données SQL, consultez documents de MSDN SSDTFor more information about developing a database with SQL Data Tools, see SSDT MSDN documents