Windows affiche une erreur dans un écran bleu lors du démarrage d’une machine virtuelle Azure

Cet article décrit les erreurs d'écran bleu que vous pouvez rencontrer quand vous démarrez une machine virtuelle Windows dans Microsoft Azure. Il fournit les étapes pour vous aider à collecter des données pour un ticket de support.

Symptômes

Une machine virtuelle Windows ne démarre pas. Quand vous vérifiez les captures d’écran de démarrage de la fenêtre Diagnostics de démarrage, l’un des messages d’erreur suivants apparaît dans un écran bleu :

Votre PC a rencontré un problème et doit redémarrer. Nous collectons simplement quelques informations sur l’erreur et vous pourrez ensuite redémarrer.

Votre PC a rencontré un problème et doit redémarrer.

Cause

Plusieurs raisons peuvent expliquer l’affichage d’une erreur d’arrêt. Les causes les plus courantes sont les suivantes :

  • Problème au niveau d’un pilote
  • Mémoire ou fichier système endommagé
  • Une application accède à un secteur interdit de la mémoire

Solution

Conseil

Si vous disposez d’une sauvegarde récente de la machine virtuelle, vous pouvez essayer de restaurer la machine virtuelle à partir de la sauvegarde pour résoudre le problème de démarrage.

Pour résoudre ce problème, vous devez d’abord collecter un fichier de vidage pour l’incident avant de contacter le support technique. Pour collecter le fichier d’image, effectuez les étapes suivantes :

Étape 1 : rechercher le fichier de vidage et envoyer un ticket de support

Partie 1 : connectez le disque du système d’exploitation à une machine virtuelle de récupération
  1. Prenez un instantané du disque du système d’exploitation de la machine virtuelle affectée en guise de sauvegarde. Pour plus d’informations, consultez l’article Créer un instantané d’un disque dur virtuel.

  2. Attachez le disque du système d’exploitation à une machine virtuelle de récupération.

  3. Utilisez le protocole RDP (Remote Desktop Protocol) pour vous connecter à la machine virtuelle.

  4. Si le disque du système d’exploitation est chiffré, vous devez désactiver le chiffrement avant de passer à l’étape suivante. Pour plus d’informations, consultez l’article Déchiffrer le disque de système d’exploitation chiffré.

Partie 2 : recherchez le fichier de vidage et envoyez un ticket de support
  1. Sur la machine virtuelle de récupération, accédez au dossier Windows dans le disque de système d’exploitation qui est y connecté. Par exemple, si la lettre de lecteur qui est affectée au disque du système d’exploitation attaché est F, accédez à F:\Windows.

  2. Recherchez le fichier memory.dmp, puis envoyez un ticket de support avec le fichier de vidage.

Si le fichier de vidage est introuvable, passez aux étapes suivantes pour activer le journal de vidage et la console série, puis reproduisez l’erreur.

Étape 2 : activer le journal de vidage et la console série

Importante

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour pallier à toute éventualité, sauvegardez le Registre avant de le modifier afin de pouvoir le restaurer en cas de problème. Pour plus d’informations sur la procédure de sauvegarde et de restauration du Registre, consultez l’article Comment sauvegarder et restaurer le Registre dans Windows.

Pour activer le journal de vidage et la console série, procédez comme suit :

  1. Ouvrez une invite de commandes avec élévation de privilèges exécutée avec les privilèges Administrateur.

  2. Exécutez les commandes BCDEdit suivantes à l’aide des options /ems et /emssettings :

                  Activez la console série :

    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON
    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Vérifiez que l’espace libre sur le disque du système d’exploitation est supérieur à la taille de la mémoire (RAM) sur la machine virtuelle.

    Si l’espace sur le disque de système d’exploitation est insuffisant, modifiez l’emplacement où le fichier de vidage de la mémoire sera créé et assignez cet emplacement à tout disque de données connecté à la machine virtuelle qui dispose de suffisamment d’espace libre. Pour modifier l’emplacement, remplacez %SystemRoot% par la lettre de lecteur du disque de données, telle que F:, dans les commandes suivantes.

    Pour activer le fichier de vidage du système d’exploitation, exécutez les commandes charger, ajouter et décharger suivantes pour implémenter la configuration suggérée à l’aide de l’outil reg :

                  Chargez la ruche du Registre à partir du disque de système d’exploitation endommagé :

    reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
    

    Activer sur ControlSet001 :

    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Activer sur ControlSet002 :

    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Décharger le disque du système d’exploitation endommagé :

    reg unload HKLM\<broken-system>
    

Étape 3 : reproduire le problème

  1. Détachez le disque du système d’exploitation et rattachez-le à la machine virtuelle affectée.

  2. Démarrez la machine virtuelle pour reproduire le problème, et un fichier de vidage est généré.

  3. Répétez les instructions de la section Étape 1 : localiser le fichier de vidage et envoyer un ticket de support.

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