L’affichage de compatibilité est utilisé pour les sites de confiance dans Internet Explorer

Avertissement

L’application de bureau Internet Explorer 11, mise hors service et dont le support a pris fin, a été désactivée définitivement via une mise à jour Microsoft Edge sur certaines versions de Windows 10. Pour plus d’informations, consultez le forum aux questions sur la mise hors service de l’application de bureau Internet Explorer 11.

Cet article présente la solution permettant de résoudre le problème lié à l’utilisation du mode Affichage de compatibilité au lieu du mode standard pour les sites de confiance dans Internet Explorer.

Version d’origine du produit : Internet Explorer
Numéro de la base de connaissances d’origine : 2701047

Symptômes

Dans Internet Explorer, vous avez configuré les options suivantes :

  • Définissez l’option Afficher les sites web intranet dans l’affichage de compatibilité sur Oui.
  • Définissez l’option Sites intranet : incluez tous les sites qui contournent le serveur proxy sur oui.

En outre, vous disposez d’un site web accessible par nom de domaine complet (FQDN) et configuré dans la zone Sites de confiance. Toutefois, le site est rendu en mode de compatibilité au lieu du mode Standard d’Internet Explorer attendu.

Cause

L’option Afficher les sites web intranet dans la vue de compatibilité utilise l’algorithme suivant pour déterminer si l’affichage de compatibilité doit être utilisé :

  1. Vérifiez si la page appartient à la zone de sécurité intranet locale.
  2. Vérifiez si la page appartient à la zone Intranet locale, lorsque vous ignorez les mappages de zones explicites.
  3. Vérifiez si la page n’utilise pas localhost, 127.0.0.1 ou ::1.

La deuxième case activée à l’exclusion des mappages de zone s’occupe ensuite de l’option Intranet Sites intranet : inclure tous les sites qui contournent le serveur proxy. Comme la page web est accessible directement en contournant le serveur proxy, l’affichage de compatibilité est utilisé pour ce site web.

Résolution

Choisissez l’une des options suivantes pour vous assurer que le site est ouvert en mode Internet Explorer Standard :

  1. Désactivez l’option Afficher les sites web intranet dans l’affichage de compatibilité .

  2. Désactiver les sites intranet : incluez tous les sites qui contournent l’option de serveur proxy et configurez manuellement tous les sites web qui contournent le serveur proxy pour qu’ils se trouvent manuellement dans la zone de sécurité Intranet local . Ensuite, placez les sites web qui doivent utiliser le mode Internet Explorer normes dans la zone Sites de confiance.

  3. Ajoutez le nom X-UA-Compatible d’en-tête HTTP avec la valeur IE=EDGE aux sites web qui doivent s’exécuter en mode standard.

Plus d’informations

Pour plus d’informations sur la définition de la compatibilité des documents, consultez Définition de la compatibilité des documents.