La console Configuration Manager affiche la date et l’heure de la dernière mise à jour du point de terminaison obsolète

Cet article fournit une solution au problème dans lequel la console Configuration Manager affiche la version de définition de protection du point de terminaison obsolète et la date de la dernière mise à jour pendant que les clients disposent de la dernière version de définition installée.

Version du produit d’origine :   Gestionnaire de configuration
Numéro de la base de connaissances initiale :   4528414

Symptômes

Lorsque vous utilisez la protection de point de terminaison conjointement avec le gestionnaire de configuration, vous rencontrez les problèmes suivants :

  • Dans la console Configuration Manager, ouvrez l’espace de travail composants et conformité   sous le nœud appareils . Dans cet espace de travail, vous remarquez que les colonnes heure de la dernière version et dernière mise à jour du point de terminaison de la protection du point de terminaison affichent des valeurs obsolètes pour certains appareils. Toutefois, les clients indiquent que les versions les plus récentes sont appliquées.
  • La rubrique type 1901 (State_Topictype_Ep_Am_Health) n’est pas connectée à StateMessage. log sur les clients.
  • Les messages d’erreur suivants sont enregistrés dans ExternalEventAgent. log sur les clients :

ANALYSER le code XML pour obtenir la chaîne de requête SELECT * FROM MSFT_MPComputerStatus
...
Exécutez toutes les actions d’initialisation pour la modification de stratégie à partir de CCM_ExternalEventConfig.
Impossible d’ouvrir la clé de Registre SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage\SyncStatus avec l’erreur 0x80070002.
Impossible d’ouvrir la clé de Registre SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage avec l’erreur 0x80070002.
Échec du chargement des valeurs précédentes des critères de différenciation ComputerStatusStateMessage avec l’erreur 0x80070002.
Impossible d’ouvrir la clé de Registre SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage\SyncStatus avec l’erreur 0x80070002.
Impossible d’ouvrir la clé de Registre SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage avec l’erreur 0x80070002.
Échec du chargement des valeurs précédentes des critères de différenciation InfectionStatusStateMessage avec l’erreur 0x80070002.

En outre, les clés de Registre suivantes n’existent pas sur le client :

  • HKLM\SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage
  • HKLM\SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage

Cause

Ce problème se produit car l’instance de la MSFT_MpComputerStatus classe n’existe pas dans l' root\Microsoft\ProtectionManagement espace de noms. Le client demande à cette instance de remplir les clés de Registre associées.

Résolution

Pour résoudre le problème, exécutez la commande suivante sur les ordinateurs clients affectés afin de ré-enregistrer le ProtectionManagement fournisseur :

Register-CimProvider -ProviderName ProtectionManagement -Namespace root\Microsoft\protectionmanagement -Path <path of ProtectionManagement.dll> -Impersonation True -HostingModel LocalServiceHost -SupportWQL -ForceUpdate

Notes

Dans cette commande, <path of ProtectionManagement.dll> est l’espace réservé pour le chemin d’accès de ProtectionManagement.dll. Par exemple :
Defender\Platform\4.18.1907.4-0\ProtectionManagement.dll C:\ProgramData\Microsoft\Windows

Après avoir exécuté cette commande, les conditions suivantes sont vraies :

  • L’instance de MSFT_MpComputerStatus est renseignée dans l' root\Microsoft\ProtectionManagement espace de noms.
  • Le type de rubrique 1901 est enregistré dans StateMessage. log.
  • Les valeurs affectées dans la console Configuration Manager sont mises à jour.

Informations supplémentaires

Les journaux Windows Defender peuvent vous aider à identifier la cause principale de ce problème. Par exemple, l’extrait de journal suivant indique la présence d’une solution antivirus différente :

2019-09-04T08:00:11.166 Z [mini-filter] accès refusé au fichier : \ProgramData\Microsoft\Windows Defender\Platform\4.18.1907.4-0\Powershell \ MSFT_MpComputerStatus. cdxml, du processus' \Device\HarddiskVolume2\Program Files (x86) \Symantec \ Symantec Endpoint Protection\14.0.3929.1200.105\Bin\ccSvcHst.exe ' (PID : 3408)

Pour collecter les journaux de diagnostic pour Windows Defender, suivez les étapes de la procédure de collecte des données de diagnostic de conformité des mises à jour pour Windows Defender AV Assessment.

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