Configuration Manager console affiche la version obsolète de la définition Endpoint Protection et l’heure de la dernière mise à jour

Cet article fournit une solution au problème lié au fait que Configuration Manager console affiche la version obsolète de la définition Endpoint Protection et l’heure de la dernière mise à jour alors que la dernière version de la définition est installée sur les clients.

Version d’origine du produit : Configuration Manager
Numéro de la base de connaissances d’origine : 4528414

Symptômes

Lorsque vous utilisez Endpoint Protection avec Configuration Manager, vous rencontrez les problèmes suivants :

  • Dans la console Configuration Manager, vous ouvrez l’espace de travail Ressources et conformité sous le nœud Appareils. Dans cet espace de travail, vous remarquez que les colonnes Dernière version de la définition d’Endpoint Protection et Heure de la dernière mise à jour d’Endpoint Protection affichent des valeurs obsolètes pour certains appareils. Toutefois, les clients indiquent que les dernières versions sont appliquées.
  • Le type de rubrique 1901 (State_Topictype_Ep_Am_Health) n’est pas connecté StateMessage.log sur les clients.
  • Les messages d’erreur suivants sont enregistrés ExternalEventAgent.log sur les clients :

PARSE XML pour obtenir la requête String SELECT * FROM MSFT_MPComputerStatus
...
Exécutez toutes les actions d’initialisation pour la modification de la stratégie à partir de CCM_ExternalEventConfig.
Impossible d’ouvrir la clé de Registre SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage\SyncStatus avec l’erreur 0x80070002.
Impossible d’ouvrir la clé de Registre SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage avec l’erreur 0x80070002.
Échec du chargement des valeurs précédentes des critères de différenciation ComputerStatusStateMessage avec l’erreur 0x80070002.
Impossible d’ouvrir la clé de Registre SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage\SyncStatus avec l’erreur 0x80070002.
Impossible d’ouvrir la clé de Registre SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage avec l’erreur 0x80070002.
Échec du chargement des valeurs précédentes des critères de différenciation InfectionStatusStateMessage avec l’erreur 0x80070002.

En outre, les clés de Registre suivantes n’existent pas sur le client :

  • HKLM\SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage
  • HKLM\SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage

Cause

Ce problème se produit car le instance de la MSFT_MpComputerStatus classe n’existe pas dans l’espace de root\Microsoft\ProtectionManagement noms . Le client interroge cette instance pour remplir les clés de Registre associées.

Résolution

Pour résoudre le problème, exécutez la commande suivante sur les ordinateurs clients affectés pour réinscrire le ProtectionManagement fournisseur :

Register-CimProvider -ProviderName ProtectionManagement -Namespace root\Microsoft\protectionmanagement -Path <path of ProtectionManagement.dll> -Impersonation True -HostingModel LocalServiceHost -SupportWQL -ForceUpdate

Remarque

Dans cette commande, <chemin d'ProtectionManagement.dll> est l’espace réservé pour le chemin d'ProtectionManagement.dll. Par exemple :
C :\ProgramData\Microsoft\Windows Defender\Platform\4.18.1907.4-0\ProtectionManagement.dll

Après avoir exécuté cette commande, les conditions suivantes sont remplies :

  • La instance de MSFT_MpComputerStatus est renseignée dans l’espace de root\Microsoft\ProtectionManagement noms .
  • Le type de rubrique 1901 est connecté StateMessage.log.
  • Les valeurs affectées dans la console Configuration Manager sont mises à jour.

Plus d’informations

Windows Defender journaux peuvent vous aider à identifier la cause racine de ce problème. Par exemple, l’extrait de journal suivant indique la présence d’une autre solution antivirus :

2019-09-04T08 :00 :11.166Z [Mini-filtre] Accès refusé au fichier : \ProgramData\Microsoft\Windows Defender\Platform\4.18.1907.4-0\Powershell\MSFT_MpComputerStatus.cdxml, from process '\Device\HarddiskVolume2\Program Files (x86)\Symantec\Symantec Endpoint Protection\14.0.3929.1200.105\Bin\ccSvcHst.exe' (PID : 3408)

Pour collecter les journaux de diagnostic pour Windows Defender, suivez les étapes décrites dans Collecter les données de diagnostic update Compliance pour Windows Defender AV Assessment.

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