Échec de Sysprep après la suppression ou la mise à jour des applications Microsoft Store qui incluent des images Windows intégrées

Cet article traite d’un problème qui se produit lorsque vous supprimez ou mettez à jour une application Microsoft Store configurée à l’aide de Microsoft Store, puis que vous exécutez Sysprep sur l’ordinateur.

Version du produit d’origine :   Windows 10-toutes les éditions
Numéro de la base de connaissances initiale :   2769827

Introduction

Sysprep est un outil destiné aux administrateurs informatiques qui souhaitent préparer une installation de Windows pour la duplication, l’audit et la remise des clients. Les instructions de cet article sont destinées à être utilisées par les agents de support et les professionnels de l’informatique. Si vous êtes un utilisateur à domicile qui rencontre des problèmes lors de l’utilisation d’applications Microsoft Store, consultez la rubrique corriger les problèmes liés aux applications de Microsoft Store dans Windows 10.

Plusieurs applications Microsoft Store incluent des images intégrées Windows 10 et Windows 8. Il s’agit notamment des applications mail, Maps, Messaging, Bing, Travel et News, entre autres. Celles-ci sont connues sous le nom d’applications configurées . Les applications configurées sont intermédiaires dans l’image et sont planifiées pour être installées pour chaque utilisateur de l’image Windows à la première ouverture de session. En plus des applications intégrées, vous pouvez charger en parallèle vos applications Microsoft Store professionnelles dans l’image Windows sans avoir à les publier dans le Microsoft Store. Vous pouvez charger côte à côte des packages AppX à l’aide de commandes de maintenance en ligne ou hors connexion qui sont disponibles dans DISM.exe ou via le module PowerShell DISM.

Symptômes

Plusieurs scénarios sont envisageables :

Scénario 1

  • Vous créez un ordinateur de référence Windows 10 personnalisé que vous souhaitez Sysprep et capturer.
  • Vous souhaitez supprimer certaines des applications du Microsoft Store mises en service (Appx Packages) de cet ordinateur de référence.
  • Vous exécutez dism -online /Remove-ProvisionedAppxPackage /PackageName:\<packagename> pour Désapprovisionner les packages Appx.

Lorsque vous exécutez l’opération Sysprep dans ce scénario, l’opération peut échouer avec l’erreur suivante :

Outil de préparation système 3,14
Une erreur irrécupérable s’est produite lors de la tentative de Sysprep de l’ordinateur

Scénario 2

  • Vous disposez d’une image Windows existante et plusieurs applications du Microsoft Store sont chargées côte à côte dans l’image.
  • Vous souhaitez supprimer quelques-uns des packages AppX chargés de votre image et les personnaliser.
  • Vous démarrez l’ordinateur de référence et vous exécutez l’une des commandes PowerShell suivantes pour supprimer la mise en service du package AppX :
    • Remove-AppxProvisionedPackage-PackageName <PackageName>
    • Remove-ProvisionedAppxPackage-PackageName <PackageName>

Lorsque vous exécutez l’opération Sysprep dans ce scénario, l’opération peut échouer avec l’erreur suivante :

 Outil de préparation système 3,14
Une erreur irrécupérable s’est produite lors de la tentative de Sysprep de l’ordinateur

Scénario 3

  • Vous créez une image de référence Windows 10.
  • Vous vous connectez au magasin Windows 10, puis vous mettez à jour les applications Microsoft Store intégrées à l’aide du Microsoft Store.

Lorsque vous exécutez l’opération Sysprep dans ce scénario, l’opération peut échouer avec l’erreur suivante :

 Outil de préparation système 3,14 une erreur irrécupérable s’est produite lors de la tentative de Sysprep de l’ordinateur

En outre, dans le fichier SetupErr. log, vous pouvez remarquer les entrées d’erreur suivantes :

<Date><Time>, Erreur le package SYSPRP <PackageFullName> a été installé pour un utilisateur, mais il n’a pas été configuré pour tous les utilisateurs. Ce package ne fonctionnera pas correctement dans l’image Sysprep.
<Date><Time>, Erreur SYSPRP échec de la suppression des applications pour l’utilisateur actuel : 0x80073cf2.
<Date><Time>, Erreur SYSPRP le code de sortie du thread RemoveAllApps était 0x3cf2.
<Date><Time>, Erreur [0x0f0082] SYSPRP ActionPlatform :: LaunchModule : une erreur s’est produite lors de l’exécution de « SysprepGeneralize » à partir de C:\Windows\System32\AppxSysprep.dll ; dwRet = 0x3cf2
<Date><Time>, Erreur SYSPRP ActionPlatform :: ExecuteAction : erreur lors de l’exécution de l’action ; dwRet = 0x3cf2
<Date><Time>, Erreur SYSPRP ActionPlatform :: ExecuteActionList : erreur lors de l’exécution des actions ; dwRet = 0x3cf2
<Date><Time>, Erreur SYSPRP SysprepSession :: Execute : erreur lors de l’exécution d’actions à partir de C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml ; dwRet = 0x3cf2
<Date><Time>, Erreur SYSPRP RunPlatformActions : échec lors de l’exécution des actions SysprepSession ; dwRet = 0x3cf2
<Date><Time>, Erreur [0x0f0070] SYSPRP RunExternalDlls : une erreur s’est produite lors de l’exécution des dll Sysprep de Registre, ce qui interrompt l’exécution de Sysprep. dwRet = 0x3cf2
<Date><Time>, Erreur [0x0f00a8] SYSPRP WinMain : échec de la tentative d’accès pendant le traitement des fournisseurs internes de Sysprep ; HR = 0x80073cf2

Cause

Sysprep dispose d’un fournisseur supplémentaire ajouté dans Windows 10 pour nettoyer les packages AppX et généraliser l’image. Le fournisseur ne fonctionne que s’il s’agit d’un package par utilisateur ou d’un package mis en service pour tous les utilisateurs.

  • Un package par utilisateur signifie que le package AppX est installé pour un compte d’utilisateur particulier et n’est pas disponible pour les autres utilisateurs de l’ordinateur.
  • All-User package signifie que AppX a été mis en service dans l’image afin que tous les utilisateurs qui l’utilisent puissent accéder à l’application.

Si un package pour tous les utilisateurs mis en service dans l’image a été manuellement annulé de l’image, mais n’a pas été supprimé pour un utilisateur particulier, le fournisseur rencontre une erreur lors du nettoyage de ce package pendant l’opération Sysprep. Le fournisseur échouera également si un package pour tous les utilisateurs configuré dans l’image a été mis à jour par l’un des utilisateurs sur cet ordinateur de référence.

Résolution

Pour résoudre ce problème, supprimez le package de l’utilisateur qui exécute Sysprep et supprimez également la mise en service. Pour cela, procédez comme suit.

Notes

Pour empêcher Microsoft Store de mettre à jour des applications, débranchez la connexion Internet ou désactivez les mises à jour automatiques en mode audit avant de créer l’image.

  1. Exécutez la cmdlet PowerShell d’import-module pour Appx.

  2. Exécutez dism import-module.

  3. Exécuter Get-AppxPackage -AllUser | Where PublisherId -eq 8wekyb3d8bbwe | Format-List -Property PackageFullName,PackageUserInformation .

    Notes

    • Dans la sortie de cette dernière cmdlet, vérifiez les utilisateurs pour lesquels le package apparaît comme installé. Supprimez ces comptes d’utilisateur de l’ordinateur de référence, ou ouvrez une session sur l’ordinateur à l’aide de ces comptes d’utilisateur. Ensuite, exécutez l’applet de commande à l’étape 4 pour supprimer le package Appx.
    • Cette commande répertorie tous les packages publiés par Microsoft et installés par les utilisateurs de cet ordinateur de référence. Étant donné que l’ordinateur doit être sysprepped, nous partons du principe que ces profils utilisateur n’ont plus besoin du package.
    • Si vous avez des applications configurées manuellement qui appartiennent à d’autres éditeurs, exécutez la commande suivante pour les répertorier :
      Get-AppxPackage-AllUser | Format-List-Property PackageFullName, PackageUserInformation
  4. Exécuter Remove-AppxPackage -Package \<packagefullname> .

  5. Supprimez la mise en service en exécutant l’applet de commande suivante :

    Remove-AppxProvisionedPackage-Online-PackageName <packagefullname>

Si vous essayez de récupérer à partir d’un problème de mise à jour, vous pouvez reconfigurer l’application après avoir suivi ces étapes.

Notes

Le problème ne se produit pas si vous traitez une image hors connexion. Dans ce scénario, la mise en service est automatiquement désactivée pour tous les utilisateurs. Cela inclut l’utilisateur qui exécute la commande.

Informations supplémentaires

Pour plus d’informations sur l’ajout et la suppression d’applications, voir :