Message d’erreur lorsque vous essayez d’installer une imprimante réseau partagée

Cet article décrit un problème dans lequel vous ne pouvez pas installer une imprimante réseau partagée localement sur un serveur ou un ordinateur Windows.

Produits concernés : Windows 10 - toutes les éditions, Windows Server 2012 R2
Numéro de l’article d’origine dans la base de connaissances : 888046

Symptômes

Si vous essayez d’installer une imprimante réseau partagée, des symptômes se présentent si les conditions suivantes sont remplies :

  • Vous avez une imprimante réseau partagée installée sur un serveur d’impression Microsoft Windows 2000 Advanced Server.

  • Vous essayez d’installer l’imprimante réseau partagée localement sur un ordinateur qui fait partie d’un domaine Windows.

  • Vous essayez d’installer l’imprimante réseau partagée localement sur un ordinateur qui exécute l’un des systèmes d’exploitation suivants :

    • Windows XP Service Pack 1 (SP1)
    • Windows Server 2003

Dans ce scénario, les symptômes suivants se présentent lorsque vous essayez d’installer une imprimante réseau partagée :

  • Si vous essayez d’installer l’imprimante sur un client Windows XP SP1 à l’aide de l’Assistant Ajouter une imprimante ou en utilisant le nom du partage d’imprimante à partir de l’emplacement \PrintServerName\PrinterShareName, vous recevez le message d’erreur suivant :

    Une stratégie est en vigueur sur votre ordinateur, ce qui vous empêche de vous connecter à cette file d’attente d’impression. Veuillez contacter votre administrateur système.

  • Si vous utilisez l’Assistant Ajouter une imprimante pour essayer d’installer l’imprimante sur un client Windows Server 2003, vous recevez le message d’erreur suivant lorsque vous cliquez sur Terminer pour terminer l’installation de l’imprimante :

    Impossible d’installer l’imprimante. Le pilote d’imprimante n’est pas compatible avec une stratégie activée sur votre ordinateur qui bloque Windows pilotes NT 4.0. Si vous souhaitez utiliser ce pilote, contactez votre administrateur système pour savoir si cette stratégie est désactivée.

Cause

Ce problème se produit si le pilote d’imprimante installé sur le serveur d’impression est un pilote d’imprimante tiers. Vous ne pouvez pas installer une imprimante réseau partagée qui dispose d’un pilote d’imprimante tiers localement sur un ordinateur Windows XP SP1 si vous êtes un utilisateur normal ou un membre du groupe Utilisateurs avec pouvoir. Windows XP SP1 n’autorise pas les utilisateurs réguliers ou les membres du groupe Utilisateurs avec pouvoir à installer des pilotes tiers. Dans Windows XP SP1, seules les personnes suivantes sont autorisées à installer un pilote tiers :

  • Administrateur local
  • Membres du groupe Administrateurs
  • Membres du groupe Utilisateurs avec pouvoir qui ont les autorisations de stratégie Charger et décharger les pilotes de périphérique

Si l’ordinateur Windows XP SP1 est joint à un domaine Microsoft Windows NT 4.0, les utilisateurs réguliers et les membres du groupe Utilisateurs avec pouvoir peuvent installer des pilotes d’imprimante tiers sur l’ordinateur client Windows XP SP1. Vous pouvez avoir des problèmes lors de l’installation d’un pilote d’imprimante tiers sur un ordinateur Windows XP SP1 si l’ordinateur Windows XP SP1 fait partie d’un groupe de travail ou d’un domaine Microsoft Windows 2000.

Dans Windows Server 2003, vous ne pouvez pas installer une imprimante réseau partagée localement si le pilote d’imprimante installé sur le serveur d’impression utilise des pilotes d’imprimante tiers en mode noyau. Un paramètre de stratégie dans Windows Server 2003 empêche les utilisateurs d’installer des imprimantes qui utilisent des pilotes d’impression tiers en mode noyau.

Ce problème se produit lorsque les conditions suivantes sont remplies :

  • La recherche dans la zone inversée du DNS n’est pas configurée.
  • Le DNS est configuré de manière incorrecte sur le serveur d’impression.
  • Problèmes DNS sur le serveur d’impression.

Résolution

Pour résoudre ce problème, modifiez les paramètres de stratégie de groupe pour l’objet de stratégie de groupe dont les stratégies d’imprimante sont définies pour les utilisateurs du domaine sur le contrôleur de domaine. Pour cela, appliquez l’une des méthodes suivantes :

Méthode 1

  1. Configurez le paramètre de stratégie Charger et décharger les pilotes de périphérique pour le groupe Utilisateurs avec pouvoir. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, pointez sur Programmes, puis sur Outils d’administration, et cliquez sur Utilisateurs et ordinateurs Active Directory.
    2. Dans le volet de navigation, cliquez avec le bouton droit sur votre domaine, puis cliquez sur Propriétés.
    3. Cliquez sur l’onglet Stratégie de groupe, cliquez sur l’objet de stratégie de groupe que vous souhaitez modifier, puis cliquez sur Modifier.
    4. Dans l’Éditeur d’objets de stratégie de groupe, recherchez et cliquez sur le dossier Configuration ordinateur\Paramètres Windows\Sécurité Paramètres\Stratégies locales\Attribution des droits utilisateur.
    5. Recherchez, puis double-cliquez sur Charger et décharger les pilotes de périphérique.
    6. Cliquez pour cocher la case Définir ces paramètres de stratégie, puis cliquez sur Ajouter un utilisateur ou un groupe pour ajouter le groupe de domaines Utilisateurs avec pouvoir.
    7. Dans la boîte de dialogue Ajouter un utilisateur ou un groupe, cliquez sur Parcourir pour localiser le groupe de domaines Utilisateurs avec pouvoir. Sous Entrez les noms des objets à sélectionner, tapez Utilisateurs avec pouvoir, puis cliquez sur Vérifier les noms pour résoudre le nom du groupe. Cliquez sur OK à trois reprises.
  2. Désactivez la stratégie Interdire l’installation d’imprimantes à l’aide de pilotes en mode noyau. Pour cela, procédez comme suit :
    1. Dans le volet gauche, recherchez et cliquez sur le dossier Configuration ordinateur\Modèles d’administration\Imprimantes.
    2. Recherchez, puis double-cliquez sur Interdire l’installation d’imprimantes à l’aide de pilotes en mode noyau, cliquez sur Désactivé, puis cliquez sur OK.
  3. Désactivez la stratégie de Restrictions Pointer et imprimer. Pour cela, procédez comme suit :
    1. Dans le volet gauche, recherchez et cliquez sur le dossier Configuration utilisateur\Modèles d’administration\Panneau de configuration\Imprimantes.
    2. Recherchez, puis double-cliquez sur Restrictions Pointer et imprimer, cliquez sur Désactivé, puis cliquez sur OK.
  4. Dans le menu Fichier, cliquez sur Quitter.
  5. Cliquez sur Démarrer>Exécuter, tapez cmd.exe, puis cliquez sur OK.
  6. À l’invite de commandes, tapez gpupdate /force, puis appuyez sur ENTRÉE.
  7. Répétez les étapes 5 à 6 sur les ordinateurs clients Windows XP SP1 et Windows Server 2003 du domaine.

Méthode 2

  1. Sur le serveur d’impression Windows Server 2003, cliquez sur Démarrer>Exécuter, tapez Cmd, puis cliquez sur OK.

  2. À l’invite de commandes, tapez C:\, puis appuyez sur ENTRÉE.

  3. Tapez Cd\, puis appuyez sur ENTRÉE.

  4. Tapez ipconfig /all, puis appuyez sur ENTRÉE.

  5. Prenez note de l’adresse IP de l’ordinateur du serveur d’impression.

    Remarque

    La sortie de cette commande Ipconfig /all peut se présenter comme suit :

    Configuration IP Windows
    Nom d’hôte. . . . . . . . . . . .  : MachineName
    Suffixe DNS principal. . . . . . . : DomainName.com
    Liste de recherche de suffixe DNS. . . . . . : DomainName.com
    Carte LAN Ethernet :
    Adresse IP. . . . . . . . . . . .  : 169.0.0.10
    Masque de sous-réseau. . . . . . . . . . .  : 255.255.252.0
    Serveur DNS. . . . . . . . . . .  : 169.0.0.1 169.0.0.2 169.0.0.3

  6. Sur l’ordinateur client Windows XP, cliquez sur Démarrer>Exécuter, tapez Cmd, puis cliquez sur OK.

  7. À l’invite de commandes, tapez C:\, puis appuyez sur ENTRÉE.

  8. Tapez Cd\, puis appuyez sur ENTRÉE.

  9. Tapez Nslookup PrintServer_IP, puis appuyez sur ENTRÉE.

    Remarque

    PrintServer_IP est l’adresse IP que vous avez notée à l’étape 5.

  10. Assurez-vous que la sortie de la commande NsLookup contient le nom de domaine complet (FQDN) correct du serveur d’impression. Si ce n’est pas le cas, vous devez contacter l’administrateur réseau pour résoudre le problème DNS.

Informations supplémentaires

Lorsque vous désactivez la stratégie de Restrictions Pointer et imprimer située sous Configuration utilisateur\Modèles d’administration\Panneau de configuration\Imprimantes, les utilisateurs peuvent utiliser la fonctionnalité Pointer et imprimer pour sélectionner n’importe quelle imprimante partagée à laquelle ils ont accès.

Comment utiliser le Registre pour définir la stratégie de Restrictions Pointer et imprimer

Importante

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
322756 Comment sauvegarder et restaurer le Registre dans Windows

La stratégie de Restrictions Pointer et imprimer peut également être définie sous la sous-clé de Registre suivante :

HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows NT\Printers\PointAndPrint
Valeur : InForest
Type : REG_DWORD
Données : 0 ou 1

Une valeur de 0 désactive cette entrée. Le paramètre 1 limite l’accès des imprimantes aux imprimantes de la forêt.

Valeur : Restreint
Type : REG_DWORD
Données : 0 ou 1

Une valeur de 0 désactive cette entrée. Le paramètre 1 restreint toutes les imprimantes.

Valeur : TrustedServers
Type : REG_DWORD
Données : 0 ou 1

Une valeur de 0 désactive cette entrée. Le paramètre 1 permet aux imprimantes d’apparaître dans la boîte de dialogue liste du serveur.

Pour plus d’informations sur les problèmes liés à l’installation des imprimantes, cliquez sur le numéro ci-dessous pour afficher l’article dans la Base de connaissances Microsoft :

282011 Le pilote d’imprimante n’est pas compatible si une stratégie est activée sur votre ordinateur

Support technique pour les versions x64 de Microsoft Windows

Si votre matériel a été fourni avec une édition x64 de Microsoft Windows déjà installée, votre fabricant de matériel fournit un support technique et de l’aide relative à l’édition x64 de Windows. car il a ajouté une édition x64 de Windows à votre matériel. Votre fabricant de matériel a pu personnaliser l’installation de Windows Édition x64 avec des composants uniques. Les composants uniques peuvent inclure des pilotes de périphériques spécifiques ou des paramètres facultatifs ayant pour but d’optimiser les performances du matériel. Microsoft pourra, dans une certaine limite, vous fournir une assistance technique sur l’édition x64 de Windows. Toutefois, vous devrez peut-être contacter directement le fabricant de votre matériel. Celui-ci est le plus qualifié pour assurer la prise en charge des logiciels qu’il a installés sur le matériel. Si vous avez acheté une édition x64 de Windows, telle qu’une édition x64 de Microsoft Windows Server 2003 séparément, contactez Microsoft pour obtenir un support technique.

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés à l’expérience utilisateur.