Message d’erreur lorsque vous essayez d’installer une imprimante réseau partagée

Cet article décrit un problème où vous ne pouvez pas installer une imprimante réseau partagée localement sur un ordinateur Windows Server ou Windows.

Version du produit d’origine :   Windows 10 : toutes les éditions, Windows Server 2012 R2
Numéro de la base de connaissances initiale :   888046

Symptômes

Si vous essayez d’installer une imprimante réseau partagée, vous rencontrez des problèmes si les conditions suivantes sont vraies :

  • Vous disposez d’une imprimante réseau partagée installée sur un serveur d’impression Microsoft Windows 2000 Advanced Server.

  • Vous essayez d’installer l’imprimante réseau partagée localement sur un ordinateur qui fait partie d’un domaine Windows.

  • Vous essayez d’installer l’imprimante réseau partagée localement sur un ordinateur qui exécute l’un des systèmes d’exploitation suivants :

    • Windows XP Service Pack 1 (SP1)
    • Windows Server 2003

Dans ce scénario, vous êtes confronté aux problèmes suivants si vous essayez d’installer une imprimante réseau partagée :

  • Si vous essayez d’installer l’imprimante sur un client Windows XP SP1 à l’aide de l’Assistant Ajout d’imprimante ou en utilisant le nom de partage d’imprimante à partir de l’emplacement * \ \PrintServerName\PrinterShareName* , vous recevez le message d’erreur suivant :

    Une stratégie est en vigueur sur votre ordinateur, ce qui vous empêche de vous connecter à cette file d’attente d’impression. Veuillez contacter votre administrateur système.

  • Si vous utilisez l’Assistant Ajout d’imprimante pour essayer d’installer l’imprimante sur un client Windows Server 2003, le message d’erreur suivant s’affiche lorsque vous cliquez sur Terminer pour terminer l’installation de l’imprimante :

    Impossible d’installer l’imprimante. Le pilote d’imprimante n’est pas compatible avec une stratégie activée sur votre ordinateur qui bloque les pilotes Windows NT 4,0. Si vous souhaitez utiliser ce pilote, contactez votre administrateur système à propos de la désactivation de cette stratégie.

Cause

Ce problème se produit si le pilote d’imprimante installé sur le serveur d’impression est un pilote d’imprimante tiers. Vous ne pouvez pas installer une imprimante réseau partagée qui a un pilote d’imprimante tiers localement sur un ordinateur Windows XP SP1 si vous êtes un utilisateur ordinaire ou un membre du groupe utilisateurs avec pouvoir. Windows XP SP1 n’autorise pas les utilisateurs réguliers ou les membres du groupe utilisateurs avec pouvoir à installer des pilotes tiers. Dans Windows XP SP1, seules les personnes suivantes sont autorisées à installer un pilote tiers :

  • Administrateur local
  • Membres du groupe administrateurs
  • Membres du groupe utilisateurs avec pouvoir qui disposent des autorisations de stratégie de chargement et de déchargement des pilotes de périphérique

Si l’ordinateur Windows XP SP1 est lié à un domaine Microsoft Windows NT 4,0, les utilisateurs et les membres réguliers du groupe utilisateurs avec pouvoir peuvent installer des pilotes d’imprimante tiers sur l’ordinateur client Windows XP SP1. Vous pouvez être confronté à des problèmes lors de l’installation d’un pilote d’imprimante tiers sur un ordinateur Windows XP SP1 si l’ordinateur Windows XP SP1 fait partie d’un groupe de travail ou d’un domaine Microsoft Windows 2000.

Dans Windows Server 2003, vous ne pouvez pas installer une imprimante réseau partagée localement si le pilote d’imprimante installé sur le serveur d’impression utilise des pilotes d’imprimante en mode noyau tiers. Un paramètre de stratégie dans Windows Server 2003 empêche les utilisateurs d’installer des imprimantes qui utilisent des pilotes d’impression en mode noyau tiers.

Ce problème peut également se produire si les conditions suivantes sont remplies :

  • La recherche DNS inversée de zone n’est pas configurée.
  • DNS n’est pas configuré correctement sur le serveur d’impression.
  • Problèmes DNS sur le serveur d’impression.

Résolution

Pour résoudre ce problème, modifiez les paramètres de stratégie de groupe pour l’objet de stratégie de groupe (GPO) dont les stratégies d’imprimante sont définies pour les utilisateurs de domaine sur le contrôleur de domaine. Pour ce faire, utilisez l’une des méthodes suivantes.

Méthode 1

  1. Configurez le paramètre de stratégie de chargement et de déchargement des pilotes de périphériques pour le groupe utilisateurs avec pouvoir. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, pointez sur programmes, sur Outils d’administration, puis cliquez sur utilisateurs et ordinateurs Active Directory.
    2. Dans le volet de navigation, cliquez avec le bouton droit sur le nom de votre domaine, puis cliquez sur Propriétés.
    3. Cliquez sur l’onglet stratégie de groupe , cliquez sur l’objet de stratégie de groupe que vous souhaitez modifier, puis cliquez sur modifier.
    4. Dans l’éditeur d’objets de stratégie de groupe, recherchez et cliquez sur le dossier ordinateur \ paramètres de configuration \ stratégies Locales\attribution des droits.
    5. Recherchez et double-cliquez sur charger et décharger les pilotes de périphériques.
    6. Activez la case à cocher définir ces paramètres de stratégie , puis cliquez sur Ajouter un utilisateur ou un groupe pour ajouter le groupe de domaines utilisateurs avec pouvoir .
    7. Dans la boîte de dialogue Ajouter un utilisateur ou un groupe , cliquez sur Parcourir pour localiser le groupe de domaines utilisateurs avec pouvoir . Sous Entrez les noms d’objets à sélectionner, tapez utilisateurs avec pouvoir, puis cliquez sur vérifier les noms pour résoudre le nom du groupe. Cliquez sur OK à trois reprises.
  2. Désactivez la stratégie interdire l’installation d’imprimantes à l’aide de pilotes en mode noyau. Pour cela, procédez comme suit :
    1. Dans le volet gauche, recherchez et cliquez sur le dossier Configuration de l' ordinateur \ Templates\Printers .
    2. Recherchez et double-cliquez sur interdire l’installation des imprimantes utilisant des pilotes en mode noyau, cliquez sur désactivé, puis cliquez sur OK.
  3. Désactivez la stratégie restrictions pointer et imprimer. Pour cela, procédez comme suit :
    1. Dans le volet de gauche, recherchez et cliquez sur le dossier Configuration de l' utilisateur \ modèles d’Panel\Printers .
    2. Recherchez et double-cliquez sur restrictions pointage et impression, cliquez sur désactivé, puis cliquez sur OK.
  4. Dans le menu fichier , cliquez sur quitter.
  5. Cliquez sur Démarrerl' > exécution, tapez cmd.exe, puis cliquez sur OK.
  6. À l’invite de commandes, tapez gpupdate/force, puis appuyez sur entrée.
  7. Répétez les étapes 5 à 6 sur les ordinateurs clients Windows XP SP1 et Windows Server 2003 du domaine.

Méthode 2

  1. Sur le serveur d’impression Windows Server 2003, cliquez sur Démarrerl' > exécution, tapez cmd, puis cliquez sur OK.

  2. À l’invite de commandes, tapez C \ :, puis appuyez sur entrée.

  3. Tapez *CD \ *, puis appuyez sur entrée.

  4. Tapez ipconfig/all, puis appuyez sur entrée.

  5. Notez l’adresse IP de l’ordinateur serveur d’impression.

    Notes

    La sortie de la Ipconfig /all commande peut ressembler à ce qui suit :

    Configuration IP Windows
    Nom de l’hôte. . . . . . . . . . . . : MachineName
    Suffixe DNS principal. . . . . . . : DomainName.com
    Liste de recherche de suffixe DNS. . . . . . : DomainName.com
    Carte Ethernet LAN :
    Adresse IP. . . . . . . . . . . . : 169.0.0.10
    Masque de sous-réseau. . . . . . . . . . . : 255.255.252.0
    Serveurs DNS. . . . . . . . . . . : 169.0.0.1 169.0.0.2 169.0.0.3

  6. Sur l’ordinateur client Windows XP, cliquez sur Démarrer l' > exécution, tapez cmd, puis cliquez sur OK.

  7. À l’invite de commandes, tapez C \ :, puis appuyez sur entrée.

  8. Tapez *CD \ *, puis appuyez sur entrée.

  9. Tapez * nslookup PrintServer_IP_, puis appuyez sur entrée.

    Notes

    _PrintServer_IP* est l’adresse IP que vous avez notée à l’étape 5.

  10. Assurez-vous que la sortie de la commande NsLookup contient le nom de domaine complet (FQDN) correct du serveur d’impression. Si ce n’est pas le cas, vous devez contacter l’administrateur réseau pour résoudre le problème DNS.

Informations supplémentaires

Lorsque vous désactivez la stratégie restrictions pointer et imprimer située sous User Configuration\Administrative Administration\panneau Panel\Printers, les utilisateurs peuvent utiliser la fonctionnalité pointage et imprimer pour sélectionner une imprimante partagée à laquelle ils ont accès. Pour plus d’informations sur cette stratégie, consultez l’article suivant de la base de connaissances Microsoft : 319939 Description du paramètre de stratégie restrictions pointer et imprimer dans windows Server 2003 et Windows XP

Utilisation du Registre pour définir la stratégie de restrictions pointer et imprimer

Important

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la sauvegarde et la restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la base de connaissances Microsoft :
322756 Comment sauvegarder et restaurer le Registre dans Windows

La stratégie de restriction point et Print peut également être définie sous la sous-clé de Registre suivante :

HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows NT\Printers\PointAndPrint
Valeur : inforest
Type : REG_DWORD
Données : 0 ou 1

Un paramètre de 0 désactive cette entrée. Un paramètre de 1 limite l’accès de l’imprimante aux imprimantes de la forêt.

Valeur : restreint
Type : REG_DWORD
Données : 0 ou 1

Un paramètre de 0 désactive cette entrée. La valeur 1 limite toutes les imprimantes.

Valeur : TrustedServers
Type : REG_DWORD
Données : 0 ou 1

Un paramètre de 0 désactive cette entrée. La valeur 1 permet aux imprimantes d’apparaître dans la boîte de dialogue Liste des serveurs.

Pour plus d’informations sur les problèmes liés à l’installation de l’imprimante dans Windows XP et Windows Server 2003, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la base de connaissances Microsoft :

326473 vous êtes invité à fournir des informations d’identification d’administrateur lorsque vous essayez d’installer une imprimante Plug-and-Play

le pilote d’imprimante 282011 n’est pas compatible si une stratégie est activée sur votre ordinateur

319939 Description du paramètre de stratégie restrictions pointer et imprimer dans windows Server 2003 et Windows XP

Support technique pour les versions x64 de Microsoft Windows

Si votre matériel provenait d’une édition x64 de Microsoft déjà installée, votre fabricant de matériel fournit un support technique et une assistance pour Windows x64 Edition. Dans ce cas, votre fabricant de matériel prend en charge, car une édition x64 de Windows a été incluse avec votre matériel. Votre fabricant de matériel peut avoir personnalisé l’installation de Windows x64 Edition à l’aide de composants uniques. Les composants uniques peuvent inclure des pilotes de périphérique spécifiques ou peuvent inclure des paramètres facultatifs pour maximiser les performances du matériel. Microsoft vous fournira une assistance raisonnable si vous avez besoin d’aide technique avec une édition x64 de Windows. Toutefois, vous devrez peut-être contacter directement votre fabricant. Votre fabricant est le mieux qualifié pour prendre en charge le logiciel que votre fabricant a installé sur le matériel. Si vous avez acheté séparément une édition x64 de Windows telle que Microsoft Windows Server 2003 x64 Edition, contactez Microsoft pour obtenir une assistance technique.