Importer un projet XcodeImport an XCode Project

Microsoft Visual C++ pour le développement mobile multiplateforme prend en charge le déplacement de vos projets Xcode dans Visual Studio, où vous pouvez créer des bibliothèques multiplateformes et partager du code avec d’autres projets.Microsoft Visual C++ for Cross-Platform Mobile Development includes support for moving your XCode projects into Visual Studio, where you can create cross-platform libraries and share code with other projects. L’Assistant Importation à partir de Xcode simplifie le processus d’importation de projets et de fractionnement du code C++ de vos cibles Xcode à utiliser en tant que bibliothèque statique ou projet de code partagé.The Import from XCode wizard simplifies the process of importing projects and splitting out the C++ code in your XCode targets for use as a static library or shared code project. Vous pouvez gérer votre code spécifique à iOS dans Visual Studio et continuer à utiliser Xcode pour effectuer des storyboards et des builds.You can manage your iOS-specific code in Visual Studio and still use XCode to do storyboards and builds. Pour plus d’informations sur la façon de déplacer facilement du code entre Visual Studio et Xcode, consultez les détails relatifs au transfert de changements entre Xcode et Visual Studio.For information on how to easily move code back and forth between Visual Studio and XCode, see Move Changes Between XCode and Visual Studio.

Utiliser l’Assistant Importation à partir de XcodeUse the Import From XCode wizard

Cette rubrique montre comment déplacer un projet Xcode dans Visual Studio pour tirer parti du partage de code et des solutions multiplateformes.This topic shows you how to move an XCode project into Visual Studio to take advantage of code sharing and cross-platform solutions. Au préalable, vous devez jumeler votre Mac à Visual Studio pour pouvoir importer, exporter et générer votre projet.As a prerequisite, you must pair your Mac to Visual Studio to be able to import, export, and build your project. Pour obtenir des instructions sur la configuration du jumelage, consultez Installer et configurer des outils de génération en utilisant iOS.For instructions on how to set up pairing, see Install and configure tools to build using iOS. Vous devez également partager votre projet Xcode sur le réseau ou le déplacer vers votre ordinateur Visual Studio pour utiliser l’Assistant Importation à partir de Xcode.You must also share your XCode project over the network or move it to your Visual Studio computer to use the Import from XCode wizard.

Importer à partir de XcodeImport from XCode

  1. Dans le menu Fichier, choisissez Nouveau, Importer, Importer à partir de Xcode.On the File menu, choose New, Import, Import from XCode. Cela permet d’afficher la boîte de dialogue d’Assistant intitulée Importer à partir de Xcode.This starts the Import from XCode wizard dialog.

    Choisir le projet cible Xcode à importerChoose the XCode target project to import

  2. Dans le volet Choisir un projet, choisissez le bouton Parcourir pour sélectionner un fichier .pbxproj Xcode.In the Choose a project pane, choose the Browse button to select an XCode .pbxproj file. Accédez au fichier projet via la boîte de dialogue Sélectionner un fichier projet Xcode, puis choisissez Ouvrir.Navigate to the project file in the Select XCode project file dialog, and then choose Open.

    Sélectionner un fichier projet dans la boîte de dialogue Sélectionner un fichier projet XcodeSelect a project file in the Select Xcode project file dialog

    Dans l’Assistant Importation à partir de Xcode, choisissez Suivant.In the Import from XCode wizard, choose Next.

  3. Dans le volet Cibles de destination, choisissez les cibles du projet Xcode à importer dans les projets Visual Studio.In the Destination targets pane, choose the targets from the XCode project to import into Visual Studio projects. Les cibles Xcode sont semblables aux projets Visual Studio. Il s’agit pour la plupart d’un ensemble de codes et de ressources qui permettent de produire un fichier binaire.XCode targets are similar to Visual Studio projects; most are a collection of code and resources that produce a binary. L’Assistant Importation à partir de Xcode autorise uniquement l’importation des cibles qui produisent un fichier binaire, mais pas une bibliothèque statique, en tant que cibles de destination.The Import from XCode wizard only allows import of targets that produce a binary, but not a static library, as destination targets. Les cibles de bibliothèque statique Xcode sont traitées à l’étape suivante.XCode static library targets are the subject of the next step.

    Volet Cibles de destination de l’Assistant Importation à partir de XcodeImport from XCode wizard Destination Targets pane

    Pour chaque cible sélectionnée dans Cibles à importer, l’Assistant détecte automatiquement les fichiers de code C++ qui peuvent être fractionnés en projet de bibliothèque statique distinct, puis les place dans la section Éléments de projet C++.For each target selected in Targets to import, the wizard automatically detects C++ code files that can be split into a separate static library project, and puts them in the C++ project items section. Le reste du code et des ressources est laissé dans la section Éléments de projet Xcode.Other code and resources are left in the XCode project items section. Une fois que l’Assistant a effectué le processus d’importation, ils deviennent des projets de bibliothèque statique et d’application distincts dans Visual Studio.These become separate static library and application projects in Visual Studio when the wizard completes the import process. Par défaut, les cibles de test unitaire et de framework ne sont pas fractionnées en projets distincts par l’Assistant.By default, unit test and framework targets are not split into separate projects by the wizard.

    Pour changer les fichiers contenus dans chaque projet, utilisez les boutons de déplacement vers le haut et le bas.To change which files are in each project, use the up and down buttons. Une fois que la liste des fichiers de chaque projet vous convient, choisissez Suivant pour continuer.When you are satisfied with the files in each project, choose Next to continue.

  4. Dans le volet Cibles de bibliothèques, choisissez les cibles de bibliothèque statique du projet Xcode à importer dans les projets Visual Studio.In the Library targets pane, choose which static library targets from the XCode project to import into Visual Studio projects. Dans ce volet, vous pouvez choisir les fichiers à placer dans un projet de code partagé, et ceux à placer dans un projet de bibliothèque statique.In this pane, you can choose which files are placed in a Shared Code project, and which are placed in a static library project. Dans chacune des cibles de la liste Cibles à importer, vous pouvez contrôler les fichiers à placer dans les Éléments de projet de code partagé et les Éléments de projet de bibliothèque statique à l’aide des boutons de déplacement vers le haut et le bas.In each of targets in the Targets to import list, you can control which files are placed in the Shared Code project items and the Static Library project items by using the up and down buttons.

    Volet Cibles de bibliothèques de l’importation à partir de XcodeImport from XCode Library Targets pane

    Un projet de code partagé est un moyen de partager un ensemble de fichiers de code source entre plusieurs projets dans Visual Studio.A Shared Code project is a way of sharing a set of source code files between projects in Visual Studio. Le code est généré dans le cadre du projet où il se trouve, et non en tant que projet à part entière.The code is built as part of the project that includes it, not as a project of its own. Comme les projets qui incluent du code partagé peuvent avoir différentes architectures et configurations, ceci est le meilleur moyen de fournir un projet unique qui contient le code à générer pour de nombreux genres de plateforme.Because the projects that include the shared code may have different architectures and configurations, this is the best way to provide a single project that contains code that may be built for many kinds of platforms.

    Une fois que la liste des fichiers de chaque projet vous convient, choisissez Suivant pour continuer.When you are satisfied with the files in each project, choose Next to continue.

  5. Vous pouvez utiliser le volet Propriétés globales pour définir un chemin de recherche de frameworks et un chemin de recherche de fichiers d’en-tête Include pour tous les projets iOS dans Visual Studio.The Global Properties pane can be used to set a framework search path and an include header search path for all iOS projects in Visual Studio. Visual Studio utilise ces chemins pour la recherche du code source et pour IntelliSense.Visual Studio uses these paths for source code browsing and for IntelliSense. Ces chemins globaux sont utiles quand vous créez des projets iOS qui utilisent un ensemble commun d’en-têtes et de frameworks.These global paths are useful when you create iOS projects that use a common set of headers and frameworks.

    Volet Propriétés globales de l’importation à partir de XcodeImport from XCode Global Properties pane

    Vous pouvez également définir ces chemins globaux dans Visual Studio, dans la boîte de dialogue Options.These global paths can also be set in Visual Studio in the Options dialog. Pour les trouver, dans le menu Outils, sélectionnez Options.To find them, on the Tools menu, select Options. Dans la boîte de dialogue Options, développez Multiplateforme, C++, iOS, Propriétés globales.In the Options dialog, expand Cross Platform, C++, iOS, Global Properties.

    Choisissez Suivant pour continuer.Choose Next to continue.

  6. Le volet Frameworks permet de configurer les chemins utilisés par Visual Studio pour parcourir les éléments de votre projet, ainsi que pour IntelliSense.The Frameworks pane is used to configure the paths used by Visual Studio for browsing and IntelliSense for your project. Les chemins doivent être accessibles à Visual Studio pour chaque framework référencé par votre projet Xcode.The paths must be accessible to Visual Studio for each framework referenced by your XCode project. L’Assistant vérifie les références de framework dans les projets Xcode et indique si Visual Studio peut trouver le framework.The wizard checks the framework references in the XCode projects and displays whether Visual Studio can find the framework. Si vous avez déjà configuré un chemin dans les propriétés globales, il doit être découvert par Visual Studio.Any path you have already set up in the Global Properties should be discovered by Visual Studio. Les exceptions sont répertoriées dans la liste Frameworks.The exceptions are listed in the Frameworks list. Pour chaque framework listé avec un X, indiquez un chemin accessible au PC afin de permettre à Visual Studio de trouver le framework.For each framework listed with an X, provide a PC accessible path for Visual Studio to find the framework. Vous pouvez utiliser le bouton Parcourir ... pour afficher une boîte de dialogue Sélectionner un dossier et trouver le chemin.You can use the browse button ... to use a Select Folder dialog to find the path. Le chemin du framework peut être celui d’une copie locale ou d’un partage réseau sur votre Mac.The framework path can be either to a local copy, or to a network-accessible share on your Mac.

    Volet Frameworks de l’importation à partir de XcodeImport from XCode Frameworks pane

    Choisissez Suivant pour continuer.Choose Next to continue.

  7. Le volet Paramètres du projet vous permet de changer le framework et d’inclure les paramètres du chemin de recherche de fichiers d’en-tête Include pour chaque projet créé par l’Assistant.The Project Settings pane allows you to change the framework and include header search path settings for each project the wizard creates. Utilisez ce volet pour définir les chemins spécifiques au projet qui diffèrent des paramètres globaux.Use this pane to set project-specific paths that differ from the global settings.

    Pour définir un chemin spécifique à un projet, dans la liste déroulante Projet de destination, sélectionnez le fichier projet, puis définissez les valeurs des contrôles Chemin de recherche de frameworks et Chemin de recherche de fichiers d’en-tête Include.To set a path for a specific project, In the Destination project drop-down, select the project file, then set the values in the Framework Search Path and Include Header Search Path controls. Vous pouvez utiliser le bouton Parcourir ... près de chaque contrôle pour afficher une boîte de dialogue Sélectionner un dossier et trouver le chemin.You can use the browse button ... next to each control to use a Select Folder dialog to find the path.

    Volet Projets de l’importation à partir de XcodeImport from XCode Projects pane

    Si aucun Mac distant n’a été jumelé à ce PC dans Visual Studio, le lien Configurer une machine distante s’affiche.If no remote Mac has been paired with this PC in Visual Studio, the Configure a Remote Machine link is shown. Pour obtenir des instructions sur la configuration du jumelage, consultez Installer et configurer des outils de génération en utilisant iOS.For instructions on how to set up pairing, see Install and configure tools to build using iOS.

    Pour importer le projet Xcode à l’aide des paramètres de l’Assistant, choisissez Importer.To import the XCode project by using the wizard settings, choose Import.

    L’Assistant Importation à partir de Xcode crée des projets dans Visual Studio qui correspondent aux cibles de projets Xcode sélectionnées.The Import from XCode wizard creates projects in Visual Studio that correspond to the selected XCode project targets. Le code partageable avec d’autres projets C++ est fractionné en projets de code partagé et de bibliothèque statique distincts.The code that can be shared with other C++ projects is split into separate Shared Code and static library projects. Le code restant est placé dans les projets de bibliothèque iOS et d’application qui peuvent être générés à distance par Visual Studio.The remaining code is placed in iOS library and application projects that can be built remotely by Visual Studio. Pour plus d’informations sur le déplacement du code entre Visual Studio et Xcode, consultez Synchroniser les changements entre Xcode et Visual Studio.For more information about moving code between Visual Studio and XCode, see Sync changes between XCode and Visual Studio.