Développer du code dans Visual Studio sans projets ni solutionsDevelop code in Visual Studio without projects or solutions

Visual Studio 2017 permet d’ouvrir du code à partir de presque n’importe quel type de projet basé sur un répertoire dans Visual Studio sans avoir recours à un fichier solution ou de projet.In Visual Studio 2017, you can open code from nearly any type of directory-based project into Visual Studio without the need for a solution or project file. Cela signifie que vous pouvez, par exemple, cloner un référentiel sur GitHub, l’ouvrir directement dans Visual Studio et commencer à développer sans avoir à créer de solution ou de projet.This means you can, for example, clone a repo on GitHub, open it directly into Visual Studio, and begin developing, without having to create a solution or project. Si nécessaire, vous pouvez spécifier des tâches de génération et des paramètres de lancement personnalisés à l’aide de simples fichiers JSON.If needed, you can specify custom build tasks and launch parameters through simple JSON files.

Une fois que vous avez ouvert vos fichiers de code dans Visual Studio, l’Explorateur de solutions les affiche dans le dossier.After you open your code files in Visual Studio, Solution Explorer displays all the files in the folder. Vous pouvez cliquer sur n’importe quel fichier pour le modifier.You can click on any file to begin editing it. En arrière-plan, Visual Studio démarre l’indexation des fichiers pour activer les fonctionnalités IntelliSense, de navigation et de refactorisation.In the background, Visual Studio starts indexing the files to enable IntelliSense, navigation, and refactoring features. Au fil des modifications, créations, déplacements et suppressions de fichiers, Visual Studio effectue automatiquement le suivi des modifications et met à jour en permanence son index IntelliSense.As you edit, create, move, or delete files, Visual Studio tracks the changes automatically and continuously updates its IntelliSense index. Le code apparaît avec coloration syntaxique ; dans de nombreux cas, il comprend la saisie semi-automatique des instructions IntelliSense de base.Code will appear with syntax colorization and, in many cases, include basic IntelliSense statement completion.

Ouvrir du codeOpen any code

Vous pouvez ouvrir du code dans Visual Studio de différentes façons :You can open code into Visual Studio in any of the following ways:

  • Dans la barre de menus de Visual Studio, choisissez Fichier > Ouvrir > Dossier, puis accédez à l’emplacement du code.On the Visual Studio menu bar, choose File > Open > Folder, and then browse to the code location.
  • Dans le menu contextuel (clic droit) d’un dossier contenant le code, choisissez la commande Ouvrir dans Visual Studio.On the context (right-click) menu of a folder containing code, choose the Open in Visual Studio command.
  • Choisissez le lien Ouvrir le dossier lien sur la page de démarrage de Visual Studio.Choose the Open Folder link on the Visual Studio Start Page.
  • Si vous préférez utiliser le clavier, appuyez sur Ctrl+Maj+Alt+O dans Visual Studio.If you are a keyboard user, press Ctrl+Shift+Alt+O in Visual Studio.
  • Ouvrez le code d’un référentiel GitHub cloné.Open code from a cloned GitHub repo.

Pour ouvrir du code à partir d’un référentiel GitHub clonéTo open code from a cloned GitHub repo

L’exemple suivant montre comment cloner un référentiel GitHub, puis ouvrir son code dans Visual Studio.The following example shows how to clone a GitHub repo and then open its code in Visual Studio. Pour suivre cette procédure, vous devez disposer d’un compte GitHub et installer Git pour Windows sur votre système.To follow this procedure, you must have a GitHub account and Git for Windows installed on your system. Consultez la page Signing up for a new GitHub account (Inscription à un nouveau compte GitHub) et Git for Windows (Git pour Windows) pour plus d’informations.See Signing up for a new GitHub account and Git for Windows for more information.

  1. Accédez au dépôt que vous souhaitez cloner sur GitHub.Go to the repo you want to clone on GitHub.

  2. Cliquez sur le bouton Cloner ou télécharger, puis choisissez le bouton Copier dans le Presse-papiers du menu déroulant pour copier l’URL sécurisée pour le dépôt GitHub.Choose the Clone or Download button and then choose the Copy to Clipboard button in the dropdown menu to copy the secure URL for the GitHub repo.

    Bouton de clonage GitHub

  3. Dans Visual Studio, cliquez sur l’onglet Team Explorer onglet pour ouvrir Team Explorer.In Visual Studio, choose the Team Explorer tab to open Team Explorer. Si l’onglet n’apparaît pas, ouvrez-le dans Affichage > Team Explorer.If you don't see the tab, open it from View > Team Explorer.

  4. Dans Team Explorer, sous la section relative aux référentiels Git locaux , choisissez la commande Cloner, puis collez l’URL de la page GitHub dans la zone de texte.In Team Explorer, under the Local Git Repositories section, choose the Clone command and then paste the URL of the GitHub page into the text box.

    Cloner le projet

  5. Cliquez sur le bouton Cloner pour cloner les fichiers du projet dans un référentiel Git local.Choose the Clone button to clone the project's files to a local Git repository. Ceci peut prendre plusieurs minutes, selon la taille du référentiel.Depending on the size of the repo, this process could take several minutes.

  6. Une fois le dépôt cloné sur votre système, dans Team Explorer, choisissez la commande Ouvrir dans le menu contextuel (clic droit) du dépôt qui vient d’être cloné.After the repo has been cloned to your system, in Team Explorer, choose the Open command on the context (right-click) menu of the newly cloned repo.

    Dépôt cloné

  7. Choisissez la commande Présenter l’affichage des dossiers pour afficher les fichiers dans l’Explorateur de solutionsChoose the Show Folder View command to view the files in Solution Explorer

    Présenter l’affichage des dossiers

    Vous pouvez parcourir les dossiers et fichiers dans le dépôt cloné, et afficher et rechercher le code dans l’éditeur de code Visual Studio, avec la colorisation de la syntaxe et d’autres fonctionnalités.You can now browse folders and files in the cloned repo, and view and search the code in the Visual Studio code editor, complete with syntax colorization and other features.

Icône représentant une caméra pour les vidéosmovie camera icon for video Regarder une vidéo montrant comment cloner et ouvrir du code à partir d’un dépôt GitHub dans Visual Studio.Watch a video on how to clone and open code from a GitHub repo in Visual Studio.

Exécuter et déboguer son codeRun and debug your code

Vous pouvez déboguer votre code dans Visual Studio sans projet ni solution !You can debug your code in Visual Studio without a project or solution! Dans certains langages, vous devrez peut-être spécifier un fichier de démarrage valide dans le codebase, par exemple, un script, un exécutable ou un projet.To debug some languages, you may need to specify a valid startup file in the codebase, such as a script, executable, or project. La zone de liste déroulante à côté du bouton Démarrer de la barre d’outils répertorie tous les éléments de démarrage détectés par Visual Studio, ainsi que les éléments spécifiquement désignés par vos soins.The drop-down list box next to the Start button on the toolbar lists all of the startup items that Visual Studio detects, as well as items you specifically designate. Visual Studio exécute tout d’abord ce code lors du débogage.Visual Studio runs this code first when you debug your code.

La façon de configurer le code pour qu’il s’exécute dans Visual Studio diffère selon le type de code et les outils de génération.Configuring your code to run in Visual Studio differs depending on what kind of code it is, and what the build tools are.

Codebases qui utilisent MSBuildCodebases that use MSBuild

Les codebases MSBuild peuvent avoir plusieurs configurations de build qui s’affichent dans la liste déroulante du bouton Démarrer.MSBuild-based codebases can have multiple build configurations that appear in the Start button's drop-down list. Sélectionnez le fichier que vous souhaitez utiliser comme élément de démarrage, puis cliquez sur le bouton Démarrer pour commencer le débogage.Select the file that you want to use as the startup item, and then choose the Start button to begin debugging.

Note

Dans le cas des codebases C# et Visual Basic, vous devez installer la charge de travail Développement Desktop .NET.For C# and Visual Basic codebases, you must have the .NET desktop development workload installed. Dans le cas des codebases C++, vous devez installer la charge de travail Développement Desktop en C++.For C++ codebases, you must have the Desktop development with C++ workload installed.

Codebases qui utilisent des outils de génération personnalisésCodebases that use custom build tools

Si votre codebase utilise des outils de génération personnalisés, vous devez indiquer à Visual Studio comment générer votre code à l’aide des tâches de génération définies dans un fichier .json.If your codebase uses custom build tools, then you must tell Visual Studio how to build your code using build tasks that are defined in a .json file. Pour plus d’informations, consultez la page Personnaliser les tâches de génération et de débogage.For more information, see Customize build and debug tasks.

Codebases qui contiennent du code Python ou JavaScriptCodebases that contain Python or JavaScript code

Si votre codebase contient du code Python ou JavaScript, il est inutile de configurer les fichiers .json, mais vous devez installer la charge de travail correspondante.If your codebase contains Python or JavaScript code, you don't have to configure any .json files, but you do have to install the corresponding workload. Il vous faudra également configurer le script de démarrage :You must also configure the startup script:

  1. Installez la charge de travail Développement Node.js ou Développement Python en choisissant Outils > Obtenir des outils et des fonctionnalités..., ou ben en fermant Visual Studio et en exécutant Visual Studio Installer.Install the Node.js development or Python development workload by choosing Tools > Get Tools and Features..., or by closing Visual Studio and running the Visual Studio Installer.

    Charges de travail de développement Node.js et Python

  2. Dans l’Explorateur de solutions, dans le menu contextuel ou le menu accessible par clic droit d’un fichier JavaScript ou Python, choisissez la commande Définir comme élément de démarrage.In Solution Explorer, on the right-click or context menu of a JavaScript or Python file, choose the Set as Startup Item command.

  3. Choisissez le bouton Démarrer pour commencer le débogage.Choose the Start button to begin debugging.

Codebases qui contiennent du code C++Codebases that contain C++ code

Pour savoir comment ouvrir du code C++ sans solutions ni projets dans Visual Studio, consultez la page Ouvrir des projets de dossier pour C++.For information about opening C++ code without solutions or projects in Visual Studio, see Open Folder projects for C++.

Codebases qui contiennent un projet Visual StudioCodebases that contain a Visual Studio project

Si votre dossier de code contient un projet Visual Studio, vous pouvez désigner ce projet comme élément de démarrage.If your code folder contains a Visual Studio project, you can designate the project as the startup item.

Définir un projet comme élément de démarrage

Le texte du bouton Démarrer évolue pour refléter le fait que le projet est l’élément de démarrage.The Start button's text changes to reflect that the project is the startup item.

Projet sur le bouton Démarrer

Voir aussiSee also