Bien démarrer avec C++ dans Visual StudioGet started with C++ in Visual Studio

Suivez ce guide de démarrage rapide pour vous familiariser avec la plupart des outils et boîtes de dialogue que vous pouvez utiliser quand vous développez des applications en C++ avec Visual Studio.Complete this quickstart to become familiar with many of the tools and dialog boxes that you can use when you develop applications in C++ with Visual Studio. Créez une application console du style « Hello, World » pour découvrir plus en détail comment utiliser l’IDE (environnement de développement intégré).Create a "Hello, World"-style console application while you learn more about working in the integrated development environment (IDE).

PrérequisPrerequisites

Pour suivre ce guide de démarrage rapide, vous n’avez pas besoin de connaître le langage C++, mais vous devez être familiarisé avec certains concepts généraux de la programmation et du débogage.You don't need to be familiar with C++ to complete this quickstart, but you should be familiar with some general programming and debugging concepts. La documentation Visual Studio n’est pas conçue pour vous apprendre la programmation en C++.The Visual Studio documentation doesn't teach you how to program in C++. Pour savoir où trouver des ressources d’apprentissage en C++, consultez la page Get Started sur le site web ISO C++.A good guide to C++ learning resources is the Get started page on the ISO C++ website.

Pour ce guide de démarrage rapide, vous avez besoin de Visual Studio 2017 version 15.3 ou ultérieure, avec la charge de travail Développement Desktop en C++ installée.To follow along, you need a copy of Visual Studio 2017 version 15.3 or later, with the Desktop development with C++ workload installed. Pour obtenir un guide d’installation rapide, consultez Installer la prise en charge de C++ dans Visual Studio.For a fast guide to installation, see Install C++ support in Visual Studio.

Créer une application consoleCreate a console app

Démarrez Visual Studio, s’il y a lieu.If it's not running yet, start Visual Studio.

IDE avec les paramètres Visual C++ appliquésIDE with Visual C++ settings applied

Après avoir ouvert Visual Studio, vous pouvez voir les trois composants de base de l’IDE : les fenêtres Outil, les menus et les barres d’outils, ainsi que l’espace de la fenêtre principale.After you open Visual Studio, you can see the three basic parts of the IDE: tool windows, menus and toolbars, and the main window space. Les fenêtres Outil sont ancrées sur les côtés gauche et droit de la fenêtre de l’application.Tool windows are docked on the left and right sides of the app window. La zone Lancement rapide, la barre de menus et la barre d’outils standard sont situées en haut de la fenêtre.The Quick Launch box, the menu bar, and the standard toolbar are found at the top. La page de démarrage se trouve au centre de la fenêtre.The center of the window contains the Start Page. Lorsque vous ouvrez une solution ou un projet, les éditeurs et les concepteurs apparaissent dans cet espace.When you open a solution or project, editors and designers appear in this space. Durant le développement d’une application, la plupart des opérations se passent dans cette zone centrale.When you develop an app, most of your time is spent in this central area.

Visual Studio organise le code des applications dans des projets, et vos projets dans des solutions.Visual Studio uses projects to organize the code for an app, and solutions to organize your projects. Un projet contient l’ensemble des options, des configurations et des règles utilisées pour créer une application.A project contains all the options, configurations, and rules used to build your apps. Il gère également le lien entre tous les fichiers d’un projet et les éventuels fichiers externes.It also manages the relationship between all the project's files and any external files. Pour créer votre application, commencez par créer un projet et une solution.To create your app, first, you create a new project and solution.

Pour créer un projet d’application consoleTo create a console app project

  1. Dans la barre de menus, choisissez Fichier > Nouveau > Projet pour ouvrir la boîte de dialogue Nouveau projet.On the menu bar, choose File > New > Project to open the New Project dialog box.

    Dans la barre de menus, choisir Fichier > Nouveau > ProjetOn the menu bar, choose File > New > Project

  2. Dans la boîte de dialogue Nouveau projet, sélectionnez Installé > Visual C++ si ce n’est pas déjà fait.In the New Project dialog, select Installed > Visual C++ if it isn't selected already. Dans le volet central, sélectionnez le modèle Application console Windows.In the center pane, select the Windows Console Application template. Dans la zone d’édition Nom, entrez HelloApp.In the Name edit box, enter HelloApp.

    Utiliser la boîte de dialogue Nouveau projet pour créer votre projet d’applicationUse the New Project dialog to create your app project

    Votre boîte de dialogue peut présenter des options différentes, selon les charges de travail et composants Visual Studio que vous avez installés.Your dialog box may have different choices, depending on the Visual Studio workloads and components you've installed. Si vous ne voyez pas les modèles de projet Visual C++, vous devez réexécuter le programme Visual Studio Installer et installer la charge de travail Développement Desktop en C++.If you don't see Visual C++ project templates, you need to run the Visual Studio installer again and install the Desktop development with C++ workload. Vous pouvez le faire directement à partir de la boîte de dialogue Nouveau projet.You can do this directly from the New Project dialog. Pour lancer le programme Visual Studio Installer, choisissez le lien Ouvrir Visual Studio Installer dans la boîte de dialogue.To launch the installer, choose the Open Visual Studio Installer link on the dialog.

  3. Choisissez le bouton OK pour créer le projet et la solution de votre application.Choose the OK button to create your app project and solution.

    La solution et le projet HelloApp, avec les fichiers de base d’une application console Windows, sont créés, puis automatiquement chargés dans l’Explorateur de solutions.The HelloApp project and solution, with the basic files for a Windows console app, are created and automatically loaded into Solution Explorer. Le fichier HelloApp.cpp s’ouvre dans l’éditeur de code.The HelloApp.cpp file is opened in the code editor. Ces éléments s’affichent dans l’Explorateur de solutions :These items appear in Solution Explorer:

    Fichiers de la solution dans l’Explorateur de solutionsFiles for the solution in Solution Explorer

Ajouter du code à l’applicationAdd code to the app

Ensuite, vous devez ajouter le code nécessaire pour afficher le mot « Hello » dans la fenêtre de console.Next, add code to display the word "Hello" in the console window.

Pour modifier le code dans l’éditeurTo edit code in the editor

  1. Dans le fichier HelloApp.cpp, insérez une ligne vide avant la ligne return 0;, puis entrez ce code :In the HelloApp.cpp file, enter a blank line before the line return 0; and then enter this code:

    cout << "Hello\n";
    

    Une ligne ondulée rouge s’affiche sous cout.A red squiggly line appears under cout. Si vous placez le pointeur dessus, un message d’erreur s’affiche.If you hover the pointer over it, an error message appears.

    Texte d’erreur pour coutError text for cout

    Le message d’erreur s’affiche également dans la fenêtre Liste d’erreurs .The error message also appears in the Error List window. Vous pouvez afficher cette fenêtre en choisissant Affichage > Liste d’erreurs dans la barre de menus.You can display this window by choosing View > Error List on the menu bar.

    Erreur dans la fenêtre Liste d’erreursError in Error List window

    Dans votre code, il manque une déclaration pour std::cout, qui se trouve dans le fichier d’en-tête <iostream>.Your code is missing a declaration for std::cout, which is found in the <iostream> header file.

  2. Pour ajouter l’en-tête iostream, entrez ce code après #include "stdafx.h" :To include the iostream header, enter this code after #include "stdafx.h":

    #include <iostream>
    using namespace std;
    

    Vous avez sans doute remarqué qu’une zone est apparue quand vous avez commencé à entrer le code.You probably noticed that a box appeared as you entered code. Cette zone contient des suggestions de saisie semi-automatique pour les caractères que vous venez d’entrer.This box contains auto-completion suggestions for the characters that you enter. Il s’agit d’une option de la fonctionnalité IntelliSense C++, qui fournit des invites de codage, notamment des membres de classe ou d’interface et des informations sur les paramètres.It's part of C++ IntelliSense, which provides coding prompts, including class or interface members and parameter information. Vous pouvez aussi utiliser des extraits de code, qui sont des blocs de code prédéfinis.You can also use code snippets, which are pre-defined blocks of code. Pour plus d’informations, consultez Utilisation d’IntelliSense et Extraits de code.For more information, see Using IntelliSense and Code snippets.

    Code fixe dans l’éditeurThe fixed code in the editor

    La ligne ondulée rouge sous cout disparaît lorsque vous corrigez l’erreur.The red squiggly line under cout disappears when you fix the error.

  3. Pour enregistrer les modifications dans le fichier, appuyez sur Ctrl+S.To save the changes to the file, press Ctrl+S.

Générer l’applicationBuild the app

Vous pouvez facilement générer votre code.It's easy to build your code. Dans la barre de menus, choisissez Générer > Générer la solution.On the menu bar, choose Build > Build Solution. Visual Studio génère la solution HelloApp, tout en affichant l’avancement de l’opération dans la fenêtre Sortie.Visual Studio builds the HelloApp solution, and reports progress in the Output window.

Générer la solution HelloAppBuild the HelloApp solution

Déboguer et tester l’applicationDebug and test the app

Vous pouvez déboguer HelloApp pour vérifier si le mot « Hello » s’affiche bien dans la fenêtre de console.You can debug HelloApp to see whether the word "Hello" appears in the console window.

Pour déboguer l'applicationTo debug the app

Pour démarrer le débogueur, choisissez Déboguer > Démarrer le débogage dans la barre de menus.To start the debugger, choose Debug > Start Debugging on the menu bar.

Commande Démarrer le débogage dans le menu DéboguerStart Debugging command on the Debug menu

Le débogueur démarre et exécute le code.The debugger starts and runs the code. La fenêtre de console (une fenêtre distincte qui ressemble à une invite de commandes) s’affiche pendant quelques secondes, mais se clôt rapidement lorsque le débogueur s’arrête en cours d’exécution.The console window (a separate window that looks like a command prompt) appears for a few seconds but closes quickly when the debugger stops running. Pour afficher le texte, vous devez définir un point d’arrêt afin d’interrompre l’exécution du programme.To see the text, you need to set a breakpoint to stop program execution.

Pour ajouter un point d’arrêtTo add a breakpoint

  1. Dans l’éditeur, placez le curseur dans la ligne return 0;.In the editor, put the cursor on the line return 0;. Dans la barre de menus, choisissez Déboguer > Basculer le point d’arrêt.On the menu bar, choose Debug > Toggle Breakpoint. Vous pouvez également cliquer dans la marge de gauche pour définir un point d’arrêt.You can also click in the left margin to set a breakpoint.

    Commande Basculer le point d’arrêt dans le menu DéboguerToggle Breakpoint command on the Debug menu

    Un cercle rouge apparaît à côté de la ligne de code dans la bordure gauche de la fenêtre de l’éditeur.A red circle appears next to the line of code in the far left margin of the editor window.

    Point d’arrêt indiqué dans la marge de la fenêtreBreakpoint indicated in window margin

  2. Pour démarrer le débogage, appuyez sur F5.To start debugging, press F5.

    Le débogueur démarre et une fenêtre de console apparaît avec le mot Hello.The debugger starts, and a console window appears showing the word Hello.

    Texte Hello dans la fenêtre de consoleHello text in the console window

  3. Pour arrêter le débogage, appuyez sur Maj+F5.To stop debugging, press Shift+F5.

Pour plus d’informations sur le débogage d’un projet de console, consultez Projets de console.For more information about console project debugging, see Console projects.

Générer une version release de l’applicationBuild a release version of the app

Maintenant que vous avez vérifié que tout fonctionne, vous pouvez préparer une version Release de l’application.Now that you've verified that everything works, you can prepare a release build of the application. Les versions de mise en production ne conservent pas les informations de débogage et utilisent des options d’optimisation du compilateur pour créer du code d’une taille plus petite et qui s’exécute plus vite.Release builds leave out the debugging information, and use compiler optimization options to create smaller, faster code.

Pour nettoyer les fichiers solution et générer une version ReleaseTo clean the solution files and build a release version

  1. Dans la barre de menus, choisissez Générer > Nettoyer la solution pour supprimer les fichiers intermédiaires et les fichiers de sortie créés pendant les générations précédentes.On the menu bar, choose Build > Clean Solution to delete intermediate files and output files that were created during previous builds.

    Commande Nettoyer la solution du menu GénérerThe Clean Solution command on the Build menu

  2. Pour changer la configuration de la solution HelloApp de Debug à Release, dans la barre d’outils, sélectionnez la liste déroulante du contrôle Configurations de solutions, puis choisissez Release.To change the solution configuration for HelloApp from Debug to Release, in the toolbar, select the dropdown on the Solution Configurations control and then choose Release.

    Générer une version Release de l’applicationBuild a release version of the application

  3. Générez la solution.Build the solution. Dans la barre de menus, choisissez Générer > Générer la solution.On the menu bar, choose Build > Build Solution.

Quand cette génération est terminée, vous avez une nouvelle application prête à être copiée et exécutée dans une fenêtre d’invite de commandes.When this build completes, you've created an app that you can copy and run in any command prompt window. Cette application est très simple, mais il ne tient qu’à vous de créer des applications plus complexes.It may not do much, but it's the gateway to greater things.

Félicitations ! Vous avez terminé ce guide de démarrage rapide.Congratulations on completing this quickstart! Pour explorer d’autres exemples, consultez Exemples Visual Studio.If you want to explore more examples, see Visual Studio samples.

Voir aussiSee also