Guide pratique pour mettre à jour des modèles existantsHow to: Update existing templates

Vous pouvez modifier un modèle que vous avez créé et dont vous avez compressé les fichiers dans un fichier .zip.After you create a template and compress the files into a .zip file, you may want to modify the template. Vous pouvez modifier les fichiers manuellement dans le modèle ou exporter un nouveau modèle à partir d'un projet basé sur le modèle.You can do this by manually changing the files in the template, or by exporting a new template from a project that is based on the template.

Utilisation de l’Assistant Exportation de modèle pour mettre à jour un modèle de projet existantUsing the Export Template Wizard to update an existing project template

Visual Studio fournit un Assistant Exportation de modèle utilisable pour mettre à jour un modèle existant :Visual Studio provides an Export Template Wizard that can be used to update an existing template:

  1. Ouvrez la boîte de dialogue Nouveau projet en choisissant Fichier > Nouveau > Projet.Open the New Project dialog box by choosing File > New > Project.

  2. Sélectionnez le modèle que vous souhaitez mettre à jour, entrez le nom et l’emplacement de votre projet, puis choisissez OK.Select the template that you want to update, enter a name and location for your project, and choose OK.

  3. Modifiez le projet dans Visual Studio.Modify the project in Visual Studio.

  4. Dans le menu Projet, choisissez Exporter le modèle...On the Project menu, choose Export Template....

    L’Assistant Exportation de modèle s’ouvre.The Export Template Wizard opens.

  5. Suivez les instructions de l’Assistant pour exporter le modèle sous la forme d’un fichier .zip.Follow the prompts in the wizard to export the template as a .zip file.

  6. (Facultatif) Pour ajouter le modèle à la boîte de dialogue Nouveau projet, placez le fichier .zip dans le répertoire suivant : %USERPROFILE%\Documents\Visual Studio <version>\Templates\ProjectTemplates.(Optional) To add the template to the New Project dialog box, place the .zip file in the following directory: %USERPROFILE%\Documents\Visual Studio <version>\Templates\ProjectTemplates. Vous devez effectuer cette étape si vous n’avez pas sélectionné l’option Importer automatiquement le modèle dans Visual Studio dans l’Assistant Exportation de modèle.You'll need to perform this step if you did not select the option Automatically import the template into Visual Studio in the Export Template Wizard.

  7. Supprimez l’ancien fichier .zip du modèle.Delete the old template .zip file.

Mise à jour manuelle d’un modèle existantManually updating an existing template

Vous pouvez mettre à jour un modèle existant sans utiliser l’Assistant Exportation de modèle, en modifiant les fichiers inclus dans le fichier .zip compressé.You can update an existing template without using the Export Template Wizard, by modifying the files in the compressed .zip file.

Pour mettre à jour manuellement un modèle existantTo manually update an existing template

  1. Localisez le fichier .zip qui contient le modèle.Locate the .zip file that contains the template. Les modèles de projet utilisateur se trouvent généralement dans %USERPROFILE%\Documents\Visual Studio <version>\Templates\ProjectTemplates.User project templates are usually located at %USERPROFILE%\Documents\Visual Studio <version>\Templates\ProjectTemplates.

  2. Extrayez le fichier zip.Extract the .zip file.

  3. Modifiez ou supprimez les fichiers modèles actuels ou ajoutez de nouveaux fichiers au modèle.Modify or delete the current template files, or add new files to the template.

  4. Ouvrez, modifiez et enregistrez le fichier XML .vstemplate pour gérer le comportement mis à jour ou les nouveaux fichiers.Open, modify, and save the .vstemplate XML file to handle updated behavior or new files.

    Pour plus d’informations sur le schéma .vstemplate, consultez Informations de référence sur les schémas de modèles Visual Studio (extensibilité).For more information about the .vstemplate schema, see Visual Studio template schema reference (Extensibility). Pour plus d’informations sur ce que vous pouvez paramétrer dans les fichiers sources, consultez Paramètres de modèle.For more information about what you can parameterize in the source files, see Template parameters.

  5. Sélectionnez les fichiers inclus dans votre modèle, cliquez avec le bouton droit pour faire apparaître un menu contextuel, puis choisissez Envoyer vers > Dossier compressé.Select the files in your template, and from the right-click or context menu, and choose Send to > Compressed (zipped) folder.

    Les fichiers que vous avez sélectionnés sont compressés dans un fichier .zip.The files that you selected are compressed into a .zip file.

  6. Placez le nouveau fichier .zip dans le même répertoire que l'ancien fichier .zip.Put the new .zip file in the same directory as the old .zip file.

  7. Supprimez les fichiers de modèles extraits et l'ancien fichier .zip du modèle.Delete the extracted template files and the old template .zip file.

Voir aussiSee also

Personnalisation des modèlesCustomizing Templates
Création de modèles de projet et d’élémentCreating Project and Item Templates
Référence du schéma de modèle Visual StudioVisual Studio Template Schema Reference
Paramètres de modèleTemplate Parameters
Guide pratique pour créer des Starter KitsHow to: Create Starter Kits