mode PlanOutlining

Vous pouvez choisir de masquer certaines parties du code en réduisant une zone de code pour qu’elle apparaisse sous un signe plus (+).You can choose to hide some code from view by collapsing a region of code so that it appears under a plus sign (+). Pour développer une zone réduite, vous devez cliquer sur le signe plus (+).You expand a collapsed region by clicking the plus sign. Si vous utilisez le clavier, choisissez Ctrl+M+M pour réduire et développer.If you are a keyboard user, you can choose Ctrl+M+M to collapse and expand. Vous pouvez aussi réduire une zone en mode Plan en double-cliquant sur n’importe quelle ligne dans la zone dans la marge de mode Plan, affichée juste à gauche du code.You can also collapse an outlining region by double-clicking any line in the region on the outlining margin, which appears just to the left of the code. Vous pouvez afficher le contenu d’une zone réduite sous forme d’info-bulle quand vous pointez sur la partie réduite.You can see the contents of a collapsed region as a tooltip when you hover over the collapsed region.

Les zone dans la marge de mode Plan sont également mises en surbrillance quand vous pointez sur la marge avec la souris.Regions in the outlining margin are also highlighted when you hover over the margin with the mouse. La couleur de mise en surbrillance par défaut peut sembler plutôt fade dans certaines configurations de couleur.The default highlighting color may seem rather faint in some color configurations. Vous pouvez la modifier dans Outils > Options > Environnement > Polices et couleurs > Zone réductible.You can change it in Tools > Options > Environment > Fonts and Colors > Collapsible Region.

Quand vous travaillez dans du code en mode Plan, vous pouvez développer les sections sur lesquelles vous souhaitez travailler, les réduire quand vous avez terminé, puis basculer vers d’autres sections.When you work in outlined code, you can expand the sections you want to work on, collapse them when you are done, and then move to other sections. Quand vous ne souhaitez pas afficher le mode Plan, vous pouvez utiliser la commande Arrêter le mode Plan pour supprimer les informations de mode Plan sans endommager le code sous-jacent.When you do not wish to have outlining displayed, you can use the Stop Outlining command to remove the outline information without disturbing your underlying code.

Les commandes Annuler et Restaurer du menu Edition affectent ces actions.The Undo and Redo commands on the Edit menu affect these actions. Les opérations Copier, Couper, Coller et glisser-déplacer conservent les informations de mode Plan, mais pas l’état de la zone réductible.The Copy, Cut, Paste, and drag-and-drop operations retain outlining information, but not the state of the collapsible region. Par exemple, quand vous copiez une zone réduite, l’opération Coller colle le texte copié en tant que zone développée.For example, when you copy a region that is collapsed, the Paste operation will paste the copied text as an expanded region.

Caution

Quand vous modifiez une zone en mode Plan, vous risquez de perdre le mode Plan.When you change an outlined region, the outlining may be lost. Par exemple, une suppression ou une opération de remplacement peut effacer la fin de la zone.For example, deletions or Find and Replace operations may erase the end of the region.

Les commandes suivantes sont disponibles dans le sous-menu Edition > Mode Plan.The following commands can be found on the Edit > Outlining submenu.

Masquer la sélectionHide Selection (Ctrl+M, Ctrl+H) - Réduit un bloc de code sélectionné qui ne serait normalement pas disponible pour le mode Plan, par exemple un bloc if.(Ctrl+M, Ctrl+H) - Collapses a selected block of code that would not normally be available for outlining, for example an if block. Pour supprimer la zone personnalisée, utilisez Arrêter le masquage actuel (ou Ctrl+M, Ctrl+U).To remove the custom region, use Stop Hiding Current (or Ctrl+M, Ctrl+U). Non disponible en Visual Basic.Not available in Visual Basic.
Activer/Désactiver le développement du mode PlanToggle Outlining Expansion - Inverse l’état masqué ou développé actuel de la section en mode Plan la plus intérieure quand le curseur se trouve dans une section réduite imbriquée.- Reverses the current hidden or expanded state of the innermost outlining section when the cursor lies in a nested collapsed section.
Activer/Désactiver toutes les régions en mode PlanToggle All Outlining (Ctrl+M, Ctrl+L) : définit toutes les zones au même état réduit ou développé.(Ctrl+M, Ctrl+L) - Sets all regions to the same collapsed or expanded state. Si certaines zones sont développées et d’autres réduites, les zones réduites sont développées.If some regions are expanded and some collapsed, then the collapsed regions are expanded.
Arrêter le mode PlanStop Outlining (Ctrl+M, Ctrl+P) : supprime toutes les informations de mode Plan pour la totalité du document.(Ctrl+M, Ctrl+P) - Removes all outlining information for the entire document.
Arrêter le masquage actuelStop Hiding Current (Ctrl+M, Ctrl+U) : supprime les informations de mode Plan pour la zone définie par l’utilisateur actuellement sélectionnée.(Ctrl+M, Ctrl+U) - Removes the outlining information for the currently selected user-defined region. Non disponible en Visual Basic.Not available in Visual Basic.
Réduire aux définitionsCollapse to Definitions (Ctrl+M, Ctrl+O) : réduit les membres de tous les types.(Ctrl+M, Ctrl+O) - Collapses the members of all types.
Réduire le bloc :<limite logique>Collapse Block:<logical boundary> (Visual C++) Réduit une zone dans la fonction contenant le point d’insertion.(Visual C++) Collapses a region in the function containing the insertion point. Par exemple, si le point d’insertion se trouve à l’intérieur d’une boucle, celle-ci est masquée.For example, if the insertion point lies inside a loop, the loop is hidden.
Réduire tout dans : <structures logiques>Collapse All in: <logical structures> (Visual C++) Réduit toutes les structures à l’intérieur de la fonction.(Visual C++) Collapses all the structures inside the function.

Vous pouvez également utiliser le SDK Visual Studio pour définir les zones de texte que vous souhaitez développer ou réduire.You can also use the Visual Studio SDK to define the text regions you want to expand or collapse. Consultez Procédure pas à pas : mode Plan.See Walkthrough: Outlining.

Voir aussiSee also