Récupération automatique, Environnement, boîte de dialogue OptionsAutoRecover, Environment, Options Dialog Box

Utilisez cette page de la boîte de dialogue Options pour spécifier si les fichiers sont automatiquement sauvegardés ou non.Use this page of the Options dialog box to specify whether or not files are automatically backed up. Cette page vous permet également de spécifier si les fichiers modifiés sont restaurés ou non quand l’environnement de développement intégré (IDE) s’arrête de façon inattendue.This page also allows you to specify whether or not modified files are restored when the integrated development environment (IDE) shuts down unexpectedly. Vous pouvez accéder à cette boîte de dialogue en sélectionnant Options dans le menu Outils, puis la page Récupération automatique dans le dossier Environnement.You can access this dialog box by selecting the Tools menu and choosing Options, and then selecting the Environment folder and choosing the AutoRecover page. Si cette page n’apparaît pas dans la liste, sélectionnez Afficher tous les paramètres dans la boîte de dialogue Options.If this page does not appear in the list, select Show all setting in the Options dialog box.

Note

Les boîtes de dialogue et les commandes de menu qui s'affichent peuvent être différentes de celles qui sont décrites dans l'aide, en fonction de vos paramètres actifs ou de l'édition utilisée.The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. Pour modifier vos paramètres, choisissez Importation et exportation de paramètres dans le menu Outils.To change your settings, choose Import and Export Settings on the Tools menu. Pour plus d’informations, consultez Personnaliser l’IDE Visual Studio.For more information, see Personalize the Visual Studio IDE.

Enregistrer les informations de récupération automatique toutes les <n> minutes Utilisez cette option pour personnaliser la fréquence d’enregistrement automatique d’un fichier dans l’éditeur.Save AutoRecover information every <n> minutes Use this option to customize how often a file is automatically saved in the editor. Pour les fichiers déjà enregistrés, une copie du fichier est enregistrée dans \...\Mes documents\Visual Studio <version>\Fichiers de sauvegarde\<NomProjet>.For previously saved files, a copy of the file is saved in \...\My Documents\Visual Studio <version>\Backup Files\<projectname>. Si le fichier est nouveau et n’a pas été enregistré manuellement, le fichier est enregistré automatiquement à l’aide d’un nom de fichier généré de manière aléatoire.If the file is new and has not been manually saved, the file is auto-saved using a randomly generated file name.

Conserver les informations de récupération automatique pendant <n> jours Utilisez cette option pour spécifier la durée de conservation des fichiers créés pour la récupération automatique par Visual Studio.Keep AutoRecover information for <n> days Use this option to specify how long Visual Studio keeps files created for autorecovery.

Voir aussiSee Also