Options, Éditeur de texte, Tous les langagesOptions, Text Editor, All Languages

Cette boîte de dialogue vous permet de modifier le comportement par défaut de l’éditeur de code.This dialog box allows you to change the default behavior of the Code Editor. Ces paramètres s’appliquent également à d’autres éditeurs basés sur l’éditeur de code, tels que le mode Source du concepteur HTML.These settings also apply to other editors based upon the Code Editor, such as the HTML Designer's Source view. Pour ouvrir cette boîte de dialogue, sélectionnez Options dans le menu Outils.To open this dialog box, select Options from the Tools menu. Dans le dossier Éditeur de texte, développez le sous-dossier Tous les langages, puis choisissez Général.Within the Text Editor folder, expand the All Languages subfolder and then choose General.

Attention

Cette page définit les options par défaut pour tous les langages de développement.This page sets default options for all development languages. N’oubliez pas que la réinitialisation d’une option dans cette boîte de dialogue entraîne la réinitialisation des options générales dans tous les langages quels que soient les choix effectués.Remember that resetting an option in this dialog will reset the General options in all languages to whatever choices are selected here. Pour modifier les options de l’éditeur de texte pour un seul langage, développez le sous-dossier de ce langage et sélectionnez ses pages d’options.To change Text Editor options for just one language, expand the subfolder for that language and select its option pages.

Une coche grisée s’affiche quand une option a été sélectionnée dans les pages d’options générales pour certains langages de programmation mais pas pour d’autres.A grayed checkmark is displayed when an option has been selected on the General options pages for some programming languages, but not for others.

Note

Les boîtes de dialogue et les commandes de menu qui s'affichent peuvent être différentes de celles qui sont décrites dans l'aide, en fonction de vos paramètres actifs ou de l'édition utilisée.The dialog boxes and menu commands you see might differ from those described in Help depending on your active settings or edition. Pour modifier vos paramètres, choisissez Importation et exportation de paramètres dans le menu Outils .To change your settings, choose Import and Export Settings on the Tools menu. Pour plus d’informations, consultez Personnaliser l’IDE Visual Studio.For more information, see Personalize the Visual Studio IDE.

Compléter automatiquement les instructionsStatement Completion

Répertorier automatiquement les membresAuto list members

Lorsque cette option est sélectionnée, les listes contextuelles des membres disponibles, les propriétés, les valeurs ou les méthodes sont affichées par IntelliSense lorsque vous tapez dans l’éditeur.When selected, pop-up lists of available members, properties, values, or methods are displayed by IntelliSense as you type in the editor. Choisissez un élément dans la liste contextuelle pour l’insérer dans votre code.Choose any item from the pop-up list to insert the item into your code. La sélection de cette option active l’option Masquer les membres avancés.Selecting this option enables the Hide advanced members option.

Masquer les membres avancésHide advanced members

Lorsque cette option est activée, les listes de saisie semi-automatique d’instructions contextuelles se limitent à l’affichage des éléments les plus couramment utilisés.When selected, shortens pop-up statement completion lists by displaying only those items most commonly used. Les autres éléments sont filtrés dans la liste.Other items are filtered from the list.

Information sur les paramètresParameter information

Lorsque cette option est sélectionnée, la syntaxe complète de la procédure ou déclaration actuelle s’affiche sous le point d’insertion dans l’éditeur, avec tous ses paramètres disponibles.When selected, the complete syntax for the current declaration or procedure is displayed under the insertion point in the editor, with all of its available parameters. Le paramètre suivant que vous pouvez assigner est affiché en gras.The next parameter you can assign is displayed in bold.

ParamètresSettings

Activer l'espace virtuelEnable virtual space

Lorsque cette option est sélectionnée et que l’option Retour automatique à la ligne est désactivée, vous pouvez cliquer hors de la limite d’une ligne de l’éditeur de code et saisir du texte.When this option is selected and Word wrap is cleared, you can click anywhere beyond the end of a line in the Code Editor and type. Cette fonctionnalité peut être utilisée pour placer des commentaires à un point précis en regard de votre code.This feature can be used to position comments at a consistent point next to your code.

Retour automatique à la ligneWord wrap

Lorsque cette option est sélectionnée, toute partie d’une ligne qui dépasse horizontalement de la zone affichable de l’éditeur est automatiquement affichée à la ligne suivante.When selected, any portion of a line that extends horizontally beyond the viewable editor area is automatically displayed on the next line. La sélection de cette option active l’option Afficher des glyphes visuels pour le retour automatique à la ligne.Selecting this option enables the Show visual glyphs for word wrap option.

Note

La fonctionnalité Espace virtuel est désactivée quand l’option Retour automatique à la ligne est activée.The Virtual Space feature is turned off while Word Wrap is on.

Afficher des glyphes visuels pour le retour automatique à la ligneShow visual glyphs for word wrap

Lorsque cette option est sélectionnée, un indicateur fléché de retour s’affiche à l’endroit où une ligne longue est automatiquement renvoyée à une deuxième ligne.When selected, a return-arrow indicator is displayed where a long line wraps onto a second line.

Capture d’écran LineBreakSymbolLineBreakSymbol screenshot

Désactivez cette option si vous préférez ne pas afficher ces indicateurs.Clear this option if you prefer not to display these indicators.

Note

Ces flèches de rappel ne sont pas ajoutées à votre code et ne sont pas imprimées.These reminder arrows are not added to your code, and do not print. Elles ne sont utilisées qu'à titre de référence.They are for reference only.

Appliquer les commandes Couper ou Copier aux lignes vides en l'absence de sélectionApply Cut or Copy commands to blank lines when there is no selection

Cette option définit le comportement de l’éditeur lorsque vous placez le point d’insertion sur une ligne vide, ne sélectionnez rien, puis effectuez une action Copier ou Couper.This option sets the behavior of the editor when you place the insertion point on a blank line, select nothing, and then Copy or Cut.

  • Lorsque cette option est sélectionnée, la ligne vide est copiée ou coupée.When this option is selected, the blank line is copied or cut. Si vous effectuez ensuite une action Coller, une nouvelle ligne vide est insérée.If you then Paste, a new, blank line is inserted.

  • Lorsque cette option est désactivée, la commande Couper supprime les lignes vides.When this option is cleared, the Cut command removes blank lines. Toutefois, les données figurant dans le Presse-papiers sont conservées.However, the data on the Clipboard is preserved. Par conséquent, si vous utilisez ensuite la commande Coller, le contenu le plus récemment copié dans le Presse-papiers est collé.Therefore, if you then use the Paste command, the content most recently copied onto the Clipboard is pasted. Si vous n'avez rien copié auparavant, rien n'est collé.If nothing has been copied previously, nothing is pasted.

Ce paramètre n’a aucun effet sur les actions Copier ni Couper lorsqu’une ligne n’est pas vide.This setting has no effect on Copy or Cut when a line is not blank. Si rien n'est sélectionné, toute la ligne est copiée ou coupée.If nothing is selected, the entire line is copied or cut. Si vous effectuez ensuite une action Coller, le texte de la ligne toute entière et son caractère de ligne de fin sont collés.If you then Paste, the text of the entire line and its endline character are pasted.

Conseil

Pour afficher les indicateurs d’espaces, de tabulations et de fins de ligne et distinguer ainsi les lignes en retrait de celles qui sont complètement vides, sélectionnez Avancé dans le menu Edition, puis choisissez Afficher les espaces blancs.To display indicators for spaces, tabs, and line ends, and thus distinguish indented lines from lines that are entirely blank, select Advanced from the Edit menu and choose View White Space.

AfficherDisplay

Numéros de ligneLine numbers

Lorsque cette option est sélectionnée, un numéro de ligne apparaît en regard de chaque ligne de code.When selected, a line number appears next to each line of code.

Note

Ces numéros de lignes ne sont pas ajoutés à votre code et ne sont pas imprimés.These line numbers are not added to your code, and do not print. Elles ne sont utilisées qu'à titre de référence.They are for reference only.

Activer la navigation dans les URL par simple clicEnable single-click URL navigation

Lorsque cette option est sélectionnée, le curseur de souris prend la forme d’une main avec un doigt pointé lorsqu’il passe sur une URL dans l’éditeur.When selected, the mouse cursor changes to a pointing hand as it passes over a URL in the editor. Vous pouvez cliquer sur l'URL pour afficher la page indiquée dans votre navigateur Web.You can click the URL to display the indicated page in your Web browser.

Barre de navigationNavigation bar

Lorsque cette option est sélectionnée, la barre de navigation est affichée en haut de l’éditeur de code.When selected, displays the Navigation bar at the top of the code editor. Ses listes déroulantes Objets et Membres vous permettent de choisir un objet particulier dans votre code, de sélectionner parmi ses membres et d’accéder à la déclaration du membre sélectionné dans l’éditeur de code.Its dropdown Objects and Members lists allow you to choose a particular object in your code, select from its members, and navigates to the declaration of the selected member in the Code Editor.

Voir aussiSee Also