Solutions et projets dans Visual StudioSolutions and projects in Visual Studio

Cette page décrit le concept d’un projet et d’une solution dans Visual Studio.This page describes the concept of a project and a solution in Visual Studio. Elle aborde également brièvement la fenêtre outil Explorateur de solutions et explique comment créer un nouveau projet.It also briefly covers the Solution Explorer tool window and how to create a new project.

Notes

Cette rubrique s’applique à Visual Studio sur Windows.This topic applies to Visual Studio on Windows. Pour Visual Studio pour Mac, consultez Projets et solutions dans Visual Studio pour Mac.For Visual Studio for Mac, see Projects and solutions in Visual Studio for Mac.

ProjetsProjects

Lorsque vous créez une application ou un site Web dans Visual Studio, vous démarrez avec un projet.When you create an app or website in Visual Studio, you start with a project. Dans un sens logique, un projet contient tous les fichiers qui sont compilés dans un fichier exécutable, une bibliothèque ou un site Web.In a logical sense, a project contains all files that are compiled into an executable, library, or website. Ces fichiers peuvent inclure du code source, des icônes, des images, des fichiers de données, etc.Those files can include source code, icons, images, data files, and so on. Un projet contient également des paramètres de compilateur et d’autres fichiers de configuration qui peuvent être nécessaires aux différents services ou composants avec lesquels votre programme communique.A project also contains compiler settings and other configuration files that might be needed by various services or components that your program communicates with.

Fichier projetProject file

Visual Studio utilise MSBuild pour générer chaque projet dans une solution, et chaque projet contient un fichier projet MSBuild.Visual Studio uses MSBuild to build each project in a solution, and each project contains an MSBuild project file. L’extension de fichier reflète le type de projet, par exemple, un projet C# (. csproj), un projet de Visual Basic (. vbproj) ou un projet de base de données (. dbproj).The file extension reflects the type of project, for example, a C# project (.csproj), a Visual Basic project (.vbproj), or a database project (.dbproj). Le fichier projet est un document XML qui contient toutes les informations et les instructions dont MSBuild a besoin pour générer votre projet, y compris le contenu, la plateforme requise, les informations de versioning, les paramètres du serveur Web ou du serveur de base de données, ainsi que les tâches à effectuer.The project file is an XML document that contains all the information and instructions that MSBuild needs in order to build your project, including the content, platform requirements, versioning information, web server or database server settings, and the tasks to perform.

Les fichiers projet sont basés sur le schéma XML MSBuild.Project files are based on the MSBuild XML schema. Pour examiner le contenu des fichiers projet de type SDK plus récents dans Visual Studio, cliquez avec le bouton droit sur le nœud du projet dans Explorateur de solutions puis sélectionnez modifier <projectname>.To look at the contents of newer, sdk-style project files in Visual Studio, right-click on the project node in Solution Explorer and select Edit <projectname>. Pour examiner le contenu de .NET Framework et d’autres projets de ce style, déchargez tout d’abord le projet (cliquez avec le bouton droit sur le nœud du projet dans Explorateur de solutions puis sélectionnez décharger le projet).To look at the contents of .NET Framework and other projects of that style, first unload the project (right-click on the project node in Solution Explorer and select Unload Project). Ensuite, cliquez avec le bouton droit sur le projet, puis choisissez modifier <projectname>.Then, right-click on the project and choose Edit <projectname>.

Notes

Vous n’êtes pas obligé d’utiliser des solutions ou des projets dans Visual Studio pour modifier, générer et déboguer du code.You don't have to use solutions or projects in Visual Studio to edit, build, and debug code. Vous pouvez simplement ouvrir le dossier qui contient vos fichiers de code source dans Visual Studio et commencer à les modifier.You can simply open the folder that contains your source files in Visual Studio and start editing. Pour plus d’informations, consultez Développer du code dans Visual Studio sans projets ni solutions.For more information, see Develop code in Visual Studio without projects or solutions.

Créer de nouveaux projetsCreate new projects

Le moyen le plus simple de créer un nouveau projet consiste à utiliser un modèle de projet pour le type de projet souhaité.The easiest way to create a new project is to use a project template for the project type you want. Un modèle de projet comprend un ensemble de base de fichiers de code prégénérés, de fichiers de configuration, de ressources et de paramètres.A project template includes a basic set of pre-generated code files, config files, assets, and settings. Utilisez fichier > nouveau > projet pour sélectionner un modèle de projet.Use File > New > Project to select a project template. Pour plus d’informations, consultez créer un nouveau projet.For more information, see Create a new project.

Vous pouvez également créer un modèle de projet personnalisé que vous pouvez utiliser pour créer des projets à partir de.You can also create a custom project template that you can use to create new projects from. Pour plus d’informations, consultez Créer des modèles de projet et d’élément.For more information, see Create project and item templates.

Lorsque vous créez un projet, Visual Studio l’enregistre à son emplacement par défaut, %UserProfile%\source\repos.When you create a new project, Visual Studio saves it to its default location, %USERPROFILE%\source\repos. Pour modifier cet emplacement, accédez à Outils > options > projets et solutions > emplacements.To change this location, go to Tools > Options > Projects and Solutions > Locations. Pour plus d’informations, consultez boîte de dialogue Options : projets et Solutions > emplacements.For more information, see Options dialog box: Projects and Solutions > Locations.

SolutionsSolutions

Un projet est contenu dans une solution.A project is contained within a solution. Malgré son nom, une solution n’est pas une « réponse ».Despite its name, a solution is not an "answer". Il s’agit simplement d’un conteneur pour un ou plusieurs projets associés, ainsi que des informations de génération, des paramètres de la fenêtre Visual Studio et des fichiers divers qui ne sont pas associés à un projet spécifique.It's simply a container for one or more related projects, along with build information, Visual Studio window settings, and any miscellaneous files that aren't associated with a particular project.

Fichier solutionSolution file

Visual Studio utilise deux types de fichiers (. sln et . suo) pour stocker les paramètres des solutions :Visual Studio uses two file types (.sln and .suo) to store settings for solutions:

ExtensionExtension NomName DescriptionDescription
.sln.sln Solution Visual StudioVisual Studio Solution Organise les projets, les éléments de projet et les éléments de solution dans la solution.Organizes projects, project items, and solution items in the solution.
.suo.suo Options utilisateur de solutionSolution User Options Stocke les personnalisations et les paramètres au niveau de l’utilisateur, tels que les points d’arrêt.Stores user-level settings and customizations, such as breakpoints.

Important

Une solution est décrite par un fichier texte (extension .sln) qui a son propre format unique. Il n’est pas destiné à être modifié manuellement.A solution is described by a text file (extension .sln) with its own unique format; it's not intended to be edited by hand. Inversement, le fichier . suo est un fichier masqué qui n’est pas affiché sous les paramètres par défaut de l’Explorateur de fichiers.Conversely, the .suo file is a hidden file that is not displayed under the default File Explorer settings. Pour afficher les fichiers masqués, dans le menu Affichage de l’Explorateur de fichiers, cochez la case Éléments masqués.To show hidden files, on the View menu in File Explorer, select the Hidden Items checkbox.

Dossier de solutionSolution folder

Un « dossier de solution » est un dossier virtuel qui se trouve uniquement dans Explorateur de solutions, où vous pouvez l’utiliser pour regrouper des projets dans une solution.A "solution folder" is a virtual folder that's only in Solution Explorer, where you can use it to group projects in a solution. Si vous souhaitez localiser un fichier solution sur un ordinateur, accédez à Outils > options > projets et solutions > emplacements.If you want to locate a solution file on a computer, go to Tools > Options > Projects and Solutions > Locations. Pour plus d’informations, consultez boîte de dialogue Options : projets et Solutions > emplacements.For more information, see Options dialog box: Projects and Solutions > Locations.

Conseil

Pour obtenir un exemple de projet et de solution créés à partir de zéro, ainsi que des instructions pas à pas et des exemples de code, consultez Présentation des projets et des solutions.For an example of a project and solution created from scratch, complete with step-by-step instructions and sample code, see Introduction to projects and solutions.

Explorateur de solutionsSolution Explorer

Après avoir créé un nouveau projet, vous pouvez utiliser l’Explorateur de solutions pour afficher et gérer le projet et la solution, ainsi que leurs éléments associés.After you create a new project, you can use Solution Explorer to view and manage the project and solution and their associated items. L’illustration suivante montre Explorateur de solutions avec une solution C# qui contient deux projets :The following illustration shows Solution Explorer with a C# solution that contains two projects:

Capture d’écran de Explorateur de solutions avec deux projets.

La barre d’outils en haut de l’Explorateur de solutions comprend des boutons pour basculer d’un affichage de solutions à un affichage de dossiers, afficher les fichiers cachés, réduire tous les nœuds et bien plus encore.The toolbar across the top of Solution Explorer has buttons to switch from a solution view to a folder view, show hidden files, collapse all nodes, and more.

Capture d’écran de Explorateur de solutions avec deux projets dans Visual Studio 2019.

La barre d’outils en haut de Explorateur de solutions contient des boutons pour passer d’un affichage de solution à un affichage des dossiers, filtrer les modifications en attente, afficher tous les fichiers, réduire tous les nœuds, afficher les pages de Propriétés , afficher un aperçu du code dans l' éditeur de code, et bien plus encore.The toolbar across the top of Solution Explorer has buttons to switch from a solution view to a folder view, filter pending changes, show all files, collapse all nodes, view properties pages, preview code in the code editor, and more.

De nombreuses commandes de menu sont disponibles dans le menu contextuel, accessible par un clic droit, sur les différents éléments de Explorateur de solutions.Many menu commands are available from the right-click context menu on various items in Solution Explorer. Ces commandes incluent la génération d’un projet, la gestion de packages NuGet, l’ajout d’une référence, l’affectation d’un nouveau nom de fichier et l’exécution de tests, entre autres.These commands include building a project, managing NuGet packages, adding a reference, renaming a file, and running tests, just to name a few.

Pour les projets ASP.NET Core, vous pouvez personnaliser la façon dont les fichiers sont imbriqués dans l’Explorateur de solutions.For ASP.NET Core projects, you can customize how files are nested in Solution Explorer. Pour plus d’informations, consultez Personnaliser l’imbrication de fichiers dans l’Explorateur de solutions.For more information, see Customize file nesting in Solution Explorer.

Conseil

Si vous avez fermé Explorateur de solutions et que vous souhaitez l’ouvrir à nouveau, choisissez Afficher les > Explorateur de solutions dans la barre de menus ou appuyez sur CTRL + ALT + L.If you've closed Solution Explorer and you want to open it again, choose View > Solution Explorer from the menu bar, or press Ctrl+Alt+L. Et, si vous avez fermé les onglets latéraux et que vous souhaitez les restaurer à leurs emplacements par défaut, choisissez fenêtre > Réinitialiser la disposition de fenêtre dans la barre de menus.And, if you've closed side tabs and you want to restore them to their default locations, choose Window > Reset Window Layout from the menu bar.

Notes

Pour afficher les images d’application et les icônes qui apparaissent dans Visual Studio, téléchargez la bibliothèque d’images Visual Studio.To view the application images and icons that appear in Visual Studio, download the Visual Studio Image Library.

Voir aussiSee also